Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

[GRUB] Nie ładuje Windowsa 10 + brak obrazu na Debianie

Zaczęty przez koleczkowsky, Marzec 01, 2018, 02:20:54 PM

Poprzedni wątek - Następny wątek

koleczkowsky

Cześć wszystkim!

Otóż wczoraj postanowiłem postawić obok Windowsa 10 Debiana w najnowszej wersji 9.3.0. Pobrałem pakiet instalacyjny DVD, żebym po prostu mógł spokojnie zainstalować cały system wraz ze wszystkimi dodatkami. Posiadam dwa dyski twarde - SSD 128GB na systemy oraz 1TB na dane.
Wszystko szło elegancko - wydzieliłem sobie ok. 15GB pamięci na Linuxa na dysku SSD, zgrałem Rufusem Debiana na pendrive, zrestartowałem komputer.
Etap instalacji też przeszedł jak po maśle - wydzieliłem obszar wymiany na 3GB, resztę przeznaczyłem na system. Proces instalacji raczej był formalnością. Zainstalowałem system poprawnie wraz z GRUBem na tym samym dysku (bo na mbr).

I niestety tutaj zaczęły się schody - gdy zrestartowałem komputer, zmieniłem opcje bootowania najpierw na dysk SSD (wcześniej jako pierwszy był Boot Manager i tylko się Windows odpalał) i uruchomił się rzecz jasna GRUB - zgodnie z planem. Ale dalej już nie jest tak kolorowo. ŻADEN system nie chce się załadować. Gdy wybiorę Windowsa - chwilkę komputer pomyśli, zgaśnie ekran, po czym znowu się ładuje GRUB. Gdy spróbuję załadować Debiana - początek wygląda bardziej obiecująco - jakiś tekst się przewija na ekranie, jakby chciał się system zbootować, po czym... ciemność, widzę ciemność! Z komunikatem "obraz nieobsługiwany" na monitorze.

Czy wiecie może co może być przyczyną tego całego zamieszania? Ręce rozkładam, bo w BIOSie grzebie i nic to nie daje - system Windows 10 udaje mi się uruchomić bez szwanku, gdy ustawię opcję "Windows Boot Manager" jako first boot device. Ale wtedy uruchamia się tylko on bez GRUBa.
Debian jest mi bardzo potrzebny ze względu na terminal, kompilację plików C, C++ oraz ASM, a wirtualna maszyna zbytnio mnie nie urządza.

Bardzo proszę o pomoc i z góry dziękuję! ;)

robson75

Prawdopodobnie Debian nie zainstalował tobie pakietu os-prober.
Arch Linux Xfce+compiz - 64Bit Linux User #621110

robson75

Ja bym proponował wejść do Debian-a przez tty (Ctrl+Alt+F2) i zainstalować pakiet poleceniem:
sudo apt get install os-prober
A następnie:
sudo update-grub
Arch Linux Xfce+compiz - 64Bit Linux User #621110

koleczkowsky

A w którym momencie mam wejść do tego trybu tty? Będąc w GRUBIe? Czy jak wybiorę Debiana do załadowania i wtedy użyć tej kombinacji klawiszy?

gom1

Wtedy, gdy widzisz komunikat o "nieobsługiwanym obrazie".
Wszędzie dobrze, ale w /home najlepiej

koleczkowsky

Niestety - wypróbowałem to i nic to nie dało, ekran jak był czarny tak i dalej jest.

robson75

Aby wejść do tty, trzeba jednocześnie wcisnąć klawisze Ctrl+Alt+F2.
Arch Linux Xfce+compiz - 64Bit Linux User #621110

TataPingu

koleczkowsky
- jesteś pewien, że ssd formatowany jest z MBRem ?
- posiadasz partycję UEFI ?
- jak wyglada funkcja "Secure Boot" (lub coś podobnego) w BIOSie ?

koleczkowsky

1. Raczej dysk SSD jest z rekordem rozruchowym.
2. Tak, posiadam partycję UEFI na SSD.
3. Zdjęcia z zakładki Secure boot w UEFI:




TataPingu

Chmmm....
- trzeba by po prostu pewne rzeczy przetestować...
Widzę, że to MSI. Oni często coś tam pichcą swojego i pomimo, że "Secure" wygląda na OK, to cholera go tam wie...

Osobiście sprawdziłbym to w ten sposób, że wgrałbym jeszcze raz debiana. A najlepiej Ubuntu.
Z tym, że partycję systemową sformatowałbym GPT...
- jeśli BIOS jest OK, linux powinien pojawić się, jako system po załączeniu "Secure Boot" na enable.

astasz

#10
Cze koleczkowsky
Jak zwykle TataPingu swoje a ja swoje.
Po co GPT - to jest system stworzony do obsługi dysków powyżej 2TB a dla małych SSD lepiej pozostac przy MBR i  nic nie ruszać
Ponowną insatalcję debiana faktycznie mozesz spróbować - jak dasz radę to w wersji minimal z podłączonym netem (pomijasz ryzyko błedów obrazu ISO) .
Może coś by pomogło gdybyś najpierw odpalił system z Live CD i wkleił tu skany podziału dysku na partycje (najlepiej chyba z Gparted)
Chociaż z biosem od MSI nie miałem do czynienia to wydaje mi się że tutaj coś może być namieszane. Masz odhaczone botowanie UEFI czy Legacy?
No i wg mnie Secure boot powinno być na disabled (ja tak mam - u mnie na przyład secure boot wymusza bootowanie UEFI - nie wiem jak w tym biosie od MSI)
Debian Buster MATE

TataPingu

Astasz
- TataPingu wie co mówi...

https://docs.microsoft.com/en-us/windows-server/storage/disk-management/change-a-gpt-disk-into-an-mbr-disk

https://www.techrrival.com/mbr-vs-gpt/

Jeśli jego winda jest na GPT to nie ma szans tego skorygować...

koleczkowsky

Jeśli chodzi o bootowanie to mam mam załączone Legacy wraz z UEFI. Jeśli wyłączę bootowanie UEFI to po restarcie komputera wchodzi od razu do UEFI (BIOSu) bez względu na ustawioną kolejność bootowania peryferiów.

Obawiam się, że ponowna instalacja Debiana może znów zakończyć się powodzeniem, ponieważ jak już wspomniałem skorzystałem z trzech instalatorów (netinst, CD oraz DVD) i ich instalacja kończyła się tym samym - przy wybraniu Win 10 w GRUBie ponowne załadowanie GRUBa, a przy wyborze Debiana - nieobsługiwany obraz.

Myślicie, że instalacja Ubuntu coś zmieni?

TataPingu

"a przy wyborze Debiana - nieobsługiwany obraz"
- no chyba, że coś ze sterownikiem karty graficznej...

W takim przypadku Ubuntu już przy instalacji ma więcej sterowników do "wyboru"...

Ew., tak, jak powiedziałem, sformatuj partycję przeznaczoną na linuxa na GPT. W tym przypadku Ubuntu jest również zalecany, gdyż ujęto go, jako "oficjalnie dpopuszczoną" wersję linuxa do wszystkich firmware producentów płyt...
Wówczas jest szansa, że "pojawi" się w BootManagerze

astasz

#14
możesz spróbować zainstalować bez trybu graficznego. Jak się uda odpalić w trybie tekstowym to xorgi, displaymanagery itp mozesz sobie doinstalowac póżniej.
tryb tekstowy powinien działać bez sterów do grafiki
po prost na końcu instalacji minimal pozostawiesz nie zaznaczoną żadną z mozliwych opcji
Debian Buster MATE

Zobacz najnowsze wiadomości na forum