Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: Przeźroczystość w conky  (Przeczytany 2739 razy)

Offline jaworek

  • Newbie
  • *
  • Wiadomości: 7
  • Reputacja: 0
Przeźroczystość w conky
« dnia: Październik 11, 2015, 02:12:54 pm »
Cześć.
Zainstalowałem sparkiego w wersji LXDE, a potem dodałem Gnome. I nie wiem dlaczego widget conky wyświetla się cały czas na tle głównej tapety z LXDE (na tle niebueskiego paska). Czy ktoś wie co należy zmienić w conky.conf, aby uzyskać pełną przeźroczystość także dla innych tapet pod gnome?

Offline jaworek

  • Newbie
  • *
  • Wiadomości: 7
  • Reputacja: 0
Odp: Przeźroczystość w conky
« Odpowiedź #1 dnia: Listopad 15, 2015, 12:56:27 pm »
Sam znalazłem rozwiązanie problemu, dokładnie tu: http://www.debian.pl/entries/187-Przezroczysty-conky-w-xfce-4-8
Mówiąc krótko, ustawienie tych opcji:
own_window yes
own_window_type desktop
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
own_window_argb_visual yes
own_window_argb_value 100
double_buffer yes
own_window_transparent yes

daje pełną przeźroczystość, pod każdą tapetą w gnome.

Offline rapper3d

  • Newbie
  • *
  • Wiadomości: 3
  • Reputacja: 0
Odp: Przeźroczystość w conky
« Odpowiedź #2 dnia: Sierpień 28, 2021, 11:55:24 am »
Witam, na wstępie dziękuję za przyznanie mi tytułu górnika stulecia oraz platynowej łopaty. Jednakże mam problem dotyczący przezroczystości Conky w LXDE choć właściwie to LXqt bo to Lubuntu 21.04

Ustawiam wszystko według instrukcji, punktem wyjścia jest oryginalny conky.conf gdzie komendy mają wartość  true zamiast yes i są przypisywane znakiem równości. Jak do tej pory ustawiłem sobie wszystko co chciałem jednak właśnie mam problem z przezroczystością. Nie ma znaczenia jak podaję wartość tej opcji czy to przez yes czy przez true. Conky albo się nie uruchomi albo uruchomi się na czarnym tle. I właśnie tego tła nie chcę.

poniżej mój konfig:
conky.config = {
    alignment = 'top_right',
    background = false,
    border_width = 0,
    cpu_avg_samples = 2,
    default_color = 'white',
    default_outline_color = 'white',
    default_shade_color = 'white',
    double_buffer = true,
    draw_borders = false,
    draw_graph_borders = true,
    draw_outline = false,
    draw_shades = false,
    extra_newline = false,
    font = 'DejaVu Sans Mono:size=12',
    gap_x = 10,
    gap_y = 20,
    minimum_height = 5,
    minimum_width = 5,
    net_avg_samples = 2,
    no_buffers = true,
    out_to_console = false,
    out_to_ncurses = false,
    out_to_stderr = false,
    out_to_x = true,
    own_window = true,
    own_window_transparent = true,
    own_window_hints = 'undecorated,below,sticky,skip_taskbar,skip_pager',
own_window_argb_visual = true,
own_window_argb_value = 0,
own_window_class = 'Conky',
    own_window_type = 'normal',
    show_graph_range = false,
    show_graph_scale = false,
    stippled_borders = 0,
    update_interval = 1.0,
    uppercase = false,
    use_spacer = 'none',
    use_xft = true,
}

Offline robson75

  • Hero Member
  • *****
  • Wiadomości: 1667
  • Reputacja: 12
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: Przeźroczystość w conky
« Odpowiedź #3 dnia: Sierpień 28, 2021, 12:13:23 pm »
Szukaj sobie sam, ja Ci mogę jedynie podać fragment swojego configu conky, na którym nie ma problemu z przezroczystością
conky.config = {
--- Conky settings ---
    update_interval = 1,
    total_run_times = 0,
    background = false,
    cpu_avg_samples = 1,
    net_avg_samples = 1,
    double_buffer = true,
    no_buffers  = true,
   
--- Window specifications ---
    own_window = true,
    own_window_type = 'normal',
    own_window_transparent = true,
    own_window_argb_visual = true,
    own_window_hints = 'undecorated,sticky,below,skip_taskbar,skip_pager',
    --own_window_colour = '#000000',
    maximum_width = 300,
    alignment = 'top_right',
    gap_x = 0,
    gap_y = 0,

--- Graphics settings ---
    draw_shades = false,
    draw_outline = false,
    draw_borders = true,
    draw_graph_borders = true,
    border_width = 0,
    border_inner_margin = 0,
    border_outer_margin = 2,

--- Text settings ---
    override_utf8_locale = true,
    use_xft = true,
    font = 'Bold:size= 9',
    xftalpha = 1, 
    text_buffer_size = 2048,

--- Color settings ---
    default_color = '#0A960F',
    color0 = '#FFFFFF',
    color1 = '#0998ED',
    color2 = '#C37D0E',
    color3 = '#0EB3C3',
    color4 = '#FCE94F',
}

Arch Linux Xfce+compiz - 64Bit Linux User #621110 

Offline rapper3d

  • Newbie
  • *
  • Wiadomości: 3
  • Reputacja: 0
Odp: Przeźroczystość w conky
« Odpowiedź #4 dnia: Sierpień 28, 2021, 12:51:24 pm »
Niestety porównałem konfigi i dalej mi to nie działa, przez chwile było przezroczyste ale po ponownym uruchomieniu znowu jest na czarnym tle. Nie bardzo mam pomysł co robię źle.

EDIT----
Nie jestem zbyt zaawansowanym uzytkownikiem Linuxa ale dokopałem sie do źródła problemu, po pierwsze dla całkowitej pewności doinstalowałem pakiet xcompmgr chociaż w systemie jest juz compton który na nim bazuje i picom. Metodą prób i błędów doszedłem, że uruchomienie picom od razu daje przezroczystość Conky. Tak więc by efekt był stały i od strzała nalezy dodac picom i Conky do autostartu.
« Ostatnia zmiana: Sierpień 29, 2021, 12:33:51 am wysłana przez rapper3d »