Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Drukarka w CUPS-ie

Zaczęty przez Grzegorz, Marzec 20, 2015, 11:08:11 AM

Poprzedni wątek - Następny wątek

Grzegorz

Dzień dobry bardzo
Czy żeby zainstalować ponownie drukarkę w systemie należy stary CUPS usunąć i zainstalować ponownie?
Grzegorz

pavroo

Witaj
Narzędzia do instalacji drukarki w systemie powinny posiadać opcję odinstalowania już zainstalowanej drukarki.
Do tego zadania nie jest konieczne reinstalowanie CUPS.
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

Grzegorz

Może nie potrzebnie ale wykonałem :
sudo pacman -S cups ghostscript gsfonts
ostrzeżenie: cups-2.0.1-1 jest w najnowszej wersji -- ponowne instalowanie
ostrzeżenie: ghostscript-9.15-1 jest w najnowszej wersji -- ponowne instalowanie
ostrzeżenie: gsfonts-20130917-1 jest w najnowszej wersji -- ponowne instalowanie
rozwiązywanie zależności...
szukanie konfliktów międzypakietowych...

Pakiety (3): cups-2.0.1-1  ghostscript-9.15-1  gsfonts-20130917-1

Całkowity rozmiar do pobrania:    21,18 MiB
Całkowity rozmiar po instalacji:  72,41 MiB
Zmiana po aktualizacji:            0,00 MiB

i nie pomogło.Za to straciłem z panelu sterowania ---> system--->dodaj drukarkę
Grzegorz

pavroo

W takim wypadku spróbuj interfejsu webowego.
Uruchom przeglądarke internetową i wpisz adres:
http://localhost:631/
Wybierz: CUPS for Administrators-> Adding Printers and Classes
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

Grzegorz


Add Printer
Add Printer Error

Unable to add printer:

    Forbidden

Grzegorz

pavroo

W każdym systemie jest to trochę inaczej ustawione.
Spróbuj uruchomić przeglądarkę www z prawami administratora systemu.
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

Grzegorz

Administratora systemu ? nie wiem jak to zrobić.
Grzegorz

Grzegorz

Znalazłem taką stronę
http://pl.docs.pld-linux.org/uslugi_cups.html
Grzegorz

pavroo

#8
su lub sudo, np (w terminalu):
sudo firefox
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

darekradzan

#9
jaka masz drukarke ? , juz raz to przerabialismy przeciez , sterowniki doinstalowales?
dla drukarki samsung
sudo pacman -S splix
jesli nie zadziala
to jeszcze
yaourt -S samsung-unified-driver

dla druk. HP
sudo pacman -S hplip
nieraz jeszcze trzeba doinstalowac
yaourt -S hpoj

i na koiniec podalem Ci strone do poczytania
sudo systemctl  enable org.cups.cupsd.service
oraz
sudo systemctl start org.cups.cupsd.service

chyba tak musza byc te  komendy ,sprawdz na stronie ktora Ci podalem , czyli https://wiki.archlinux.org/index.php/CUPSi masz po klopocie

Grzegorz

sudo firefox
(process:3976): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
Grzegorz

Grzegorz

Dareczku
Tak myśmy to już przerabiali. Mam Samsunga ML-1675.
Grzegorz

darekradzan

#12
a masz w ogole w swoim systemie firefox-a jako przegladarke?

Edit.
Masz samsunga , czyli zainstaluj te sterowniki , co podalem Ci w poprzednim poscie , wykonaj te polecenia co napisalem aby zrobic/zapisac zmiany w grubie i sprobuj

Grzegorz

Używam tylko Firefox-a.
sudo firefox
(process:3976): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
1426873394775   addons.update-checker   WARN   Update manifest for {972ce4c6-7e08-4474-a285-3208198ce6fd} did not contain an updates property
Grzegorz

darekradzan

najpierw zainstaluj sterowniki i wykonaj te polecenia

Zobacz najnowsze wiadomości na forum