Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: Po odpięciu dysku od sprzętu system nie chce się bootować (Kali)  (Przeczytany 431 razy)

Offline troian1337

  • Newbie
  • *
  • Wiadomości: 2
  • Reputacja: 0
Witam, posiadam dwa dyski ssd, na pierwszym mam zainstalowanego windowsa 10 a na drugim Kali (od niedawana), dyski te nie są podłączone jednocześnie do komputera, w zależności od potrzeb przepinam je sobie, problem w tym że po zainstalowaniu na drugim dysku kali system uruchamia się do póki nie odłączę dysku. Po odłączeniu i ponownym podłączeniu dysku system się nie uruchamia. Sprawdzałem czy nie jest to może wina windowsa (zmiana jakichś ustawień bios) jednak testy wykluczyły taką ewentualność a dwa Ubuntu oraz Debian nie mają takiego problemu, Próbowałem jeszcze z Mint Debbie i on ma ma takie same problemy jak Kali. Spotkał się ktoś z podobnym problemem? Może to kwestia odpowiedniego ustawienia grub?

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 3138
  • Reputacja: 51
Odp: Po odpięciu dysku od sprzętu system nie chce się bootować (Kali)
« Odpowiedź #1 dnia: Marzec 01, 2021, 03:21:09 pm »
A oprócz tego, że się nie uruchamia, to jakieś informacje? Z Twojej opowieści wynika, że... owe Kali uruchomiło Ci się raz :) (wpiąłeś dysk, wystartowałeś, zamknąłeś, odpiąłeś i już nie wstał - to jednak sprzeczne z inną częścią Twojej wypowiedzi: "kali (...) uruchamia się".
Opisz to dokładniej, bo sprzeczne informacje. Jeśli Kali jednak potrafi Ci się uruchomić, to podaj logi z poprzedniego bootowania (tego, gdy się nie uruchomił).

Offline troian1337

  • Newbie
  • *
  • Wiadomości: 2
  • Reputacja: 0
Odp: Po odpięciu dysku od sprzętu system nie chce się bootować (Kali)
« Odpowiedź #2 dnia: Marzec 03, 2021, 01:46:22 pm »
Pisałem to na szybko i faktycznie trochę nielogicznie, chodzi o to że dopóki był podpięty dysk z kali to mogłem bez problemu wyłączać go i włączać, system się uruchamiał jednak jeżeli wypiąłem dysk (po wyłączeniu systemu) i wpiąłem dysk z systemem windows to kiedy chciałem ponownie wpiąć dysk z kali otrzymywałem informację "No boot device found..." W skrócie póki dysk był podpięty nie było żadnego problemu, zmiana dysku na ten z Windows powodowała niemożność uruchomienia się Kali (wcześniej wspomniany komunikat)

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 3138
  • Reputacja: 51
Odp: Po odpięciu dysku od sprzętu system nie chce się bootować (Kali)
« Odpowiedź #3 dnia: Marzec 03, 2021, 02:15:51 pm »
Czy na dysku z Kali masz bootloadera? Rozumiem, że sytuacja "No boot device found" jest po starcie z podpiętym jedynym dyskiem z Kali.
Czy jeśli dasz oba dyski - możesz wystartować Kali?