Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: openSuse Tumbleweed { nie uruchamia programów }  (Przeczytany 463 razy)

Offline wojtek001

  • Newbie
  • *
  • Wiadomości: 3
  • Reputacja: 0
openSuse Tumbleweed { nie uruchamia programów }
« dnia: Luty 25, 2021, 02:30:07 am »
Witam szanowne grono użytkowników - na wstępie pozdrawiam ! - Mam problem z uruchamianiem programów , tj np gry potato guy , edydory tekstowe  ( kwrite , kate ) i jeszcze kilka innnych , robiłem update - nic to nie pomaga- jestem raczej początkującym użytkownikiem Linuxa ;-) może mi ktoś pomoże rozwiązać problem ?
edit : klikając na uruchomienie programu po prostu nic się nie dzieje

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 3081
  • Reputacja: 48
Odp: openSuse Tumbleweed { nie uruchamia programów }
« Odpowiedź #1 dnia: Luty 25, 2021, 07:36:51 am »
Skoro robiłeś jakąś aktualizację, masz zainstalowaną potato guy, to jakieś programy jednak działają. Skoro tak, to sprawdź, czy działa konsola, a w niej wpisz program, który się nie uruchamia (np. kwrite, czy kate) i to co się ukaże w konsoli wrzuć tu.
Czy dokonywałeś jakichś zmian w Plazma (chyba ten DE masz, skoro masz tam kate i kwrite), a jeśli tak to jakich?

Offline wojtek001

  • Newbie
  • *
  • Wiadomości: 3
  • Reputacja: 0
Odp: openSuse Tumbleweed { nie uruchamia programów }
« Odpowiedź #2 dnia: Luty 26, 2021, 12:15:43 pm »
wojtek@localhost:~> kwrite
kwrite: symbol lookup error: /usr/lib64/libKF5XmlGui.so.5: undefined symbol: _ZN19KeySequenceRecorder16recordingChangedEv
wojtek@localhost:~> kate
kate: symbol lookup error: /usr/lib64/libKF5XmlGui.so.5: undefined symbol: _ZN19KeySequenceRecorder16recordingChangedEv
wojtek@localhost:~>

żadnych zmian nie wprowadzałem , jestem " początkującym użyszkodnikiem :/
edit: :/
Tak dzialaja programy takie jak pakiety office libre program ftp filezilla , gnome i przegladarki pewnie inne również
« Ostatnia zmiana: Luty 26, 2021, 01:44:46 pm wysłana przez lami07 »

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 3081
  • Reputacja: 48
Odp: openSuse Tumbleweed { nie uruchamia programów }
« Odpowiedź #3 dnia: Luty 26, 2021, 12:42:32 pm »
1. Z jakim środowiskiem masz system?
2. Czy system jest w całości zaktualizowany? (Masz system typu rolling release, w którym zwykle instalując jakąś paczkę dobrze jest to zrobić wraz z aktualizacją systemu; nie wiem akurat, czy Tumbleweed ma na sztywno wpisane wersje zależności, na których paczki są budowane, ale dokonanie aktualizacji przy instalacji paczek w rollingach nigdy nie przeszkadza).
3. Skąd pochodzą paczki, które nie chcą działać? (repozytorium, jakieś pakiety uniwersalne, inne)

Offline wojtek001

  • Newbie
  • *
  • Wiadomości: 3
  • Reputacja: 0
Odp: openSuse Tumbleweed { nie uruchamia programów }
« Odpowiedź #4 dnia: Luty 26, 2021, 01:20:32 pm »
  Takie coś udało mi się wykombinować w termialu
OS: openSUSE 2020081

        Kernel: x86_64 Linux 5.8.0-1-default
        Uptime: 1d 11h 36m
   lKO.       Packages: 2485
      Shell: bash
    Resolution: 1920x1080
    DE: GNOME 3.36.4
   WM: Mutter
   WM Theme:
GTK Theme: Adwaita [GTK2/3]
   kKAVKKKKKKKKKKKK0x;,,......,;od
 lKP      Icon Theme: Adwaita
     Font: Cantarell 11
    Disk: 274G / 394G (71%)
    CPU: Intel Core i7-2630QM @ 8x 2.9GHz [57.0°C]
 GPU: Mesa DRI Intel(R) HD Graphics 3000 (SNB GT2)
     RAM: 5321MiB / 7854MiB
edit : paczki pochodza ze stron autora glownie rpm instaluje


edit2: jeszcze takie oś

[sudo] hasło użytkownika root:
Pobieranie metadanych repozytorium 'openSUSE:Tumbleweed' .................[błąd]
Repozytorium 'openSUSE:Tumbleweed' jest niepoprawne.
[https-download.opensuse.org-1d97804a|https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/dod/] Pod podanym adresem URL nie znaleziono prawidłowych metadanych
Historia:
 - [https-download.opensuse.org-1d97804a|https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/dod/] Repository type can't be determined.

Proszę sprawdzić, czy zdefiniowane adresy URI dla tego repozytorium wskazują na poprawne repozytorium.
Ostrzeżenie: Pominięto repozytorium 'openSUSE:Tumbleweed' z powodu powyższego błędu.
Pobieranie metadanych repozytorium 'openSUSE:Tumbleweed' .................[błąd]
Repozytorium 'openSUSE:Tumbleweed' jest niepoprawne.
[https-download.opensuse.org-a3b22c15|https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/dod_debug/] Pod podanym adresem URL nie znaleziono prawidłowych metadanych
Historia:
 - [https-download.opensuse.org-a3b22c15|https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/dod_debug/] Repository type can't be determined.

edit3

przy aktualizacji wszystkich pakietow mam błąd którego również nie rozumiem

ruby2.7-2.7.2-2.2.x86_64 jest w konflikcie z namespace:otherproviders(ruby-default) dostarczonym przez ruby2.6-2.6.5-1.2.x86_64
libusbmuxd-2_0-6-2.0.2-1.2.x86_64 wymaga libplist-2.0.so.3()(64bit), lecz nie można spełnić tego wymagania
« Ostatnia zmiana: Luty 26, 2021, 01:47:38 pm wysłana przez lami07 »

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 3081
  • Reputacja: 48
Odp: openSuse Tumbleweed { nie uruchamia programów }
« Odpowiedź #5 dnia: Luty 26, 2021, 02:01:57 pm »
Zrób sobie porządek z repozytoriami (czyli dodaj prawidłowe). Od lat nie używam SUSE, ale tu masz jakieś tutoriale:
https://en.opensuse.org/SDB:Add_package_repositories
Oficjalne paczki: https://en.opensuse.org/Package_repositories, dodatkowe https://en.opensuse.org/Additional_package_repositories
Po porządkach z repozytoriami, dokonaj pełnej aktualizacji systemu. Bez tego niczego nie wskórasz.
PS: Gnome, które masz, ma swoje edytory tekstu, kate/kwrite, to stajnia KDE. Można używać, ale czy jest sens, to na takie pytanie sam sobie musisz odpowiedzieć (funkcjonalnie to samo, używanie paczek opartych o "obcy" framework zawsze będzie odbywać się kosztem większego zapotrzebowania na RAM itp.).