Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: netplan statyczny adres ip nie działa  (Przeczytany 149 razy)

Offline m72

  • Newbie
  • *
  • Wiadomości: 11
  • Reputacja: 0
netplan statyczny adres ip nie działa
« dnia: Luty 06, 2021, 02:30:45 am »
Witam, potrzebuję mieć statyczny adres ale coś nie działa, na DHCP działa.
System Ubuntu Server 20 (nie desktop!)
Plik netplana wyedytowany przeze mnie wygląda tak
# This is the network config written by 'subiquity'
network:
  version: 2
  renderer: networkd
  ethernets:
    enp0s3:
      addresses: [192.168.1.100/24]
      gateway4: 192.168.1.255
      nameservers:
        addresses: [8.8.8.8]

Polecenie ifconfig:
enp0s3: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.100  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::a00:27ff:fe2e:1cc7  prefixlen 64  scopeid 0x20<link>
        ether 08:00:27:2e:1c:c7  txqueuelen 1000  (Ethernet)
        RX packets 1  bytes 243 (243.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 72  bytes 10861 (10.8 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 373  bytes 29105 (29.1 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 373  bytes 29105 (29.1 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


I dla powyższych ustawień netu nie ma :(
"netplan try" nie wyrzuca błędów

Na oryginalnym pliku netplana

# This is the network config written by 'subiquity'
network:
  ethernets:
    enp0s3:
      dhcp4: true
  version: 2

Internet jest

Polecenie ifconfig:

enp0s3: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.112  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::a00:27ff:fe2e:1cc7  prefixlen 64  scopeid 0x20<link>
        ether 08:00:27:2e:1c:c7  txqueuelen 1000  (Ethernet)
        RX packets 3465  bytes 4231997 (4.2 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2232  bytes 238109 (238.1 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 1205  bytes 105817 (105.8 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1205  bytes 105817 (105.8 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


Czemu to dziadostwo nie działa ?


EDIT:
Dodam jeszcze że próbowałem ustawić statica na virtualboxie i dwóch żywych linuxach, wszystkie się zachowują identycznie, internet znika po ustawieniu na statica.
« Ostatnia zmiana: Luty 06, 2021, 02:53:53 am wysłana przez m72 »

Offline microsofter

  • Full Member
  • ***
  • Wiadomości: 154
  • Reputacja: 5
Odp: netplan statyczny adres ip nie działa
« Odpowiedź #1 dnia: Luty 06, 2021, 04:12:04 pm »
Nie znam Netplanu, ale zwyczajnie patrząc na twój plik, wygląda on nielogicznie, niekonsekwentnie.
1. 192.168.1.100/24 - jeśli ma być IP 192.168.1.100, co robi to /24? W dystrybucjach, jakie używałem, nie występowało nic takiego,
2. gateway jest bez nawiasów, a pozostałe numery w naw. kwadratowych, jesteś pewien, że tak nakazuje dokumentacja?

Offline m72

  • Newbie
  • *
  • Wiadomości: 11
  • Reputacja: 0
Odp: netplan statyczny adres ip nie działa
« Odpowiedź #2 dnia: Luty 06, 2021, 06:45:59 pm »
Jest nielogiczny i niekonsekwentny, zauważyłem to ale widocznie tak musi być, inaczej wywala błędy.
A jeśli nie wiesz co to jest /24 to znaczy że się nie znasz :)

W dokumentacji jest jeszcze gorzej, tam są jakieś minusy przed adresem, to to już w ogóle nie przechodzi, same błędy.
network:
  version: 2
  renderer: networkd
  ethernets:
    eth0:
      addresses:
        - 10.10.10.2/24
      gateway4: 10.10.10.1
      nameservers:
          search: [mydomain, otherdomain]
          addresses: [10.10.10.1, 1.1.1.1]



https://ubuntu.com/server/docs/network-configuration



Offline m72

  • Newbie
  • *
  • Wiadomości: 11
  • Reputacja: 0
Odp: netplan statyczny adres ip nie działa
« Odpowiedź #3 dnia: Luty 06, 2021, 07:36:29 pm »
Ok, błąd był w adresie bramy, już internet jest ale.... dalej nie mogę się dobić z zewnątrz do swojego kompa mimo tego że adres stały mam. Firewall wyłączony :(

Mój dostawca internetu zrobił tak że ustawił DMZ-ta na kompa za routerem ktróry będzie miał końcówkę 100. Po to mi był static IP.
Początkowo miałem adres przydzielany dymamicznie z końcówką 100 (sam się tak przydzielał) to wszystko działało. Po przeinstalowaniu systemu router nie wiem czemu zaczął przyedzielać końcówkę inną niż 100 i przestałem być widoczny na zewnątrz. Po to mi ten static. Teraz niby internet już jest ale i tak się nie mogę dobić z zewnątrz. :(

Offline microsofter

  • Full Member
  • ***
  • Wiadomości: 154
  • Reputacja: 5
Odp: netplan statyczny adres ip nie działa
« Odpowiedź #4 dnia: Luty 06, 2021, 08:16:03 pm »
A jeśli nie wiesz co to jest /24 to znaczy że się nie znasz :)
Prawda! Wpadłem na forum właśnie żeby poduczyć się. Podpiąłem już do netu kilka Uniksów, lecz w żadnym nie miałem /xx na końcu IP.

Rozumiem, że dostawca netu dał ci router, do którego konfiguracji nie masz dostępu. Próbuj wejść na tego kompa z innego obok, z tej samej strony routera. Jeśli uda się, a zza routera nie, to już wiesz, kogo musisz pomęczyć.