Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: apt (update|upgrade) dist/full-upgrade  (Przeczytany 214 razy)

Offline Sajmon

  • Jr. Member
  • **
  • Wiadomości: 58
  • Reputacja: +0/-0
apt (update|upgrade) dist/full-upgrade
« dnia: Październik 08, 2020, 08:58:03 pm »
Cześć Wam,

Nie chodzi mi o pomoc, a raczej o wytlumaczenie tego co na dole widać.

Jakieś pół godziny temu wyrzuciłem grubo ponad 200 paczek - tak ma być

tu jest OK
..cut.. apt update ..cut..

root@proxysrv:/var/log# LANG=en_US.UTF-8 ; apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

i tego tu na dole już nie rozumiem!

Dlaczego full / dist-upgrade próbuje dociągnąć pakiety których nie ma w systemie?
mintsources który jest odpowiedzialny za ściąganie poniższych pakietów też poszedł do "kosza".
Skąd to się nagle wzieło?

root@proxysrv:/var/log# LANG=en_US.UTF-8 ; apt dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  adwaita-icon-theme aptdaemon aptdaemon-data at-spi2-core dconf-gsettings-backend dconf-service gir1.2-appstreamglib-1.0 gir1.2-atk-1.0 gir1.2-freedesktop
  gir1.2-gdkpixbuf-2.0 gir1.2-glib-2.0 gir1.2-gtk-3.0 gir1.2-packagekitglib-1.0 gir1.2-pango-1.0 gir1.2-vte-2.91 gir1.2-xapp-1.0 glib-networking
  gsettings-desktop-schemas gtk-update-icon-cache hicolor-icon-theme humanity-icon-theme iso-flag-png libappstream-glib8 libatk-bridge2.0-0 libatspi2.0-0
  libcairo-gobject-perl libcairo-gobject2 libcairo-perl libcairo2 libdbusmenu-gtk3-4 libdconf1 libfontenc1 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-bin libgl1 libglx-mesa0
  libglx0 libgnomekbd-common libgnomekbd8 libgtk-3-0 libgtk-3-bin libgtk-3-common libgtk3-perl libice6 libnet-dbus-perl libpangocairo-1.0-0 libpangoxft-1.0-0
  librest-0.7-0 librsvg2-2 librsvg2-common libsm6 libsoup-gnome2.4-1 libsoup2.4-1 libvte-2.91-0 libwayland-client0 libwayland-cursor0 libx11-6 libx11-data
  libx11-protocol-perl libxapp1 libxau6 libxaw7 libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0 libxcb-present0 libxcb-render0 libxcb-shape0 libxcb-shm0 libxcb-sync1 libxcb1
  libxcomposite1 libxcursor1 libxdamage1 libxdmcp6 libxext6 libxfixes3 libxft2 libxi6 libxinerama1 libxkbfile1 libxklavier16 libxmu6 libxmuu1 libxpm4 libxrandr2
  libxrender1 libxt6 libxtst6 libxv1 libxxf86dga1 libxxf86vm1 mint-common mint-translations mintsources python-apt-common python3-apt python3-aptdaemon
  python3-aptdaemon.gtk3widgets python3-cairo python3-dbus python3-defer python3-gi python3-gi-cairo python3-pycurl ubuntu-mono x11-common x11-utils x11-xkb-utils
  x11-xserver-utils xapps-common xdg-utils
0 upgraded, 112 newly installed, 0 to remove and 0 not upgraded.
Need to get 22.8 MB of archives.
After this operation, 91.8 MB of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort.

root@proxysrv:/var/log# LANG=en_US.UTF-8 ; dpkg -l adwaita-icon-theme
dpkg-query: no packages found matching adwaita-icon-theme

Dzięki z góry za odpowiedź.

Pozdr.
Sajmon

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2575
  • Reputacja: +35/-9
Odp: apt (update|upgrade) dist/full-upgrade
« Odpowiedź #1 dnia: Październik 08, 2020, 09:05:31 pm »
Najprawdopodobniej:
1. wyrzuciłeś zależności jakichś paczek jednocześnie forsując zerwanie ich zależności,
2. w systemie masz jakieś meta-paczki, które chcą teraz dociągnąć te zależności
PS: Jak widzę to masz raczej Minta, którego wszystkie 3 wersje są zbudowane z użyciem gtk3, a ta biblioteka ma w swoich zależnościach m.in. adwaita-icon-theme

Offline Sajmon

  • Jr. Member
  • **
  • Wiadomości: 58
  • Reputacja: +0/-0
Odp: apt (update|upgrade) dist/full-upgrade
« Odpowiedź #2 dnia: Październik 08, 2020, 09:33:50 pm »
Zgadza się - Mint 20

właśnie nie widzę żadnego mety pakietu, został podstawowy system na router z ogromną ilością bibliotek (659). audio/video/inne do programowania
Może to tu jest gdzieś pies pogrzebany.

No nic, dzięki, będę próbował dalej. :)

mata:
root@proxysrv:/var/log# dpkg -l | grep 'meta\|gtk\|x11'
ii  init                                       1.57                                  amd64        metapackage ensuring an init system is installed
ii  libexempi8:amd64                           2.5.1-1build1                         amd64        library to parse XMP metadata (Library)
ii  libexiv2-27:amd64                          0.27.2-8ubuntu2                       amd64        EXIF/IPTC/XMP metadata manipulation library
ii  libx11-xcb1:amd64                          2:1.6.9-2ubuntu1.1                    amd64        Xlib/XCB interface library

Pozdr.
Sajmon

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2575
  • Reputacja: +35/-9
Odp: apt (update|upgrade) dist/full-upgrade
« Odpowiedź #3 dnia: Październik 08, 2020, 10:58:08 pm »
Czyli to są zależności, które wcześniej zerwałeś odinstalowując.
PS: Po jakiego diabła się męczyć z Mintem jako systemem na router? Są pod to specjalnie robione. Pytanie retoryczne.

Offline Sajmon

  • Jr. Member
  • **
  • Wiadomości: 58
  • Reputacja: +0/-0
Odp: apt (update|upgrade) dist/full-upgrade
« Odpowiedź #4 dnia: Październik 10, 2020, 06:30:48 am »
Gdyby to był tylko mój mini-pc..., ale to komp sąsiada i mówi że minta zna najlepiej :D
Tutaj mają takie powiedzenie - "Czego rolnik nie zna, nie weżmie do pyska" Kasztanowi nie przetłumaczysz.

Z zależnościami już sobie poradziłem, full/dist-upgrade działa już poprawnie.

Jeszscze raz dzięki.

Pozdr.
Sajmon