Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: witam , sddm autologowanie  (Przeczytany 211 razy)

Offline darekradzan

  • Sr. Member
  • ****
  • Wiadomości: 293
  • Reputacja: +0/-0
witam , sddm autologowanie
« dnia: Sierpień 27, 2020, 02:48:58 pm »
Witam , czy możecie mi pomóc  jeśli chodzi o sddm, nigdy z niego nie korzystałem,  a mianowicie chodzi o autologin , z tego co wyczytałem to tak ustawiłem , wydawało mi się ze będzie ok , ale niestety system nie uruchamia się automatycznie , muszę za każdym razem wpisywać hasło
Mój  /etc/sddm.conf
Cytuj
[Autologin]
Session=xfce4
User=darek

[General]
HaltCommand=/usr/bin/loginctl poweroff
InputMethod=qtvirtualkeyboard
Numlock=none
RebootCommand=/usr/bin/loginctl reboot

[Theme]
Current=artix
CursorTheme=
DisableAvatarsThreshold=7
EnableAvatars=true
FacesDir=/usr/share/sddm/faces
ThemeDir=/usr/share/sddm/themes

[Users]
DefaultPath=/usr/local/bin:/usr/bin:/bin
HideShells=
HideUsers=
MaximumUid=60000
MinimumUid=1000
RememberLastSession=true
RememberLastUser=true
ReuseSession=false

[Wayland]
EnableHiDPI=false
SessionCommand=/usr/share/sddm/scripts/wayland-session
SessionDir=/usr/share/wayland-sessions
SessionLogFile=.local/share/sddm/wayland-session.log

[X11]
DisplayCommand=/usr/share/sddm/scripts/Xsetup
DisplayStopCommand=/usr/share/sddm/scripts/Xstop
EnableHiDPI=false
MinimumVT=7
ServerArguments=-nolisten tcp
ServerPath=/usr/bin/X
SessionCommand=/usr/share/sddm/scripts/Xsession
SessionDir=/usr/share/xsessions
SessionLogFile=.local/share/sddm/xorg-session.log
UserAuthFile=.Xauthority
XauthPath=/usr/bin/xauth
XephyrPath=/usr/bin/Xephyr
Z góry dziękuję za pomoc , pozdrawiam wszystkich serdecznie
Darek
Ps system Artix Linux /runit/

Online pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2694
  • Reputacja: +54/-38
Odp: witam , sddm autologowanie
« Odpowiedź #1 dnia: Sierpień 27, 2020, 03:22:37 pm »
Używanie SDDM z xfce jest z deka bez sensu. SDDM cały czas jest podniesiony i zabiera Ci z zasobów komputera (głównie RAM) część, która - jeśli nie używasz też aplikacji opartych o Qt5 nie będzie nawet współdzielona.
W przypadku KDE jest apka sddm-kcm, która ułatwia ustawianie SDDM; nie znam takiej dla innych środowisk, opartych o Gtk.
W istocie, wpis w sekcji autologin winien wyglądać mniej więcej tak, jak to masz (zob.: https://wiki.archlinux.org/index.php/SDDM#Autologin). O ile jednak pamiętam, to autologowanie się wymaga jeszcze jakichś ustawień PAM w przypadku SDDM. Niestety nie napisałeś jaka to dystrybucja i trochę ciężko dociec o co chodzi.

Offline robson75

  • Hero Member
  • *****
  • Wiadomości: 1476
  • Reputacja: +9/-1
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: witam , sddm autologowanie
« Odpowiedź #2 dnia: Sierpień 27, 2020, 04:00:53 pm »
Też jadę na Xfce4, ale używam LightDM, i mam włączony autologin. A tak wygląda część mojego pliku lightdm.conf

[Seat:*]
autologin-user=robson
autologin-session=xfce
#type=local
#pam-service=lightdm
#pam-autologin-service=lightdm-autologin
#pam-greeter-service=lightdm-greeter
#xserver-backend=
#xserver-command=X
#xmir-command=Xmir
#xserver-config=
#xserver-layout=
#xserver-allow-tcp=false
#xserver-share=true
#xserver-hostname=
#xserver-display-number=
#xdmcp-manager=
#xdmcp-port=177
#xdmcp-key=
#unity-compositor-command=unity-system-compositor
#unity-compositor-timeout=60
greeter-session=lightdm-gtk-greeter
#greeter-hide-users=false
#greeter-allow-guest=true
#greeter-show-manual-login=false
#greeter-show-remote-login=true
user-session=xfce
#allow-user-switching=true
#allow-guest=true
#guest-session=
session-wrapper=/etc/lightdm/Xsession
#greeter-wrapper=
#guest-wrapper=
#display-setup-script=
#display-stopped-script=
#greeter-setup-script=
#session-setup-script=
#session-cleanup-script=
#autologin-guest=false
#autologin-user-timeout=0
#autologin-in-background=false
#autologin-session=
#exit-on-failure=false

#
# XDMCP Server configuration
#
# enabled = True if XDMCP connections should be allowed
# port = UDP/IP port to listen for connections on
# listen-address = Host/address to listen for XDMCP connections (use all addresses if not present)
# key = Authentication key to use for XDM-AUTHENTICATION-1 or blank to not use authentication (stored in keys.conf)
# hostname = Hostname to report to XDMCP clients (defaults to system hostname if unset)
#
# The authentication key is a 56 bit DES key specified in hex as 0xnnnnnnnnnnnnnn.  Alternatively
# it can be a word and the first 7 characters are used as the key.
#
[XDMCPServer]
#enabled=false
#port=177
#listen-address=
#key=
#hostname=

#
# VNC Server configuration
#
# enabled = True if VNC connections should be allowed
# command = Command to run Xvnc server with
# port = TCP/IP port to listen for connections on
# listen-address = Host/address to listen for VNC connections (use all addresses if not present)
# width = Width of display to use
# height = Height of display to use
# depth = Color depth of display to use
#
[VNCServer]
#enabled=false
#command=Xvnc
#port=5900
#listen-address=
#width=1024
#height=768
#depth=8
I mam nadzieje że wykonałeś to co pisze na wiki
https://wiki.archlinux.org/index.php/LightDM#Enabling_autologin
Arch Linux Xfce+compiz - 64Bit Linux User #621110

Online pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2694
  • Reputacja: +54/-38
Odp: witam , sddm autologowanie
« Odpowiedź #3 dnia: Sierpień 27, 2020, 04:19:29 pm »
Robert, tyle, że to dla lightDM. I... moment... @darekradzan - w którym momencie musisz wpisać hasło?

Offline darekradzan

  • Sr. Member
  • ****
  • Wiadomości: 293
  • Reputacja: +0/-0
Odp: witam , sddm autologowanie
« Odpowiedź #4 dnia: Sierpień 27, 2020, 04:22:20 pm »
Dziękuję "Robsonie" , cały kłopot był trywialny, ale dzięki twojej sugestii doszedłem do niego , a mianowicie zamiast  w  /etc/sddm.conf


[Autologin]
Session=xfce4
User=darek

Powinno byc

[Autologin]
Session=xfce
User=darek

czyli bez 4 przy xfce , jeszcze raz wielkie dzięki , pozdarwiam

Offline darekradzan

  • Sr. Member
  • ****
  • Wiadomości: 293
  • Reputacja: +0/-0
Odp: witam , sddm autologowanie
« Odpowiedź #5 dnia: Sierpień 27, 2020, 04:28:44 pm »
Pawle zdaję sobie sprawę , ze korzystanie z sddm mija się z celem , ale zmiana menadżera logowania w artixie przysparza mi kłopoty  ( opieram się na wiki void linux , ze względu na runit) , dlatego tak podchodzę do tego, troszkę  od tylu.Jeszcze raz pozdrawiam Ciebie serdecznie.

P.s Sir Lucjan , kierowca bombowca, korzysta jeszcze z linuxa ?, bo dawno nigdzie go nie spotkałem na forum
« Ostatnia zmiana: Sierpień 27, 2020, 04:46:17 pm wysłana przez darekradzan »

Online pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2694
  • Reputacja: +54/-38
Odp: witam , sddm autologowanie
« Odpowiedź #6 dnia: Sierpień 27, 2020, 07:05:50 pm »
Ależ oczywiście, że Lucek korzysta z lina. Dokładnie z Archa. Mniej więcej tyle samo lat, co ja. Obaj jesteśmy na forum.archlinux.org.pl, #archlinux.org.pl na freenodzie.
No właśnie - tak jak w linku, który podałem. SDDM ciągnie info z /usr/share/xsessions/ dla Xów i z /usr/share/wayland-sessions/ dla Waylanda. Pliki tam mają postać *.desktop i trzeba dokładnie wpisać sesję o takiej nazwie, jaka tam jest uwidoczniona. Niektóre dystrybucje robią to 1:1 z upstreamem, a niektóre mają swoje "nawyki", stąd np. raz może tam być plasma.desktop, raz kde.desktop i obie wywołają Plazmę, ale SDDM pogubi się, gdy wpiszesz mu nie to co jest w tym katalogu. Nawet taka "4" robi różnicę.