Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: [ROZWIĄZANY] Wywala mi Curl  (Przeczytany 360 razy)

Offline Mamut

  • Jr. Member
  • **
  • Wiadomości: 66
  • Reputacja: +0/-0
[ROZWIĄZANY] Wywala mi Curl
« dnia: Lipiec 21, 2020, 12:03:22 pm »
Robię według tego:

https://www.cyberciti.biz/faq/howto-install-curl-command-on-debian-linux-using-apt-get/

ale są tam jakieś paczki, których nie chce mi zainstalować.

sudo apt install curl
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 curl : Depends: libcurl4 (= 7.64.0-4+deb10u1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

root@neutron:~# sudo apt update && sudo apt upgrade
Ign:1 http://deb.debian.org/debian stretch InRelease
Hit:2 http://deb.opera.com/opera-stable stable InRelease                       
Hit:3 http://deb.debian.org/debian stretch-updates InRelease                   
Hit:4 http://security.debian.org/debian-security stretch/updates InRelease     
Hit:5 http://security.debian.org stable/updates InRelease                     
Hit:6 http://deb.debian.org/debian stable-updates InRelease                   
Hit:7 http://www.deb-multimedia.org stretch InRelease                   
Hit:8 http://deb.debian.org/debian stretch Release
Reading package lists... Done                     
Building dependency tree       
Reading state information... Done
151 packages can be upgraded. Run 'apt list --upgradable' to see them.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  apache2-data apache2-utils apt apt-transport-https apt-utils bind9-host ca-certificates dnsutils e2fslibs e2fsprogs evince-common evolution-data-server-common exim4 exim4-base
  exim4-config exim4-daemon-light firefox-esr-l10n-en-gb gir1.2-javascriptcoregtk-4.0 gir1.2-lokdocview-0.1 gir1.2-pango-1.0 git-man imagemagick-6.q16 libcomerr2 libcomerr2:i386
  libebackend-1.2-10 libebook-contacts-1.2-2 libedata-book-1.2-25 libexpat1-dev libgs9-common libjavascriptcoregtk-4.0-18 libkf5config-data libkf5configcore5 libkf5configgui5 libnss3
  libqt5concurrent5 libqt5dbus5 libqt5printsupport5 libqt5sql5-sqlite libqt5test5 libqt5widgets5 libqt5xml5 libreoffice-base libreoffice-java-common libreoffice-kde libreoffice-l10n-en-gb
  libreoffice-math libreoffice-ogltrans libreoffice-report-builder-bin libreoffice-script-provider-js libreoffice-script-provider-python libreoffice-sdbc-postgresql
  libreoffice-style-breeze libreofficekit-data libsasl2-2 libss2 libssl-dev libwbclient0 openssl ppp qt5-gtk-platformtheme uno-libs3 ure
0 upgraded, 0 newly installed, 0 to remove and 62 not upgraded.




« Ostatnia zmiana: Lipiec 29, 2020, 01:04:30 pm wysłana przez Mamut »
Abnormal Termination Error Processing Request

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1712
  • Reputacja: +1/-0
Odp: Wywala mi Curl
« Odpowiedź #1 dnia: Lipiec 21, 2020, 12:24:42 pm »
Masz pomieszane repozytoria Debiana stable i oldstable.
Większość repozytoriów wskazuje na oldstable Stretch, dwa na stable.
Zakomentuj repo :
http://security.debian.org stable/updates
http://deb.debian.org/debian stable-updates
czyli wstaw # na początku linii:
#http://security.debian.org stable/updates
#http://deb.debian.org/debian stable-updates
w pliku:
/etc/apt/sources.listlub w którymś z plików w katalogu:
/etc/apt/sources.list.d/następnie odśwież listę pakietów:
sudo apt-get updatei ponownie spróbuj zainstalować pakiet curl
« Ostatnia zmiana: Lipiec 21, 2020, 01:08:11 pm wysłana przez pavroo »
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline Mamut

  • Jr. Member
  • **
  • Wiadomości: 66
  • Reputacja: +0/-0
Odp: Wywala mi Curl
« Odpowiedź #2 dnia: Lipiec 21, 2020, 02:24:33 pm »
Zrobiłem tak i w  sources.list mam teraz tak:

# Stretch
deb http://deb.debian.org/debian stretch main contrib non-free
deb http://deb.debian.org/debian stretch-updates main contrib non-free
deb http://security.debian.org/debian-security/ stretch/updates main contrib non-free



deb http://www.deb-multimedia.org stretch main non-free

# deb https://dl.winehq.org/wine-builds/debian/ stretch main
# deb-src https://dl.winehq.org/wine-builds/debian/ stretch main
deb http://deb.opera.com/opera-stable/ stable non-free


#http://security.debian.org/ stable/updates main contrib non-free
#http://deb.debian.org/debian stable-updates main contrib non-free

update

root@neutron:~# sudo apt update
Ign:1 http://deb.debian.org/debian stretch InRelease
Hit:2 http://security.debian.org/debian-security stretch/updates InRelease     
Hit:3 http://deb.debian.org/debian stretch-updates InRelease                   
Hit:4 http://deb.opera.com/opera-stable stable InRelease                       
Hit:5 http://www.deb-multimedia.org stretch InRelease                         
Hit:6 http://deb.debian.org/debian stretch Release                       
Reading package lists... Done                     
Building dependency tree       
Reading state information... Done
4 packages can be upgraded. Run 'apt list --upgradable' to see them.

Wiem że mam tam bałagan ale ja nie umiem tego znaleźć i jak to ustawić?
W /etc/apt/sources.list.d katalog jest pusty.

« Ostatnia zmiana: Lipiec 21, 2020, 02:28:25 pm wysłana przez Mamut »
Abnormal Termination Error Processing Request

Online pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2577
  • Reputacja: +35/-9
Odp: Wywala mi Curl
« Odpowiedź #3 dnia: Lipiec 21, 2020, 05:25:55 pm »
Obecnie w repozytoriach porządek jest (nie wiem jedynie czy opera-stable jest dla stretch). Co chcesz obecnie zrobić? Masz zsynchronizowane repozytoria, z informacji wynika, że są 4 paczki, które możesz zaktualizować (zatem nie update, a upgrade, o ile pamiętam). Możesz też je zobaczyć wg komendy, która Ci się pokazała.
Jeśli chcesz instalować curl - to po prostu instaluj.

Offline Mamut

  • Jr. Member
  • **
  • Wiadomości: 66
  • Reputacja: +0/-0
Odp: Wywala mi Curl
« Odpowiedź #4 dnia: Lipiec 28, 2020, 09:49:17 am »
...wstaw # na początku linii:
#http://security.debian.org stable/updates
#http://deb.debian.org/debian stable-updates
Po tej zmianie update i upgrade poszły prawidłowo  i curl się zainstalował. Dzięki wielkie.
Abnormal Termination Error Processing Request

Offline lami07

  • Global Moderator
  • Sr. Member
  • *****
  • Wiadomości: 493
  • Reputacja: +1/-0
Odp: Wywala mi Curl
« Odpowiedź #5 dnia: Lipiec 28, 2020, 09:38:51 pm »
Oznacz wątek jako [ROZWIĄZANY].
IRC - #linuxiarze.pl w sieci freenode.net
Matrix - #linuxiarze.pl w sieci matrix.org