Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: problem z aktualizacją z AUR  (Przeczytany 1629 razy)

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2318
  • Reputacja: +16/-5
Odp: problem z aktualizacją z AUR
« Odpowiedź #45 dnia: Maj 24, 2020, 06:08:35 pm »
Samo w sobie, to nic nie robi. Ot, zainstalowałeś jako zależność innego programu, którego obecnie już nie masz. W sumie - możesz odinstalować i po kłopocie.

PS: Nie, moja "aktualizacja" w POLAUR tego typu paczek jest na indywidualne życzenie, zgłaszane na forum.archlinux.org.pl. Jak nie jest zgłoszone - to nie mam ochoty się bawić. Pewnie inni, którzy pracują nad POLAUR również.

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 400
  • Reputacja: +0/-0
Odp: problem z aktualizacją z AUR
« Odpowiedź #46 dnia: Maj 24, 2020, 09:29:20 pm »
@pavbaranov

Zrobione. Dzięki za pomoc. Zdrowia.


PS.
Wykombinowałem, że omawiana [java-openjfx] była potrzebna do zainstalowania ZOOM-a. Wnioskuję z tego, że problem był na laptopie, na którym niedawno zainstalowałem ZOOM-a, a na netbooku tego nie uczyniłem. Poza tym staram się aby wszystko było na obu maszynach jednakowe.
Jedyna różnica, to niedawno doinstalowany ZOOM na laptopie..
« Ostatnia zmiana: Maj 25, 2020, 03:06:34 pm wysłana przez Piejanto »

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 400
  • Reputacja: +0/-0
Odp: problem z aktualizacją z AUR
« Odpowiedź #47 dnia: Maj 27, 2020, 11:48:54 am »
Dziś, podczas aktualizacji z AUR, otrzymałem następujący komunikat:


:: Uruchamianie aktualizacji z AUR...
ostrzeżenie: idnkit => zainstalowana: 2.3-4, dostępna: 2.3-4, opiekun: Brak, oflagowana: Nie
 nie ma nic do zrobienia

:: Uruchamianie aktualizacji z POLAUR...
 nie ma nic do zrobienia

Czy powinienem się przejmować?

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2318
  • Reputacja: +16/-5
Odp: problem z aktualizacją z AUR
« Odpowiedź #48 dnia: Maj 27, 2020, 12:34:03 pm »
Czym? Bo ja nie wiem, co tu nie jest jasne. Paczka idnkit nie ma opiekuna, co oznacza, że wszelkie z nią problemy, także ewentualną aktualizację (jak na razie nie jest to potrzebne), przebudowanie, gdy będzie (o ile) to potrzebne, obciążają użytkownika. Nic więcej.

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 400
  • Reputacja: +0/-0
Odp: problem z aktualizacją z AUR
« Odpowiedź #49 dnia: Maj 27, 2020, 11:27:31 pm »
@pavbaranov
Dzięki.
Po kolejnej aktualizacji całości, znów pokazała mi się informacja :

" :: Uruchamianie aktualizacji z AUR...
ostrzeżenie: idnkit => zainstalowana: 2.3-4, dostępna: 2.3-4, opiekun: Brak, oflagowana: Nie
 nie ma nic do zrobienia "

Czy to oznacza, ze teraz już zawsze będę miał tę informację o tym pakiecie?  Nie żeby mi to jakoś przeszkadzało, ale tak pytam z ciekawości.
Dobra.. sprawdzę do czego to w ogóle jest i zdecyduję, co zrobić.

@pavbaranow
Jak zagadać w sprawie ewentualnego Linuxa na nową maszynę bez systemu? Chciałbym mieć Archa, ale chyba nie dam rady z instalacją.
Myślałem też o Manjaro...
Ale to już nowy temat.


A wracając do tematu:

pak -Qi idnkit
Używana jest konfiguracja użytkownika: /home/jan/.config/pak/pak.conf

Nazwa                 : idnkit
Wersja                : 2.3-4
Opis                  : Provides functionalities about Internationalized Domain
                        Name processing
Architektura          : any
Adres url             : https://www.nic.ad.jp/ja/idn/idnkit/download/
Licencje              : custom:BSD
Grupy                 : Brak
Dostarcza             : Brak
Zależy od             : glibc
Opcjonalne zależności : Brak
Wymagany przez        : Brak
Opcjonalny dla        : Brak
Konfliktuje z         : Brak
Zastępuje             : Brak
Rozmiar po instalacji : 1481,66 KiB
Autor pakietu         : Unknown Packager
Data zbudowania       : nie, 29 mar 2020, 12:33:27
Data zainstalowania   : nie, 29 mar 2020, 12:35:25
Powód zainstalowania  : Zależność innego pakietu
Skrypt instalacyjny   : Nie
Potwierdzone przez    : Brak

Taki jest wynik sprawdzania pakietu [idnkit]...  Wywalić?
« Ostatnia zmiana: Maj 27, 2020, 11:35:28 pm wysłana przez Piejanto »

Offline robson75

  • Hero Member
  • *****
  • Wiadomości: 1370
  • Reputacja: +2/-0
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: problem z aktualizacją z AUR
« Odpowiedź #50 dnia: Maj 27, 2020, 11:39:35 pm »
Jak zagadać w sprawie ewentualnego Linuxa na nową maszynę bez systemu? Chciałbym mieć Archa, ale chyba nie dam rady z instalacją.
Myślałem też o Manjaro...
Tylko nie Manjaro, to jest taki potworek podszywający się pod Archa. Bier Anarchy, na pewno sobie poradzisz z instalacją.
Arch Linux Xfce+compiz - 64Bit Linux User #621110

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2318
  • Reputacja: +16/-5
Odp: problem z aktualizacją z AUR
« Odpowiedź #51 dnia: Maj 28, 2020, 12:06:16 am »
@pavbaranov
Dzięki.
Po kolejnej aktualizacji całości, znów pokazała mi się informacja :

" :: Uruchamianie aktualizacji z AUR...
ostrzeżenie: idnkit => zainstalowana: 2.3-4, dostępna: 2.3-4, opiekun: Brak, oflagowana: Nie
 nie ma nic do zrobienia "

Czy to oznacza, ze teraz już zawsze będę miał tę informację o tym pakiecie? 
Informacja, którą masz dotyczy wyłącznie porzucenia (orphaned) czegoś w AUR. I dopóki nie pojawi się ktoś, kto tę paczkę przejmie - będziesz mieć tego typu informację.

Cytuj
Jak zagadać w sprawie ewentualnego Linuxa na nową maszynę bez systemu? Chciałbym mieć Archa, ale chyba nie dam rady z instalacją.
Nie rozumiem pytania, ale najprościej Archa zainstalować przez Anarchy Linux ew. przez EndeavourOS.

Cytuj
Myślałem też o Manjaro...
Nie, żebym wrogowi tego nie polecał, ale jako były użytkownik Manjaro, przeglądnąwszy ich paczki/PKGBUILDy/rozwiązania - nie polecę tego nikomu. Nie chce mi się robić gównoburzy dlaczego i nie będę na ten temat odpowiadać dopóki konkretne pytania nie zostaną zadane i postawione i przez osoby, które mają jakąkolwiek wiedzę, by można było nawiązać normalną rozmowę.
Jeśli chcesz mieć Manjaro - ok - nikt Ci tego nie broni. Ten system może w Twoim przypadku sprawdzić się w 100%. Jeśli Ci przypasuje - polecam forum.manjaro.pl - to jedyne, które na pewno wspiera ten system. Z mojej strony na pewno jednak żadnego "wsparcia" dla niego nie otrzymasz. I proszę traktuj to po prostu informacyjnie. Po prostu: Manjaro - ja się nie znam, nic nie mówię, nic nie twierdzę - nie ma mnie. Tyle.

Cytuj
A wracając do tematu:

Wymagany przez        : Brak
Opcjonalny dla        : Brak
Powód zainstalowania  : Zależność innego pakietu

Taki jest wynik sprawdzania pakietu [idnkit]...  Wywalić?
[/quote]

Janek, błagam... Skąd ja bidny mam wiedzieć, czy ta paczka jest Ci do czegokolwiek potrzebna. Wyciąłem z informacji to co istotne:
- paczka nie jest wymagana przez żadną inną (co nie oznacza, że z innego powodu nie chcesz jej mieć),
- paczka nie jest opcjonalną zależnością dla żadnej innej (i jw.),
- zainstalowana została w systemie jako zależność jakiejś innej paczki, której obecnie w systemie nie masz.
Masz pełną wiedzę jak dalej postąpić sprowadzającą się do odpowiedzi na pytanie - czy tej paczki (czyli programów/aplikacji/binarek) używam - wówczas zostaw, czy też nie - wówczas możesz wywalić.

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 400
  • Reputacja: +0/-0
Odp: problem z aktualizacją z AUR
« Odpowiedź #52 dnia: Maj 28, 2020, 05:09:39 pm »
robson75
Dzięki. O Anarchy nawet nie wiedziałem.
W sumie na Archu czuję się najlepiej, bo chyba już przewalczyłem wszystko najgorsze. Dzięki Wam (nawiasem mówiąc).
No właśnie wiedziałem, ze jest jakiś pomocnik do instalacji Archa.
Dzięki

« Ostatnia zmiana: Maj 28, 2020, 05:11:55 pm wysłana przez Piejanto »

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 400
  • Reputacja: +0/-0
Odp: problem z aktualizacją z AUR
« Odpowiedź #53 dnia: Maj 28, 2020, 05:28:00 pm »
@pavbaranov
Rozumiem. Qrdę... trudna decyzja (jak dla mnie). A jeśli usunę, to powinienem w razie czegoś otrzymać informację o braku tej paczki?

Dzięki za informację o Manjaro. Spróbuję zainstalować jednak Archa tak jak mi radzisz Ty i  @robson75.
Muszę się ino do tego jakosi przygotować.
Poczytać i pooglądać jakieś poradniki. Mam całkiem czystego Asusa, więc instalacja będzie na całym gołym dysku.
Spróbuję.

PS
W sprawie zagadania o wyborze systemu miałem na myśli jak to zrobić tu, u Linuxiarzy.pl , bo temay tutaj są podzielone na różne Linuxy.


 i jeszcze:
" Skąd ja bidny mam wiedzieć, czy ta paczka jest Ci do czegokolwiek potrzebna. Wyciąłem z informacji to co istotne:
- paczka nie jest wymagana przez żadną inną (co nie oznacza, że z innego powodu nie chcesz jej mieć),"

Dzięki. Nie nie ma innego powodu, dla którego pragnę mieć paczkę [idnkit]. Ani praktycznych ani estetycznych. Nie znam jej.

Ale obecnie już sprawa jest bezprzedmiotowa, skoro Ty i @robson75 twierdzicie, że jednak Arch
« Ostatnia zmiana: Maj 28, 2020, 05:34:33 pm wysłana przez Piejanto »

Offline ciubaka

  • Sr. Member
  • ****
  • Wiadomości: 436
  • Reputacja: +4/-1
Odp: problem z aktualizacją z AUR
« Odpowiedź #54 dnia: Maj 28, 2020, 05:38:28 pm »
A ja - patrząc na Twoje zmagania z Twoją ulubioną dystrybucją - namawiam Cię do zainstalowania czegokolwiek prostszego. Naprawdę, bez żartów. Najwyżej wywalisz. I wtedy wgrasz co innego - inną prostą na przykład. Lub Archa. Spróbuj, to nie boli!

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2318
  • Reputacja: +16/-5
Odp: problem z aktualizacją z AUR
« Odpowiedź #55 dnia: Maj 28, 2020, 05:45:56 pm »
@ciubaka - Siedzę na linuksach naście lat. Arch jest wprawdzie do co najmniej średniozaawansowanych, ale jego prostota jest powalająca. Debian? Ubuntu? Kudy im do tego :)

Offline ciubaka

  • Sr. Member
  • ****
  • Wiadomości: 436
  • Reputacja: +4/-1
Odp: problem z aktualizacją z AUR
« Odpowiedź #56 dnia: Maj 28, 2020, 05:51:54 pm »
Pawle, z Tobą to ja mogę o siatkówce popolemizować, nie o linuxach :-) A buntu jakieś Janek na próbę by mógł sobie wgrać, tak dla sportu :-) Jakby się tak dobrze napatrzył, to by potem bardziej nienawidził wraże plemię :-)
« Ostatnia zmiana: Maj 28, 2020, 06:00:14 pm wysłana przez ciubaka »

Offline robson75

  • Hero Member
  • *****
  • Wiadomości: 1370
  • Reputacja: +2/-0
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: problem z aktualizacją z AUR
« Odpowiedź #57 dnia: Maj 28, 2020, 06:24:10 pm »
A buntu jakieś Janek na próbę by mógł sobie wgrać, tak dla sportu :-) Jakby się tak dobrze napatrzył, to by potem bardziej nienawidził wraże plemię :-)
@ciubaka
Mogę Cię zapewnić że Arch jest mniej wymagającym system niż Ubuntu, bo raz postawiony Arch nie wymaga takiego dłubania jak to jest w Ubuntu. Trzeba tylko dbać o ciągłość aktualizacji.
Arch Linux Xfce+compiz - 64Bit Linux User #621110

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2318
  • Reputacja: +16/-5
Odp: problem z aktualizacją z AUR
« Odpowiedź #58 dnia: Maj 28, 2020, 07:40:35 pm »
@ciubaka & @robson75 - To wszystko zależy od tego co rozumiemy pod "wymagający". Sorry - Janek nie jest pozbawiony mózgu i pomiędzy uszami nie ma galaretki. Jeśli ktoś instaluje system i nic nie chce z nim robić, bo mu podano na tacy, to tak - jakieś Ubu jest super. Najlepiej LTS. Minie 5 lat i... No właśnie - podejdzie do tego jak do Windowsa: pojawił się "nowy" system - stary muszę wywalić, nowy zainstalować. Tzw. upgrade może, ale nie musi się udać.
Systemy rolling, w tym głównie Arch mają to do siebie, że na początku posiedzimy chwilę. Trzeba się zdecydować na instalację określonego oprogramowania, bo nikt za mnie tego nie wymyślił. Być może trzeba będzie zrobić jakąś konfigurację (no, ale być może w "Ubu" również - tu nic się nie zmienia). I jak już spędzę tych kilka chwil na początku, to ręczę (podobnie jak to pisze Robert) - Arch jest jednym z najmniej wymagających od użytkownika systemów. Po prostu używać, aktualizować, używać... Nie zaskoczy mnie coś jak w Debianie, że po instalacji nowej wersji mam 1/4 pulpitu i jestem odganiany od jednego do drugiego miejsca, w którym błąd mogę zgłosić, a i tak to będzie moja wina (nie dotyczy to Ubu - tu jest zdecydowanie lepiej). Czy może coś się wydarzyć? Ależ oczywiście, że może. Używając jednak sprzętu, który linux lubi prawdopodobieństwo, że ten system przestanie działąć jest mizerne.
Fakt - trzeba czytać.
Zatem pomimo tego, że Janek może się nam jawić jako linuksowy "neptyk", to facet nie poddaje się, stara się zrozumieć o co w tym wszystkim chodzi itd. itp. To, że zadaje tu czasem pytania, które wydawać się mogą idiotyczne, dla kogoś, kto bardziej rozumie o co w tym wszystkim chodzi, to jedno. Niemniej jednak - nie upiera się, że amdgpu jest closed software, choć nie ma na ten temat żadnej wiedzy. W sumie obserwując go od kilku już ładnych lat - ja na jego miejscu nie bałbym się Archa. Fakt - zainstalowałbym go przez Anarchy, przez Endeavour lub coś takiego. Później już będzie "z górki".
Powodzenia Janku!

Offline ciubaka

  • Sr. Member
  • ****
  • Wiadomości: 436
  • Reputacja: +4/-1
Odp: problem z aktualizacją z AUR
« Odpowiedź #59 dnia: Maj 28, 2020, 08:29:32 pm »
Zaprawdę powiadam Wam - nie jest Janek linuxowym neptykiem! Na pewno ja jestem nim prędzej niż on (ba, przyznam się - po prostu nim jestem). Ale parę rzeczy widziałem, paru spróbowałem, każdego zawsze zachęcę też do prób własnych. Dowolnych. Gdyby mi kiedyś kolega Mięty nie pokazał to do dziś siedziałbym w okienkach.
Janku - powodzenia. I nie zamykaj się tylko w tym co masz. Pawle i Robercie - dzięki że jesteście. Całej załodze portalu - szacun.
PS. Używam produktów debianopochodnych głównie, i z tych 4 które mam (xubu, lubu, sparx i mx) żadna nie sprawiła mi kłopotu od dawna :-)