Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: problem z aktualizacją z AUR  (Przeczytany 2255 razy)

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 413
  • Reputacja: +0/-0
problem z aktualizacją z AUR
« dnia: Kwiecień 16, 2020, 10:51:56 pm »
Od wczoraj próbuję zaktualizować Skype z AUR za pomocą [pak'a]
Zabiera się do aktualizacji i kończy komunikatem " (END) " bez żadnego rezultatu.
Wygląda to tak:

[jan@piejanto ~]$ pak -Syu
:: Uruchamianie aktualizacji systemu...

Pakiety do aktualizacji:
chromium 81.0.4044.92-1 => 81.0.4044.113-1
libreoffice-fresh 6.4.2-2 => 6.4.3-1
libreoffice-fresh-pl 6.4.2-1 => 6.4.3-1
libtirpc 1.2.5-1 => 1.2.6-1
man-pages 5.05-2 => 5.06-1
perl-alien-build 2.20-1 => 2.21-1
pygtk 2.24.0-11 => 2.24.0-12
xf86-video-intel 1:2.99.917+899+gf66d3954-1 => 1:2.99.917+901+gf2a54e25-1

:: Zaktualizować pakiety? [T/n]
[sudo] hasło użytkownika jan:
:: Synchronizowanie baz danych z pakietami…
 core                  135,1 KiB  2,09 MiB/s 00:00 [######################] 100%
 extra                1648,0 KiB  6,88 MiB/s 00:00 [######################] 100%
 community               4,9 MiB  2,82 MiB/s 00:02 [######################] 100%
 multilib jest aktualne
 chaotic-aur           988,5 KiB   738 KiB/s 00:01 [######################] 100%
:: Rozpoczynanie pełnej aktualizacji systemu…
rozwiązywanie zależności…
szukanie sprzecznych pakietów...

Pakiety (8) chromium-81.0.4044.113-1  libreoffice-fresh-6.4.3-1
            libreoffice-fresh-pl-6.4.3-1  libtirpc-1.2.6-1  man-pages-5.06-1
            perl-alien-build-2.21-1  pygtk-2.24.0-12
            xf86-video-intel-1:2.99.917+901+gf2a54e25-1

Do pobrania:             196,95 MiB
Do zainstalowania:       607,67 MiB
Zmiana po aktualizacji:    0,09 MiB

:: Kontynuować instalację? [T/n] T
:: Pobieranie pakietów…
 libtirpc-1.2.6-1...   177,2 KiB  2,37 MiB/s 00:00 [######################] 100%
 man-pages-5.06-1-any    5,7 MiB  4,99 MiB/s 00:01 [######################] 100%
 chromium-81.0.40...    58,1 MiB  3,41 MiB/s 00:17 [######################] 100%
 libreoffice-fres...   127,9 MiB  3,02 MiB/s 00:42 [######################] 100%
 libreoffice-fres...     3,2 MiB  4,03 MiB/s 00:01 [######################] 100%
 perl-alien-build...   323,3 KiB  1796 KiB/s 00:00 [######################] 100%
 xf86-video-intel...   737,2 KiB  3,55 MiB/s 00:00 [######################] 100%
 pygtk-2.24.0-12-...   923,5 KiB   700 KiB/s 00:01 [######################] 100%
(8/8) sprawdzanie kluczy w bazie                   [######################] 100%
(8/8) sprawdzanie spójności pakietów               [######################] 100%
(8/8) wczytywanie listy plików                     [######################] 100%
(8/8) sprawdzanie konfliktów plików                [######################] 100%
(8/8) sprawdzanie dostępnego miejsca na dysku      [######################] 100%
:: Przetwarzanie zmian pakietu...
(1/8) aktualizowanie libtirpc                      [######################] 100%
ostrzeżenie: Różne uprawnienia dla katalogu dla /etc/
system plików: 777 pakiet: 755
(2/8) aktualizowanie chromium                      [######################] 100%
(3/8) aktualizowanie libreoffice-fresh             [######################] 100%
ostrzeżenie: Różne uprawnienia dla katalogu dla /etc/
system plików: 777 pakiet: 755
(4/8) aktualizowanie libreoffice-fresh-pl          [######################] 100%
(5/8) aktualizowanie man-pages                     [######################] 100%
(6/8) aktualizowanie perl-alien-build              [######################] 100%
(7/8) aktualizowanie pygtk                         [######################] 100%
(8/8) aktualizowanie xf86-video-intel              [######################] 100%
:: Uruchamianie po-transakcji...
(1/5) Arming ConditionNeedsUpdate...
(2/5) Warn about old perl modules
(3/5) Updating icon theme caches...
(4/5) Updating the desktop file MIME type cache...
(5/5) Updating the MIME type database...

:: Uruchamianie aktualizacji z AUR...
ostrzeżenie: skypeforlinux-stable-bin => zainstalowana: 8.58.0.93-1, dostępna: 8.59.0.77-1, opiekun: bulletmark, oflagowana: Nie

Pakiety do aktualizacji:
skypeforlinux-stable-bin 8.58.0.93-1 => 8.59.0.77-1

ostrzeżenie: Pakiety zostaną zaktualizowane w kolejności alfabetycznej. Przerwij aktualizację, jeśli jakikolwiek pakiet musi zostać zaktualizowany przed innym widniejącym na liście. W takim przypadku wykonaj pak -SA nazwa_pakietu, następnie uruchom aktualizację jeszcze raz.

:: Zaktualizować pakiety? [T/n]
:: Uruchamianie aktualizacji systemu...
[sudo] hasło użytkownika jan:
:: Synchronizowanie baz danych z pakietami…
 core jest aktualne
 extra jest aktualne
 community jest aktualne
 multilib jest aktualne
 chaotic-aur jest aktualne
:: Rozpoczynanie pełnej aktualizacji systemu…
 nie ma nic do zrobienia

:: Instalowanie pakietu skypeforlinux-stable-bin

:: Najnowsze zmiany...
diff --git a/.SRCINFO b/.SRCINFO
index fdbc052..c67deba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
 pkgbase = skypeforlinux-stable-bin
        pkgdesc = Skype for Linux - Stable/Release Version
-       pkgver = 8.58.0.93
+       pkgver = 8.59.0.77
        pkgrel = 1
        url = http://www.skype.com
        install = install.sh
@@ -22,8 +22,8 @@ pkgbase = skypeforlinux-stable-bin
        conflicts = skypeforlinux-preview-bin
        conflicts = skypeforlinux-beta-bin
        conflicts = skype
-       source = https://repo.skype.com/deb/pool/main/s/skypeforlinux/skypeforlinux_8.58.0.93_amd64.deb
-       sha256sums = 836e25800320d96e8d35d05e60b98a6dd4da077f02880c9e34097d50686c0adb
+       source = https://repo.skype.com/deb/pool/main/s/skypeforlinux/skypeforlinux_8.59.0.77_amd64.deb
+       sha256sums = d1d86a16127e6a3ff0777954ef7afb6a2b19e1fec0f41125f78224822ee5d4b2
 
 pkgname = skypeforlinux-stable-bin
 
diff --git a/PKGBUILD b/PKGBUILD
index 7e74b91..6f5476b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
 
 _pkgname=skypeforlinux
 pkgname=$_pkgname-stable-bin
-pkgver=8.58.0.93
+pkgver=8.59.0.77
 pkgrel=1
 pkgdesc="Skype for Linux - Stable/Release Version"
 arch=("x86_64")
@@ -18,7 +18,7 @@ install=install.sh
 source=(
 "https://repo.skype.com/deb/pool/main/s/$_pkgname/${_pkgname}_${pkgver}_amd64.deb"
 )
-sha256sums=('836e25800320d96e8d35d05e60b98a6dd4da077f02880c9e34097d50686c0adb')
+sha256sums=('d1d86a16127e6a3ff0777954ef7afb6a2b19e1fec0f41125f78224822ee5d4b2')
 
 package() {
   tar --no-same-owner -xJC "$pkgdir" -f data.tar.xz
(END)


O co chodzi?
Czy powinienem odinstalować Skype i ponownie zainstalować?
 Pierwszy raz uruchomiła mi się aktualizacja z AUR.

« Ostatnia zmiana: Kwiecień 16, 2020, 11:13:43 pm wysłana przez lami07 »

Offline nycko

  • Newbie
  • *
  • Wiadomości: 24
  • Reputacja: +1/-0
Odp: problem z aktualizacją z AUR
« Odpowiedź #1 dnia: Kwiecień 17, 2020, 09:30:33 am »
Wciśnij q by przejść do kolejnego etapu. Ten komunikat można wyłączyć jeśli powoduje u Ciebie konsternację.

Skopiuj domyślna konfigurację do swojego katalogu HOME, jeśli do tej pory tego nie zrobiłeś
mkdir -p ~/.config/pak && cp /etc/xdg/pak.conf ~/.config/pak/i zmień tam opcję show_diff z 1 na 0

PS. zwróć też uwagę na ten komunikat:
Cytuj
ostrzeżenie: Różne uprawnienia dla katalogu dla /etc/
system plików: 777 pakiet: 755
i w razie problemów załóż nowy wątek, bo to nie powinno się wydarzyć w dobrze użytkowanym systemie.
« Ostatnia zmiana: Kwiecień 17, 2020, 10:54:55 am wysłana przez nycko »

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 413
  • Reputacja: +0/-0
Odp: problem z aktualizacją z AUR
« Odpowiedź #2 dnia: Kwiecień 17, 2020, 01:46:46 pm »
Dzięki.
Faktycznie mam kłopot z doczytywaniem komunikatów. Przepraszam. To jednak chyba sprawa oczu.
Ale się staram, tylko mam trudności z koncentracją wzroku. Jednak komunikaty nie wprawiają mnie w konsternację.

Co do komunikatu:

"ostrzeżenie: Różne uprawnienia dla katalogu dla /etc/
system plików: 777 pakiet: 755"

Pojawia mi się on od czasu, gdy zainstalowałem modem do odbioru TV. To już parę lat tak jadę z tym komunikatem.
Można powiedzieć, że wiem o tym komunikacie i go akceptuję.
Jeśli stanowi jakieś większe zagrożenie, proszę o sugestie.
Dzięki
« Ostatnia zmiana: Kwiecień 17, 2020, 01:51:30 pm wysłana przez Piejanto »

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 413
  • Reputacja: +0/-0
Odp: problem z aktualizacją z AUR
« Odpowiedź #3 dnia: Kwiecień 17, 2020, 02:28:21 pm »
Wcisnąłem - zgodnie z Twoją radą - [q] i aktualizacja ruszyła. Jednak tym razem nie miiałem na końcu "etapu" komunikatu:

" tar --no-same-owner -xJC "$pkgdir" -f data.tar.xz
(END)"

To znaczy, że aktualizacja z AUR (z niewiadomych przyczyn) przebiegała nieco inaczej.

Tutaj wklejam całość przeprowadzonej aktualizacji z AUR, która się zatrzymała po czerwonych i zielonych textach, cytuję:
-       source = https://repo.skype.com/deb/pool/main/s/skypeforlinux/skypeforlinux_8.58.0.93_amd64.deb
-       sha256sums = 836e25800320d96e8d35d05e60b98a6dd4da077f02880c9e34097d50686c0adb
+       source = https://repo.skype.com/deb/pool/main/s/skypeforlinux/skypeforlinux_8.59.0.77_amd64.deb
+       sha256sums = d1d86a16127e6a3ff0777954ef7afb6a2b19e1fec0f41125f78224822ee

i ruszyła dalej po wciśnięciu [q]

Całość wygląda tak jak niżej i jest dobrze. Na razie nie poprawiałem katalogu HOME i niewiem czy jest w obecnej sytuacji taka potrzeba. Na wszelki wypadek tamto rozwiązanie wpisałem sobie do swojego podręcznika.
NIŻEJ CAŁOŚĆ AKTUALIZACJI


:: Uruchamianie aktualizacji z AUR...
ostrzeżenie: skypeforlinux-stable-bin => zainstalowana: 8.58.0.93-1, dostępna: 8.59.0.77-1, opiekun: bulletmark, oflagowana: Nie

Pakiety do aktualizacji:
skypeforlinux-stable-bin 8.58.0.93-1 => 8.59.0.77-1

ostrzeżenie: Pakiety zostaną zaktualizowane w kolejności alfabetycznej. Przerwij aktualizację, jeśli jakikolwiek pakiet musi zostać zaktualizowany przed innym widniejącym na liście. W takim przypadku wykonaj pak -SA nazwa_pakietu, następnie uruchom aktualizację jeszcze raz.

:: Zaktualizować pakiety? [T/n]
:: Uruchamianie aktualizacji systemu...
[sudo] hasło użytkownika jan:
:: Synchronizowanie baz danych z pakietami…
 core jest aktualne
 extra jest aktualne
 community jest aktualne
 multilib jest aktualne
 chaotic-aur jest aktualne
:: Rozpoczynanie pełnej aktualizacji systemu…
 nie ma nic do zrobienia

:: Instalowanie pakietu skypeforlinux-stable-bin

:: Najnowsze zmiany...
diff --git a/.SRCINFO b/.SRCINFO
index fdbc052..c67deba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
 pkgbase = skypeforlinux-stable-bin
        pkgdesc = Skype for Linux - Stable/Release Version
-       pkgver = 8.58.0.93
+       pkgver = 8.59.0.77
        pkgrel = 1
        url = http://www.skype.com
        install = install.sh
@@ -22,8 +22,8 @@ pkgbase = skypeforlinux-stable-bin
        conflicts = skypeforlinux-preview-bin
        conflicts = skypeforlinux-beta-bin
        conflicts = skype
-       source = https://repo.skype.com/deb/pool/main/s/skypeforlinux/skypeforlinux_8.58.0.93_amd64.deb
-       sha256sums = 836e25800320d96e8d35d05e60b98a6dd4da077f02880c9e34097d50686c0adb
+       source = https://repo.skype.com/deb/pool/main/s/skypeforlinux/skypeforlinux_8.59.0.77_amd64.deb
+       sha256sums = d1d86a16127e6a3ff0777954ef7afb6a2b19e1fec0f41125f78224822ee
:: Sprawdzanie poprawności PKGBUILD...
namcap nie jest zainstalowany

:: Edytować PKGBUILD? (t/n)
Przerwane przez użytkownika

:: Kontynuować? [T/n]
Enter zatwierdza wybór: T

:: Szukanie zależności
==> Tworzenie pakietu: skypeforlinux-stable-bin 8.59.0.77-1 (pią, 17 kwi 2020, 14:17:22)
==> Sprawdzanie zależności potrzebnych do uruchomienia...
==> Sprawdzanie zależności potrzebnych do budowy...
==> Instalowanie brakujących zależności...
[sudo] hasło użytkownika jan:
rozwiązywanie zależności…
szukanie sprzecznych pakietów...

Pakiety (3) c-ares-1.16.0-1  nodejs-13.13.0-1  asar-3.0.3-1

Do pobrania:         7,53 MiB
Do zainstalowania:  27,26 MiB

:: Kontynuować instalację? [T/n] T
:: Pobieranie pakietów…
 c-ares-1.16.0-1-...   117,4 KiB  1957 KiB/s 00:00 [######################] 100%
 nodejs-13.13.0-1...     7,4 MiB  4,60 MiB/s 00:02 [######################] 100%
 asar-3.0.3-1-any       57,1 KiB  7,96 MiB/s 00:00 [######################] 100%
(3/3) sprawdzanie kluczy w bazie                   [######################] 100%
(3/3) sprawdzanie spójności pakietów               [######################] 100%
(3/3) wczytywanie listy plików                     [######################] 100%
(3/3) sprawdzanie konfliktów plików                [######################] 100%
(3/3) sprawdzanie dostępnego miejsca na dysku      [######################] 100%
:: Przetwarzanie zmian pakietu...
(1/3) instalowanie c-ares                          [######################] 100%
(2/3) instalowanie nodejs                          [######################] 100%
Opcjonalne zależności dla nodejs
    npm: nodejs package manager
(3/3) instalowanie asar                            [######################] 100%
:: Uruchamianie po-transakcji...
(1/1) Arming ConditionNeedsUpdate...
==> Pobieranie źródeł...
  -> Pobieranie skypeforlinux_8.59.0.77_amd64.deb...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 77.0M  100 77.0M    0     0  4704k      0  0:00:16  0:00:16 --:--:-- 4322k
==> Sprawdzanie plików source za pomocą sha256sums...
    skypeforlinux_8.59.0.77_amd64.deb ... Zgadza się
==> Rozpakowywanie źródeł...
  -> Rozpakowywanie skypeforlinux_8.59.0.77_amd64.deb za pomocą bsdtar
==> Wchodzenie do środowiska fakeroot...
==> Rozpoczynanie package()...
==> Sprzątanie instalacji...
  -> Usuwanie libtool plików...
  -> Usuwanie niechcianych plików...
  -> Usuwanie statycznych plików bibliotek
  -> Wyrzucanie niepotrzebnych symboli z plików binarnych i bibliotek
  -> Kompresowanie stron man oraz info...
==> Sprawdzanie problemów z pakietami...
==> Tworzenie pakietu "skypeforlinux-stable-bin"...
  -> Generowanie pliku .PKGINFO...
  -> Generowanie pliku .BUILDINFO...
  -> Dodawanie pliku install...
  -> Generowanie pliku .MTREE...
  -> Kompresowanie pakietu...
==> Opuszczanie środowiska fakeroot.
==> Ukończono tworzenie: skypeforlinux-stable-bin 8.59.0.77-1 (pią, 17 kwi 2020, 14:18:40)
==> Removing installed dependencies...
sprawdzanie zależności…

Pakiety (3) asar-3.0.3-1  c-ares-1.16.0-1  nodejs-13.13.0-1

Odzyskane miejsce na dysku:  27,26 MiB

:: Czy chcesz usunąć te pakiety? [T/n] T
:: Przetwarzanie zmian pakietu...
(1/3) usuwanie asar                                [######################] 100%
(2/3) usuwanie nodejs                              [######################] 100%
(3/3) usuwanie c-ares                              [######################] 100%
:: Uruchamianie po-transakcji...
(1/1) Arming ConditionNeedsUpdate...

:: Sprawdzić poprawność zbudowanego pakietu? (t/n)
==> Sprawdzanie poprawności pakietu...
namcap nie jest zainstalowany

:: Instalowanie pakietu
wczytywanie pakietów…
rozwiązywanie zależności…
szukanie sprzecznych pakietów...

Pakiety (1) skypeforlinux-stable-bin-8.59.0.77-1

Do zainstalowania:       323,64 MiB
Zmiana po aktualizacji:   -0,25 MiB

:: Kontynuować instalację? [T/n] T
(1/1) sprawdzanie kluczy w bazie                   [######################] 100%
(1/1) sprawdzanie spójności pakietów               [######################] 100%
(1/1) wczytywanie listy plików                     [######################] 100%
(1/1) sprawdzanie konfliktów plików                [######################] 100%
(1/1) sprawdzanie dostępnego miejsca na dysku      [######################] 100%
:: Przetwarzanie zmian pakietu...
(1/1) aktualizowanie skypeforlinux-stable-bin      [######################] 100%
:: Uruchamianie po-transakcji...
(1/3) Arming ConditionNeedsUpdate...
(2/3) Updating icon theme caches...
(3/3) Updating the desktop file MIME type cache...

:: Usunąć źródła? (t/n)

Źródła zostały usunięte.

:: Uruchamianie aktualizacji z POLAUR...
 nie ma nic do zrobienia


DZIĘKUJĘ.
« Ostatnia zmiana: Kwiecień 17, 2020, 03:00:53 pm wysłana przez lami07 »

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2505
  • Reputacja: +32/-8
Odp: problem z aktualizacją z AUR
« Odpowiedź #4 dnia: Kwiecień 17, 2020, 02:35:06 pm »
Nie masz co sprawdzać poprawności stworzonej paczki, gdy nie masz zainstalowanej paczki namcap. Inna sprawa, że w Twoim przypadku będzie to (efekt sprawdzania) wyłącznie źródłem niezbyt potrzebnego Ci stresu.

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 413
  • Reputacja: +0/-0
Odp: problem z aktualizacją z AUR
« Odpowiedź #5 dnia: Kwiecień 17, 2020, 09:49:23 pm »
@pavbaranov
Się ubawiłem. Masz rację.
W każdym razie teraz po aktualizacji całościowej wykazało mi że :
Aktualizacja z AUR
"nie ma nic do zrobienia"
i podobnie z POLAUR.

Co do komunikatu :
"ostrzeżenie: Różne uprawnienia dla katalogu dla /etc/
system plików: 777 pakiet: 755"

Mam go oad czasu, gdym zainstalował linuxowe firmware do Widowsowego modemu TV.
Jest to komunikat z głębokiego Antergosa i pojawia mi się przy każdej aktualizacji.
Przestałem na niego zwracać uwagę, choć początkowo mnie stresował.

Dzięki i ... do następnego.


Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 413
  • Reputacja: +0/-0
Odp: problem z aktualizacją z AUR
« Odpowiedź #6 dnia: Kwiecień 19, 2020, 09:07:09 pm »
@nycko

Wszedłem pod kontrolą Midnight Commandera do
/etc/xdg/pak.conf
i znalazłem
show_diff=1

 
 Zmieniłem w zaawansowanych (pod kontrolą MC) ustawieniach praw właściciela na [r-w-x] .
Spróbowałem zmiany bezpośrednio z pulpitu i  się udało.
mam teraz w /etc/xdg/pak.conf linię :

# show what's changed in new version of AUR PKGBUILD: 0/1
show_diff=0

Powinno być OK?
Dzięki
« Ostatnia zmiana: Kwiecień 19, 2020, 09:36:46 pm wysłana przez Piejanto »

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2505
  • Reputacja: +32/-8
Odp: problem z aktualizacją z AUR
« Odpowiedź #7 dnia: Kwiecień 20, 2020, 08:33:30 am »
Wszedłem pod kontrolą Midnight Commandera do
/etc/xdg/pak.conf
i znalazłem
show_diff=1
 
 Zmieniłem w zaawansowanych (pod kontrolą MC) ustawieniach praw właściciela na [r-w-x] .
Spróbowałem zmiany bezpośrednio z pulpitu i  się udało.
mam teraz w /etc/xdg/pak.conf linię :

# show what's changed in new version of AUR PKGBUILD: 0/1
show_diff=0

Powinno być OK?

Nie. Dostałeś dokładną informację co masz zrobić:
Skopiuj domyślna konfigurację do swojego katalogu HOME, jeśli do tej pory tego nie zrobiłeś
mkdir -p ~/.config/pak && cp /etc/xdg/pak.conf ~/.config/pak/i zmień tam opcję show_diff z 1 na 0
ale wolisz po swojemu.
Czy działać będzie w sposób założony (czyli nie pokazywać różnic)? Tak. Czy zrobione to prawidłowo? Nie. Czy w przyszłości będzie rodzić jakieś konsekwencje? Może. Do czasu, gdy pak otrzyma nowy pak.conf i użytkownik tego pliku nie zmieni wówczas sam.

PS: Kurcze dlaczego wszyscy (niemal) użytkownicy, zwłaszcza legitymujący się niewielką wiedzą, tak bardzo chcą zmieniać system tam, gdzie nie mają prawa?

Offline ciubaka

  • Sr. Member
  • ****
  • Wiadomości: 452
  • Reputacja: +5/-1
Odp: problem z aktualizacją z AUR
« Odpowiedź #8 dnia: Kwiecień 20, 2020, 10:52:02 am »
Kurcze, Pawle, oni, ci co kombinują, po prostu usiłują zrobić to co należy tak jak potrafią. I nie da rady nie wywalić parę razy systemu po drodze, zanim się człowiek trochę nie połapie. Dotyczy to przecież nawet windowsa, wcale nie tylko linuxa, wcale nie tylko archa. Największy problem moim zdaniem, że łapią się niektórzy na siłę za dystrybucje, hmm, lekko skomplikowane. A przecież można prościej, bez  zbędnej udręki. Co oczywiście nie znaczy, że lepiej. Ale z kolei - lepsze jest wrogiem dobrego ...

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2505
  • Reputacja: +32/-8
Odp: problem z aktualizacją z AUR
« Odpowiedź #9 dnia: Kwiecień 20, 2020, 11:28:07 am »
@ciubaka - Największy problem, to... kombinowanie. Bo komuś się wydaje, że jeśli "tylko ja mam dostęp do komputera", to wszystko mi tu wolno. Dlaczego np. mam mieć "utrudnione" życie i system jeszcze ode mnie wymaga jakiegoś hasła. Po co, na co to? I grzebią do woli tam, gdzie w ogóle grzebać albo nie powinni, albo - jak w tym przypadku - kompletnie nie muszą. Bo zmienić sobie ustawienia pak można bez problemu, ale dlaczego od razu robić to tam, gdzie spowoduje to w przyszłości problem? Potem jesteśmy zarzucani "problemami" - "coś nie działa"; "doprawdy nie wiem, dlaczego u Was jest to inaczej, ale u mnie jest tak", "ja nie mam takiej funkcji, a mam system zaktualizowany"... Kurcze, wymieniać można od groma. Nikt jednak przy zdrowych zmysłach nie wpadnie na pomysł, że to użytkownik spieprzył coś ingerując tam, gdzie nie miał prawa. I najgorsze w tym wszystkim to, że w znakomitej większości na ów przymus działania w przestrzeni nie przeznaczonej dla zwykłego użytkownika cierpią osoby, które mają niemal zerową wiedzę o systemie, dokonując w nim zmian przepisując jakieś internetowe mądrości bez żadnej refleksji, bo o zrozumieniu już nawet nie wspomnę. I to nawet wówczas, gdy podaje się wszędzie - nie rób nic na roocie jeśli nie wiesz co robisz i nie rozumiesz tego, a przede wszystkim nie masz takiej potrzeby. A potem: "system nie działa po aktualizacji, a ja nic innego nie zrobiłem". Czyżby :)

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 413
  • Reputacja: +0/-0
Odp: problem z aktualizacją z AUR
« Odpowiedź #10 dnia: Kwiecień 20, 2020, 11:41:42 am »
@pavbaranov
Zmianę w pak.conf zalecił mi kol @nycko Zmiana polega na zmianie jedynki na zero w pliku [pak.conf] "...i zmień tam opcję show_diff z 1 na 0"


Też mi się wydawało, że nie powinno być problemu ze zmainą [pak.conf] za pomocą MC.
Niestety. Po uruchomieniu MC i wciśnięciu F3 wyświetlił mi się pak.conf bez problemu, ale gdy chciałem go zmodyfikować za pomocą [F4], okazało się, że tam nie ma nic. Po prostu miałem niebieskie tło i niemigający kursor bez ruchu.
Poszedłem do [pak,conf] bezpośrednio z pulpitu i zmieniłem jedynkę na zero po czym przyklepałem i otrzymałem komunikat, że nie mogę nic zmienić.
Pomyślałem, że to kwestia uprawnień, dlatego uruchomiłem znów MC i zmieniłem w "zaawansowanych uprawnieniach" tak jak to opisałem, ale MC i tak nie pokazywał zawartości pliku pak.conf więc zmiany dokonałem schodząc do pak.conf z [katalogu użytkownika].
Dziś odinstalowałem i zainstalowałem MC i nie ma zmiany.

I tu ciekawostka. dziś nad ranem uruchomiłem drugi komputer [netbook] i zmiany w [pak.conf] dokonałem pod kontrolą MC bez żadnego kombinowania.
Wniosek mój jest taki, że mój laptop HP jest na wykończeniu i coś mu nie styka.

A teraz pytanie: Czy kol. @nycko źle mi doradził i czy mam wrócić do jedynki w [show_diff=1] czy pozostawić poprawkę tak jak jest czyli [show_diff=0]?


Pozdrawiam i dziękuję za cierpliwość.
Zdrowia.
« Ostatnia zmiana: Kwiecień 20, 2020, 11:54:57 am wysłana przez Piejanto »

Offline ciubaka

  • Sr. Member
  • ****
  • Wiadomości: 452
  • Reputacja: +5/-1
Odp: problem z aktualizacją z AUR
« Odpowiedź #11 dnia: Kwiecień 20, 2020, 12:12:42 pm »
Janku, to nie problem laptopa lecz ustawień systemowych. Masz je odmiennie skonfigurowane na swoich urządzeniach. Zresztą często o tym sam mówisz przecież -
 na tym mi tak to działa a na tym inaczej. Kolega Nycko raczej rzeczowo się wyraża na forum. Janku - z całym szacunkiem, Arch to nie Antegros, nie ma szans żeby było tak przyjaźnie jak było onegdaj, a szkoda :-(

Offline nycko

  • Newbie
  • *
  • Wiadomości: 24
  • Reputacja: +1/-0
Odp: problem z aktualizacją z AUR
« Odpowiedź #12 dnia: Kwiecień 20, 2020, 12:30:28 pm »
Dziękuję za dobre słowo @ciubaka - nie potrafię inaczej niż rzeczowo i konkretnie. Tym bardziej jeśli sprawa dot. paka.
« Ostatnia zmiana: Kwiecień 20, 2020, 12:44:15 pm wysłana przez nycko »

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2505
  • Reputacja: +32/-8
Odp: problem z aktualizacją z AUR
« Odpowiedź #13 dnia: Kwiecień 20, 2020, 01:15:28 pm »
@pavbaranov
Zmianę w pak.conf zalecił mi kol @nycko
Tak polecił. Nie doczytałeś jednak do końca, albowiem polecił Ci:
1. nie polecił Ci w ogóle grzebania w /etc/xdg/pak.conf, a tego właśnie dokonałeś,
2. polecił Ci stworzenie "lokalnego" pak.conf dla użytkownika podając Ci nawet instrukcję: mkdir -p ~/.config/pak && cp /etc/xdg/pak.conf ~/.config/pak/ i tego w ogóle nie zrobiłeś,
3. polecił dokonania zmiany w pliku ~/.config/pak/pak.conf i tego nie dokonałeś zamiast tego grzebiąc się w /etc/xdg/pak.conf
Innymi słowy efekt wynikający ze zmiany w poleceniu show_diff oczywiście otrzymałeś, ale nie w sposób, który miałeś go uzyskać. Wiele razy prosimy: wykonujcie polecania, tak jak je podajemy, bo to gwarantuje poprawne działanie (także w przyszłości), ale wiecie swoje, wiecie lepiej. To teraz zastanówcie się: jak można Wam pomagać? Bo ja już lekko przestaję widzieć możliwość i coraz częściej do chodzę do przekonania: radźcie sobie sami, a ja po prostu umywam ręce. Nie da się pomagać, gdy wbrew temu, co pomocą jest ktoś robi coś innego, bo wie lepiej. Otóż nie wie!
Cytuj
A teraz pytanie: Czy kol. @nycko źle mi doradził i czy mam wrócić do jedynki w [show_diff=1] czy pozostawić poprawkę tak jak jest czyli [show_diff=0]?
Kolega @nycko bardzo dobrze Ci doradził. Problem z Tobą, że nie wykonałeś tej porady, wprowadzając do systemu obcy plik /etc/xdg/pak.conf. Jak wspomniałem - jeśli od tej chwili pak uzyska nowy plik pak.conf (nie jest to wykluczone), to po instalacji nowej wersji pak, plik /etc/xdg/pak.conf nie zostanie zamieniony na nowy, a ów nowy zostanie zapisany jako /etc/xdg/pak.conf.pacnew i z tego pliku pak nie będzie korzystać do póki nie zrobi się ich połączenia (merge) lub nie zamieni nowym starego. I znów będzie lament.
Zatem zamiast kombinować jak koń pod górę, po prostu rób to o czym np. @nycko pisze i dokładnie tak, jak to pisze, albowiem tylko to jest warunkiem bezproblemowej pracy programu. Dotyczy to zwłaszcza Ciebie, który masz lekko małą wiedzę o systemie i czynisz różne rzeczy bez świadomości jak to wszystko działa.

Offline LinGruby

  • Jr. Member
  • **
  • Wiadomości: 97
  • Reputacja: +0/-0
  • notoryczny brak weny ;)
Odp: problem z aktualizacją z AUR
« Odpowiedź #14 dnia: Kwiecień 20, 2020, 07:46:26 pm »
[...]@nycko pisze i dokładnie tak, jak to pisze, albowiem tylko to jest warunkiem bezproblemowej pracy programu.

w kilku słowach ujęta kwintesencja kilku postów...

za to wypiję, dobrą kawę mam ;-)

no to łokciem panowie...
( ͡° ͜ʖ ͡°)  Linux User #592024  System:  arch-bspwm  Kernel: 5.6.15.ll56-1-lingruby x86_64 (64 bit gcc: 10.1.0)
Desktop: twm info: polybar wm: spectrwm 3.3.0  dm: lightdm  Distro: Arch Linux