Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: problem z aktualizacją z AUR  (Przeczytany 1357 razy)

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 340
  • Reputacja: +0/-0
Odp: problem z aktualizacją z AUR
« Odpowiedź #30 dnia: Maj 01, 2020, 06:16:18 pm »
@pavbaranov
Aktualizacja sie dokonała, więc chyba wszystko jest w porządku. Po restarcie nic mi nie wykazuje i SKYPE działa.
To może być,że chodziło niewadomoco. Nawet miałem Ci wrzucić tutaj to co się tam wyświetlało, ale pomyślałem sobie, że nie ma sensu abyś wypatrywał oczy, skoro wszystko działa. W sumie, gdybyk nie zrobił sprawadzania namcapem, to nawet bym nie wiedział, że taki komunikat istnieje.
Jakby faktycznie coś się zadziało, to Cię poproszę o pomoc. To pytanie było z czystej ciekawości.
Dziękuję.
Zdrowia.

PS.
Polecenie, które mi przesłałeś, oczywiście wykonam.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2188
  • Reputacja: +11/-1
Odp: problem z aktualizacją z AUR
« Odpowiedź #31 dnia: Maj 01, 2020, 08:52:13 pm »
Mein Gott! Sprawdź sobie czym jest program namcap. Krótko mówiąc to walidator PKGBUILDów oraz paczek Archa. To, że jakiś program przechodzi tę walidację lub nie, o niczym jeszcze nie stanowi. Paczka może ją przejść i program może nie działać, albo nie przejść a program będzie działać. Działanie programu nie ma nic wspólnego z tym, czy paczka jest prawidłowo wykonana, czyli czy prawidłowo określone ma wszystkie zależności, czy pliki trafiają do katalogów, do których powinny itp. Ba, w niektórych przypadkach sam namcap ma problemy z prawidłowym stwierdzeniem, czy paczka jest, czy nie jest prawidłowa. Jak wcześniej gdzieś napisałem - niestety z Twoją wiedzą i tak nic nie poradzisz na to, że namcap stwierdzi, że PKGBUILD bądź paczka są do bani.
Jeśli jednak zadajesz pytanie, to musisz podawać w nim jakieś informacje. Informacja: paczka X nie przeszła testu namcap, to nie jest to żadna informacja. Dopiero treść, którą podaje namcap (także pak), to jest coś, co można analizować.

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 340
  • Reputacja: +0/-0
Odp: problem z aktualizacją z AUR
« Odpowiedź #32 dnia: Maj 03, 2020, 01:51:18 pm »
@pavbaranov
Dzięki za odpowiedź. Rozjaśniło mi się. Miałeś rację.
W moim przypadku po prostu, lepiej nie mieć namcapa, bo to tylko stres i koszmarne sny.
Jeśli mi wszystko działa, to według mnie jest dobrze. Nie przesłałem całej wiadomości, bo podejrzewałem, że się narobisz, a ja i tak guzik z tego będę wiedział. Ponadto namcap nie jest "obowiązkowy" i gdybym go nie miał, to po prostu nie miałbym tego komunikatu.

Dodatkowo pozytywna wiadomość jest taka, że wsiąkłem już w PAK-a i chętnie go włączam. Jest wyraźny i "opowiada" o wszystkim co robi w kolorach i z użyciem pogrubionej czcionki, co w moim przypadku jest bardzo wskazane. Dzięki, żeś mnie do niego namówił.
To, że po uruchomieniu pokazuje, jakich poleceń można użyć aby działał, to uważam, za najlepszy pomysł, bo mam od razu "samouczek", bez szukania po wikipediach.
To, że obsługuje dodatkowo nie tylko AUR ale też POLAUR jest nie do przecenienia.

Jakby co, będę znów prosił o poradę.
Zdrowia.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2188
  • Reputacja: +11/-1
Odp: problem z aktualizacją z AUR
« Odpowiedź #33 dnia: Maj 03, 2020, 02:44:00 pm »
namcap, niezależnie, czy wywoływany przez konsolę, czy via pak, ma jedną wielką zaletę: niestety paczki, które są budowane z AUR bardzo często nie są przez ich opiekunów poddawane procesowi walidacji, a są budowane nie na tzw. czystym chroocie, a na działającym systemie. W efekcie zdarza się, że paczka się u kogoś prawidłowo zbuduje i prawidłowo będzie działać. U innego użytkownika, też się zbuduje, ale już prawidłowo działać nie będzie, bo będzie jej brakować jakiejś zależności. Ot, magia :) Narzędzie pn. namcap po prostu pomaga zrozumieć o co chodzi i np. jest przydatne w diagnozowaniu błędów zgłaszanych przez użytkowników odnośnie wadliwie działających paczek z AUR. Jest też przydatne dla kogoś, kto rozumie jak są PKGBUILDy tworzone i dlaczego w taki sposób. Wówczas też sobie można zdiagnozować gdzie jest błąd i naprawić to we własnym zakresie. Niemniej jednak - jak powiedziałem - namcap nie jest omylny i np. nie jest w stanie stwierdzić, że taka paczka jak qt5-svg jest niezbędna dla prawidłowego wyświetlania okna programu (chodzi głównie o ikony). Paczka w tym przypadku się zbuduje. Namcap nawet nie stwierdzi błędu, ale okno programu będzie pozbawione ikon. I wówczas większa zabawa.
Akurat w przypadku Skype'a jest to aplikacja budowana bez źródeł (przepakowywana z binarki przygotowanej przez MS). Zdiagnozowanie problemu bywa... problematyczne, ale możliwe. Skype może działać, ale może też nie obsługiwać pełnej funkcjonalności.
Czy "jeśli mi działa", to wszystko jest ok? Nie.
Czy dla mnie (i kilku innych użytkowników forum) odczytać komunikat namcapa i stwierdzić, czy problem istnieje, czy też wcale to nie jest kwestia "narobienia się", a niekiedy zaledwie zerknięcia na pokazywane błędy. Roboty nawet na krócej niż trwało napisanie tego postu.

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 340
  • Reputacja: +0/-0
Odp: problem z aktualizacją z AUR
« Odpowiedź #34 dnia: Maj 14, 2020, 12:33:43 am »
@pavbaranov
Dzięki za wyjaśnienie. W dalszym ciągu "wiem, że nic nie wiem" ale chyba trochę rozumiem.
Jedyny program jaki mam z AUR to jest SKYPE i na tyle na ile jest mi potrzebny, dział bez zarzutu.
Jeśli chce Ci się bawić w rozwiązywanie problemu, który dla mnie problemem nie jest, to oczywiście pchnę Ci całość komunikatu, gdy tylko pojawi się kolejna aktualizacja z AUR. Oczywiście ma być NIEZOBOWIĄZUJĄCO i bez pracy. Wyłącznie hobby.
Obecnie oba moje kompy funkcjonują pięknie i w zasadzi można już rzecm że jestem zauroczony PAK-iem.
Sprawdziłem za pomocą Pamac-a jakie tam jeszcze są części Pacmana i się okazuje, że jest Pacman obsługujący AUR, ale nie ma Pacmana obsługującego POLAUR.
Ponadto wyrazistość PAK-a jest nie do przecenienia.Pisałem i będę to powtarzał. Aktualizacja z PAK-iem to po prostu frajda.
Pak jest wyraźny i się niegubię. Wszystkie komunikaty łatwo się czyta, bo są wyodrębnione. Same zalety.
Wiem, że powinienem więcej czytać o Archu, ale znów się zaniedbałem.
Niestety, system jest dodatkiem do życia i trudno mi śledzić zmiany, tym bardziej, ze jako wybitny antytalent komputrowy zapominam nazwy i konstrukcje poleceń.
Siedzę, gdzieś tam w Mandake i w Midnight Commanderze i trudno mi spamiętać co do czego służy i co od czego zależy, ale ostatni problem z aktualizacją
był dla mnie wielce odświeżający. 
Jak już pisałem, kiedyś za czasów Mandrake 6,0 trzeba było trzyumać rękę na pulsie i więcej było podobieństw do DOS-a (pomijając nawet Commandera).
Później była taka stabilizacja, że zgłupiałem i wypadłem całkowicie.
Teraz znów jest pięknie i za pół roku (jeśli dożyję) może się okazać, że jestem dzieckiem we mgle. Trudności rozwijają..
Dzięki @pavbaranov. Wielkie Dzięki.

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 340
  • Reputacja: +0/-0
Odp: problem z aktualizacją z AUR
« Odpowiedź #35 dnia: Maj 18, 2020, 06:13:20 pm »
@pavbaranov

Znów pojawiły się aktualizacje z AUR. Tym razem miałem jeszcze doinstalowany ZOOM i podobnie jak SKYPE coś mu przeszkaddzało. Skopiowałem to sprawdzanie, ale zrobiłem to tylko dla ZOOM-a,  bo aktualizacja i sprawdzanie SKYPE poleciała mi gdzieś do góry i już nie mogłem się do niej dostać.

Niestety nie mogę wkleić całości tego sprawdzania, bo w pewnym momencie się ucina i dalej nie idzie.  Jest tego strasznie dużo.
 

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2188
  • Reputacja: +11/-1
Odp: problem z aktualizacją z AUR
« Odpowiedź #36 dnia: Maj 18, 2020, 08:31:02 pm »
I co ja z tego mam wiedzieć?
namcap, to namcap, jak się paczka zbudowała możesz zrobić:
namcap nazwa_paczki > info.txta potem - jeśli masz pastebinit (jeśli nie, to możesz zainstalować):
pastebinit info.txtwklejasz tu link, który Ci się pojawi. Oczywiście można skorzystać bez pastebinit, ale z nim prościej.

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 340
  • Reputacja: +0/-0
Odp: problem z aktualizacją z AUR
« Odpowiedź #37 dnia: Maj 19, 2020, 03:33:26 pm »
@pavbaranov
Dobra. Dzięki. Sobie to zapisałem. A teraz przesyłam wynik sprawdzania budowy pakietu SKYPE.
Ja oczywiście nic z tego nie pojmuję, ale Ty chciałeś zerknąć to przesyłam. Po tym sprawdzaniu, kazałem się paczce zainstalować i się dokonało. Według mnie, działa poprawnie. To jest wynik z netbooka, gdzie nie doinstalowałem ZOOM-a i dlatego mam tylko sprawdzanie SKYPE.  Wszystko działa, więc Ja, na Twoim miejscu, bym nie sprawdzał, bo to wielka robota. I obawiam się że to robota Dananejska. Ale przesyłam, bo chciałeś. Proszszsz

==> Opuszczanie środowiska fakeroot.
==> Ukończono tworzenie: skypeforlinux-stable-bin 8.60.0.76-1 (wto, 19 maj 2020, 15:11:58)

:: Sprawdzić poprawność zbudowanego pakietu? (t/n)
==> Sprawdzanie poprawności pakietu...
skypeforlinux-stable-bin
skypeforlinux-stable-bin E: ELF file ('usr/share/skypeforlinux/chrome-sandbox') outside of a valid path.
skypeforlinux-stable-bin E: ELF file ('usr/share/skypeforlinux/libEGL.so') outside of a valid path.
skypeforlinux-stable-bin E: ELF file ('usr/share/skypeforlinux/libGLESv2.so') outside of a valid path.
skypeforlinux-stable-bin E: ELF file ('usr/share/skypeforlinux/libffmpeg.so') outside of a valid path.
skypeforlinux-stable-bin E: ELF file ('usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/electron-ssid/build/Release/electron-ssid.node') outside of a valid path.
skypeforlinux-stable-bin E: ELF file ('usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/electron-utility/build/Release/electron_utility.node') outside of a valid path.
skypeforlinux-stable-bin E: ELF file ('usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/keytar/build/Release/keytar.node') outside of a valid path.
skypeforlinux-stable-bin E: ELF file ('usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/sharing-indicator.node') outside of a valid path.
skypeforlinux-stable-bin E: ELF file ('usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node') outside of a valid path.
skypeforlinux-stable-bin E: ELF file ('usr/share/skypeforlinux/skypeforlinux') outside of a valid path.
skypeforlinux-stable-bin E: ELF file ('usr/share/skypeforlinux/swiftshader/libEGL.so') outside of a valid path.
skypeforlinux-stable-bin E: ELF file ('usr/share/skypeforlinux/swiftshader/libGLESv2.so') outside of a valid path.
skypeforlinux-stable-bin E: ELF file ('usr/share/skypeforlinux/swiftshader/libvk_swiftshader.so') outside of a valid path.
skypeforlinux-stable-bin W: ELF file ('usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/electron-ssid/build/Release/electron-ssid.node') lacks FULL RELRO, check LDFLAGS.
skypeforlinux-stable-bin W: ELF file ('usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/electron-utility/build/Release/electron_utility.node') lacks FULL RELRO, check LDFLAGS.
skypeforlinux-stable-bin W: ELF file ('usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/keytar/build/Release/keytar.node') lacks FULL RELRO, check LDFLAGS.
skypeforlinux-stable-bin W: ELF file ('usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/sharing-indicator.node') lacks FULL RELRO, check LDFLAGS.
skypeforlinux-stable-bin W: ELF file ('usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node') lacks FULL RELRO, check LDFLAGS.
skypeforlinux-stable-bin W: ELF file ('usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/electron-ssid/build/Release/electron-ssid.node') lacks PIE.
skypeforlinux-stable-bin W: ELF file ('usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/electron-utility/build/Release/electron_utility.node') lacks PIE.
skypeforlinux-stable-bin W: ELF file ('usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/keytar/build/Release/keytar.node') lacks PIE.
skypeforlinux-stable-bin W: ELF file ('usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/sharing-indicator.node') lacks PIE.
skypeforlinux-stable-bin W: ELF file ('usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node') lacks PIE.
skypeforlinux-stable-bin W: Referenced library 'libffmpeg.so' is an uninstalled dependency
skypeforlinux-stable-bin W: Unused shared library '/usr/lib/librt.so.1' by file ('usr/share/skypeforlinux/libGLESv2.so')
skypeforlinux-stable-bin W: Unused shared library '/usr/lib/librt.so.1' by file ('usr/share/skypeforlinux/libffmpeg.so')
skypeforlinux-stable-bin W: Unused shared library '/usr/lib/libm.so.6' by file ('usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/electron-ssid/build/Release/electron-ssid.node')
skypeforlinux-stable-bin W: Unused shared library '/usr/lib/libm.so.6' by file ('usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/electron-utility/build/Release/electron_utility.node')
skypeforlinux-stable-bin W: Unused shared library '/usr/lib/libpthread.so.0' by file ('usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/electron-utility/build/Release/electron_utility.node')
skypeforlinux-stable-bin W: Unused shared library '/usr/lib/libgio-2.0.so.0' by file ('usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/keytar/build/Release/keytar.node')
skypeforlinux-stable-bin W: Unused shared library '/usr/lib/libgobject-2.0.so.0' by file ('usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/keytar/build/Release/keytar.node')
skypeforlinux-stable-bin W: Unused shared library '/usr/lib/libm.so.6' by file ('usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/keytar/build/Release/keytar.node')
skypeforlinux-stable-bin W: Unused shared library '/usr/lib/librt.so.1' by file ('usr/share/skypeforlinux/swiftshader/libvk_swiftshader.so')
skypeforlinux-stable-bin W: Dependency alsa-lib included but already satisfied
skypeforlinux-stable-bin W: Dependency libxtst included but already satisfied
skypeforlinux-stable-bin W: Dependency glibc included but already satisfied

skypeforlinux-stable-bin został poprawnie zbudowany, ale pakiet nie przeszedł testu poprawności.

Sprawdź powyższe komunikaty i zdecyduj co zrobić dalej.
Możesz kontynuować instalację lub dokonać zmian w /home/jan/.cache/pak/pkgs/skypeforlinux-stable-bin i zainstalować ręcznie przy pomocy makepkg.

I po tym komunikacie kazałem zainstalować zaktualizowany pakiet SKYPE i on działa.

J.

« Ostatnia zmiana: Maj 19, 2020, 04:01:09 pm wysłana przez lami07 »

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2188
  • Reputacja: +11/-1
Odp: problem z aktualizacją z AUR
« Odpowiedź #38 dnia: Maj 19, 2020, 04:50:13 pm »
Musi działać :) Błędy to:
skypeforlinux-stable-bin E: ELF file ('usr/share/skypeforlinux/*') outside of a valid path.To błąd związany z wadliwą - w rozumieniu założeń Archa (i nie tylko) lokalizacją plików wykonywalnych (ELF). Są one nie tam, gdzie je system oczekuje, ale z uwagi na to, że Skype jest skompilowany i jest zamkniętym oprogramowaniem, to sam "program" znajduje je i dlatego może działać.
skypeforlinux-stable-bin W: ELF file ('usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/electron-ssid/build/Release/electron-ssid.node') lacks FULL RELRO, check LDFLAGS.Tu musiałby się wypowiedzieć jakiś programista. Błąd może być wynikiem np. starego pliku makepkg.conf (jeśli jest makepkg.conf.pacnew), ale może leżeć (i tak najprawdopodobniej) po stronie paczkujących w MS. Zasadniczo jest to "Warning" zatem winno przechodzić bez większego echa działanie takiego programu, choć czytałem również, że tego typu błędy również pojawiają się z błędami w zakresie ogólnie rozumianego bezpieczeństwa.
skypeforlinux-stable-bin W: ELF file ('usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/electron-ssid/build/Release/electron-ssid.node') lacks PIE.Jak wyżej.
skypeforlinux-stable-bin W: Referenced library 'libffmpeg.so' is an uninstalled dependencyWskazuje na to, że program został zbudowany z jakąś biblioteką, która nie jest obecnie zainstalowana w systemie. Jeśli jest dostarczana wraz z paczką programu - nie ma problemu. Jeśli nie, to programowi może brakować do pełnej funkcjonalności takiej biblioteki. W takim przypadku winien on ją mieć w optdepends. Jeśli nie ma - błąd, który łatwo można naprawić doinstalowując paczkę dostarczającą taką bibliotekę.
skypeforlinux-stable-bin W: Unused shared library '/usr/lib/librt.so.1' by file ('usr/share/skypeforlinux/libGLESv2.so')(itd.) - Zasadniczo jak wyżej.
skypeforlinux-stable-bin W: Dependency * included but already satisfiedNiewiele znacząca informacja. W depends znajduje się paczka, która jest również zależnością jakiejś innej paczki, która znajduje się w tym samym polu PKGBUILD. Błąd, ale zasadniczo bez żadnych konsekwencji.
skypeforlinux-stable-bin został poprawnie zbudowany, ale pakiet nie przeszedł testu poprawności.Informacja paka, który wskazuje na konieczność dokonania takiej analizy jak przed chwilą zrobiłem. W zależności od jej wyników można instalować paczkę (z całym bagażem wiedzy, że coś z nią nie jest do końca w porządku) i mieć nadzieję (lub nawet pewność), że funkcjonować będzie, albo trzeba zmieniać PKGBUILD i zbudować paczkę od nowa, by ona prawidłowo działała, lub też doinstalować jakieś paczki, które winny być opcjonalnymi zależnościami, ale nie zostały wymienione w PKGBUILD jako takie. Niekiedy to także paczki, które nie zostały wymienione w depends, ale zostały (z innego powodu) zainstalowane w systemie. Opcjonalne - nie dadzą pełnej funkcjonalności. Te, które mylnie nie zostały wymienione w depends, po odinstalowaniu ich (choćby jako zależności innej paczki, która w ten sposób - czyli z "niepotrzebnymi" zależnościami - będzie odinstalowana, spowoduje, że program przestanie działać. To akurat do prostego (w miarę) zdiagnozowania.
I mam nadzieję, że cokolwiek rozjaśniłem. Przy okazji - nie zgrywam się na alfę i omegę kompilacji i PKGBUILDów, zwłaszcza, że podstaw w zakresie wykształcenia w tym zakresie nie mam żadnych. Kompletnie. Jeśli napisałem jakieś farmazony, to prosiłbym o korektę.

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 340
  • Reputacja: +0/-0
Odp: problem z aktualizacją z AUR
« Odpowiedź #39 dnia: Maj 23, 2020, 09:10:17 pm »
@pavbaranov
Rozjaśniłeś i to bardzo wiele. Niestety, ja nie potrafię tego wszystkiego naprawić i od początku zbudować, tak żeby było "ortograficznie".

Przy okazji:
Od dwóch dni Pamac pokazywał mi, że jest jakaś aktualizacja. Usiłowałem więc zrobić aktualizację przez PAK-a ale za każdym razem (po dłuższym czasie) dostawałem odpowiedź "Error" i że "nie ma nic do zrobienia". Dziś po powrocie z roboty znów mi się pokazało, że jest aktualizacja, więc użyłem PAK-a i znów to samo. Wtedy użyłem Pamac-a. Kręcił, kręcił i nagle pokazało mi się okno  z zaznaczonym na zielono [auracle-git  r322.def6a]. Zdumiało mnie to trochę, ale kliknąłem [zastosuj]. Wtedy właczyło się [odświeżanie chaotic-aur.db...] - trzy kropki na końcu coś pewnie zastąpiły, ale nie wiem co. 
Dość długo to trwało, aż wreszcie dostałem komunikat, że mój system jest całkowicie zaktualizowany.
Myślę, że to, iż PAK nie chciał ruszyć tej aktualizacji mogo wynikać ze zbyt wolnego łączenia z eternetem, bo u mnie czasem Sieć "siada".
Zresztą... wczoraj też próbowałem aktualizować Pamacem i Pacmanem i nic to nie dawało.
Teraz spróbuję, co mi się zmieniło po tej aktualizacji, bo to było przed chwilą.
Mam wrażenie, że jakby lżej komp chodzi, ale może to tylko wrażenie.
Dzięki 

Offline robson75

  • Hero Member
  • *****
  • Wiadomości: 1319
  • Reputacja: +1/-0
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: problem z aktualizacją z AUR
« Odpowiedź #40 dnia: Maj 23, 2020, 09:50:26 pm »
@pavbaranov
Rozjaśniłeś i to bardzo wiele. Niestety, ja nie potrafię tego wszystkiego naprawić i od początku zbudować, tak żeby było "ortograficznie".

Przy okazji:
Od dwóch dni Pamac pokazywał mi, że jest jakaś aktualizacja. Usiłowałem więc zrobić aktualizację przez PAK-a ale za każdym razem (po dłuższym czasie) dostawałem odpowiedź "Error" i że "nie ma nic do zrobienia". Dziś po powrocie z roboty znów mi się pokazało, że jest aktualizacja, więc użyłem PAK-a i znów to samo. Wtedy użyłem Pamac-a. Kręcił, kręcił i nagle pokazało mi się okno  z zaznaczonym na zielono [auracle-git  r322.def6a]. Zdumiało mnie to trochę, ale kliknąłem [zastosuj]. Wtedy właczyło się [odświeżanie chaotic-aur.db...] - trzy kropki na końcu coś pewnie zastąpiły, ale nie wiem co. 
Dość długo to trwało, aż wreszcie dostałem komunikat, że mój system jest całkowicie zaktualizowany.
Myślę, że to, iż PAK nie chciał ruszyć tej aktualizacji mogo wynikać ze zbyt wolnego łączenia z eternetem, bo u mnie czasem Sieć "siada".
Zresztą... wczoraj też próbowałem aktualizować Pamacem i Pacmanem i nic to nie dawało.
Teraz spróbuję, co mi się zmieniło po tej aktualizacji, bo to było przed chwilą.
Mam wrażenie, że jakby lżej komp chodzi, ale może to tylko wrażenie.
Dzięki
Bo przynajmniej raz w tygodniu trzeba wygenerować nowe mirrory
reflector --verbose --latest 5 --sort rate --save /etc/pacman.d/mirrorlistTo nie będziesz dostawał fałszywych powiadomień o aktualizacjach.
Arch Linux Xfce+compiz - 64Bit Linux User #621110

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2188
  • Reputacja: +11/-1
Odp: problem z aktualizacją z AUR
« Odpowiedź #41 dnia: Maj 23, 2020, 09:59:39 pm »
@robson75 - Masz absolutną rację, ale... od tego mamy pak:
pak -mI więcej nic nie trzeba pamiętać.
Cytat: Piejanto
Wtedy użyłem Pamac-a. Kręcił, kręcił i nagle pokazało mi się okno  z zaznaczonym na zielono [auracle-git  r322.def6a].
Tu w istocie są 2 kwestie:
1. pak - zakłada zawsze pełną aktualizację systemu, łącznie ze swoją własną i jest dostosowany do aktualnych swoich zależności (jeśli coś się wadliwego pojawia, bo bywa, jest to naprawiane); może się zdarzyć zatem tak, że np. pak będzie dostosowany do określonej wersji auracle i tę wersję będzie obsługiwać, ale w systemie będzie inna wersja, czy to pak, czy to auracle. W takim przypadku współdziałanie tych programów będzie niemożliwe, a konsekwencją będzie to, że pak nie będzie wyświetlać aktualizacji z AUR, co będzie powodować, że użytkownik nie będzie wiedzieć o tym, że ma dokonać aktualizacji auracle. Jak zawsze - wszelkie informacje o pak w tym zakresie są na stronie forum.archlinux.org.pl
2. Repozytorium chaotic-aur. W istocie niekiedy, przy gorszym połączeniu to repozytorium ma problemy we wczytaniu nowej bazy. Trzeba na to uważać i ewentualnie powtarzać operację. Dodatkowo trzeba pamiętać, że w tym repozytorium znajdują się paczki zbudowane na podstawie AUR oraz, że programy tego typu jak pak mają preferencje: repozytorium przed AUR, choć pak pokaże, że w AUR jest paczka "wyższa" niż w chaotic-aur proponując jej instalację. Trzeba to jednak wychwycić.
« Ostatnia zmiana: Maj 24, 2020, 12:12:08 pm wysłana przez pavbaranov »

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 340
  • Reputacja: +0/-0
Odp: problem z aktualizacją z AUR
« Odpowiedź #42 dnia: Maj 24, 2020, 01:24:53 pm »
[pak -m] robię praktycznie po każdej aktualizacji. Tak na wszelki wypadek.
Dziś, po wczorajszej aktualizacji auracle, pojawiła mi się nowa wielka aktualizacja.
uruchomiłem PAK-a i otrzymałem następujący komunikat:

 błąd:  nie udało się przygotować transakcji (nie udało się rozwiązać zależności)
:: instalacja jre-openjdk (14.0.1.u7-1) uszkodzi zależności 'java-runtime-openjdk=13' wymagane przez java-openjfx


I co teraz? Może coś trzeba ręcznie usunąć? Jednak teraz wpadłomi do głowy, że powinienem sprawdzić, do czego mi jest potrzebne [java-openjfx] i ewentualnie wówczas usunąć  [java-runtime-openjdk=13]. Czy ja dobrze myślę?

*********************

W uzupełnieniu. Wykonałem następujące polecenie ale niewiele mi ono powiedziało:

pak -Qs java-openjfx
Używana jest konfiguracja użytkownika: /home/jan/.config/pak/pak.conf

local/java-openjfx 13.u14-1
    Java OpenJFX 13 client application platform (open-source implementation of
    JavaFX)
*********************************************

Ale jeszcze zrobiłem [-rd] i jest tak:

$ pak -rd java-openjfx
Używana jest konfiguracja użytkownika: /home/jan/.config/pak/pak.conf


:: Pakiety zależne od: java-openjfx
java-openjfx

Wychodzi mi na to, że [java-openjfx] istnieje tylko sama dla siebie? - czy ja dobrze myślę?
Czy w tej sytuacji usunięcie [java-openjfx] jest możliwe ? Bo nie wiem do czego może służyć ten pakiet. Ostatnio zainstalowane to SKYPE i ZOOM, czy im to jest potrzebne?

« Ostatnia zmiana: Maj 24, 2020, 02:33:12 pm wysłana przez Piejanto »

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2188
  • Reputacja: +11/-1
Odp: problem z aktualizacją z AUR
« Odpowiedź #43 dnia: Maj 24, 2020, 03:07:27 pm »
Ogólnie - dobrze myślisz, ale nie: pak -Qs java-openjfx, a pak -Qi java-openfx będzie lepsze. I wówczas zobacz co tego wymaga.
Wygląda jednak na to, że java-openjfx ma "zbyt stare" zależności. I prawdopodobnie tak jest, bowiem jest oflagowana. Po prostu trzeba poczekać aż zostanie ona zbudowana w wersji 14, albo... cóż, niech stracę, zrobię taką wersję i wrzucę do POLAUR.

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 340
  • Reputacja: +0/-0
Odp: problem z aktualizacją z AUR
« Odpowiedź #44 dnia: Maj 24, 2020, 04:46:45 pm »
@pavbaranov

pak -Qi java-openjfx
Używana jest konfiguracja użytkownika: /home/jan/.config/pak/pak.conf

Nazwa                 : java-openjfx
Wersja                : 13.u14-1
Opis                  : Java OpenJFX 13 client application platform (open-source
                        implementation of JavaFX)
Architektura          : x86_64
Adres url             : https://wiki.openjdk.java.net/display/OpenJFX/Main
Licencje              : custom
Grupy                 : Brak
Dostarcza             : Brak
Zależy od             : alsa-lib  cairo  ffmpeg  gdk-pixbuf2  glib2  gtk2  gtk3
                        java-runtime-openjdk=13  libavcodec.so=58-64
                        libavformat.so=58-64  libfreetype.so=6-64  libgl
                        libx11  libxtst  pango  python2  qt5-base  ruby  unzip
                        webkit2gtk
Opcjonalne zależności : Brak
Wymagany przez        : Brak
Opcjonalny dla        : Brak
Konfliktuje z         : Brak
Zastępuje             : Brak
Rozmiar po instalacji : 127,53 MiB
Autor pakietu         : Levente Polyak <anthraxx@archlinux.org>
Data zbudowania       : śro, 9 paź 2019, 18:50:33
Data zainstalowania   : czw, 10 paź 2019, 21:55:52
Powód zainstalowania  : Zależność innego pakietu
Skrypt instalacyjny   : Nie
Potwierdzone przez    : Podpis

Wychodzi nam że :

    Wymagany przez        : Brak


Wniosek jest jak poprzednio, że jest potrzebne samo dla siebie. Tak?
Czy mogę to wywalić?

Najbardziej podoba mi się, cytuję:
"(...) albo... cóż, niech stracę, zrobię taką wersję i wrzucę do POLAUR."
Qrdę... zazdroszczę.

Znaczy... Wywalić, czy nie wywalać? Bo rozumiem, że będzie w POLAUR Twoja aktualizacja.

« Ostatnia zmiana: Maj 24, 2020, 09:34:19 pm wysłana przez lami07 »