Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

NIe mogę zainstalować Opery

Zaczęty przez Barman997, Marzec 26, 2020, 09:56:32 AM

Poprzedni wątek - Następny wątek

Barman997

Witam Forumowiczów.
Na pewno będę się powtarzał, ale nie mogę znaleźć podobnego wątku, a chodzi mi o brak możliwości instalacji przeglądarki Opera. Próbowałem wielu sposobów niestety nieskutecznie.
mój system : LDME 4 Debbie Cinamon 4.4.8
Komputer Samsung N130 32 bity
Dodam, że jestem nowicjuszem, wiec informacje w wersji łopatologicznej mile widziane.

MSki

#1
A możesz napisać, jakich sposobów próbowałeś ?

edit;
Opera jest 64bit i pewnie z tego powodu masz problemy.

pavbaranov

A Opera w ogóle ma jeszcze wersję 32 bitową?

Barman997

Pierwsza opcja
Zgodnie z info w przewodniku poprzez terminal polecenie apt install Opera
Następnie sciągnąłem plik instalacyjny opera-stable 45.02552.898_i386.deb i próbowałem zainstalować z instalatora pakietów GDebi
I jeszcze kilka możliwości ściągniętych z internetu i nic.

pavbaranov

Z tego co widzę to ani w repozytoriach Debiana, ani Minta paczka z "opera" w nazwie nie występuje. Być może jest jakieś dodatkowe PPA.
Paczka opera-stable-itd.deb nie jest "plikiem instalacyjnym". Możesz go zainstalować używając apt. Piszesz, że próbowałeś, ale konkretnie dlaczego się nie instaluje, to nie napisałeś. Wyżej wymienioną paczkę opera-stable powinieneś móc zainstalować przez: apt install opera-stable 45.02552.898_i386.deb wywołane z katalogu, w którym znajduje się ta paczka (oczywiście trzeba mieć uprawnienia administratora).

Barman997

No i właśnie nie rozumię, co znaczy uprawniwnia instalatora.Jestem jedynym użytkownikiem tego kompa, więc o co chodzi z tymi uprawnieniami?

pavbaranov

Każdy linux dla obsługi poleceń systemowych wymaga uprawnień administratora (użytkownikowi wolno robić wyłącznie to, co dotyczy jego katalogu domowego). Nie wiem, czy LMDE ma sudo, czy masz je skonfigurowane itd. - zwykle Mint się nim posługiwał. Jeśli tak, to polecenie powyższe poprzedź poleceniem sudo - poprosi Cię o hasło (Twoje) i dokona instalacji.
Poczytaj sobie o podstawach obsługi LMDE, Minta i Debiana, czy linuksa w ogólności, bo Ci się przyda. To o czym piszesz, to absolutne podstawy obsługi systemu.

Barman997

Próbowałem użyć komendy powyższej , ale dalej nic
Opis następujący :
NIe udało się odnaleźć pakietu 45.02552.898_i386.deb
NIe udało się odnaleźć żadnego  pakietu według wyrażenia regularnego " 45.02552.898_i386.deb"

lami07

LMDE to z grubsza Debian Stable, więc możesz spróbować dodać repo opery do listy źródeł.

Na początek wpisz w terminalu
sudo nano /etc/apt/sources.list.d/opera.list

W nowo otwartym oknie edytora nano wklej
deb http://deb.opera.com/opera-stable/ stable non-free

Zapisz kombinacją klawiszy ctrl+s, zamknij przy pomocy ctrl+x

Dodaj klucz repozytorium Opery do listy zaufanych kluczy przy pomocy polecenia
wget -O - https://deb.opera.com/archive.key | sudo apt-key add -

Odśwież listą paczek przy pomocy
sudo apt update

Zainstaluj Operę
sudo apt install opera-stable


IRC - #linuxiarze.pl w sieci libera.chat
Matrix - #linuxiarze.pl w sieci matrix.org

Barman997

No i po wpisie sudo apt update
wyskoczył komunikat:
Nie udało się odczytać list żródeł.

pavbaranov

@lami07 - Słusznie prawi, ale...

Cytat: Barman997 w Marzec 26, 2020, 11:03:49 AM
Próbowałem użyć komendy powyższej , ale dalej nic
Opis następujący :
NIe udało się odnaleźć pakietu 45.02552.898_i386.deb
NIe udało się odnaleźć żadnego  pakietu według wyrażenia regularnego " 45.02552.898_i386.deb"
Powyższe oznacza prawdopodobnie, że wadliwie przepisałeś komendę albo podałeś wadliwą nazwę w swoim poście. Możesz to zrobić również przez wciśnięcie TAB po wpisaniu części nazwy paczki (np. opera-stable i teraz wciskasz TAB) co spowoduje jej prawidłowe dopełnienie. Oczywiście pozostała część polecenia pozostaje, jak również info, że musisz to wykonać w katalogu, w którym jest plik opera-stable*.

lami07

Cytat: Barman997 w Marzec 26, 2020, 11:35:11 AM
No i po wpisie sudo apt update
wyskoczył komunikat:
Nie udało się odczytać list żródeł.
Tyle tyle wyskoczyło? Na pewno nie. Podaj całość.
IRC - #linuxiarze.pl w sieci libera.chat
Matrix - #linuxiarze.pl w sieci matrix.org

Barman997

Poprawiłem niepoprawny wpis i po ponownej operacji komunikat brzmi następująco:
Następujące pakiety mają  niespełnione zależności:
opera- stable : wymaga: libcurl3(>=7.16.2) ale nie da się go zainstalować
                      poleca: pepperflashplugin- nonfree ale nie zostanie zainstalowany
                      poleca: chromium -codecs- ffmpeg- extra ale nie da się go zainstalować
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.

Barman997

Zastanawiam się czy na mój stary komputer nadawał by się jaki inny lekki system. Czy coś możecie polecić?

lami07

Ok.  Wymagana przez opere 45 biblioteka libcurl został porzucona przez Debiana. Odpuść sobie próby instalacji 32 bit opery. Jeśli masz możliwość to przejdź na 64bity, jeśli nie to wyprobuj przeglądarkę Vivaldi.
IRC - #linuxiarze.pl w sieci libera.chat
Matrix - #linuxiarze.pl w sieci matrix.org

Zobacz najnowsze wiadomości na forum