Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: Jak zainstalować flashrom ver. 1.1 na Mint/Ubuntu ?  (Przeczytany 315 razy)

Offline mintaj

  • Newbie
  • *
  • Wiadomości: 2
  • Reputacja: +0/-0
Jak zainstalować flashrom ver. 1.1 na Mint/Ubuntu ?
« dnia: Luty 29, 2020, 11:41:26 pm »
Jestem stosunkowo nowy w Linuxie. Mam prośbę o pomoc w zainstalowaniu programu flashrom w wersji 1.1. Wiem, że 0.9.9 można zainstalować poprzez menadżer oprogramowania lub przez apt-get. I taką mam zainstalowaną. Ale chciałbym zainstalować nowszą 1.1 i nie wiem jak.
 Ściągnąłem i rozpakowałem plik z tar.bz2. Przeczytałem readme z tego pliku i ... nie wiem co dalej. Coś o make mi mówi. Nie rozumiem tego - proszę o pomoc.
Pozdrawiam

Offline Piotr_1988

  • Full Member
  • ***
  • Wiadomości: 161
  • Reputacja: +1/-1
Odp: Jak zainstalować flashrom ver. 1.1 na Mint/Ubuntu ?
« Odpowiedź #1 dnia: Luty 29, 2020, 11:46:53 pm »
Zobacz tutaj:
https://linuxiarze.pl/kompilacja/
Fedora 32
CentOS 8

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2518
  • Reputacja: +32/-8
Odp: Jak zainstalować flashrom ver. 1.1 na Mint/Ubuntu ?
« Odpowiedź #2 dnia: Marzec 01, 2020, 10:44:22 am »
Opis masz w pliku README w rozpakowanym tarballu. Nie wiem jakiej dystrybucji używasz, bo warto byłoby podglądnąć instrukcje budowy paczki w Twoim systemie (dla 0.9.9) oraz wykonać paczkę systemową. Sposób budowania masz np. tu: https://git.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/flashrom. Sekcja preparep powoduje, że program trafi do /usr/sbin, sekcja package tworzy paczkę. Teoretycznie zatem wykonanie polecenia make w katalogu z rozpakowanymi źródłami stworzy Ci binarkę programu. Powinieneś go móc używać z katalogu, w którym binarka zostanie zrobiona. Polecenie make install może napotkać na trudność w instalacji programu w Twoim systemie, albowiem masz go już w innej wersji, a dokonujesz instalacji z pominięciem systemu paczkowania w Twojej dystrybucji (stąd lepiej zrobić paczkę).
Jak widzisz, ostatnia wersja programu do 1.2.