Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Zegar arch-linux idzie 4 minuty do przodu

Zaczęty przez D35CART35, Luty 19, 2020, 08:13:12 AM

Poprzedni wątek - Następny wątek

D35CART35

Witam wszystkich, ja się zwracam do was z problemem jak w tytule, nawet po przeinstalowaniu arch-a, w przeciwieństwie do niego zegar manjaro pokazuje czas prawidłowo.
Pierwszy raz się z tym spotykam bo na ogół arch pokazywał prawidłowy czas, stało się tak po którejś aktualizacji, za wszelką pomoc bardzo Dziękuje i pozdrawiam.

nycko

Haj, a co terminal wypisuje?
systemctl status systemd-timesyncd.service
systemctl status ntpd.service
GitLab = users/nycko123/projects | GitHub = nycko123 | AUR = packages/?SeB=m&K=nycko123

D35CART35

Na chwilę obecną nie mam dostępu do tego sprzętu, później umieszczę.

robson75

Proponuje uruchomić usługę systemd-timesyncd.
systemctl enable systemd-timesyncd.service
systemctl start systemd-timesyncd.service
Ja mam ją uruchomioną i wszystko działa jak trzeba, a w dodatku po zmianie czasu z zimowego na letni systemd-timesyncd sam automatycznie zmieni ten czas.
timedatectl
               Local time: śro 2020-02-19 11:21:37 CET
           Universal time: śro 2020-02-19 10:21:37 UTC
                 RTC time: śro 2020-02-19 10:21:37
                Time zone: Europe/Warsaw (CET, +0100)
System clock synchronized: yes
              NTP service: active
          RTC in local TZ: no
Arch Linux Xfce+compiz - 64Bit Linux User #621110

LinGruby

@D35CART35

dajesz gdzie chcesz ja mam w /usr/local/bin skrypt ntp.sh o zawartości

#!/bin/sh
  (
  /usr/bin/ntpdate vega.cbk.poznan.pl \
                   zegar.umk.pl \
                   ntp.nask.pl \
                   time.atman.pl \
                   ntp.task.gda.pl \
 
 
  /usr/bin/hwclock --systohc
  ) >/dev/null


potem w /etc/crontab dodajesz np:


*/14 * * * * root /usr/local/bin/ntp.sh


raz na godzinę będzie Ci się aktualizował zegar
( ja tam robię w każdym sprzęcie na którym stawiałem system )
i nie mam od ludzi trucia d... że czas maja nie aktualny ( zresztą na Windows wieki temu podobnie robiłem że co godzinę czas się aktualizował )

( ͡° ͜ʖ ͡°)  Linux User #592024 System:  spectrwm  Kernel: 5.X.X.llX-1-lin-git+ x86_64 (64 bit gcc: 12.x.x)
Desktop: twm info: polybar Wm: spectrwm 3.4.1  Dm: lightdm  Distro: Arch Linux

LinGruby

Cytat: robson75 w Luty 19, 2020, 11:28:26 AM
[...]
a w dodatku po zmianie czasu z zimowego na letni systemd-timesyncd sam automatycznie zmieni ten czas.
[...]

no to akurat większość nowszych sprzętów samoczynnie zmienia z letniego na zimowy i na odwrót ( np: smartphone ) czy większość zegarków co ma funkcję DST... o DCF 77 nie wspominam bo to każdy wie co ma sprzęt z radio-control a są i takie odbiorniki do kompów na USB co synchronizują czas z DCF 77 o GPS nie wspominam bo tam z automatu zmienia czas jak się strefę zmieni...
( ͡° ͜ʖ ͡°)  Linux User #592024 System:  spectrwm  Kernel: 5.X.X.llX-1-lin-git+ x86_64 (64 bit gcc: 12.x.x)
Desktop: twm info: polybar Wm: spectrwm 3.4.1  Dm: lightdm  Distro: Arch Linux

robson75

#6
Cytat: LinGruby w Luty 19, 2020, 07:22:48 PM

no to akurat większość nowszych sprzętów samoczynnie zmienia z letniego na zimowy i na odwrót ( np: smartphone ) czy większość zegarków co ma funkcję DST... o DCF 77 nie wspominam bo to każdy wie co ma sprzęt z radio-control a są i takie odbiorniki do kompów na USB co synchronizują czas z DCF 77 o GPS nie wspominam bo tam z automatu zmienia czas jak się strefę zmieni...
No a ja pamiętam jakieś 3 lata temu na Manjaro miałem problem ze zmianą czasu, z zimowego na letni. To kombinowałem z NTP, a dzisiaj wiem że wystarczy systemd-timesyncd.
Arch Linux Xfce+compiz - 64Bit Linux User #621110

D35CART35

@ nycko podaje wynik poleceń
systemctl status systemd-timesyncd.service
● systemd-timesyncd.service - Network Time Synchronization
     Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; disable>
     Active: inactive (dead)
       Docs: man:systemd-timesyncd.service(8)
...skipping...
● systemd-timesyncd.service - Network Time Synchronization
     Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; disable>
     Active: inactive (dead)
       Docs: man:systemd-timesyncd.service(8)
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
lines 1-4/4 (END)


systemctl status ntpd.service
● ntpd.service - Network Time Service
     Loaded: loaded (/usr/lib/systemd/system/ntpd.service; disabled; vendor pre>
     Active: inactive (dead)
lines 1-3/3 (END)


pavbaranov

Pomijając możliwość uruchomienia którejś z usług, wydaj sobie polecenie date, skonfiguruj ją prawidłowo wg jakiegoś czasu, który będzie Twoim punktem odniesienia i sprawdź za powiedzmy miesiąc, czy jest jakaś różnica. Da Ci to informację, gdzie jest jakiś problem z czasem.
BTW: Nie istnieje coś takiego jak "zegar arch-linux". Arch nie ma żadnego serwera czasu, w Twoim przypadku zegar nie jest w żaden sposób synchronizowany zewnętrznie. Ot, gdzieś przy jakiejś okazji nastąpiło z jakiegoś powodu jego przekłamanie. Nie dojdziemy obecnie z jakiego.
PS: Też na jednym z komputerów pokazywany czas był +/- 4 minuty do przodu.

D35CART35

Dziękuje wszystkim za zainteresowanie i pomoc, przetestowałem metody podane przez @robson75 jak i  @LinGruby, obie działają prawidłowo, na razie problem rozwiązany, w wolnej chwili sprawdzę to co pisał @pavbaranov, za pomoc bardzo dziękuje wszystkim i pozdrawiam.

nycko

@D35CART35
Masz w systemie 2 serwisy do aktualizacji czasu i oba nieaktywne. Rozwiązania widzę trzy:
1. zostajesz z tym, co doradził Ci LinGruby
2. decydujesz się na ntp i zamiast skryptu + crona po prostu uruchamiasz sudo systemctl enable --now ntpd.service. Tą metodę ja uważam za niewystarczającą i przestarzałą, a dodatkowe info masz tu https://wiki.archlinux.org/index.php/Network_Time_Protocol_daemon#Start_ntpd_at_boot
3. decydujesz się na systemd, co pozwoli Ci wywalić w pieruny paczkę ntp i korzystanie z dostępnej w każdej dużej dystrybucji systemd-timesyncd.service, uruchamiając sudo systemctl enable --now systemd-timesyncd.service. Ta metoda jest według mnie najprostsza i nie wymaga żadnych kombinacji od użytkownika, a dodatkowe info masz tu https://wiki.archlinux.org/index.php/Systemd-timesyncd
Ja używam i polecam opcję trzecią z taką konfiguracją:
/etc/systemd/timesyncd.conf
##  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# Entries in this file show the compile time defaults.
# You can change settings by editing this file.
# Defaults can be restored by simply deleting this file.
#
# See timesyncd.conf(5) for details.

[Time]
NTP=0.pl.pool.ntp.org 1.pl.pool.ntp.org 2.pl.pool.ntp.org 3.pl.pool.ntp.org
FallbackNTP=0.arch.pool.ntp.org 1.arch.pool.ntp.org 2.arch.pool.ntp.org 3.arch.pool.ntp.org
RootDistanceMaxSec=5
PollIntervalMinSec=32
PollIntervalMaxSec=2048
GitLab = users/nycko123/projects | GitHub = nycko123 | AUR = packages/?SeB=m&K=nycko123

pavbaranov

To jeszcze rozwiązanie dla kogoś bez dostępu do sieci:
1. Sprawdzamy czas RTC (BIOS, hardware'owy - jak go tam sobie chcecie nazwać):
# hwclock -r
2. Jeśli nasz czas systemowy (ten wyświetlany w DE) różni się od astronomicznego (tak jest u @D35CART35), ustawiamy:
# date "YYYY-MM-DD HH:MM:SS"
3. "Wyrównujemy" czas RTC do systemowego:
# hwclock -w

Rozwiązanie ma jedną zaletę, niezależną od proponowanych ustawień z odległymi serwerami czasu - te ostatnie dokonują systemowej synchronizacji czasu, ale nie wpływają na RTC. Powyższe rozwiązanie doprowadza do zgodności RTC i zegara systemowego. Oczywiście jeśli podnieśliśmy usługę np. systemd-timesyncd, to punkt 2 będzie zbędny.

PS: Dziękuję @arch_jest_super

LinGruby

@pavbaranov
ad 3. no własnie moim skrypcie jest to robione
hwclock --systohc
to to samo co
hwclock -w
( ͡° ͜ʖ ͡°)  Linux User #592024 System:  spectrwm  Kernel: 5.X.X.llX-1-lin-git+ x86_64 (64 bit gcc: 12.x.x)
Desktop: twm info: polybar Wm: spectrwm 3.4.1  Dm: lightdm  Distro: Arch Linux

Zobacz najnowsze wiadomości na forum