Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: Problem z instalacją skanera w Brother DCP-7030  (Przeczytany 1165 razy)

Offline Kano

  • Newbie
  • *
  • Wiadomości: 49
  • Reputacja: +0/-0
Odp: Problem z instalacją skanera w Brother DCP-7030
« Odpowiedź #15 dnia: Styczeń 10, 2020, 07:15:40 pm »
Wiem, że to są podstawy, ale używam Linuxa od jakichś 2 tygodni i dotąd jak chciałem coś zaintalować to robiłem to wyłącznie przez centrum oprogramowania Ubuntu. Ale jak tylko uda się zmusić skaner do działania będę systematycznie poszerzał swoją wiedzę o systemie :)
A wracając do tematu to przy instalacji driver tool'a nie było możliwości niczego odinstalować. Terminal wyświetlił umowę, zapytał czy ją akceptuję i spytał "Will you specify the DeviceURI", wydrukował stronę testową. I tyle.
Później przez terminal za pomocą apt search wyszukałem brscan3 i za pomocą apt remove go odinstalowałem. Potem zainstalowałem Synaptica i tam jedna z kategorii pakietów to był "Brother". Tam odinstalowałem brskey (czy coś w tym rodzaju, tak jak pisałeś) i teraz zostały na liście tylko dwa pakiety: "brdcp7030lpr:i386" i "cupswrapperdcp7030:i386". Więc je chyba powinienem zostawić.
A więc teraz powinienem jeszcze odinstalować "libsane". Tylko, że kiedy wpisałem to w wyszukiwarkę w synapticu wyskoczyło mi wiele pakietów mających to w nazwie:

libsane-common
libsane-hpaio (zdaje się, że to jest pakiet do drukarek HP, więc chyba nie o ten chodzi)
libsane1

Który z nich odinstalować?

p.s. Kiedy odistalowałem brscan3 przez terminal, po ponownym wyszukaniu przez apt search, pozostał po nim taki wpis:
brscan3/now 0.2.13-1 amd64 [residual-config]
  (none)
Czy da się i czy powinienem próbować to jakoś usunąć?
« Ostatnia zmiana: Styczeń 10, 2020, 07:19:26 pm wysłana przez Kano »

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2008
  • Reputacja: +0/-0
Odp: Problem z instalacją skanera w Brother DCP-7030
« Odpowiedź #16 dnia: Styczeń 10, 2020, 09:31:48 pm »
Tak, ten config jakoś winieneś usunąć, ale tu muszą Ci pomóc użytkownicy APTa.
Driver-itd. po ponownym uruchomieniu, gdy wcześniej zainstalował sterowniki ma opcję ich usunięcia. Mniejsza o to, bowiem obecnie to nie jest już istotne.
Po usunięciu tego configu - po prostu uruchom ten skrypt.
I tak - pozostałych paczek dla Brother nie ruszaj. To są sterowniki drukarki.

Offline Kano

  • Newbie
  • *
  • Wiadomości: 49
  • Reputacja: +0/-0
Odp: Problem z instalacją skanera w Brother DCP-7030
« Odpowiedź #17 dnia: Styczeń 11, 2020, 11:22:43 am »
Ok. Znalazłem ten config za pomocą Synaptica i usunąłem. Następnie wykonałem dmk@DMK:~$ sudo apt-get install --fix-broken
[sudo] hasło użytkownika dmk:
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.[/sudo]
później
[code]sudo apt clean

Następnie ponownie "Driver install tool". Może wrzucę tutaj to co wyświetlił terminal w czasie instalacji:
dmk@DMK:~/Downloads/brother$ sudo bash linux-brprinter-installer-2.2.1-1 DCP-7030
[sudo] hasło użytkownika dmk:
You are going to install following packages.
   brdcp7030lpr-2.0.2-1.i386.deb
   cupswrapperDCP7030-2.0.2-1.i386.deb
   brscan3-0.2.13-1.amd64.deb
   brscan-skey-0.2.4-1.amd64.deb
OK? [y/N] ->y

Stary:1 http://pl.archive.ubuntu.com/ubuntu bionic InRelease
Pobieranie:2 http://pl.archive.ubuntu.com/ubuntu bionic-updates InRelease [88,7 kB]
Pobieranie:3 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
Pobieranie:4 http://pl.archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]
Pobieranie:5 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages [830 kB]
Pobieranie:6 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main i386 Packages [629 kB]
Pobieranie:7 http://security.ubuntu.com/ubuntu bionic-security/main i386 Packages [417 kB]
Pobieranie:8 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main amd64 DEP-11 Metadata [295 kB]
Pobieranie:9 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages [606 kB]
Pobieranie:10 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 48x48 Icons [73,8 kB]
Pobieranie:11 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 64x64 Icons [143 kB]
Pobieranie:12 http://pl.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages [1 035 kB]
Pobieranie:13 http://security.ubuntu.com/ubuntu bionic-security/main Translation-en [196 kB]
Pobieranie:14 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [38,5 kB]
Pobieranie:15 http://security.ubuntu.com/ubuntu bionic-security/main DEP-11 48x48 Icons [17,6 kB]
Pobieranie:16 http://security.ubuntu.com/ubuntu bionic-security/main DEP-11 64x64 Icons [41,5 kB]
Pobieranie:17 http://security.ubuntu.com/ubuntu bionic-security/universe i386 Packages [606 kB]
Pobieranie:18 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [633 kB]
Pobieranie:19 http://security.ubuntu.com/ubuntu bionic-security/universe Translation-en [213 kB]
Pobieranie:20 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [42,1 kB]
Pobieranie:21 http://security.ubuntu.com/ubuntu bionic-security/universe DEP-11 48x48 Icons [16,4 kB]
Pobieranie:22 http://security.ubuntu.com/ubuntu bionic-security/universe DEP-11 64x64 Icons [111 kB]
Pobieranie:23 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 DEP-11 Metadata [2 464 B]
Pobieranie:24 http://pl.archive.ubuntu.com/ubuntu bionic-updates/universe i386 Packages [997 kB]
Pobieranie:25 http://pl.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 DEP-11 Metadata [264 kB]
Pobieranie:26 http://pl.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 48x48 Icons [199 kB]
Pobieranie:27 http://pl.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 64x64 Icons [448 kB]
Pobieranie:28 http://pl.archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2 464 B]
Pobieranie:29 http://pl.archive.ubuntu.com/ubuntu bionic-backports/universe amd64 Packages [4 044 B]
Pobieranie:30 http://pl.archive.ubuntu.com/ubuntu bionic-backports/universe i386 Packages [4 036 B]
Pobieranie:31 http://pl.archive.ubuntu.com/ubuntu bionic-backports/universe Translation-en [1 900 B]
Pobieranie:32 http://pl.archive.ubuntu.com/ubuntu bionic-backports/universe amd64 DEP-11 Metadata [7 980 B]
Pobrano 8 126 kB w 5s (1 665 kB/s)                                             
Czytanie list pakietów... Gotowe
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Pakiet ia32-libs nie ma dostępnej wersji, ale odnosi się do niego inny pakiet.
Zazwyczaj oznacza to, że pakietu brakuje, został zastąpiony przez inny
pakiet lub nie jest dostępny przy pomocy obecnie ustawionych źródeł.
Jednak następujące pakiety go zastępują:
  lib32ncurses5 lib32z1

E: Pakiet ia32-libs nie ma kandydata do instalacji
dpkg -x brdcp7030lpr-2.0.2-1.i386.deb /
dpkg -x cupswrapperDCP7030-2.0.2-1.i386.deb /
dpkg-deb: budowanie pakietu "brdcp7030lpr" w "brdcp7030lpr-2.0.2-1a.i386.deb".
dpkg -b ./brother_driver_packdir brdcp7030lpr-2.0.2-1a.i386.deb
dpkg-deb: budowanie pakietu "cupswrapperdcp7030" w "cupswrapperDCP7030-2.0.2-1a.i386.deb".
dpkg -b ./brother_driver_packdir cupswrapperDCP7030-2.0.2-1a.i386.deb
dpkg -i --force-all brdcp7030lpr-2.0.2-1a.i386.deb
(Odczytywanie bazy danych ... 178386 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu brdcp7030lpr-2.0.2-1a.i386.deb ...
Rozpakowywanie pakietu brdcp7030lpr:i386 (2.0.2-1) nad (2.0.2-1) ...
Konfigurowanie pakietu brdcp7030lpr:i386 (2.0.2-1) ...
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib32/libbrcomplpr2.so': Plik istnieje
dpkg -i --force-all cupswrapperDCP7030-2.0.2-1a.i386.deb
(Odczytywanie bazy danych ... 178386 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu cupswrapperDCP7030-2.0.2-1a.i386.deb ...
Restarting cups (via systemctl): cups.service.
Rozpakowywanie pakietu cupswrapperdcp7030:i386 (2.0.2-1) nad (2.0.2-1) ...
Konfigurowanie pakietu cupswrapperdcp7030:i386 (2.0.2-1) ...
Restarting cups (via systemctl): cups.service.
#
Will you specify the Device URI? [Y/n] ->n

Test Print? [y/N] ->n

You are going to install following packages.
   brscan3-0.2.13-1.amd64.deb
dpkg -i --force-all brscan3-0.2.13-1.amd64.deb
Wybieranie wcześniej niewybranego pakietu brscan3.
(Odczytywanie bazy danych ... 178386 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu brscan3-0.2.13-1.amd64.deb ...
Rozpakowywanie pakietu brscan3 (0.2.13-1) ...
Konfigurowanie pakietu brscan3 (0.2.13-1) ...
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/sane/libsane-brother3.so.1.0.7': Nie jest katalogiem
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/sane/libsane-brother3.so.1': Nie jest katalogiem
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/sane/libsane-brother3.so': Nie jest katalogiem
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/libbrscandec3.so.1.0.0': Plik istnieje
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/libbrscandec3.so.1': Plik istnieje
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/libbrscandec3.so': Plik istnieje
You are going to install following packages.
   brscan-skey-0.2.4-1.amd64.deb
dpkg -i --force-all brscan-skey-0.2.4-1.amd64.deb
Wybieranie wcześniej niewybranego pakietu brscan-skey.
(Odczytywanie bazy danych ... 178406 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu brscan-skey-0.2.4-1.amd64.deb ...
Rozpakowywanie pakietu brscan-skey (0.2.4-1) ...
Konfigurowanie pakietu brscan-skey (0.2.4-1) ...

Jednak skaner dalej nie działa. Drukarka jest widziana po "lsusb", jednak "scanimage -L" podaje, że skaner dalej nie jest wykrywany.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2008
  • Reputacja: +0/-0
Odp: Problem z instalacją skanera w Brother DCP-7030
« Odpowiedź #18 dnia: Styczeń 11, 2020, 11:38:02 am »
Teraz widać, że ta instalacja nie przebiega tak, jak ów skrypt zakłada. Znów powiem - nie mam Ubuntu, ale to co widzę:
- skrypt wymaga paczki ia32-libs, ale taka paczka już w repozytoriach, które masz nie istnieje, paczkę tę zastępują lib32ncurses5 i/lub lib32z1 - prawdopodobnie jedną z nich powinieneś mieć zainstalowaną, a nie masz,
- sprawdź sobie co jest właścicielem plików:
-- /usr/lib32/libbrcomplpr2.so
-- /usr/lib/sane/libsane-brother3.so.1.0.7
-- /usr/lib/sane/libsane-brother3.so.1
-- /usr/lib/sane/libsane-brother3.so
-- /usr/lib/libbrscandec3.so.1.0.0
-- /usr/lib/libbrscandec3.so.1
-- /usr/lib/libbrscandec3.so
Wygląda to tak, jakbyś pomimo odinstalowania brscan3 nadal miał tę paczkę zainstalowaną. To jakiś problem zbyt wielu prób instalacji, prawdopodobnie pochodzących z różnych "sposobów". Można się spróbować bawić to ręcznie jakoś poustawiać, ale wpierw jednak po prostu dokonałbym wyczyszczenia systemu, czyli poprawnego odinstalowania paczek związanych z tym skanerem (a nie usunięcia plików - to są 2 różne rzeczy) i dopiero potem spróbował użyć tego driver-bla-bla.
Dla pewności, gdy piszesz, że "scanimage -L" nie widzi skanera, to wykonaj próbę również jako root (sudo) i pisz, czy nie widzi w obu, czy tylko jako zwykły użytkownik, albowiem jest to dość znany "problem" z uprawnieniami sterowników brothera, że skaner widziany jest wyłącznie przy uprawnieniach administratora. W tym drugim przypadku jest to jednak przysłowiowe 5 minut roboty, by skaner był widziany również dla ZU.

EDIT:
Aha, przy okazji - widzę, że sterownik dla Archa musi mieć jako zależność również libusb-compat. Nie wiem, czy jest taka paczka w Ubuntu, ewentualnie jak się nazywa, czy też co ją zapewnia (bo coś zapewniające musi być). Tutaj: https://www.archlinux.org/packages/extra/x86_64/libusb-compat/ masz info o jaką paczkę chodzi (to nie jest paczka dla Ciebie, ta jest w Arch).
« Ostatnia zmiana: Styczeń 11, 2020, 11:40:45 am wysłana przez pavbaranov »

Offline Kano

  • Newbie
  • *
  • Wiadomości: 49
  • Reputacja: +0/-0
Odp: Problem z instalacją skanera w Brother DCP-7030
« Odpowiedź #19 dnia: Styczeń 11, 2020, 08:32:07 pm »
Ok. Więc zainstalowałem pakiety "lib32ncurses5" i "lib32n1". Chociaż dla mnie jako dla laika to trochę dziwne, że do działania sterownika w systemie 64-bitowym potrzebne są pakiety dla systemu 32-bitowego.
Jeśli chodzi o właściciela plików, to o ile dobrze wyczytałem w necie do jego określenia służy komenda ls -l lokalizacjaPliku. To wyświetlił mi terminal w odpowiedzi:
dmk@DMK:~$ ls -l /usr/lib32/libbrcomplpr2.so
lrwxrwxrwx 1 root root 25 sty  3 10:50 /usr/lib32/libbrcomplpr2.so -> /usr/lib/libbrcomplpr2.so
dmk@DMK:~$ ls -l /usr/lib/sane/libsane-brother3.so.1.0.7
ls: nie ma dostępu do '/usr/lib/sane/libsane-brother3.so.1.0.7': Nie jest katalogiem
dmk@DMK:~$ ls -l /usr/lib/sane/libsane-brother3.so.1
ls: nie ma dostępu do '/usr/lib/sane/libsane-brother3.so.1': Nie jest katalogiem
dmk@DMK:~$ ls -l /usr/lib/sane/libsane-brother3.so
ls: nie ma dostępu do '/usr/lib/sane/libsane-brother3.so': Nie jest katalogiem
dmk@DMK:~$ ls -l /usr/lib/libbrscandec3.so.1.0.0
-rwxr-xr-x 1 root root 37064 sty  9 14:04 /usr/lib/libbrscandec3.so.1.0.0
dmk@DMK:~$ ls -l /usr/lib/libbrscandec3.so.1
-rwxr-xr-x 1 root root 37064 sty  9 14:08 /usr/lib/libbrscandec3.so.1
dmk@DMK:~$ ls -l /usr/lib/libbrscandec3.so
-rwxr-xr-x 1 root root 37064 sty  9 14:07 /usr/lib/libbrscandec3.so

Co do deinstalacji pakietów poszperałem trochę w necie i jakoś nigdzie nie mogłem znaleźć informacji jak odinstalować dany pakiet. Wszędzie była mowa jedynie o instalacji i usuwaniu pakietu. Nawet w Synapticu jedyna opcja oprócz instalacji to usuwanie, więc nie mam pojęcia jak odinstalować dany pakiet.
Jeśli chodzi o polecenie "scanimage -L" to wywołałem je odrazu jako root.
Co do paczki "libusb-compat" to nie znalazło mi takiej w synapticu, ale jest "libusb + nr serii", więc może to jest odpowiednikiem tego pakietu. W opise tych pakietów jest napisane "Biblioteka programowania USB w przestrzeni użytkownika". Obydwie mam zainstalowane.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2008
  • Reputacja: +0/-0
Odp: Problem z instalacją skanera w Brother DCP-7030
« Odpowiedź #20 dnia: Styczeń 12, 2020, 10:19:24 am »
Może źle się wyraziłem. Pytając o "właściciela" pliku chodziło mi o to jaka paczka dostarczyła go podczas instalacji. W debianowatych zdaje się, że jest to do ustalenia poprzez komendy:
dpkg -S /lokalizacja/nazwa-plikulub
dlocate /lokalizacja/nazwa-pliku
Pisząc o "deinstalacji" oczywiście chodziło mi o usuwanie.

PS: 32bitowe biblioteki są potrzebne w systemie 64 bitowym np. do obsługi programów 32 bitowych w takim systemie, w tym również do działania takich sterowników. Brother co najmniej część sterowników dostarcza wyłącznie w wersji 32 bitowej (i dlatego m.in. nie używam KaOSa ;)).

Offline Kano

  • Newbie
  • *
  • Wiadomości: 49
  • Reputacja: +0/-0
Odp: Problem z instalacją skanera w Brother DCP-7030
« Odpowiedź #21 dnia: Styczeń 12, 2020, 04:31:19 pm »
dpkg -S zwraca dpkg-query: nie znaleziono ścieżki pasującej do wzorca, np. dpkg -S /usr/lib/libbrscandec3.so
dpkg-query: nie znaleziono ścieżki pasującej do wzorca /usr/lib/libbrscandec3.so
a dlocate po kilku sekundach "myślenia" nie zwraca nic. Próbowałem też komendy apt-file search ścieżka/nazwaPliku, ale ono też nic nie zwraca.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2008
  • Reputacja: +0/-0
Odp: Problem z instalacją skanera w Brother DCP-7030
« Odpowiedź #22 dnia: Styczeń 12, 2020, 04:56:37 pm »
A wydawało mi się, że piszę jasno :)
W odpowiedzi: [urlhttps://forum.linuxiarze.pl/index.php/topic,3864.msg23584.html#msg23584[/url] podałeś np. taki adres: /usr/lib/sane/libsane-brother3.so.1.0.7, a zatem polecenie dla dpkg winno wyglądać np. tak:
dpkg -S /usr/lib/sane/libsane-brother3.so.1.0.7I tak dla każdego sprawdź, choć wszystkie *.so, *.so.1, *.so.1.0.7 winny pochodzić z tej samej paczki. Dla nas (mnie) interesujące jest tylko, czy to cokolwiek zwraca (jakąś paczkę), czy nie, a zatem możesz napisać wyłącznie, że wszystko to należy do paczki X.

Offline Kano

  • Newbie
  • *
  • Wiadomości: 49
  • Reputacja: +0/-0
Odp: Problem z instalacją skanera w Brother DCP-7030
« Odpowiedź #23 dnia: Styczeń 12, 2020, 05:18:58 pm »
Właśnie w taki sam sposób sprawdziłem dpkg dla wszystkich 7 plików (dpkg -S ścieżka-do-pliku/nazwa-pliku). Tak samo kiedy skopiowałem i wkleiłem do terminala tą linijkę, którą teraz napisałeś wyskoczył mi dokładnie taki sam komunikat co wcześniej.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2008
  • Reputacja: +0/-0
Odp: Problem z instalacją skanera w Brother DCP-7030
« Odpowiedź #24 dnia: Styczeń 12, 2020, 05:46:25 pm »
Ok, sorry, na starość ślepnę.
Puść sobie ten driver-install-tool z włączonym (nieuśpionym) urządzeniem podłączonym do komputera. Jeśli drukowanie działa, to o ile się w tym skrypcie da to pominąć, to pomiń i przejdź do instalacji sterowników skanera. Po przeprowadzonej instalacji - reboot, podłączenie urządzenia i sprawdzenie przez scanimage.

Offline Kano

  • Newbie
  • *
  • Wiadomości: 49
  • Reputacja: +0/-0
Odp: Problem z instalacją skanera w Brother DCP-7030
« Odpowiedź #25 dnia: Styczeń 12, 2020, 07:21:17 pm »
Instalacja driver install tool:
dmk@DMK:~/Downloads/brother$ sudo bash linux-brprinter-installer-2.2.1-1
[sudo] hasło użytkownika dmk:
Input model name ->DCP-7030

You are going to install following packages.
   brdcp7030lpr-2.0.2-1.i386.deb
   cupswrapperDCP7030-2.0.2-1.i386.deb
   brscan3-0.2.13-1.amd64.deb
   brscan-skey-0.2.4-1.amd64.deb
OK? [y/N] ->y

Stary:1 http://pl.archive.ubuntu.com/ubuntu bionic InRelease
Stary:2 http://pl.archive.ubuntu.com/ubuntu bionic-updates InRelease
Pobieranie:3 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
Stary:4 http://pl.archive.ubuntu.com/ubuntu bionic-backports InRelease         
Pobieranie:5 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [38,6 kB]
Pobieranie:6 http://security.ubuntu.com/ubuntu bionic-security/main DEP-11 48x48 Icons [17,6 kB]
Pobieranie:7 http://security.ubuntu.com/ubuntu bionic-security/main DEP-11 64x64 Icons [41,5 kB]
Pobieranie:8 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [42,1 kB]
Pobieranie:9 http://security.ubuntu.com/ubuntu bionic-security/universe DEP-11 48x48 Icons [16,4 kB]
Pobieranie:10 http://security.ubuntu.com/ubuntu bionic-security/universe DEP-11 64x64 Icons [116 kB]
Pobieranie:11 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 DEP-11 Metadata [2 460 B]
Pobrano 364 kB w 2s (214 kB/s)                     
Czytanie list pakietów... Gotowe
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Pakiet ia32-libs nie ma dostępnej wersji, ale odnosi się do niego inny pakiet.
Zazwyczaj oznacza to, że pakietu brakuje, został zastąpiony przez inny
pakiet lub nie jest dostępny przy pomocy obecnie ustawionych źródeł.
Jednak następujące pakiety go zastępują:
  lib32ncurses5 lib32z1

E: Pakiet ia32-libs nie ma kandydata do instalacji
dpkg -x brdcp7030lpr-2.0.2-1.i386.deb /
dpkg -x cupswrapperDCP7030-2.0.2-1.i386.deb /
dpkg-deb: budowanie pakietu "brdcp7030lpr" w "brdcp7030lpr-2.0.2-1a.i386.deb".
dpkg -b ./brother_driver_packdir brdcp7030lpr-2.0.2-1a.i386.deb
dpkg-deb: budowanie pakietu "cupswrapperdcp7030" w "cupswrapperDCP7030-2.0.2-1a.i386.deb".
dpkg -b ./brother_driver_packdir cupswrapperDCP7030-2.0.2-1a.i386.deb
dpkg -i --force-all brdcp7030lpr-2.0.2-1a.i386.deb
(Odczytywanie bazy danych ... 179220 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu brdcp7030lpr-2.0.2-1a.i386.deb ...
Rozpakowywanie pakietu brdcp7030lpr:i386 (2.0.2-1) nad (2.0.2-1) ...
Konfigurowanie pakietu brdcp7030lpr:i386 (2.0.2-1) ...
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib32/libbrcomplpr2.so': Plik istnieje
dpkg -i --force-all cupswrapperDCP7030-2.0.2-1a.i386.deb
(Odczytywanie bazy danych ... 179220 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu cupswrapperDCP7030-2.0.2-1a.i386.deb ...
Restarting cups (via systemctl): cups.service.
Rozpakowywanie pakietu cupswrapperdcp7030:i386 (2.0.2-1) nad (2.0.2-1) ...
Konfigurowanie pakietu cupswrapperdcp7030:i386 (2.0.2-1) ...
Restarting cups (via systemctl): cups.service.
#
Will you specify the Device URI? [Y/n] ->n

Test Print? [y/N] ->y

wait 5s.
lpr -P DCP7030 /usr/share/cups/data/testprint
You are going to install following packages.
   brscan3-0.2.13-1.amd64.deb
dpkg -i --force-all brscan3-0.2.13-1.amd64.deb
(Odczytywanie bazy danych ... 179220 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu brscan3-0.2.13-1.amd64.deb ...
Rozpakowywanie pakietu brscan3 (0.2.13-1) nad (0.2.13-1) ...
Konfigurowanie pakietu brscan3 (0.2.13-1) ...
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/sane/libsane-brother3.so.1.0.7': Nie jest katalogiem
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/sane/libsane-brother3.so.1': Nie jest katalogiem
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/sane/libsane-brother3.so': Nie jest katalogiem
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/libbrscandec3.so.1.0.0': Plik istnieje
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/libbrscandec3.so.1': Plik istnieje
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/libbrscandec3.so': Plik istnieje
You are going to install following packages.
   brscan-skey-0.2.4-1.amd64.deb
dpkg -i --force-all brscan-skey-0.2.4-1.amd64.deb
(Odczytywanie bazy danych ... 179220 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu brscan-skey-0.2.4-1.amd64.deb ...
Rozpakowywanie pakietu brscan-skey (0.2.4-1) nad (0.2.4-1) ...
Konfigurowanie pakietu brscan-skey (0.2.4-1) ...
Hit Enter/Return key.

Spełnienie procedur poprzedzających instalację scanner driver i scan-key-tool:
dmk@DMK:~/Downloads/brother$ sudo ln -s /etc/init.d/cups /etc/init.d/lpd
ln: nie udało się utworzyć dowiązania symbolicznego '/etc/init.d/lpd': Plik istnieje
dmk@DMK:~/Downloads/brother$ sudo mkdir /var/spool/lpd
mkdir: nie można utworzyć katalogu „/var/spool/lpd”: Plik istnieje

Instalacja scanner driver:
dmk@DMK:~/Downloads/brother$ sudo dpkg -i --force-all brscan3-0.2.13-1.amd64.deb(Odczytywanie bazy danych ... 179220 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu brscan3-0.2.13-1.amd64.deb ...
Rozpakowywanie pakietu brscan3 (0.2.13-1) nad (0.2.13-1) ...
Konfigurowanie pakietu brscan3 (0.2.13-1) ...
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/sane/libsane-brother3.so.1.0.7': Nie jest katalogiem
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/sane/libsane-brother3.so.1': Nie jest katalogiem
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/sane/libsane-brother3.so': Nie jest katalogiem
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/libbrscandec3.so.1.0.0': Plik istnieje
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/libbrscandec3.so.1': Plik istnieje
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/libbrscandec3.so': Plik istnieje
Tutaj chyba coś poszło nie tak.

Instalcja scan-key-tool:
dmk@DMK:~/Downloads/brother$ sudo dpkg -i --force-all brscan-skey-0.2.4-1.amd64.deb
(Odczytywanie bazy danych ... 179220 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu brscan-skey-0.2.4-1.amd64.deb ...
Rozpakowywanie pakietu brscan-skey (0.2.4-1) nad (0.2.4-1) ...
Konfigurowanie pakietu brscan-skey (0.2.4-1) ...

Instalacja scanner setting file:
dmk@DMK:~/Downloads/brother$ sudo dpkg -i brother-udev-rule-type1-1.0.2-0.all.deb
(Odczytywanie bazy danych ... 179220 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu brother-udev-rule-type1-1.0.2-0.all.deb ...
Rozpakowywanie pakietu brother-udev-rule-type1 (1.0.2) nad (1.0.2) ...
Konfigurowanie pakietu brother-udev-rule-type1 (1.0.2) ...

Restart i:

dmk@DMK:~$ sudo scanimage -L
[sudo] hasło użytkownika dmk:

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

dmk@DMK:~$ sudo sane-find-scanner tool

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

  # No USB scanners found. If you expected something different, make sure that
  # you have loaded a kernel driver for your USB host controller and have setup
  # the USB system correctly. See man sane-usb for details.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.
:/

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2008
  • Reputacja: +0/-0
Odp: Problem z instalacją skanera w Brother DCP-7030
« Odpowiedź #26 dnia: Styczeń 12, 2020, 07:56:09 pm »
Problem leży - chyba - tu:
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/sane/libsane-brother3.so.1.0.7': Nie jest katalogiem
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/sane/libsane-brother3.so.1': Nie jest katalogiem
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/sane/libsane-brother3.so': Nie jest katalogiem
I efekt jest taki, że sterownik, którym jest libsane-brother3.so.* nie jest widziany przez SANE w Ubuntu. I tu mam problem, bowiem nie wiem, gdzie w Ubuntu lokowane są sterowniki dla SANE. Analizując libsane mogę jedynie przypuszczać, że to jest /usr/lib/x86_64-linux-gnu/sane/, ale pewności nie mam. Tu musi Ci pomóc ktoś, kto ma ten OS. Po ustaleniu należy podlinkować pliki, które są instalowane przez brscan3, tak, by widział je SANE w Ubuntu. Ten sam problem miałem w Archu i opisałem to w przywołanym wyżej linku do archlike.darmowefora.pl. Cóż... moja rola się tu kończy, mogę tylko powiedzieć, że po prawidłowym podlinkowaniu system winien współpracować z tym modelem skanera.

Offline Kano

  • Newbie
  • *
  • Wiadomości: 49
  • Reputacja: +0/-0
Odp: Problem z instalacją skanera w Brother DCP-7030
« Odpowiedź #27 dnia: Styczeń 13, 2020, 04:46:12 pm »
A czy jesteś w stanie powiedzieć mi jak podlinkować te pliki? Pytam, bo przed chwilą sprawdziłem i ścieżka którą podałeś (/usr/lib/x86_64-linux-gnu/sane/) rzeczywiście istnieje. Więc mamy chyba ustaloną lokalizację.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2008
  • Reputacja: +0/-0
Odp: Problem z instalacją skanera w Brother DCP-7030
« Odpowiedź #28 dnia: Styczeń 13, 2020, 06:55:41 pm »
No to jest dokładnie tak, jak w tym moim poradniku, oczywiście ze zmianami dla Ubu, czyli - opiszę, a nie dam Ci gotowca:
sudo ln -s skąd gdzieW miejsce skąd podstawiasz całą ścieżkę do pliku, czyli to winno być - jak widzę - w: /usr/lib64/sane/ do tego katalogu, który wskazałeś. Chodzi o pliki libsane-brother3*. Tyle, że - jak powtarzam - nie mam obecnie Ubu i to tylko tak mocno na "czuja". Prawdopodobnie jednak pójdzie.
Jeśli ten opis nie jest czytelny, to powiedz, ew. wejdź na IRC linuxiarze.pl - też pomożemy. Feedback będzie lepszy.

Offline Kano

  • Newbie
  • *
  • Wiadomości: 49
  • Reputacja: +0/-0
Odp: Problem z instalacją skanera w Brother DCP-7030
« Odpowiedź #29 dnia: Styczeń 14, 2020, 03:33:14 pm »
Zrobiłem te dowiązania w taki sposób:
sudo ln -s /usr/lib/sane/libsane-brother3.so.1.0.7 /usr/lib/x86_64-linux-gnu/sane/
sudo ln -s /usr/lib/sane/libsane-brother3.so.1 /usr/lib/x86_64-linux-gnu/sane/
sudo ln -s /usr/lib/sane/libsane-brother3.so /usr/lib/x86_64-linux-gnu/sane/

Po czym uruchomiłem ponownie komputer. Co prawda skaner nadal nie działa, ale po wpisaniu:
sudo scanimage -L i dalej sudo sane-find-scanner tool system zwraca coś takiego:

# sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x0cf3 [ATHEROS], product=0x9271 [USB2.0 WLAN]) at libusb:001:004
found USB scanner (vendor=0x04f9, product=0x01ea) at libusb:004:003
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.
« Ostatnia zmiana: Styczeń 14, 2020, 03:38:06 pm wysłana przez Kano »