Linuxiarze.pl Forum

Dystrybucje Linux => Ubuntu, Kubuntu, Xubuntu, Lubuntu => Wątek zaczęty przez: Kano w Styczeń 07, 2020, 05:09:39 pm

Tytuł: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: Kano w Styczeń 07, 2020, 05:09:39 pm
Witam. Ostatnio zainstalowałem na moim komputerze Ubuntu 18.04.3 LTS. Chciałem zainstalować drukarkę. Jest to Brother DCP-7030, trzy w jednym a więc posiada ona też skaner. No i na istalacji sterowników do tego drugiego poległem. Najpierw zrobiłem tak jak napisano na oficjalnej stronie producenta czyli tu:

https://support.brother.com/g/b/downloadhowto.aspx?c=pl&lang=pl&prod=dcp7030_all&os=128&dlid=dlf006642_000&flang=4&type3=566

Niestety po odpaleniu programu "Proste skanowanie" system nadal nie wykrywa skanera. Poszperałem trochę w sieci i na askubuntu.com znalazłem taki oto wątek sprzed kilku lat:

https://askubuntu.com/questions/113272/how-to-configure-brother-dcp-7030-scanner

Postanowiłem postąpić wg wskazówek użytkownika Daniel W. Poniżej znajduje się zapis wykonywanych komend i tego co terminal mi na nie odpowiedział:

dmk@DMK:~$ sudo apt-get remove brother-lpr-drivers-laser brother-cups-wrapper-laser
[sudo] hasło użytkownika dmk:
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Pakiet "brother-cups-wrapper-laser" nie jest zainstalowany, więc nie zostanie usunięty
Pakiet "brother-lpr-drivers-laser" nie jest zainstalowany, więc nie zostanie usunięty
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.

dmk@DMK:~$ sudo apt-get install --reinstall cups csh lib32stdc++6
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Zostaną zainstalowane następujące NOWE pakiety:
  csh
0 aktualizowanych, 1 nowo instalowanych, 2 ponownie instalowanych, 0 usuwanych i 0 nieaktualizowanych.
Konieczne pobranie 243 kB/849 kB archiwów.
Po tej operacji zostanie dodatkowo użyte 358 kB miejsca na dysku.
Pobieranie:1 http://pl.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 csh amd64 20110502-3ubuntu0.18.04.1 [243 kB]
Pobrano 243 kB w 0s (557 kB/s)
Prekonfiguracja pakietów ...
Wybieranie wcześniej niewybranego pakietu csh.
(Odczytywanie bazy danych ... 170625 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu .../csh_20110502-3ubuntu0.18.04.1_amd64.deb ...
Rozpakowywanie pakietu csh (20110502-3ubuntu0.18.04.1) ...
Przygotowywanie do rozpakowania pakietu .../cups_2.2.7-1ubuntu2.7_amd64.deb ...
Rozpakowywanie pakietu cups (2.2.7-1ubuntu2.7) nad (2.2.7-1ubuntu2.7) ...
Przygotowywanie do rozpakowania pakietu .../lib32stdc++6_8.3.0-6ubuntu1~18.04.1_amd64.deb ...
Rozpakowywanie pakietu lib32stdc++6 (8.3.0-6ubuntu1~18.04.1) nad (8.3.0-6ubuntu1~18.04.1) ...
Konfigurowanie pakietu cups (2.2.7-1ubuntu2.7) ...
Updating PPD files for cups ...
Konfigurowanie pakietu lib32stdc++6 (8.3.0-6ubuntu1~18.04.1) ...
Konfigurowanie pakietu csh (20110502-3ubuntu0.18.04.1) ...
update-alternatives: użycie /bin/bsd-csh jako dostarczającego /bin/csh (csh) w trybie automatycznym
Przetwarzanie wyzwalaczy pakietu man-db (2.8.3-2ubuntu0.1)...
Przetwarzanie wyzwalaczy pakietu libc-bin (2.27-3ubuntu1)...

dmk@DMK:~$ sudo mkdir -p /var/spool/lpd/

dmk@DMK:~$ sudo mkdir -p /usr/share/cups/model/

dmk@DMK:~$ mkdir -p ~/Downloads/brother/

dmk@DMK:~$ cd ~/Downloads/brother/

dmk@DMK:~/Downloads/brother$ wget http://pub.brother.com/pub/com/bsc/linux/dlf/brdcp7030lpr-2.0.2-1.i386.deb
--2020-01-04 11:15:33--  http://pub.brother.com/pub/com/bsc/linux/dlf/brdcp7030lpr-2.0.2-1.i386.deb
Translacja pub.brother.com (pub.brother.com)... 54.192.230.119, 54.192.230.115, 54.192.230.34, ...
Łączenie się z pub.brother.com (pub.brother.com)|54.192.230.119|:80... połączono.
Żądanie HTTP wysłano, oczekiwanie na odpowiedź... 301 Moved Permanently
Lokalizacja: http://download.brother.com/pub/com/bsc/linux/dlf/brdcp7030lpr-2.0.2-1.i386.deb [podążanie]
--2020-01-04 11:15:34--  http://download.brother.com/pub/com/bsc/linux/dlf/brdcp7030lpr-2.0.2-1.i386.deb
Translacja download.brother.com (download.brother.com)... 104.87.160.121
Łączenie się z download.brother.com (download.brother.com)|104.87.160.121|:80... połączono.
Żądanie HTTP wysłano, oczekiwanie na odpowiedź... 404 Not Found
2020-01-04 11:15:35 BŁĄD 404: Not Found.

Nie udało się (być może od napisania tego postu adres się zmienił), więc ściągnąłem te paczki ręcznie.

dmk@DMK:~/Downloads/brother$ sudo dpkg -i --force-architecture brdcp7030lpr-2.0.2-1.i386.deb
(Odczytywanie bazy danych ... 170634 pliki i katalogi obecnie zainstalowane.)
Przygotowywanie do rozpakowania pakietu brdcp7030lpr-2.0.2-1.i386.deb ...
Rozpakowywanie pakietu brdcp7030lpr:i386 (2.0.2-1) nad (2.0.2-1) ...
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu brdcp7030lpr:i386:
 brdcp7030lpr:i386 zależy od libc6 (>= 2.3.4-1).

dpkg: błąd przetwarzania pakietu brdcp7030lpr:i386 (--install):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Wystąpiły błędy podczas przetwarzania:
 brdcp7030lpr:i386

dmk@DMK:~/Downloads/brother$ sudo dpkg -i --force-architecture cupswrapperDCP7030-2.0.2-1.i386.deb
(Odczytywanie bazy danych ... 170634 pliki i katalogi obecnie zainstalowane.)
Przygotowywanie do rozpakowania pakietu cupswrapperDCP7030-2.0.2-1.i386.deb ...
[ ok ] Restarting cups (via systemctl): cups.service.
Rozpakowywanie pakietu cupswrapperdcp7030:i386 (2.0.2-1) nad (2.0.2-1) ...
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu cupswrapperdcp7030:i386:
 cupswrapperdcp7030:i386 zależy od libc6 (>= 2.3.4-1).

dpkg: błąd przetwarzania pakietu cupswrapperdcp7030:i386 (--install):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Wystąpiły błędy podczas przetwarzania:
 cupswrapperdcp7030:i386

Poszperałem trochę w necie i znalazłem sposób jak zainstalować ten brakujący pakiet.

dmk@DMK:~/Downloads/brother$ sudo apt-get install libc6:i386
[sudo] hasło użytkownika dmk:
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Należy uruchomić "apt --fix-broken install", aby je naprawić.
Następujące pakiety mają niespełnione zależności:
 libc6:i386 : Wymaga: libgcc1:i386 ale nie zostanie zainstalowany
E: Niespełnione zależności. Proszę spróbować wykonać "apt --fix-broken install" bez pakietów (lub podać rozwiązanie).

Tutaj postanowiłem zrobić tak jak system proponował.

dmk@DMK:~/Downloads/brother$ sudo apt --fix-broken install
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Naprawianie zależności... Gotowe
The following additional packages will be installed:
  gcc-8-base:i386 libc6:i386 libgcc1:i386
Sugerowane pakiety:
  glibc-doc:i386 locales:i386
Zostaną zainstalowane następujące NOWE pakiety:
  gcc-8-base:i386 libc6:i386 libgcc1:i386
0 aktualizowanych, 3 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.
2 nie w pełni zainstalowanych lub usuniętych.
Konieczne pobranie 2 617 kB archiwów.
Po tej operacji zostanie dodatkowo użyte 11,0 MB miejsca na dysku.
Kontynuować? [T/n] T
Pobieranie:1 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main i386 gcc-8-base i386 8.3.0-6ubuntu1~18.04.1 [18,7 kB]
Pobieranie:2 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main i386 libgcc1 i386 1:8.3.0-6ubuntu1~18.04.1 [48,1 kB]
Pobieranie:3 http://pl.archive.ubuntu.com/ubuntu bionic/main i386 libc6 i386 2.27-3ubuntu1 [2 551 kB]
Pobrano 2 617 kB w 1s (2 020 kB/s)           
Prekonfiguracja pakietów ...
Wybieranie wcześniej niewybranego pakietu gcc-8-base:i386.
(Odczytywanie bazy danych ... 170637 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu .../gcc-8-base_8.3.0-6ubuntu1~18.04.1_i386.deb ...
Rozpakowywanie pakietu gcc-8-base:i386 (8.3.0-6ubuntu1~18.04.1) ...
Wybieranie wcześniej niewybranego pakietu libgcc1:i386.
Przygotowywanie do rozpakowania pakietu .../libgcc1_1%3a8.3.0-6ubuntu1~18.04.1_i386.deb ...
Rozpakowywanie pakietu libgcc1:i386 (1:8.3.0-6ubuntu1~18.04.1) ...
Wybieranie wcześniej niewybranego pakietu libc6:i386.
Przygotowywanie do rozpakowania pakietu .../libc6_2.27-3ubuntu1_i386.deb ...
Rozpakowywanie pakietu libc6:i386 (2.27-3ubuntu1) ...
Zastąpienie plików z poprzedniego pakietu libc6-i386 (2.27-3ubuntu1) ...
Konfigurowanie pakietu gcc-8-base:i386 (8.3.0-6ubuntu1~18.04.1) ...
Konfigurowanie pakietu libc6:i386 (2.27-3ubuntu1) ...
Konfigurowanie pakietu brdcp7030lpr:i386 (2.0.2-1) ...
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib32/libbrcomplpr2.so': Plik istnieje
Konfigurowanie pakietu libgcc1:i386 (1:8.3.0-6ubuntu1~18.04.1) ...
Konfigurowanie pakietu cupswrapperdcp7030:i386 (2.0.2-1) ...
[....] Restarting cups (via systemctl): cups.servicePrzetwarzanie wyzwalaczy pakietu libc-bin (2.27-3ubuntu1)...
. ok

Nie byłem pewien czy te paczki już się zainstalowały i skonfigurowały, więc postanowiłem powtórzyć poprzednią operację.

dmk@DMK:~/Downloads/brother$ sudo dpkg -i --force-architecture brdcp7030lpr-2.0.2-1.i386.deb
(Odczytywanie bazy danych ... 170945 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu brdcp7030lpr-2.0.2-1.i386.deb ...
Rozpakowywanie pakietu brdcp7030lpr:i386 (2.0.2-1) nad (2.0.2-1) ...
Konfigurowanie pakietu brdcp7030lpr:i386 (2.0.2-1) ...
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib32/libbrcomplpr2.so': Plik istnieje

dmk@DMK:~/Downloads/brother$ sudo dpkg -i --force-architecture cupswrapperDCP7030-2.0.2-1.i386.deb
(Odczytywanie bazy danych ... 170945 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu cupswrapperDCP7030-2.0.2-1.i386.deb ...
[ ok ] Restarting cups (via systemctl): cups.service.
Rozpakowywanie pakietu cupswrapperdcp7030:i386 (2.0.2-1) nad (2.0.2-1) ...
Konfigurowanie pakietu cupswrapperdcp7030:i386 (2.0.2-1) ...
[....] Restarting cups (via systemctl): cups.servicedmk@DMK:~/Downloads/brother$lib64/cups/filter/ib/cups/filter/brlpdwrapper* /usr/l
ln: cel '/usr/lib64/cups/filter/' nie jest katalogiem: Nie ma takiego pliku ani katalogu

dmk@DMK:~/Downloads/brother$ sudo ln -s /usr/lib/cups/filter/brlpdwrapper* /usr/lib64/cups/filter/
ln: cel '/usr/lib64/cups/filter/' nie jest katalogiem: Nie ma takiego pliku ani katalogu
[ ok MK:~/Downloads/brother$ .
sane-commont install --reinstall sane-utils xsane xs
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
The following additional packages will be installed:
  gimp-data libgimp2.0
Sugerowane pakiety:
  gimp gocr | cuneiform | tesseract-ocr | ocrad gv hylafax-client | mgetty-fax
Zostaną zainstalowane następujące NOWE pakiety:
  gimp-data libgimp2.0 xsane xsane-common
0 aktualizowanych, 4 nowo instalowanych, 1 ponownie instalowanych, 0 usuwanych i 0 nieaktualizowanych.
Konieczne pobranie 10,2 MB/10,4 MB archiwów.
Po tej operacji zostanie dodatkowo użyte 55,5 MB miejsca na dysku.
Kontynuować? [T/n] n
Przerwane.

Tutaj przerwałem, bo coś mi się porąbało i myślałem, że jakoś źle wkleiłem powyższą komendę (takie chwilowe zaćmienie umysłu) :/ Dzisiaj chciałem wykonać ją jeszcze raz, ale dostałem taką odpowiedź:

dmk@DMK:~/Downloads/brother$ sudo ln -s /usr/lib/cups/filter/brlpdwrapper* /usr/lib64/cups/filter/
[sudo] hasło użytkownika dmk:
ln: cel '/usr/lib64/cups/filter/' nie jest katalogiem: Nie ma takiego pliku ani katalogu

Tak więc po tej przerwanej przeze mnie operacji, tak jak było napisane w tym poście podpiąłem i włączyłem drukarkę i wykonałem kolejną komendę:

dmk@DMK:~/Downloads/brother$ sudo apt-get install --reinstall sane-utils xsane xsane-common
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
The following additional packages will be installed:
  gimp-data libgimp2.0
Sugerowane pakiety:
  gimp gocr | cuneiform | tesseract-ocr | ocrad gv hylafax-client | mgetty-fax
Zostaną zainstalowane następujące NOWE pakiety:
  gimp-data libgimp2.0 xsane xsane-common
0 aktualizowanych, 4 nowo instalowanych, 1 ponownie instalowanych, 0 usuwanych i 0 nieaktualizowanych.
Konieczne pobranie 10,2 MB/10,4 MB archiwów.
Po tej operacji zostanie dodatkowo użyte 55,5 MB miejsca na dysku.
Kontynuować? [T/n] T
Pobieranie:1 http://pl.archive.ubuntu.com/ubuntu bionic/universe amd64 gimp-data all 2.8.22-1 [7 800 kB]
Pobieranie:2 http://pl.archive.ubuntu.com/ubuntu bionic/universe amd64 libgimp2.0 amd64 2.8.22-1 [765 kB]
Pobieranie:3 http://pl.archive.ubuntu.com/ubuntu bionic/universe amd64 xsane-common all 0.999-5ubuntu2 [1 375 kB]
Pobieranie:4 http://pl.archive.ubuntu.com/ubuntu bionic/universe amd64 xsane amd64 0.999-5ubuntu2 [288 kB]
Pobrano 10,2 MB w 4s (2 359 kB/s)
Prekonfiguracja pakietów ...
Wybieranie wcześniej niewybranego pakietu gimp-data.
(Odczytywanie bazy danych ... 170945 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu .../gimp-data_2.8.22-1_all.deb ...
Rozpakowywanie pakietu gimp-data (2.8.22-1) ...
Wybieranie wcześniej niewybranego pakietu libgimp2.0.
Przygotowywanie do rozpakowania pakietu .../libgimp2.0_2.8.22-1_amd64.deb ...
Rozpakowywanie pakietu libgimp2.0 (2.8.22-1) ...
Przygotowywanie do rozpakowania pakietu .../sane-utils_1.0.27-1~experimental3ubuntu2.2_amd64.deb ...
Rozpakowywanie pakietu sane-utils (1.0.27-1~experimental3ubuntu2.2) nad (1.0.27-1~experimental3ubuntu2.2) ...
Wybieranie wcześniej niewybranego pakietu xsane-common.
Przygotowywanie do rozpakowania pakietu .../xsane-common_0.999-5ubuntu2_all.deb ...
Rozpakowywanie pakietu xsane-common (0.999-5ubuntu2) ...
Wybieranie wcześniej niewybranego pakietu xsane.
Przygotowywanie do rozpakowania pakietu .../xsane_0.999-5ubuntu2_amd64.deb ...
Rozpakowywanie pakietu xsane (0.999-5ubuntu2) ...
Konfigurowanie pakietu libgimp2.0 (2.8.22-1) ...
Konfigurowanie pakietu xsane-common (0.999-5ubuntu2) ...
Konfigurowanie pakietu gimp-data (2.8.22-1) ...
Konfigurowanie pakietu sane-utils (1.0.27-1~experimental3ubuntu2.2) ...
Konfigurowanie pakietu xsane (0.999-5ubuntu2) ...
Przetwarzanie wyzwalaczy pakietu ureadahead (0.100.0-21)...
ureadahead will be reprofiled on next reboot
Przetwarzanie wyzwalaczy pakietu desktop-file-utils (0.23-1ubuntu3.18.04.2)...
Przetwarzanie wyzwalaczy pakietu libc-bin (2.27-3ubuntu1)...
Przetwarzanie wyzwalaczy pakietu systemd (237-3ubuntu10.33)...
Przetwarzanie wyzwalaczy pakietu man-db (2.8.3-2ubuntu0.1)...
Przetwarzanie wyzwalaczy pakietu gnome-menus (3.13.3-11ubuntu1.1)...
Przetwarzanie wyzwalaczy pakietu hicolor-icon-theme (0.17-2)...
Przetwarzanie wyzwalaczy pakietu mime-support (3.60ubuntu1)...

Ściągnąłem podlinkowane sterowniki (tyle, że najnowsze):

dmk@DMK:~/Downloads/brother$ sudo dpkg -i --force-all ~/Downloads/brscan3-0.2.13-1.amd64.deb
(Odczytywanie bazy danych ... 172331 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu .../brscan3-0.2.13-1.amd64.deb ...
Rozpakowywanie pakietu brscan3 (0.2.13-1) nad (0.2.13-1) ...
Konfigurowanie pakietu brscan3 (0.2.13-1) ...

dmk@DMK:~/Downloads/brother$ dpkg  -l  |  grep  Brother
ii  brdcp7030lpr:i386                          2.0.2-1                                         i386         Brother DCP-7030 LPR driver
ii  brother-udev-rule-type1                    1.0.2                                           all          Brother udev rule type 1
ii  brscan-skey                                0.2.4-1                                         amd64        Brother Linux scanner S-KEY tool
ii  brscan3                                    0.2.13-1                                        amd64        Brother Scanner Driver
ii  cupswrapperdcp7030:i386                    2.0.2-1                                         i386         Brother DCP7030 CUPS wrapper driver
ii  printer-driver-brlaser                     4-1                                             amd64        printer driver for (some) Brother laser printers
ii  printer-driver-ptouch                      1.4.2-3                                         amd64        printer driver Brother P-touch label printers

dmk@DMK:~/Downloads/brother$ sudo gedit /lib/udev/rules.d/40-libsane.rules

Tutaj otworzył się edytor tekstowy (był pusty) i jak rozumiem miałem tam wkleić tekst:
# Brother scanners
ATTRS{idVendor}=="04f9", ENV{libsane_matched}="yes"
więc tak zrobiłem i zapisałem plik. Chyba jednak coś poszło nie tak, bo terminal odpowiedział mi:

** (gedit:11411): WARNING **: 12:15:31.036: Set document metadata failed: Ustawianie atrybutu metadata::gedit-spell-language nie jest obsługiwane

** (gedit:11411): WARNING **: 12:15:31.136: Set document metadata failed: Ustawianie atrybutu metadata::gedit-encoding nie jest obsługiwane

** (gedit:11411): WARNING **: 12:15:38.250: Set document metadata failed: Ustawianie atrybutu metadata::gedit-position nie jest obsługiwane

Tak czy inaczej zrestartowałem komputer i odpaliłem "Proste skanowanie", ale skaner nadal nie jest wykrywany. Znalazłem także na naszym forum wątek o instalacji skanera brothera:

https://forum.linuxiarze.pl/index.php/topic,1421.msg5871.html#msg5871

Próbowałem zrobić to co napisał Albedo 0.64, ale zatrzymałem się na etapie instalacji sterownika LPR w tym miejscu:

Cytuj
Restart the print system.
 Command  (for  lpr):  /etc/init.d/lpr  restart
 Command  (for  lprng)  :  /etc/init.d/lprng  restart

Wpisałem w terminalu obie komendy, ale w obydwu przypadkach system odpowiedział mi:

Nie ma takiego pliku ani katalogu

Lecimy dalej. Po instrukcji instalacji sterownika cupswrapper jest coś takiego:

Cytuj
Open a web browser and go to
http://localhost:631/printers
        Check if the Device URI of your printer is "usb://Brother/(your printer's model name)

U mnie wygląda to tak:

https://tinypic.pl/7izxxh9wp3je

No i na końcu jest polecenie, którego kompletnie nie rozumiem a mianowicie:
Cytuj
Do prawidłowego działania skanera należy dodać użytkownika do grupy lp i lpadmin.
Jak mam to zrobić?


Chciałem spróbować sam się z tym uporać, ale mimo usilnych prób jak widać nie udało mi się, więc proszę Was o pomoc.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: lami07 w Styczeń 07, 2020, 10:50:46 pm
Pobierz Driver Install Tool z poniższej strony:
https://support.brother.com/g/b/downloadlist.aspx?c=pl&lang=pl&prod=dcp7030_all&os=128&flang=EnglishRozpakuj archiwum i uruchom skrypt z konsoli z podwyższonymi uprawnieniami (sudo).
Skrypt przeprowadzi instalację i wstępną konfigurację, ty skup sie na odpowiadniu na pytania.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: Kano w Styczeń 08, 2020, 12:26:40 pm
Zrobiłem to już wcześniej. Rozpoczęła się instalacja. W pewnym momencie wyskoczyło zapytanie "Will you specify the DeviceURI ?" i tak jak w instrukcji odpowiedziałem "No". Później wyświeliło się zapytanie czy chcę wydrukować stronę testową. Odpowiedziałem twierdząco i strona się wydrukowała. Później wyświeliły się treści licencji na które się zgodziłem. Tyle. Jak coś to mogę zainstalować jeszcze raz i wkleić to co terminal wyświetlił.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: pavbaranov w Styczeń 08, 2020, 05:36:21 pm
Mówimy o skanerze, a zatem:
scanimage -L
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: Kano w Styczeń 08, 2020, 08:02:56 pm
Mówimy o skanerze, a zatem:
scanimage -L

dmk@DMK:~$ scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

Kiedy wpisałem sane-find-scanner tool wtedy:

dmk@DMK:~$ sane-find-scanner tool

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

  # No USB scanners found. If you expected something different, make sure that
  # you have loaded a kernel driver for your USB host controller and have setup
  # the USB system correctly. See man sane-usb for details.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

  # You may want to run this program as root to find all devices. Once you
  # found the scanner devices, be sure to adjust access permissions as
  # necessary.

Oczywiście przy wpisywaniu tych komend skaner był podpięty i uruchomiony.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: pavbaranov w Styczeń 08, 2020, 08:46:42 pm
A z uprawnieniami roota?
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: Kano w Styczeń 08, 2020, 09:08:52 pm
To samo.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: pavbaranov w Styczeń 09, 2020, 08:35:41 am
Pokaż:
cat /etc/udev/rules.d/50-brscan3.rules
lsusb
cat /usr/lib/udev/rules.d/49-sane.conf | grep idProduct
ls /usr/lib/libbrscandec [TAB]
ls /usr/lib/sane/libsane-brother [TAB]
(Wytłumaczenie:
- po trzecim poleceniu w miejsce idProduct wpisujesz drugą serię cyfr, które zwróci polecenie lsusb /po ":"/
- po dwu ostatnich komendach masz po prostu wcisnąć klawisz TAB).
Po instalacji sterownika winien się jeszcze uruchomić program konfigurujący setupSaneScan3 - jeśli nie, to możesz go raz jeszcze wywołać: sudo /usr/local/Brother/sane/setupSaneScan3 -iJeśli to nie pomoże, sprawdź ewentualnie rozwiązania podane tu: https://support.brother.com/g/b/faqlist.aspx?c=pl&lang=pl&prod=dcp7030_all&ftype3=100258&ot=eu_ot (https://support.brother.com/g/b/faqlist.aspx?c=pl&lang=pl&prod=dcp7030_all&ftype3=100258&ot=eu_ot) i to niekoniecznie wyłącznie dla Ubuntu/Debian, ale głównie ostatnie (a już na pewno dla systemd) i te, które są dostosowane do Ciebie. Rozumiem, że cały czas mówimy o połączeniu po kablu USB. Nie znam tego modelu, ale czy on nie ma jakiegoś "usypiacza"?

PS: To jest jakieś "buntu", a zatem w miejscu lib powyżej może być lib64 nie pamiętam już dokładnie, bo lata nie używam tego OSa.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: Kano w Styczeń 09, 2020, 11:54:42 am
Oto odpowiedzi na te komedy:

dmk@DMK:~$ cat /etc/udev/rules.d/50-brscan3.rules
cat: /etc/udev/rules.d/50-brscan3.rules: Nie ma takiego pliku ani katalogu
dmk@DMK:~$ lsusb
Bus 001 Device 004: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 1a2c:0021 China Resource Semico Co., Ltd Keyboard
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 003: ID 04f9:01ea Brother Industries, Ltd DCP-7030
Bus 004 Device 002: ID 04f3:0234 Elan Microelectronics Corp.
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Dalej nie wiem czy cię dobrze zrozumiałem, bo kiedy wstawiłem ciąg liczb po ":" z pierwszego wiersza czyli "9271",  wyszło coś takiego:
dmk@DMK:~$ cat /usr/lib/udev/rules.d/49-sane.conf | grep 9271
cat: /usr/lib/udev/rules.d/49-sane.conf: Nie ma takiego pliku ani katalogu

Później kiedy wpisałem dwie następne komendy i wcisnąłem TAB nic się nie stało a kiedy wcisnąłem ENTER to:
dmk@DMK:~$ ls /usr/lib/libbrscandec
ls: nie ma dostępu do '/usr/lib/libbrscandec': Nie ma takiego pliku ani katalogu
dmk@DMK:~$ ls /usr/lib/sane/libsane-brother
ls: nie ma dostępu do '/usr/lib/sane/libsane-brother': Nie ma takiego pliku ani katalogu
A ostatnia komenda poprosiła jedynie o hasło root'a i nic więcej nie wyświetliła.
Jeśli chodzi o link, który mi podesłałeś to jest tam sporo możliwości, więc będę potrzebował trochę czasu żeby to wszystko wypróbować.
Tak cały czas mówimy o połączeniu przez USB. Po kilku minutach drukarka cichnie. Nie wiem czy to ten usypiacz, ale kiedy w winowsie chcę coś zeskanować drukarka automatycznie się wybudza.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: lami07 w Styczeń 09, 2020, 12:01:45 pm
Zacznij od tego: https://support.brother.com/g/b/sp/faqend.aspx?c=pl&lang=pl&prod=dcp7030_all&ftype3=100258&faqid=faq00100617_000&ot=eu_ot
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: pavbaranov w Styczeń 09, 2020, 12:52:21 pm
Tak jak pisałem, u Ciebie może ścieżka może być /usr/lib64 a nie /usr/lib - nie mam Ubuntu ani nawet Debiana.
Komenda z przeniesieniem odpowiedzi z lsusb ma być:
cat /usr/lib/udev/rules.d/49-sane.conf | grep 01ea(lsusb podaje Ci wszystkie urządzenia podpięte pod USB i rozpoznane przez system; to o które nam chodzi musi się zgłosić jako... Brother :)).
Oczywiście to może być /usr/lib64 - patrz uwaga wyżej (i na pewno tak jest; wypakowałem ten sterownik u siebie - wszystkie ścieżki w moich postach odnoszące się do /usr/lib/ u Ciebie odnoszą się do /usr/lib64/. Plik konfigurujący jest w /usr/local/Brother/sane i nazywa się setupSaneScan3 i/lub brsaneconfig3 oraz w /usr/bin/brsaneconfig3 (w pierwszej kolejności zacząłbym od niego, to jest dowiązanie symboliczne).
Chodzi mi o ustalenie, czy prawidłowo zostały zainstalowane paczki *.deb oraz jakie.
Ten skaner z tym sterownikiem łaski nie robi - on musi być zauważony i pracować, choć niekiedy bywają problemy ze zmuszeniem do działania, a informacje z support Brothera są sprzed wielu, wielu lat niestety.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: Kano w Styczeń 09, 2020, 02:47:07 pm
Zacznij od tego: https://support.brother.com/g/b/sp/faqend.aspx?c=pl&lang=pl&prod=dcp7030_all&ftype3=100258&faqid=faq00100617_000&ot=eu_ot

Skopiowałem wszystkie pliki tak jak w instrukcji. Nawet zrestartowałem system, ale nadal nie działa.

pavbaranov:

Ok. Pozamieniałem lib na lib64 we wszystkich komendach:

dmk@DMK:~$ cat /usr/lib64/udev/rules.d/49-sane.conf | grep 0lea
cat: /usr/lib64/udev/rules.d/49-sane.conf: Nie ma takiego pliku ani katalogu
Kiedy po wpisaniu komendy poniżej wcisnąłem TAB, do komendy dopisało się ".so"
dmk@DMK:~$ ls /usr/lib64/libbrscandec3.so
A kiedy wcisnąłem ENTER:
/usr/lib64/libbrscandec3.so
To samo przy koljnej komendzie:
dmk@DMK:~$ ls /usr/lib64/sane/libsane-brother3.so
/usr/lib64/sane/libsane-brother3.so
Wpisałem też adresy tych plików konfiguracyjnych o których wspomniałeś:
dmk@DMK:~$ /usr/bin/brsaneconfig3
USAGE: brsaneconfig3 [-OPTION]   OPTION:
       -a name=FRIENDLY-NAME model=MODEL-NAME ip=xx.xx.xx.xx   
       -a name=FRIENDLY-NAME model=MODEL-NAME nodename=BRN_xxxxx
                   : Add network scanner
       -r FRIENDLY-NAME [FRIENDLY-NAME ...]
                   : Remove network scanner
       -q          : Query supported models and available network scanners
       -d          : Diagnosis
       -p          : Ping (for network scanners) 
       -s:[LABEL]  : Save current configuration
       -l:[LABEL]  : Load saved configuration
dmk@DMK:~$ /usr/local/Brother/sane/setupSaneScan3
dmk@DMK:~$ /usr/local/Brother/sane/brsaneconfig3
USAGE: brsaneconfig3 [-OPTION]   OPTION:
       -a name=FRIENDLY-NAME model=MODEL-NAME ip=xx.xx.xx.xx   
       -a name=FRIENDLY-NAME model=MODEL-NAME nodename=BRN_xxxxx
                   : Add network scanner
       -r FRIENDLY-NAME [FRIENDLY-NAME ...]
                   : Remove network scanner
       -q          : Query supported models and available network scanners
       -d          : Diagnosis
       -p          : Ping (for network scanners) 
       -s:[LABEL]  : Save current configuration
       -l:[LABEL]  : Load saved configuration

I co teraz?
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: pavbaranov w Styczeń 09, 2020, 04:31:04 pm
Ok, ponamieszało nam się pewnie strasznie. Czy jesteś w stanie:
1. odinstalować brscan3,
2. odinstalować sane/libsane (oczywiście jeśli puści z zależnościami, jeśli nie - zostaw i po prostu przeinstaluj te paczki),
3. zrestartuj komputer i podłącz urządzenie,
4. sprawdź za pomocą lsusb, czy jest widziane,
5. upewnij się, że masz połączenie z netem, ściągnij Driver Install Tool, czyli to, o czym wspominał @lami07: https://forum.linuxiarze.pl/index.php/topic,3864.msg23558.html#msg23558 (https://forum.linuxiarze.pl/index.php/topic,3864.msg23558.html#msg23558)
6. wykonaj to co opisane jako "sposób instalowania": https://support.brother.com/g/b/downloadhowto.aspx?c=pl&lang=pl&prod=dcp7030_all&os=128&dlid=dlf006893_000&flang=4&type3=625 (https://support.brother.com/g/b/downloadhowto.aspx?c=pl&lang=pl&prod=dcp7030_all&os=128&dlid=dlf006893_000&flang=4&type3=625) (oprócz drukarki, którą jak rozumiem masz zainstalowaną, to oprogramowanie winno również zainstalować sterownik skanera - musisz do tego przejść, o ile pamiętam odbywa się to po instalacji drukarki i nie wiem, czy można pierwszy krok, tj. drukarkę, pominąć,
7. sprawdź, czy działa po reboocie komputera,
8. jeśli nie działa - sprawdź, te scanimage -L zarówno na zwykłym, jak i na koncie superusera.

TIP: Kiedyś miałem problem - wprawdzie na innym systemie i z innym sterownikiem, ale również z Brotherem i rozwiązaniem okazało się: http://www.archlike.darmowefora.pl/index.php/topic,97.msg156.html?PHPSESSID=oikfp1e5tstm87q6ud1f0ll9b7#msg156 (http://www.archlike.darmowefora.pl/index.php/topic,97.msg156.html?PHPSESSID=oikfp1e5tstm87q6ud1f0ll9b7#msg156). Jeśli jednak do dojdziesz do pkt 8 i nic nie będzie działać, a tlić Ci się będzie w głowie skorzystanie z tego poradnika, to daj wpierw znać, albowiem trzeba będzie to do Twojego skanera dostosować.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: Kano w Styczeń 10, 2020, 09:56:14 am
Ok, ponamieszało nam się pewnie strasznie. Czy jesteś w stanie:
1. odinstalować brscan3,
2. odinstalować sane/libsane (oczywiście jeśli puści z zależnościami, jeśli nie - zostaw i po prostu przeinstaluj te paczki),

Jeśli bym mógł, to prosiłbym Cię o instrukcję co do tych dwóch punktów. Bo nie mam pojęcia jak to zrobić na linuxie a nie chciałbym jeszcze bardziej zamieszać w plikach.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: pavbaranov w Styczeń 10, 2020, 10:47:42 am
Wiesz, że to jest Twój system i pytasz o jego absolutne podstawy :)
Ok. Jeśli w ogóle puściłeś ten skrypt pn. Driver Install Tool, to wykonaj go raz jeszcze (root). O ile pamiętam, to ma on również opcję deinstalacji sterowników. Jeśli będzie wybór (a winien być), to nie ruszaj drukarki, a ogranicz się wyłącznie do deinstalacji sterownika skanera (oraz narzędzia o nazwie bodaj brother-skey - to takie narzędzie, które umożliwia uruchomienie programu do skanowania na komputerze przez naciśnięcie na urządzeniu przycisku skanowania). Po przeprowadzeniu deinstalacji - najlepiej restart. Teraz sprawdź jakie paczki masz zainstalowane, które odnoszą się do Brother (znów interesują Cię wyłącznie paczki związane ze skanerem, winny mieć w nazwie brscan lub coś takiego; robiłeś to już, bo podawałeś w tym wątku - nie powtarzam się). Jeśli jeszcze będą jakieś - odinstaluj za pomocą APTa (nie chce mi się powtarzać, zatem tu: https://wiki.archlinux.org/index.php/Pacman/Rosetta (https://wiki.archlinux.org/index.php/Pacman/Rosetta) masz zestawienie i omówienie komend, nie tylko zresztą dla dystrybucji APTowych). Znów dla pewności restart i raz jeszcze sprawdzenie. Jeśli system stwierdzi, że jest czysty z tych sterowników, możesz przejść do próby odinstalowania sane/libsane, ale jeśli tu nic w plikach nie mieszałeś, to możesz to nawet pominąć (z dotychczasowych informacji podawanych przez Ciebie nie bardzo wiem). Teraz przydałoby się użyć magicznego zaklęcia dpkg, które musi ktoś podrzucić, kto ma Debian/Ubuntu itp., albowiem po prostu już nie pamiętam - chodzi o rekonfigurację zainstalowanych paczek i ewentualne dociągnięcie brakujących zależności itd. - zdaje się, że to było: apt-get --fix-broken Osobiście wykonałbym również czyszczenie, czyli apt cleanPo tym wszystkim - Driver Install Tool.
Teoretycznie nie musisz wykonywać tych restartów komputera po instalacji/deinstalacji paczek, ale dla pewności zaleciłbym.

PS: Nie wiem, czy to w Ubuntu jeszcze funkcjonuje, ale było niegdyś narzędzie pn. synaptic będące wygodnym menedżerem paczek z graficznym interfejsem. Wg mnie - najlepsze jakie kiedykolwiek się dla APTa pojawiło. Pewnie ułatwiłoby Ci wiele zadań.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: Kano w Styczeń 10, 2020, 07:15:40 pm
Wiem, że to są podstawy, ale używam Linuxa od jakichś 2 tygodni i dotąd jak chciałem coś zaintalować to robiłem to wyłącznie przez centrum oprogramowania Ubuntu. Ale jak tylko uda się zmusić skaner do działania będę systematycznie poszerzał swoją wiedzę o systemie :)
A wracając do tematu to przy instalacji driver tool'a nie było możliwości niczego odinstalować. Terminal wyświetlił umowę, zapytał czy ją akceptuję i spytał "Will you specify the DeviceURI", wydrukował stronę testową. I tyle.
Później przez terminal za pomocą apt search wyszukałem brscan3 i za pomocą apt remove go odinstalowałem. Potem zainstalowałem Synaptica i tam jedna z kategorii pakietów to był "Brother". Tam odinstalowałem brskey (czy coś w tym rodzaju, tak jak pisałeś) i teraz zostały na liście tylko dwa pakiety: "brdcp7030lpr:i386" i "cupswrapperdcp7030:i386". Więc je chyba powinienem zostawić.
A więc teraz powinienem jeszcze odinstalować "libsane". Tylko, że kiedy wpisałem to w wyszukiwarkę w synapticu wyskoczyło mi wiele pakietów mających to w nazwie:

libsane-common
libsane-hpaio (zdaje się, że to jest pakiet do drukarek HP, więc chyba nie o ten chodzi)
libsane1

Który z nich odinstalować?

p.s. Kiedy odistalowałem brscan3 przez terminal, po ponownym wyszukaniu przez apt search, pozostał po nim taki wpis:
brscan3/now 0.2.13-1 amd64 [residual-config]
  (none)
Czy da się i czy powinienem próbować to jakoś usunąć?
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: pavbaranov w Styczeń 10, 2020, 09:31:48 pm
Tak, ten config jakoś winieneś usunąć, ale tu muszą Ci pomóc użytkownicy APTa.
Driver-itd. po ponownym uruchomieniu, gdy wcześniej zainstalował sterowniki ma opcję ich usunięcia. Mniejsza o to, bowiem obecnie to nie jest już istotne.
Po usunięciu tego configu - po prostu uruchom ten skrypt.
I tak - pozostałych paczek dla Brother nie ruszaj. To są sterowniki drukarki.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: Kano w Styczeń 11, 2020, 11:22:43 am
Ok. Znalazłem ten config za pomocą Synaptica i usunąłem. Następnie wykonałem dmk@DMK:~$ sudo apt-get install --fix-broken
[sudo] hasło użytkownika dmk:
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.[/sudo]
później
[code]sudo apt clean

Następnie ponownie "Driver install tool". Może wrzucę tutaj to co wyświetlił terminal w czasie instalacji:
dmk@DMK:~/Downloads/brother$ sudo bash linux-brprinter-installer-2.2.1-1 DCP-7030
[sudo] hasło użytkownika dmk:
You are going to install following packages.
   brdcp7030lpr-2.0.2-1.i386.deb
   cupswrapperDCP7030-2.0.2-1.i386.deb
   brscan3-0.2.13-1.amd64.deb
   brscan-skey-0.2.4-1.amd64.deb
OK? [y/N] ->y

Stary:1 http://pl.archive.ubuntu.com/ubuntu bionic InRelease
Pobieranie:2 http://pl.archive.ubuntu.com/ubuntu bionic-updates InRelease [88,7 kB]
Pobieranie:3 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
Pobieranie:4 http://pl.archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]
Pobieranie:5 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages [830 kB]
Pobieranie:6 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main i386 Packages [629 kB]
Pobieranie:7 http://security.ubuntu.com/ubuntu bionic-security/main i386 Packages [417 kB]
Pobieranie:8 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main amd64 DEP-11 Metadata [295 kB]
Pobieranie:9 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages [606 kB]
Pobieranie:10 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 48x48 Icons [73,8 kB]
Pobieranie:11 http://pl.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 64x64 Icons [143 kB]
Pobieranie:12 http://pl.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages [1 035 kB]
Pobieranie:13 http://security.ubuntu.com/ubuntu bionic-security/main Translation-en [196 kB]
Pobieranie:14 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [38,5 kB]
Pobieranie:15 http://security.ubuntu.com/ubuntu bionic-security/main DEP-11 48x48 Icons [17,6 kB]
Pobieranie:16 http://security.ubuntu.com/ubuntu bionic-security/main DEP-11 64x64 Icons [41,5 kB]
Pobieranie:17 http://security.ubuntu.com/ubuntu bionic-security/universe i386 Packages [606 kB]
Pobieranie:18 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [633 kB]
Pobieranie:19 http://security.ubuntu.com/ubuntu bionic-security/universe Translation-en [213 kB]
Pobieranie:20 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [42,1 kB]
Pobieranie:21 http://security.ubuntu.com/ubuntu bionic-security/universe DEP-11 48x48 Icons [16,4 kB]
Pobieranie:22 http://security.ubuntu.com/ubuntu bionic-security/universe DEP-11 64x64 Icons [111 kB]
Pobieranie:23 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 DEP-11 Metadata [2 464 B]
Pobieranie:24 http://pl.archive.ubuntu.com/ubuntu bionic-updates/universe i386 Packages [997 kB]
Pobieranie:25 http://pl.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 DEP-11 Metadata [264 kB]
Pobieranie:26 http://pl.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 48x48 Icons [199 kB]
Pobieranie:27 http://pl.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 64x64 Icons [448 kB]
Pobieranie:28 http://pl.archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2 464 B]
Pobieranie:29 http://pl.archive.ubuntu.com/ubuntu bionic-backports/universe amd64 Packages [4 044 B]
Pobieranie:30 http://pl.archive.ubuntu.com/ubuntu bionic-backports/universe i386 Packages [4 036 B]
Pobieranie:31 http://pl.archive.ubuntu.com/ubuntu bionic-backports/universe Translation-en [1 900 B]
Pobieranie:32 http://pl.archive.ubuntu.com/ubuntu bionic-backports/universe amd64 DEP-11 Metadata [7 980 B]
Pobrano 8 126 kB w 5s (1 665 kB/s)                                             
Czytanie list pakietów... Gotowe
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Pakiet ia32-libs nie ma dostępnej wersji, ale odnosi się do niego inny pakiet.
Zazwyczaj oznacza to, że pakietu brakuje, został zastąpiony przez inny
pakiet lub nie jest dostępny przy pomocy obecnie ustawionych źródeł.
Jednak następujące pakiety go zastępują:
  lib32ncurses5 lib32z1

E: Pakiet ia32-libs nie ma kandydata do instalacji
dpkg -x brdcp7030lpr-2.0.2-1.i386.deb /
dpkg -x cupswrapperDCP7030-2.0.2-1.i386.deb /
dpkg-deb: budowanie pakietu "brdcp7030lpr" w "brdcp7030lpr-2.0.2-1a.i386.deb".
dpkg -b ./brother_driver_packdir brdcp7030lpr-2.0.2-1a.i386.deb
dpkg-deb: budowanie pakietu "cupswrapperdcp7030" w "cupswrapperDCP7030-2.0.2-1a.i386.deb".
dpkg -b ./brother_driver_packdir cupswrapperDCP7030-2.0.2-1a.i386.deb
dpkg -i --force-all brdcp7030lpr-2.0.2-1a.i386.deb
(Odczytywanie bazy danych ... 178386 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu brdcp7030lpr-2.0.2-1a.i386.deb ...
Rozpakowywanie pakietu brdcp7030lpr:i386 (2.0.2-1) nad (2.0.2-1) ...
Konfigurowanie pakietu brdcp7030lpr:i386 (2.0.2-1) ...
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib32/libbrcomplpr2.so': Plik istnieje
dpkg -i --force-all cupswrapperDCP7030-2.0.2-1a.i386.deb
(Odczytywanie bazy danych ... 178386 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu cupswrapperDCP7030-2.0.2-1a.i386.deb ...
Restarting cups (via systemctl): cups.service.
Rozpakowywanie pakietu cupswrapperdcp7030:i386 (2.0.2-1) nad (2.0.2-1) ...
Konfigurowanie pakietu cupswrapperdcp7030:i386 (2.0.2-1) ...
Restarting cups (via systemctl): cups.service.
#
Will you specify the Device URI? [Y/n] ->n

Test Print? [y/N] ->n

You are going to install following packages.
   brscan3-0.2.13-1.amd64.deb
dpkg -i --force-all brscan3-0.2.13-1.amd64.deb
Wybieranie wcześniej niewybranego pakietu brscan3.
(Odczytywanie bazy danych ... 178386 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu brscan3-0.2.13-1.amd64.deb ...
Rozpakowywanie pakietu brscan3 (0.2.13-1) ...
Konfigurowanie pakietu brscan3 (0.2.13-1) ...
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/sane/libsane-brother3.so.1.0.7': Nie jest katalogiem
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/sane/libsane-brother3.so.1': Nie jest katalogiem
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/sane/libsane-brother3.so': Nie jest katalogiem
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/libbrscandec3.so.1.0.0': Plik istnieje
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/libbrscandec3.so.1': Plik istnieje
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/libbrscandec3.so': Plik istnieje
You are going to install following packages.
   brscan-skey-0.2.4-1.amd64.deb
dpkg -i --force-all brscan-skey-0.2.4-1.amd64.deb
Wybieranie wcześniej niewybranego pakietu brscan-skey.
(Odczytywanie bazy danych ... 178406 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu brscan-skey-0.2.4-1.amd64.deb ...
Rozpakowywanie pakietu brscan-skey (0.2.4-1) ...
Konfigurowanie pakietu brscan-skey (0.2.4-1) ...

Jednak skaner dalej nie działa. Drukarka jest widziana po "lsusb", jednak "scanimage -L" podaje, że skaner dalej nie jest wykrywany.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: pavbaranov w Styczeń 11, 2020, 11:38:02 am
Teraz widać, że ta instalacja nie przebiega tak, jak ów skrypt zakłada. Znów powiem - nie mam Ubuntu, ale to co widzę:
- skrypt wymaga paczki ia32-libs, ale taka paczka już w repozytoriach, które masz nie istnieje, paczkę tę zastępują lib32ncurses5 i/lub lib32z1 - prawdopodobnie jedną z nich powinieneś mieć zainstalowaną, a nie masz,
- sprawdź sobie co jest właścicielem plików:
-- /usr/lib32/libbrcomplpr2.so
-- /usr/lib/sane/libsane-brother3.so.1.0.7
-- /usr/lib/sane/libsane-brother3.so.1
-- /usr/lib/sane/libsane-brother3.so
-- /usr/lib/libbrscandec3.so.1.0.0
-- /usr/lib/libbrscandec3.so.1
-- /usr/lib/libbrscandec3.so
Wygląda to tak, jakbyś pomimo odinstalowania brscan3 nadal miał tę paczkę zainstalowaną. To jakiś problem zbyt wielu prób instalacji, prawdopodobnie pochodzących z różnych "sposobów". Można się spróbować bawić to ręcznie jakoś poustawiać, ale wpierw jednak po prostu dokonałbym wyczyszczenia systemu, czyli poprawnego odinstalowania paczek związanych z tym skanerem (a nie usunięcia plików - to są 2 różne rzeczy) i dopiero potem spróbował użyć tego driver-bla-bla.
Dla pewności, gdy piszesz, że "scanimage -L" nie widzi skanera, to wykonaj próbę również jako root (sudo) i pisz, czy nie widzi w obu, czy tylko jako zwykły użytkownik, albowiem jest to dość znany "problem" z uprawnieniami sterowników brothera, że skaner widziany jest wyłącznie przy uprawnieniach administratora. W tym drugim przypadku jest to jednak przysłowiowe 5 minut roboty, by skaner był widziany również dla ZU.

EDIT:
Aha, przy okazji - widzę, że sterownik dla Archa musi mieć jako zależność również libusb-compat. Nie wiem, czy jest taka paczka w Ubuntu, ewentualnie jak się nazywa, czy też co ją zapewnia (bo coś zapewniające musi być). Tutaj: https://www.archlinux.org/packages/extra/x86_64/libusb-compat/ (https://www.archlinux.org/packages/extra/x86_64/libusb-compat/) masz info o jaką paczkę chodzi (to nie jest paczka dla Ciebie, ta jest w Arch).
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: Kano w Styczeń 11, 2020, 08:32:07 pm
Ok. Więc zainstalowałem pakiety "lib32ncurses5" i "lib32n1". Chociaż dla mnie jako dla laika to trochę dziwne, że do działania sterownika w systemie 64-bitowym potrzebne są pakiety dla systemu 32-bitowego.
Jeśli chodzi o właściciela plików, to o ile dobrze wyczytałem w necie do jego określenia służy komenda ls -l lokalizacjaPliku. To wyświetlił mi terminal w odpowiedzi:
dmk@DMK:~$ ls -l /usr/lib32/libbrcomplpr2.so
lrwxrwxrwx 1 root root 25 sty  3 10:50 /usr/lib32/libbrcomplpr2.so -> /usr/lib/libbrcomplpr2.so
dmk@DMK:~$ ls -l /usr/lib/sane/libsane-brother3.so.1.0.7
ls: nie ma dostępu do '/usr/lib/sane/libsane-brother3.so.1.0.7': Nie jest katalogiem
dmk@DMK:~$ ls -l /usr/lib/sane/libsane-brother3.so.1
ls: nie ma dostępu do '/usr/lib/sane/libsane-brother3.so.1': Nie jest katalogiem
dmk@DMK:~$ ls -l /usr/lib/sane/libsane-brother3.so
ls: nie ma dostępu do '/usr/lib/sane/libsane-brother3.so': Nie jest katalogiem
dmk@DMK:~$ ls -l /usr/lib/libbrscandec3.so.1.0.0
-rwxr-xr-x 1 root root 37064 sty  9 14:04 /usr/lib/libbrscandec3.so.1.0.0
dmk@DMK:~$ ls -l /usr/lib/libbrscandec3.so.1
-rwxr-xr-x 1 root root 37064 sty  9 14:08 /usr/lib/libbrscandec3.so.1
dmk@DMK:~$ ls -l /usr/lib/libbrscandec3.so
-rwxr-xr-x 1 root root 37064 sty  9 14:07 /usr/lib/libbrscandec3.so

Co do deinstalacji pakietów poszperałem trochę w necie i jakoś nigdzie nie mogłem znaleźć informacji jak odinstalować dany pakiet. Wszędzie była mowa jedynie o instalacji i usuwaniu pakietu. Nawet w Synapticu jedyna opcja oprócz instalacji to usuwanie, więc nie mam pojęcia jak odinstalować dany pakiet.
Jeśli chodzi o polecenie "scanimage -L" to wywołałem je odrazu jako root.
Co do paczki "libusb-compat" to nie znalazło mi takiej w synapticu, ale jest "libusb + nr serii", więc może to jest odpowiednikiem tego pakietu. W opise tych pakietów jest napisane "Biblioteka programowania USB w przestrzeni użytkownika". Obydwie mam zainstalowane.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: pavbaranov w Styczeń 12, 2020, 10:19:24 am
Może źle się wyraziłem. Pytając o "właściciela" pliku chodziło mi o to jaka paczka dostarczyła go podczas instalacji. W debianowatych zdaje się, że jest to do ustalenia poprzez komendy:
dpkg -S /lokalizacja/nazwa-plikulub
dlocate /lokalizacja/nazwa-pliku
Pisząc o "deinstalacji" oczywiście chodziło mi o usuwanie.

PS: 32bitowe biblioteki są potrzebne w systemie 64 bitowym np. do obsługi programów 32 bitowych w takim systemie, w tym również do działania takich sterowników. Brother co najmniej część sterowników dostarcza wyłącznie w wersji 32 bitowej (i dlatego m.in. nie używam KaOSa ;)).
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: Kano w Styczeń 12, 2020, 04:31:19 pm
dpkg -S zwraca dpkg-query: nie znaleziono ścieżki pasującej do wzorca, np. dpkg -S /usr/lib/libbrscandec3.so
dpkg-query: nie znaleziono ścieżki pasującej do wzorca /usr/lib/libbrscandec3.so
a dlocate po kilku sekundach "myślenia" nie zwraca nic. Próbowałem też komendy apt-file search ścieżka/nazwaPliku, ale ono też nic nie zwraca.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: pavbaranov w Styczeń 12, 2020, 04:56:37 pm
A wydawało mi się, że piszę jasno :)
W odpowiedzi: [urlhttps://forum.linuxiarze.pl/index.php/topic,3864.msg23584.html#msg23584[/url] podałeś np. taki adres: /usr/lib/sane/libsane-brother3.so.1.0.7, a zatem polecenie dla dpkg winno wyglądać np. tak:
dpkg -S /usr/lib/sane/libsane-brother3.so.1.0.7I tak dla każdego sprawdź, choć wszystkie *.so, *.so.1, *.so.1.0.7 winny pochodzić z tej samej paczki. Dla nas (mnie) interesujące jest tylko, czy to cokolwiek zwraca (jakąś paczkę), czy nie, a zatem możesz napisać wyłącznie, że wszystko to należy do paczki X.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: Kano w Styczeń 12, 2020, 05:18:58 pm
Właśnie w taki sam sposób sprawdziłem dpkg dla wszystkich 7 plików (dpkg -S ścieżka-do-pliku/nazwa-pliku). Tak samo kiedy skopiowałem i wkleiłem do terminala tą linijkę, którą teraz napisałeś wyskoczył mi dokładnie taki sam komunikat co wcześniej.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: pavbaranov w Styczeń 12, 2020, 05:46:25 pm
Ok, sorry, na starość ślepnę.
Puść sobie ten driver-install-tool z włączonym (nieuśpionym) urządzeniem podłączonym do komputera. Jeśli drukowanie działa, to o ile się w tym skrypcie da to pominąć, to pomiń i przejdź do instalacji sterowników skanera. Po przeprowadzonej instalacji - reboot, podłączenie urządzenia i sprawdzenie przez scanimage.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: Kano w Styczeń 12, 2020, 07:21:17 pm
Instalacja driver install tool:
dmk@DMK:~/Downloads/brother$ sudo bash linux-brprinter-installer-2.2.1-1
[sudo] hasło użytkownika dmk:
Input model name ->DCP-7030

You are going to install following packages.
   brdcp7030lpr-2.0.2-1.i386.deb
   cupswrapperDCP7030-2.0.2-1.i386.deb
   brscan3-0.2.13-1.amd64.deb
   brscan-skey-0.2.4-1.amd64.deb
OK? [y/N] ->y

Stary:1 http://pl.archive.ubuntu.com/ubuntu bionic InRelease
Stary:2 http://pl.archive.ubuntu.com/ubuntu bionic-updates InRelease
Pobieranie:3 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
Stary:4 http://pl.archive.ubuntu.com/ubuntu bionic-backports InRelease         
Pobieranie:5 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [38,6 kB]
Pobieranie:6 http://security.ubuntu.com/ubuntu bionic-security/main DEP-11 48x48 Icons [17,6 kB]
Pobieranie:7 http://security.ubuntu.com/ubuntu bionic-security/main DEP-11 64x64 Icons [41,5 kB]
Pobieranie:8 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [42,1 kB]
Pobieranie:9 http://security.ubuntu.com/ubuntu bionic-security/universe DEP-11 48x48 Icons [16,4 kB]
Pobieranie:10 http://security.ubuntu.com/ubuntu bionic-security/universe DEP-11 64x64 Icons [116 kB]
Pobieranie:11 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 DEP-11 Metadata [2 460 B]
Pobrano 364 kB w 2s (214 kB/s)                     
Czytanie list pakietów... Gotowe
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Pakiet ia32-libs nie ma dostępnej wersji, ale odnosi się do niego inny pakiet.
Zazwyczaj oznacza to, że pakietu brakuje, został zastąpiony przez inny
pakiet lub nie jest dostępny przy pomocy obecnie ustawionych źródeł.
Jednak następujące pakiety go zastępują:
  lib32ncurses5 lib32z1

E: Pakiet ia32-libs nie ma kandydata do instalacji
dpkg -x brdcp7030lpr-2.0.2-1.i386.deb /
dpkg -x cupswrapperDCP7030-2.0.2-1.i386.deb /
dpkg-deb: budowanie pakietu "brdcp7030lpr" w "brdcp7030lpr-2.0.2-1a.i386.deb".
dpkg -b ./brother_driver_packdir brdcp7030lpr-2.0.2-1a.i386.deb
dpkg-deb: budowanie pakietu "cupswrapperdcp7030" w "cupswrapperDCP7030-2.0.2-1a.i386.deb".
dpkg -b ./brother_driver_packdir cupswrapperDCP7030-2.0.2-1a.i386.deb
dpkg -i --force-all brdcp7030lpr-2.0.2-1a.i386.deb
(Odczytywanie bazy danych ... 179220 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu brdcp7030lpr-2.0.2-1a.i386.deb ...
Rozpakowywanie pakietu brdcp7030lpr:i386 (2.0.2-1) nad (2.0.2-1) ...
Konfigurowanie pakietu brdcp7030lpr:i386 (2.0.2-1) ...
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib32/libbrcomplpr2.so': Plik istnieje
dpkg -i --force-all cupswrapperDCP7030-2.0.2-1a.i386.deb
(Odczytywanie bazy danych ... 179220 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu cupswrapperDCP7030-2.0.2-1a.i386.deb ...
Restarting cups (via systemctl): cups.service.
Rozpakowywanie pakietu cupswrapperdcp7030:i386 (2.0.2-1) nad (2.0.2-1) ...
Konfigurowanie pakietu cupswrapperdcp7030:i386 (2.0.2-1) ...
Restarting cups (via systemctl): cups.service.
#
Will you specify the Device URI? [Y/n] ->n

Test Print? [y/N] ->y

wait 5s.
lpr -P DCP7030 /usr/share/cups/data/testprint
You are going to install following packages.
   brscan3-0.2.13-1.amd64.deb
dpkg -i --force-all brscan3-0.2.13-1.amd64.deb
(Odczytywanie bazy danych ... 179220 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu brscan3-0.2.13-1.amd64.deb ...
Rozpakowywanie pakietu brscan3 (0.2.13-1) nad (0.2.13-1) ...
Konfigurowanie pakietu brscan3 (0.2.13-1) ...
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/sane/libsane-brother3.so.1.0.7': Nie jest katalogiem
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/sane/libsane-brother3.so.1': Nie jest katalogiem
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/sane/libsane-brother3.so': Nie jest katalogiem
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/libbrscandec3.so.1.0.0': Plik istnieje
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/libbrscandec3.so.1': Plik istnieje
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/libbrscandec3.so': Plik istnieje
You are going to install following packages.
   brscan-skey-0.2.4-1.amd64.deb
dpkg -i --force-all brscan-skey-0.2.4-1.amd64.deb
(Odczytywanie bazy danych ... 179220 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu brscan-skey-0.2.4-1.amd64.deb ...
Rozpakowywanie pakietu brscan-skey (0.2.4-1) nad (0.2.4-1) ...
Konfigurowanie pakietu brscan-skey (0.2.4-1) ...
Hit Enter/Return key.

Spełnienie procedur poprzedzających instalację scanner driver i scan-key-tool:
dmk@DMK:~/Downloads/brother$ sudo ln -s /etc/init.d/cups /etc/init.d/lpd
ln: nie udało się utworzyć dowiązania symbolicznego '/etc/init.d/lpd': Plik istnieje
dmk@DMK:~/Downloads/brother$ sudo mkdir /var/spool/lpd
mkdir: nie można utworzyć katalogu „/var/spool/lpd”: Plik istnieje

Instalacja scanner driver:
dmk@DMK:~/Downloads/brother$ sudo dpkg -i --force-all brscan3-0.2.13-1.amd64.deb(Odczytywanie bazy danych ... 179220 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu brscan3-0.2.13-1.amd64.deb ...
Rozpakowywanie pakietu brscan3 (0.2.13-1) nad (0.2.13-1) ...
Konfigurowanie pakietu brscan3 (0.2.13-1) ...
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/sane/libsane-brother3.so.1.0.7': Nie jest katalogiem
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/sane/libsane-brother3.so.1': Nie jest katalogiem
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/sane/libsane-brother3.so': Nie jest katalogiem
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/libbrscandec3.so.1.0.0': Plik istnieje
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/libbrscandec3.so.1': Plik istnieje
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/libbrscandec3.so': Plik istnieje
Tutaj chyba coś poszło nie tak.

Instalcja scan-key-tool:
dmk@DMK:~/Downloads/brother$ sudo dpkg -i --force-all brscan-skey-0.2.4-1.amd64.deb
(Odczytywanie bazy danych ... 179220 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu brscan-skey-0.2.4-1.amd64.deb ...
Rozpakowywanie pakietu brscan-skey (0.2.4-1) nad (0.2.4-1) ...
Konfigurowanie pakietu brscan-skey (0.2.4-1) ...

Instalacja scanner setting file:
dmk@DMK:~/Downloads/brother$ sudo dpkg -i brother-udev-rule-type1-1.0.2-0.all.deb
(Odczytywanie bazy danych ... 179220 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu brother-udev-rule-type1-1.0.2-0.all.deb ...
Rozpakowywanie pakietu brother-udev-rule-type1 (1.0.2) nad (1.0.2) ...
Konfigurowanie pakietu brother-udev-rule-type1 (1.0.2) ...

Restart i:

dmk@DMK:~$ sudo scanimage -L
[sudo] hasło użytkownika dmk:

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

dmk@DMK:~$ sudo sane-find-scanner tool

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

  # No USB scanners found. If you expected something different, make sure that
  # you have loaded a kernel driver for your USB host controller and have setup
  # the USB system correctly. See man sane-usb for details.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.
:/
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: pavbaranov w Styczeń 12, 2020, 07:56:09 pm
Problem leży - chyba - tu:
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/sane/libsane-brother3.so.1.0.7': Nie jest katalogiem
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/sane/libsane-brother3.so.1': Nie jest katalogiem
ln: nie udało się utworzyć dowiązania symbolicznego '/usr/lib/sane/libsane-brother3.so': Nie jest katalogiem
I efekt jest taki, że sterownik, którym jest libsane-brother3.so.* nie jest widziany przez SANE w Ubuntu. I tu mam problem, bowiem nie wiem, gdzie w Ubuntu lokowane są sterowniki dla SANE. Analizując libsane mogę jedynie przypuszczać, że to jest /usr/lib/x86_64-linux-gnu/sane/, ale pewności nie mam. Tu musi Ci pomóc ktoś, kto ma ten OS. Po ustaleniu należy podlinkować pliki, które są instalowane przez brscan3, tak, by widział je SANE w Ubuntu. Ten sam problem miałem w Archu i opisałem to w przywołanym wyżej linku do archlike.darmowefora.pl. Cóż... moja rola się tu kończy, mogę tylko powiedzieć, że po prawidłowym podlinkowaniu system winien współpracować z tym modelem skanera.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: Kano w Styczeń 13, 2020, 04:46:12 pm
A czy jesteś w stanie powiedzieć mi jak podlinkować te pliki? Pytam, bo przed chwilą sprawdziłem i ścieżka którą podałeś (/usr/lib/x86_64-linux-gnu/sane/) rzeczywiście istnieje. Więc mamy chyba ustaloną lokalizację.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: pavbaranov w Styczeń 13, 2020, 06:55:41 pm
No to jest dokładnie tak, jak w tym moim poradniku, oczywiście ze zmianami dla Ubu, czyli - opiszę, a nie dam Ci gotowca:
sudo ln -s skąd gdzieW miejsce skąd podstawiasz całą ścieżkę do pliku, czyli to winno być - jak widzę - w: /usr/lib64/sane/ do tego katalogu, który wskazałeś. Chodzi o pliki libsane-brother3*. Tyle, że - jak powtarzam - nie mam obecnie Ubu i to tylko tak mocno na "czuja". Prawdopodobnie jednak pójdzie.
Jeśli ten opis nie jest czytelny, to powiedz, ew. wejdź na IRC linuxiarze.pl - też pomożemy. Feedback będzie lepszy.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: Kano w Styczeń 14, 2020, 03:33:14 pm
Zrobiłem te dowiązania w taki sposób:
sudo ln -s /usr/lib/sane/libsane-brother3.so.1.0.7 /usr/lib/x86_64-linux-gnu/sane/
sudo ln -s /usr/lib/sane/libsane-brother3.so.1 /usr/lib/x86_64-linux-gnu/sane/
sudo ln -s /usr/lib/sane/libsane-brother3.so /usr/lib/x86_64-linux-gnu/sane/

Po czym uruchomiłem ponownie komputer. Co prawda skaner nadal nie działa, ale po wpisaniu:
sudo scanimage -L i dalej sudo sane-find-scanner tool system zwraca coś takiego:

# sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x0cf3 [ATHEROS], product=0x9271 [USB2.0 WLAN]) at libusb:001:004
found USB scanner (vendor=0x04f9, product=0x01ea) at libusb:004:003
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: pavroo w Styczeń 14, 2020, 03:50:18 pm
Moj Brother również nie chce działać prawidłowo, pomimo sterowników od producenta.
Drukarka drukuje bez polskich znaków, ale skaner trzeba zmuszać do współpracy za każdym razem.
Po podłączeniu skanera do portu USB, w terminalu:
lsusbprzykładowy wynik:
Bus 003 Device 004: ID 04f9:02d0 Brother Industries, Ltd DCP-NUMERUrządzenie jest podłączone do portu: 003/004 (za każdym podłączeniem jest inny port)
Następnie:
sudo chmod a+w /dev/bus/usb/003/004I skaner działa, spróbuj.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: Kano w Styczeń 14, 2020, 04:10:32 pm
dmk@DMK:~$ lsusb
Bus 001 Device 004: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 1a2c:0021 China Resource Semico Co., Ltd Keyboard
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 003: ID 04f9:01ea Brother Industries, Ltd DCP-7030
Bus 004 Device 002: ID 04f3:0234 Elan Microelectronics Corp.
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
dmk@DMK:~$ sudo chmod a+w /dev/bus/usb/004/003
[sudo] hasło użytkownika dmk:

Niestety nadal nie działa.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: pavbaranov w Styczeń 14, 2020, 04:24:52 pm
Co daje samo:
scanimage -L?
Dowiązania wyglądają na prawidłowe. Jeśli dalej system nie widzi, to musi Ci ktoś pomóc, kto ma Ubu 18.04. Nie chce mi się go instalować...
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: Kano w Styczeń 14, 2020, 04:49:29 pm
To samo:
No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

Tak czy inaczej wielkie dzięki pavbaranov za pomoc. Poszukam pomocy jeszcze gdzieś indziej a ten wątek pozostawiłbym otwarty. Być może jeszcze ktoś inny poda jeszcze jakąś propozycję rozwiązania tego problemu a jeśli sam ją znajdę, to napiszę tutaj co mi pomogło.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: Albedo 0.64 w Styczeń 14, 2020, 05:45:58 pm
Witajcie. Ja mam już kilka lat Brothera DCP-J105, którego kupiłem ze względu na jakość sprzętu i dostępność sterowników linuksowych. Sterowniki były załączone na płytce CD wraz z instukcją instalacji. Nie chce mi się wierzyć, że Brother zmienił swoją politykę i sterowniki nie działają. A że są 32-bitowe, to już inna bajka. Dla przykładu załączam instrukcję instalacji sterowników, żeby było wiadomo czego szukać lub ewentualnie porównać z własną. Aby proces zakończyła się powodzeniem, należy najpierw umieścić komplet sterowników i skryptów w dowolnym folderze w katalogu domowym a następnie otworzyć to położenie w terminalu. Moja instrukcja wygląda tak:

How to Install driver install tool

Step1. Download the tool.(linux-brprinter-installer-*.*.*-*.gz)

The tool will be downloaded into the default "Download" directory.
(The directory location varies depending on your Linux distribution.)
e.g. /home/(LoginName)/Download

Step2. Open a terminal window and go to the directory you downloaded the file to in the last step.

Step3. Enter this command to extract the downloaded file:

Command: gunzip linux-brprinter-installer-*.*.*-*.gz

Step4. Get superuser authorization with the "su" command or "sudo su" command.

Step5. Run the tool:

Command: bash linux-brprinter-installer-*.*.*-* Brother machine name

Step6. The driver installation will start. Follow the installation screen directions.
 

 When you see the message "Will you specify the DeviceURI ?",

 For USB Users: Choose N(No)
 For Network Users: Choose Y(Yes) and DeviceURI.

The install process may take some time. Please wait until it is complete.

How to Install LPR driver (deb package)

    Download LPR driver.
     
    Login as a superuser ( or use "sudo" option if required).
     
    Check if pre-required procedures are completed
    For Debian/Ubuntu 64bit
     
    Install the driver.
        Turn on the printer and connect the usb, network or parallel cable.
        Go to the directory where the driver is.
        Install LPR driver.The install process may take some time. Please wait until it is complete.
        Command  :  dpkg -i --force-all  (lpr-drivername)
        Check if the LPR driver is installed.
        Command  :  dpkg -l  |  grep  Brother
         
    Confirm/Configure a file according to your connection.

     
        Check the configuration filename for your distribution.
        Example:
        openSUSE, Ubuntu, Debian : /etc/printcap
        Redhat, fedora, Mandriva : /etc/printcap.local
         
        Edit the file according to your connection.
        For USB Connection (Default)
        Check if the parameter of ":lp" is ":lp=/dev/usb/lp0"
        For Network Connection
        replace ":lp" line to the following 2 lines
        :rm=(ip address of your printer)\
        :rp=lp\
        For Parallel Connection
        replace ":lp" line to the following line
        :lp=/dev/lp0\
         
        Restart the print system.
        Command  (for  lpr):  /etc/init.d/lpr  restart
        Command  (for  lprng)  :  /etc/init.d/lprng  restart
         
    Try a test print.

How to Install CUPSwrapper printer driver (deb package)

    Login as a superuser ( or use "sudo" option if it is required )
     
    Check if pre-required procedures are completed
    For Debian/Ubuntu 64 bit
    For Ubuntu8.04 or greater
     
    Download drivers
    Download LPR driver and cupswrapper driver.
     
    Install LPR driver and cupswrapper driver
        Turn on the printer and connect the USB cable.
        Open the terminal and go to the directory where the drivers are.
        Install LPR driver.The install process may take some time. Please wait until it is complete.
        Command (for dpkg)  :  dpkg  -i  --force-all  (lpr-drivername)
         
        Install cupswrapper driver.The install process may take some time. Please wait until it is complete.
        Command (for dpkg)  :  dpkg  -i  --force-all  (cupswrapper-drivername)
         
        Check if the LPR driver and cupswrapper driver are installed
        Command (for dpkg)  :  dpkg  -l  |  grep  Brother
         
    Depending on the connection type you are using (USB or Network), follow one of the steps below.

    (for USB Connection)
        Open a web browser and go to "http://localhost:631/printers".
        Check if the Device URI of your printer is "usb://Brother/(your printer's model name)"

        If the device URI is different from the example above, please go to "Modify Printer" of your printer to select proper device and driver.
        If your printer is not listed on "http://localhost:631/printers", please go to "http://localhost:631/admin" and click "Add printer" and select proper device and driver.

     
    (for Network Connection)

     
        Open a web browser and go to "http://localhost:631/printers".
        Click "Modify Printer" and set following parameters.
        - "LPD/LPR Host or Printer" or "AppSocket/HP JetDirect"            for Device
        - lpd://(Your printer's IP address)/binary_p1            for Device URI
        - Brother            for Make/Manufacturer Selection
        - Your printer's name            for Model/Driver Selection
    Try a test print
    Open a text editor, write something and select "print" from the menu.

Do prawidłowego działania skanera należy dodać użytkownika do grupy lp i lpadmin.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: Kano w Styczeń 14, 2020, 05:58:16 pm
Hej Albedo znalazłem twoją instrukcję w innym wątku i zrobiłem tak jak napisałeś. Nie wiem tylko jak dodać użytkownika do grupy lp i lpadmin.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: pavbaranov w Styczeń 14, 2020, 06:26:25 pm
Załapiesz: https://wiki.archlinux.org/index.php/Users_and_groups#Group_management (https://wiki.archlinux.org/index.php/Users_and_groups#Group_management)? Jeśli nie to pytaj. Być może w tym Twoim Ubu jest jakieś GUI, które łatwo to robi. Nie wiem, nie znam się.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: Kano w Styczeń 16, 2020, 04:51:18 pm
Dzięki za link pavbaranov.
dmk@DMK:~$ groups dmk
dmk : dmk adm cdrom sudo dip plugdev lpadmin sambashare
Czy to znaczy, że jestem już w tych dwóch grupach?
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: pavbaranov w Styczeń 16, 2020, 05:08:12 pm
W lpadmin - tak, w lp - nie.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: Kano w Styczeń 16, 2020, 06:40:27 pm
Racja.
dmk@DMK:~$ sudo gpasswd -a dmk lp
[sudo] hasło użytkownika dmk:
Dodaję nowego użytkownika dmk do grupy lp
Teraz już ok :)
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: pavbaranov w Styczeń 16, 2020, 09:37:36 pm
Tak - najlepiej reboot i sprawdzić.
Tytuł: Odp: Problem z instalacją skanera w Brother DCP-7030
Wiadomość wysłana przez: Kano w Marzec 25, 2020, 01:28:48 pm
Witam po długiej przerwie. Napisałem wcześniej, że jeśli rozwiążę problem, wrócę tutaj i napiszę co mi pomogło. Tak więc udało mi się w końcu zmusić skaner do działania. Niestety nie w Ubuntu a w Mincie. Po zainstalowaniu systemu i jego aktualizacji podłączyłem urządzenie do komputera i włączyłem. System sam znalazł i rozpoznał drukarkę, więc nie musiałem nawet instalować sterowników do niej. Skaner niestety nie został wykryty. Ściągnąłem więc sterowniki i wykonałem wszystkie wstępne procedury (poprzedzające instalację):

https://support.brother.com/g/b/midlink_faqid.aspx?c=pl&lang=pl&prod=dcp7030_all&site=pc&faqid=faq00100548&orgc=pl&orglang=pl&orgprod=dcp7030_all&orgfaqid=faq00100548&targetpage=14

Następnie zainstalowałem sterowniki zgodnie z instrukcją na stronie. Niestety skaner nadal nie został wykryty. Następnie wykonałem ten krok:

https://support.brother.com/g/b/faqend.aspx?c=pl&lang=pl&prod=dcp7030_all&ftype3=100258&faqid=faq00100617_000&ot=eu_ot

Niestety bez oczekiwanego skutku.

Już miałem się poddać, ale przypomniałem sobie o jednym rozwiązaniu, które znalazłem w internecie pod tym adresem (post #9):

https://www.linuxquestions.org/questions/linux-hardware-18/scanner-will-not-install-on-fresh-installation-of-mint-19-64bit-4175640527/

Próbowałem tego już wcześniej pod Ubuntu, ale po:
sudo cp /usr/lib64/sane/libsane-brother* /usr/lib/x86_64-linux-gnu/sane
otrzymałem:
cp: nie można wykonać stat na '/usr/lib64/sane/libsane-brother*': Nie ma takiego pliku ani katalogu
Natomiast w Mincie to zadziałało. Po tym skaner zaczął działać :)
Może komuś się to przyda. Zamykam temat.