Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: [ROZWIĄZANY] Problem z IDE opartym o Jave  (Przeczytany 488 razy)

Offline funn

  • Jr. Member
  • **
  • Wiadomości: 91
  • Reputacja: +0/-0
[ROZWIĄZANY] Problem z IDE opartym o Jave
« dnia: Październik 07, 2019, 12:11:18 am »
Gdy klikam na edytor z kodem w NetBeans czy Intellij, to kursor nie reaguje, nie mogę nic napisać, zaznaczyć. Dopiero jak kliknę w lewym rogu Gnome na Podgląd to mogę pisać i zaznaczać kod.  To może być wina tego nowego Gnome 3.34?
« Ostatnia zmiana: Październik 14, 2019, 06:10:22 pm wysłana przez funn »

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2572
  • Reputacja: +35/-9
Odp: Problem z IDE opartym o Jave
« Odpowiedź #1 dnia: Październik 07, 2019, 07:55:43 am »
Prędzej z javą, aczkolwiek jakiś problem na styku javy i GNOME jest zgłoszony: https://bugs.archlinux.org/task/63310. Także problem z Intellij: https://bugs.archlinux.org/task/63670.
W jakiej wersji masz oprogramowanie, o którym wspomniałeś oraz javę?

Offline funn

  • Jr. Member
  • **
  • Wiadomości: 91
  • Reputacja: +0/-0
Odp: Problem z IDE opartym o Jave
« Odpowiedź #2 dnia: Październik 07, 2019, 06:41:53 pm »
Intellij mam w wersji 2019.2.3, NetBeans 11.1, a Java 12.0.2. Używam Intellij pobierając ją bezpośrednio ze strony JetBrains, ponieważ ten pakiet Intellij dostępny w Archu chce zainstalować od razu Jave w wersji 11, a mi zależy na 12. Nie chcę mieć dwie wersje Javy w systemie.
« Ostatnia zmiana: Październik 07, 2019, 06:45:47 pm wysłana przez funn »

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2572
  • Reputacja: +35/-9
Odp: Problem z IDE opartym o Jave
« Odpowiedź #3 dnia: Październik 07, 2019, 06:51:58 pm »
Skoro pobierasz coś bezpośrednio ze strony, to im musisz zgłosić błąd. W istocie intellij-idea-community-edition ma ustawioną javę na =11. Widać z jakiegoś powodu w Archu stwierdzili, że tak ma być. Skoro jednak używasz czegoś innego, to musisz mieć pretensje do twórców oprogramowania. Jeśli chodzi o netbeans, to on wymaga javy w wersji min. 9. Może wypróbuj zatem z inną niż masz. Niestety oprogramowanie javy jest mocno, ale to mocno... "dziabnięte".

Offline funn

  • Jr. Member
  • **
  • Wiadomości: 91
  • Reputacja: +0/-0
Odp: Problem z IDE opartym o Jave
« Odpowiedź #4 dnia: Październik 07, 2019, 08:32:09 pm »
Tylko jak pisałem wyżej, ten problem występuje też pod NetBeans który zainstalowałem z repozytorium Archa, czyli to nie wina samego IDE.

Edyta. Program już działa poprawnie, odinstalowałem go i skasowałem katalog .netbeans, .cache/netbeans. Tak samo zrobiłem z Javą i katalogiem .java.
« Ostatnia zmiana: Październik 13, 2019, 03:50:09 am wysłana przez funn »