Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: Lubuntu po zainstalowaniu nie startuje  (Przeczytany 1893 razy)

Offline roskibart

  • Newbie
  • *
  • Wiadomości: 15
  • Reputacja: +0/-0
Lubuntu po zainstalowaniu nie startuje
« dnia: Wrzesień 18, 2019, 03:12:25 pm »
Witam
Zainstalowałem Lubuntu na starym laptopie (Acer Aspire 5320, 512MB DDR2 powiększona do 1024MB) jako jedyny system na tym komputerze z pobranego obrazu ISO ze strony https://linuxiarze.pl/download_lubuntu/.
Bootowalny pendrive przygotowałem za pomocą programu Universal-USB-Installer-1.9.8.8. Instalacja przebiega bez problemu lecz po restarcie tylko czarny ekran bez jakiejkolwiek zmiany przez dowolny okres czasu. Instalacji dokonywałem wielokrotnie używając różnych wersji Lubuntu: 18.04.3 LTS i386, 18.10 w wersji deskop i altemate zawsze z tym samym skutkiem. Próbowałem różnych wersji instalacji z systemowym partycjonowaniem dysku oraz ręcznym bez rezultatu. Przygotowanie pendriva przy pomocy Rufusa też nic nie dało. Po zainstalowaniu wersji 16.04.3 LTS system odpalił lecz po aktualizacji do wersji 16.04.4 po restarcie czarny ekran. Podczas rozruchu komputera odpaliłem przypadkiem tryb awaryjny i za jego pomocą udało mi się wystartować. Obecnie po aktualizacji do wersji 18.04 też można go odpalić tylko z trybu awaryjnego. Może problem jest z grubem? Jak to sprawdzić. Moja wiedza w tej materii jest znikoma i prosiłbym o w miarę prosty i zrozumiały do laika sposób podpowiedzi.
Dziękuję za pomoc.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2552
  • Reputacja: +35/-8
Odp: Lubuntu po zainstalowaniu nie startuje
« Odpowiedź #1 dnia: Wrzesień 18, 2019, 03:30:52 pm »
Prawdopodobnie kwestia jakichś sterowników grafiki. Jakie tam masz GPU?
Zamiast męczyć się - skoro 18.04 wydaje jakieś oznaki życia, a zdaje się, że nie masz tam w komputerze jeszcze jakichś znaczących rzeczy - po prostu spróbowałbym instalacji najnowszego wydania 18.04 lub nawet 19.04 (jeśli tam jest 64bitowy procesor). Jeśli się uda - problem z głowy. Jeśli również nie - wrócimy do tematu, ale w takim przypadku fajnie by było, abyś nawet w tym trybie awaryjnym zainstalował inxi i podał nam:
inxi -Fxxoraz
cat /etc/default/grub

Offline roskibart

  • Newbie
  • *
  • Wiadomości: 15
  • Reputacja: +0/-0
Odp: Lubuntu po zainstalowaniu nie startuje
« Odpowiedź #2 dnia: Wrzesień 18, 2019, 04:06:03 pm »
wykonałem polecenie zapis poniżej:
robert@robert-Aspire-5320:~$ inxi -Fxx

Command 'inxi' not found, but can be installed with:

sudo apt install inxi

robert@robert-Aspire-5320:~$ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
 

 Intel Celeron M processor 540 (1.86 GHz, 533 MHz FSB, 1 MB L2 cache)
Mobile Intel GraphicsMedia Accelerator X3100
robert@robert-Aspire-5320:~$ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 03)
« Ostatnia zmiana: Wrzesień 18, 2019, 04:30:31 pm wysłana przez lami07 »

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2552
  • Reputacja: +35/-8
Odp: Lubuntu po zainstalowaniu nie startuje
« Odpowiedź #3 dnia: Wrzesień 18, 2019, 07:43:41 pm »
To skoro zainstalowałeś już to inxi, to pokaż co on widzi.
Dodatkowo możesz jeszcze - znów z awaryjnego - sprawdź sobie, czy masz możliwość zainstalowania czegoś co się nazywa pastebinit (być może w ubuntowych jest to jakieś inne narzędzie podobne, niech ktoś zerknie w swój komputer) i:
journalctl -b > 1.txt && pastebinit 1.txtWstaw tu linka, który Ci się pojawi.
Dodatkowo również - przy uruchomieniu przejdź do edycji GRUBa, usuń "quiet splash" i napisz nam co widzisz, a w zasadzie na czym się zatrzymuje.

Offline roskibart

  • Newbie
  • *
  • Wiadomości: 15
  • Reputacja: +0/-0
Odp: Lubuntu po zainstalowaniu nie startuje
« Odpowiedź #4 dnia: Wrzesień 18, 2019, 08:14:34 pm »
robert@robert-Aspire-5320:~$ journalctl -b > 1.txt && pastebinit 1.txt
http://paste.ubuntu.com/p/4jjF8dmZ2m/
robert@robert-Aspire-5320:~$

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2552
  • Reputacja: +35/-8
Odp: Lubuntu po zainstalowaniu nie startuje
« Odpowiedź #5 dnia: Wrzesień 18, 2019, 08:35:52 pm »
Dalej nie podajesz wszystkich informacji, ale prawdopodobnie masz przeprowadzoną wadliwie aktualizację. System odpala się - i to częściowo, bo części nie ma - z kernela z 16.04.2. Wg Ciebie to jest 18.04.3. Coś tu nie gra. Być może w GRUBym masz możliwość (powinieneś mieć) wyboru kernela 4.15 (bo taki winien być w 18.04.3) - sprawdź, może pójdzie.
I znów powiem - masz tam w tym komputerze jakieś dokumenty itp. - przekopiuj i spróbuj zainstalować sobie 18.04.3 od spodu, bo najwyraźniej aktualizację zepsułeś. Być może to się jakoś uda poukładać, ale niech się tym bawi ktoś, kto obecnie pracuje na ubuntowatych.

Offline roskibart

  • Newbie
  • *
  • Wiadomości: 15
  • Reputacja: +0/-0
Odp: Lubuntu po zainstalowaniu nie startuje
« Odpowiedź #6 dnia: Wrzesień 18, 2019, 08:56:43 pm »
OK. ponowię instalację w/g zaleceń a co do inxi nie umiem tego pokazać mam zrobione fotki ale nie umiem ich wrzucić na forum.
Dzięki za poświęcony czas. Dam znać o wyniku ponownej instalacji.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2552
  • Reputacja: +35/-8
Odp: Lubuntu po zainstalowaniu nie startuje
« Odpowiedź #7 dnia: Wrzesień 18, 2019, 10:04:24 pm »
Najprościej "pokazać" przekierowując strumień do pliku tak samo jak to robiłeś z journalctl, czyli:
inxi -Fxx > 1.txtco spowoduje, że wynik działania inxi zostanie przekazany nie na ekran komputera, a do pliku, a potem umieszczasz treść pliku dowolnie, choćby przez różne pastebinity.

Offline roskibart

  • Newbie
  • *
  • Wiadomości: 15
  • Reputacja: +0/-0
Odp: Lubuntu po zainstalowaniu nie startuje
« Odpowiedź #8 dnia: Wrzesień 19, 2019, 05:51:02 pm »
Witam

zainstalowałem ponownie zgodnie z poleceniem Lubuntu 18.04.3 odhaczając opcje w instalatorze:
- Normal installation
-Pobierz aktualizacje podczas instalowania Lubuntu
-Install third-party software graphics and Wi-Fi hardwere and additional media formats
następnie:
-wyczyszczenie dysku i zainstalowanie Lubuntu.

Po instalacji i ponownym uruchomieniu pojawiło się logo Lubuntu i po ok. 5 min. system ruszył.
Na pasku zadań pojawiła się informacja o pobranych aktualizacjach i przygotowanych do zainstalowania.
Przeprowadziłem aktualizacje i po rozruchu system się zawiesił (czarny ekran). Efekt dokładnie ten sam jak po instalacji Lubuntu 16.04.3 opisanej w pierwszym poście.
Można było wystartować jedynie z trybu awaryjnego klikając:
- opcje zaawansowane dla systemu Ubuntu
- Ubuntu, za pomocą systemu Linux 5.0.0-23-generic
Nie umiem dokładnie opisać wszystkich kolejnych komunikatów jakie się pojawiały (dla laika czarna magia) zrobiłem fotki lecz nie umiem ich wrzucić na forum. Ogólnie zasada jest taka iż po restarcie gdy w prawym górnym rogu pojawia się kursor (pozioma kreseczka) na kilka sekund a po dłuższej przerwie wyświetla kolejne linie a potem długo nic (kilka minut) wtedy pojawia się login i po wpisaniu hasła pulpit. Po kilku włączeniach nastąpiła zmiana i po restarcie czarny ekran, długo długo nic a potem niebieski ekran z napisem Lubuntu tak jak przy starcie załadowanego systemu potem długo nic i laptop się wyłącza przechodząc w stan czuwania.
I z tym nie można już nic zrobić. Jedynie wyłączenie laptopa na zał/wył i uruchamianie od nowa. Wystartowanie z trybu awaryjnego (patrz wyżej) jest niemożliwe gdyż dzieje się tak jak opisałem (niebieski ekran).
Postanowiłem dokonać ponownej instalacji Lubuntu 18.04.3 i po restarcie jest tak jak było: czarny ekran, niebieski, logo, stan czuwania. Utraciłem możliwość przeprowadzania jakichkolwiek operacji przy moich umiejętnościach. Opisuję to wszystko na drugim lapku. Sory za przydługi i kulawy opis ale jest to dla mnie trudne a chciałem w miarę wiernie przedstawić problem. Dodam jeszcze iż kiedyś poddając się Linuxowej pasji na tym laptopie doinstalowałem obok Windowsa XP openSUSE. Potem sformatowałem cały dysk razem z grubem i jak pamiętam były problemy z ponowną instalacją windy. Może to ma jakiś związek z obecnymi problemami.
Jeszcze raz dzięki wszystkim, którzy to doczytają do końca, proszę o wyrozumiałość i będę wdzięczny za sugestie czy podpowiedzi.
Pozdrawiam.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2552
  • Reputacja: +35/-8
Odp: Lubuntu po zainstalowaniu nie startuje
« Odpowiedź #9 dnia: Wrzesień 19, 2019, 08:43:33 pm »
Pokaż, po "awaryjnym" - journalctl

Offline roskibart

  • Newbie
  • *
  • Wiadomości: 15
  • Reputacja: +0/-0
Odp: Lubuntu po zainstalowaniu nie startuje
« Odpowiedź #10 dnia: Wrzesień 19, 2019, 09:10:39 pm »
Rzecz w tym, że nie mogłem uruchomić nawet trybu awaryjnego.
Przeprowadziłem kilka ponownych prób instalacji... bezskutecznie. Próbowałem nawet instalacji ubuntu-budgie-18.04.3-desktop-i386 i tu kiedy wyświetliło się logo jeszcze przed dokonaniem wyboru ustawień lapek przełączył się w stan czuwania. Dalsza instalacja okazała się niemożliwa. Powróciłem do instalacji Lubuntu 16.04.3 i tu wydaje się być wszystko w porządku ale nie przeprowadzam aktualizacji bo powróci problem. Odpaliłem tryb awaryjny i wpisałem polecenie: journalctl i nie wiem jak to pokazać

Offline ciubaka

  • Sr. Member
  • ****
  • Wiadomości: 460
  • Reputacja: +5/-1
Odp: Lubuntu po zainstalowaniu nie startuje
« Odpowiedź #11 dnia: Wrzesień 19, 2019, 09:37:49 pm »
zmień dystrybucję skoro ta nie współpracuje z komputerem, spróbuj mxlinux 32 bity, też jest prosty i mało potrzebuje zasobów - rada może nie na temat ale szkoda nerwów i energii

Offline roskibart

  • Newbie
  • *
  • Wiadomości: 15
  • Reputacja: +0/-0
Odp: Lubuntu po zainstalowaniu nie startuje
« Odpowiedź #12 dnia: Wrzesień 19, 2019, 10:00:16 pm »
OK. Dzięki, spróbuję z nowym wyzwaniem. Może z tym lepiej mi pójdzie.
Dzięki temat zakończony.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2552
  • Reputacja: +35/-8
Odp: Lubuntu po zainstalowaniu nie startuje
« Odpowiedź #13 dnia: Wrzesień 19, 2019, 11:20:31 pm »
A nowe, współczesne, wersje liveiso odpalają Ci się bez problemów?

Offline ciubaka

  • Sr. Member
  • ****
  • Wiadomości: 460
  • Reputacja: +5/-1
Odp: Lubuntu po zainstalowaniu nie startuje
« Odpowiedź #14 dnia: Wrzesień 20, 2019, 07:18:05 am »
No właśnie, pytanie z głupia frant - odpalasz najpierw wersję live czy od razu próbujesz instalować, bez sprawdzenia jak działa? i drugie, równie dziwne - dlaczego próbujesz uruchamiać stare wersje?