Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Które środowisko graficzne wybrać?

Zaczęty przez lunatyk, Lipiec 24, 2019, 09:47:37 PM

Poprzedni wątek - Następny wątek

lunatyk

Cześć, do Archa podchodziłem już wcześniej, szukałem wtedy ładnego i spójnego środowiska graficznego. Potem używałem chwilę Fedory i Ubuntu, jednak chciałbym wrócić do Archa. Stwierdziłem że większość czasu i tak spędzam nad kodem lub w przeglądarce i wcale nie potrzebuję jakiś bajerów. Myślę nad klasycznym XFCE, ale jest już trochę stare. Zaciekawiło mnie też LXQt, ale jest dopiero w wersji 0.14.1. i3, dwm itp odpadają póki co.

pavbaranov

Jezu, wybierz takie, w jakim Tobie najlepiej się pracuje. Numerkami nie masz się co zastanawiać.

lunatyk

Myślałem że korzystanie ze starego XFCE może mieć jakieś konsekwencje. Dziękuję za odpowiedź

ciubaka


PomPom

A tam stare, będzie Xfce 4.14 elegancko śmigać na nowych bibliotekach. Jak dobrze pamiętam, to przy Archu Xfce wymaga trochę więcej pracy niż Plasma, GNOME i MATE, ale to chwilka.
Komputer - Card Reader | Gry - Xbox Series X | Użytkownik - zadowolony

robson75

Cytat: lunatyk w Lipiec 24, 2019, 10:26:53 PM
Myślałem że korzystanie ze starego XFCE może mieć jakieś konsekwencje.
Co masz na myśli "stare Xfce"? Obecnie Xfce4 jest w wersji 4.13, faktem jest że to DE się rozwija bardzo powoli, ale mimo wszystko jest aktualizowane.
Arch Linux Xfce+compiz - 64Bit Linux User #621110

pavbaranov

Tak, może mieć "konsekwencje", albowiem Xfce korzysta z pewnych bibliotek, które zostały porzucone lata temu i o których wiadomo, że mają bugi. Niestety. Niemniej jednak - nie jest tak źle. Ogólna zaś zasada jest taka, by korzystać z czegoś, gdzie się dobrze czujesz. Dla przykładu - ja nie mam wątpliwości, że KDE jest tym DE, gdzie się czuję jak u siebie w domu, zaś w GNOME (3) czuję się tak, jakby kazali mi sięgać prawą ręką do lewej kieszeni w poszukiwaniu kluczy, które mam w marynarce :)
Jeśli chodzi zaś o Twoje wcześniejsze pytanie odnośnie LXQt - to jest ostatnia wersja. Równie dobrze mogliby to nazwać np. 1.14 itp. Bez sensu się nad tym głowić.

lunatyk

A jak do wymienionych XFCE i LXQt ma się LXDE?

pavbaranov

#8
W jakim sensie?
Ogólnie - DE to sprawa indywidualnych preferencji. Jednemu pracuje się lepiej w jednym, innemu w drugim. Po prostu trzeba próbować i pozostać przy tym, w którym najlepiej się czujesz. Techologia chyba Cię nie interesuje. Jedyne ograniczenie wyboru występuje w przypadku, gdy komputer nie dysponuje zasobami umożliwiającymi wygodne posługiwanie się zasobożernymi środowiskami. W tym przypadku - jeśli się da - można pokusić się albo o "odchudzenie" wybranego środowiska, albo w istocie wybór trzeba ograniczyć do tych "najlżejszych", a jeszcze lepiej jest w takim przypadku zdecydować się wyłącznie na jakieś WM (np. OpenBox), które ewentualnie obudować dodatkami, tak, by wygodnie w nim pracować. Inna sprawa, że taki "obudowany" OpenBox może mieć apetyt większy nie tylko od JWM (tu na 99% tak będzie) ale nawet od LXQt/DE/.

funn

Cytat: pavbaranov w Lipiec 24, 2019, 11:12:47 PM
Tak, może mieć "konsekwencje", albowiem Xfce korzysta z pewnych bibliotek, które zostały porzucone lata temu i o których wiadomo, że mają bugi.
Czyli Xfce4 przez przestarzałe biblioteki jest najmniej bezpiecznym środowiskiem graficznym na Linuksie? Podobno przepisanie XFCE4 na GTK4 może całkowicie zmienić jego wygląd.

robson75

Cytat: funn w Lipiec 25, 2019, 11:59:10 AM
Czyli Xfce4 przez przestarzałe biblioteki jest najmniej bezpiecznym środowiskiem graficznym na Linuksie?
Osobiście korzystam z DE Xfce4 niezmiennie od 2 lat, i nie zauważyłem aby to DE działało jakoś wadliwie.
Arch Linux Xfce+compiz - 64Bit Linux User #621110

ciubaka


Fibogacci

Według zapowiedzi, nowa wersja Xfce 4.14 (po długim czasie) ma się pojawić w sierpniu lub inaczej pisząc, późnym latem.

https://blog.xfce.org/

To już wkrótce.

pavbaranov

Cytat: funn w Lipiec 25, 2019, 11:59:10 AM
Czyli Xfce4 przez przestarzałe biblioteki jest najmniej bezpiecznym środowiskiem graficznym na Linuksie? Podobno przepisanie XFCE4 na GTK4 może całkowicie zmienić jego wygląd.
Samo w sobie? Nie. Nie chodzi bowiem o Gtk2, na których w dalszym ciągu, w części jest oparte. A o przepisaniu Xfce4 na Gtk4 nic nie wiem. Jak na razie są dopiero w trakcie przepisywania na Gtk3, a samo Gtk4 jest obecnie w wersji 3.96.0, czyli to jest jeszcze bodaj któraś beta. Jeszcze nieco czasu upłynie do skończenia tego projektu: https://wiki.gnome.org/Projects/GTK/Roadmap/GTK4.

Zobacz najnowsze wiadomości na forum