Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Nie działa przewijanie myszy

Zaczęty przez funn, Lipiec 11, 2019, 03:40:43 PM

Poprzedni wątek - Następny wątek

funn

Po wczorajszej aktualizacji kernela do wersji 5.2 padły wszystkie myszki usb, nie działa przewijanie myszy pod laptopem, czasem całkowicie się kursor zacina. Touchpad działa. Wyczytałem w przeglądarce, że to wina kernela, więc zainstalowałem kernel linux-hardened o numerku 5.1. Podobno kernel zen też działał na wersji 5.1, ale teraz jest 5.2 więc wybrałem wersje hardened. Edytowałem /etc/default/grub i zmieniłem wpis na GRUB_DEFAULT=1. Jak to zrobić, żeby Arch uruchamiał się z tym innym kernelem? W ogóle w tym nowym grubie 2 nie mam wyboru kerneli jak to było w starszych wersjach.

pavbaranov

Od końca:
Cytat: funn w Lipiec 11, 2019, 03:40:43 PM
W ogóle w tym nowym grubie 2 nie mam wyboru kerneli jak to było w starszych wersjach.
Przebudowałeś grubego po dostarczeniu drugiego kernela?
Cytat: funn w Lipiec 11, 2019, 03:40:43 PM
Jak to zrobić, żeby Arch uruchamiał się z tym innym kernelem?
Po pierwsze patrz wyżej. Wówczas pojawi się w grubym możliwość wyboru kerneli. Można dokonać edycji pliku /etc/default/grub i przypisać "cyferkę" odpowiadającą za ten kernel, który chcesz uruchamiać (uwaga liczone od 0), można też skorzystać z jakichś narzędzi GUI, które są dostępne np. dla Plazmy czy GNOME.
Cytat: funn w Lipiec 11, 2019, 03:40:43 PM
Po wczorajszej aktualizacji kernela do wersji 5.2 padły wszystkie myszki usb, nie działa przewijanie myszy pod laptopem, czasem całkowicie się kursor zacina.
Bez informacji o sprzęcie, bez logów systemowych co się dzieje po podłączeniu myszy po USB - nic nie będziemy wiedzieć. Pokaż dane o komputerze wykorzystując np. inxi, podaj dane o myszy USB poprzez lsusb po jej podłączeniu, oraz podaj wynik dmesg | tail bezpośrednio po podłączeniu myszy.

robson75

A czy po instalacji kernela przeładowaleś GRUB-a komendą update-grub?
Proponuje zainstalować z AUR update-grub.
A co do kolejności startu kerneli zajrzyj tutaj
https://forum.archlinux.org.pl/viewtopic.php?pid=5104#p5104
Arch Linux Xfce+compiz - 64Bit Linux User #621110

gosc

To ogólnie znany błąd tego kernela.
Proponuje powrócić do starego do czasu naprawy.

funn

#4
Tak mój błąd miałem literówkę przy poleceniu

sudo grub-mkconfig -o /boot/grub/grub.cfg


No więc przewijanie myszy już działa na kernel 5.1.16.a-1-hardened. Jednak występują zacięcia myszy, zatrzymuje się kursor na ekranie. Na linux-lts 4.19.58-1 kursor się nie zacina, ale nie działa przewijanie myszy.

[  200.894121] usb 2-1.4: new low-speed USB device number 43 using ehci-pci
[  200.996513] usb 2-1.4: New USB device found, idVendor=09da, idProduct=000a, bcdDevice= 0.17
[  200.996526] usb 2-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[  200.996532] usb 2-1.4: Product: USB Mouse
[  200.996538] usb 2-1.4: Manufacturer: A4Tech
[  201.004349] input: A4Tech USB Mouse as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4/2-1.4:1.0/0003:09DA:000A.0022/input/input48
[  201.004940] a4tech 0003:09DA:000A.0022: input,hidraw0: USB HID v1.10 Mouse [A4Tech USB Mouse] on usb-0000:00:1d.0-1.4/input0
[  202.682437] usb 2-1.4: USB disconnect, device number 43
[  205.137303] usb 2-1.4: new low-speed USB device number 44 using ehci-pci
[  205.624086] usb 2-1.4: device not accepting address 44, error -32


Ok już się nie zacina mysz na hardened, ale dla pewności muszę kupić nową mysz. Jaką polecacie najbardziej kompatybilną pod Linux?

robson75

Arch Linux Xfce+compiz - 64Bit Linux User #621110

pavbaranov

Czy pomiędzy:
[  201.004940] a [  202.682437] dokonałeś wypięcia myszki?
Na którym to kernelu? Interesujący jest 5.2

funn

Tak przełączałem myszki, teraz używam innej. To było na 5.2.

pavbaranov

Masz mysz kompatybilną :)

Wracając do kwestii przycinania się myszy, albo powróć na wcześniejszy kernel (obojętne jaki, najnowsze wersje dostępne to np. linux-ck, dodatkowo możesz sobie wybrać dla swojego CPU), albo... mogę podrzucić 5.2, na którym tego zjawiska nie powinno być, ale będziesz go musiał sam sobie skompilować. Dla pewności - abyś nie kompilował go niepotrzebnie - sprawdzę jutro, jak tylko znajdę jakąś myszkę w domu.

Przy okazji - zawsze jesteś w stanie zainstalować starszy kernel w Archu. Raz - wygodnie możesz to zrobić z downgrade, dwa - nawet prościej, jeśli nie wyczyściłeś cache pacmana, to starszą wersję kernela masz w /var/cache/pacman/pkg.

Zobacz najnowsze wiadomości na forum