Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Google Earth - nie mogę uruchomić...

Zaczęty przez wujo, Czerwiec 29, 2019, 10:26:55 PM

Poprzedni wątek - Następny wątek

wujo

Tak jak w temacie, nie mam chyba zainstalowanego program - proszę o pomoc, ale tak dla słabszych ( krok po kroku)

pavbaranov

Jak nie masz zainstalowane, to pobierz stąd: https://www.google.pl/intl/pl_ALL/earth/versions/#download-pro i zainstaluj (nie wiem, czy w Sparky jest jakiś "ułatwiacz", jeśłi nie, to przez dpkg). To jest wersja 64bitowa, jeśli nie masz takiego systemu/komputera, to jej nie zainstalujesz.
Najprościej jednak używać GE w przeglądarce: https://www.google.pl/intl/pl_ALL/earth/versions/#earth-for-web

Alternatywą jest zrobić sobie paczkę AppImage z wykorzystaniem tego skryptu: https://bintray.com/probono/AppImages/download_file?file_path=run_this_script_to_generate_the_AppImage.sh, ale tak skonstruowany AppImage i tak wykorzystuje oryginalną paczkę deb, co w Twoim przypadku niewielki ma sens.


wujo


Piotr_1988

#3
Na SparkyLinux wystarczy otworzyć aplikację APTus, wejść pod zakładkę "sieć", po czym dwukrotnie kliknąć na ikonkę "Google Earth", by uruchomić instalator Google Earth.

Jeśli to nie zadziała, jest też ułatwiacz do dpkg, czyli DEBiTool. Wystarczy pobrać aplikację ze strony, po czym kliknąć na pobrany plik .deb, by się uruchomił instalator.

Można też klasycznie otworzyć terminal w folderze z pilkiem .deb do zainstalowania i z roota wpisać dpkg -i plik_do_instalacji.deb

Cytat: wujo w Czerwiec 30, 2019, 09:38:31 AM
Mam 32 bitowy system.
Możesz zainstalować 64-bitowy?

EDIT: Z tego co widzę, jest wersja działająca na 32-bitowym Windows. Możesz spróbować zainstalować ją przez Wine.
Fedora Silverblue 36  |  EndeavourOS

pavbaranov

Cytat: wujo w Czerwiec 30, 2019, 09:38:31 AM
Mam 32 bitowy system.
Zatem jedyna możliwość, to używanie Google Earth w przeglądarce. Od dłuższego czasu nie ma wersji 32-bit tego oprogramowania, a z uwagi na to, że nie są również dostępne źródła, to nie jest możłiwe jej skompilowanie na system 32-bitowy. Jeśli chcesz 32-bitową wersję tej aplikacji, to musiałbyś przeszukać sieć i zobaczyć, czy ktoś nie zarchiwizował starej wersji oraz liczyć na to, że będzie ona jeszcze działać (co pewne nie jest).
Alternatywą Google Earth jest Marble, które winno być w repozytorium. Do Marble są też dodatkowe mapy m.in. od Google'a.

TataPingu

#5
Cytat: Piotr_1988 w Czerwiec 30, 2019, 09:50:40 AM
Cytat: wujo w Czerwiec 30, 2019, 09:38:31 AM
Mam 32 bitowy system.
Możesz zainstalować 64-bitowy?

Nie, tego się nie da...
- relacja odwrotna tzn. 32bity na 64-bitowym systemem jest możliwa, ale odwrotnie nie...

Zobacz tutaj:
https://www.linuxquestions.org/questions/linux-newbie-8/google-earth-installation-for-32-and-64-bit-ubuntu-and-linux-mint-systems-4175510473/
- widzę, że można ściągnąć 32-bitową paczkę .DEB

Ps. Czy to "zadziała", tego nie wiem, bo nie sprawdzałem...

Piotr_1988

Cytat: TataPingu w Czerwiec 30, 2019, 01:03:17 PM
Cytat: Piotr_1988 w Czerwiec 30, 2019, 09:50:40 AM
Cytat: wujo w Czerwiec 30, 2019, 09:38:31 AM
Mam 32 bitowy system.
Możesz zainstalować 64-bitowy?

Nie, tego się nie da...
- relacja odwrotna tzn. 32bity na 64-bitowym systemie jest możliwa, ale odwrotnie nie...
Ale być może może zainstalować 64-bitowy system..., skoro potrzebne są takie programy.
Fedora Silverblue 36  |  EndeavourOS

wujo

Wynika, że pozostaje korzystać z przeglądarki :) Dzięki za pomoc.

pavroo

APTus posiada możliwość zainstalowania ostatniej dostępnej wersji 32 bitowej Google Earth na systemie 32 bitowym.
Jeśli skrypt wykryje działające jądro 32bit, to automatycznie zainstaluje Earth 32 bit.
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

wujo

Cytat: pavroo w Czerwiec 30, 2019, 08:18:59 PM
APTus posiada możliwość zainstalowania ostatniej dostępnej wersji 32 bitowej Google Earth na systemie 32 bitowym.
Jeśli skrypt wykryje działające jądro 32bit, to automatycznie zainstaluje Earth 32 bit.
Sorry, ale nic mi to nie mówi, nie wiem jak mam zainstalować  :(

Piotr_1988

Cytat: wujo w Lipiec 03, 2019, 08:20:14 PM
Cytat: pavroo w Czerwiec 30, 2019, 08:18:59 PM
APTus posiada możliwość zainstalowania ostatniej dostępnej wersji 32 bitowej Google Earth na systemie 32 bitowym.
Jeśli skrypt wykryje działające jądro 32bit, to automatycznie zainstaluje Earth 32 bit.
Sorry, ale nic mi to nie mówi, nie wiem jak mam zainstalować  :(
Wejdź w System Tools -> APTus -> wpisz hasło -> Sieć -> Google Earth
Fedora Silverblue 36  |  EndeavourOS

wujo

Pojawia się komunikat, cyt. :
" Coś poszło źle ! Prawdopodobnie zatrzymałeś instalację lub połączenie z internetem jest uszkodzone lub ten pakiet nie jest dostępny dla wersji twojego systemu. Sprawdź to i spróbuj ponownie".
NIe zatrzymałem instalacji, internet działa, zatem pozostaje, że ten pakiet nie jest dostępny dla wersji mojego systemu  :(

pavroo

Pobierz pakiet ręcznie, przez przeglądarkę www:
https://dl.google.com/dl/earth/client/current/google-earth-pro-stable_current_i386.deb
Odśwież listę pakietów, np. APTus-> Akcesoria-> Aktualizacja listy pakietów
Następnie otwórz katalog z pobranym pakietem Google-Earth-xxx.deb i zainstaluj go wybierając DebiTool
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

wujo

Program się zainstalował, ale ... nie działa, i nie można z niego korzystać  :(

pavbaranov

Uruchom z konsoli - pokaż o co chodzi, ale istnieje bardzo duże prawdopodobieństwo, że ten program - nierozwijany wszak od dłuższego czasu - został skompilowany przy użyciu innych bibliotek niż ich wersje, które masz obecne w systemie. Niekiedy można się z tym pobawić, ale początkującemu nie zaproponuję tu żadnego rozwiązania. Niestety program nie ma udostępnionych źródeł, wersja jest porzucona przez producenta. Innymi słowy: korzystaj w przeglądarce bądź - jeśli możesz - zmień system na 64bitową wersję.

Zobacz najnowsze wiadomości na forum