Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

ubuntu 18.04 problem z uruchomieniem Freecol

Zaczęty przez agatix76, Kwiecień 21, 2019, 07:07:38 AM

Poprzedni wątek - Następny wątek

agatix76

Witam ponownie.
lubiłem wspomnianą grę na 16.04, a teraz po instalacji pojawia się przez chwilę ikona gry i na tym koniec.
może miałby ktoś pomysł co z tym zrobić, dlaczego tak się dzieje?
dzieki
pozdrawiam
agatix76

  Edit

ps. instalowałem przez "oprogramowanie" i przez synaptica, efekt ten sam

pavbaranov

Odpal to z konsoli, może coś wypluje, a wówczas przedstaw. Po samym zachowaniu (pojawia się ikona gry) nic nie można wymyślić.

agatix76

#2
nie mogę znaleźć polecenia jak odpalić grę z konsoli?

Edit

ale za to gdy robię apt autoremove pojawia się"Nie udało się otworzyć pliku blokady /var/lib/dpkg/lock-frontend - open (13: Brak dostępu)", co to oznacza?

Edit2

odpaliłem i pojawił się taki komunikat
"Disabling IPV6 network stack to work around bug #560056 on openjdk
If you experience problems with connecting to remote servers,
you can put it back by running Freecol this way:
  freecol --enable-ipv6
Unrecognized option: -Xincgc
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit"
?
dzięki za pomoc
agatix76

lami07

@agatix76. Nie pisz kilku postów, jeden pod drugim. Masz możliwość modyfikowania swoich postów, korzystaj z niej.
IRC - #linuxiarze.pl w sieci libera.chat
Matrix - #linuxiarze.pl w sieci matrix.org

pavbaranov

Jakim konkretnie poleceniem odpaliłeś freecol? Prawdopodobnie plik wywołujący tę grę - jeśli zainstalowałeś ją z jakiejś paczki deb (a tak powinieneś) - znajdziesz w /usr/bin (albo tam, gdzie w Ubuntu się on instaluje). Powinien to być skrypt bash. Jaką ma zawartość? W Archu to:
#!/bin/bash
FC_PATH=/usr/share/java/freecol
java -Xmx512M -jar $FC_PATH/FreeCol.jar "$@" --freecol-data $FC_PATH/data --no-intro

Przy takich ustawieniach - w Archu - gra prawidłowo startuje. Możesz ewentualnie spróbować też skopiować powyższy kod i spróbować grę z niego uruchomić.

Zobacz najnowsze wiadomości na forum