Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: Linux Mint 19.1 Cinnamon problem z GRUB i wyświetlaniem obrazu na monitorze z la  (Przeczytany 1887 razy)

Offline daiwd2000

  • Newbie
  • *
  • Wiadomości: 4
  • Reputacja: +0/-0
Cześć, chciałem zainstalować Linuxa Mint na laptopie w którym jest już zainstalowany Windows 10, postepowałem zgodnie ze wskazówkami z poradnika z internetu i wydaje mi się, że zrobiłem wszystko ok, jednakże na samym początku coś mnie zdziwiło, bo ogólnie korzystam z laptopa + monitor podłączony na HDMI jako rozszerzenie przy czym w Windows monitor z laptopa mialem ustawiony jako główny i sytuacja wyglada tak że Linux Mint Live z pendrive uruchomił się jedynie na tym monitorze zewnetrznym (monitor z laptopa był czarny) nie zwrociłem na to uwagi i instalowałem tak jak było w instrukcji, teraz jest problem, bo ten zainstalowany Linux włącza sie tylko na monitorze zewnetrznym, bios i GRUB pokazuje się na monitorze z laptopa i po wyborze minta mam przez chwile ladowanie sie linuxa na obu monitorach po czym gdy jest logowanie monitor z laptopa gaśnie. Instalowałem sterownik z nvidii ale to nic nie dało a w ustawienaiach ekranu w Linuxie monitor z laptopa jest wykrywany jednak jest w kolorze czerwonym.
Mam rowniez problem z GRUB bo nie ma tam opcji wyboru Windowsa, probowalem to naprawic tym recovery mode ale ten tryb uruchamia sie ale podejrzewam ze włacza sie na monitorze z laptopa ktory nie wysietla w tej chwili obrazu, jest szansa przywrocic wybor widnowsa przez jakies komendy w Linux Mint ktory uruchomi mi sie na zewnetrznym monitorze?
Bardzo prosze o pomoc, walcze z tym juz drugi dzien i nie mam sily ;/
Jesli jest to potrzebne moge pozniej doslac screeny z ustawien monitora i nagrania jak to wszystko wyglada z mojej perspektywy. Z gory dziekuje za pomoc i pozdrawiam :)

Offline D35CART35

  • Newbie
  • *
  • Wiadomości: 40
  • Reputacja: +1/-0
To może ustaw ten sam obraz na wszystkich monitorach.
To tak na początek.

Offline daiwd2000

  • Newbie
  • *
  • Wiadomości: 4
  • Reputacja: +0/-0
Dziękuje za zainteresowanie tematem, próbowałem już tak ustawiać, monitor z laptopa, wydaje ze bym sobie z tym poradził tak na spokojnie ale jak narazie pilnie potrzebuje windowsa który nie pokazuje się na liscie systemów, jest możliwość z poziomu linuxa minta w terminalu zresetować ten grub żeby Windows się pojawił na liscie?

Offline lami07

  • Global Moderator
  • Sr. Member
  • *****
  • Wiadomości: 484
  • Reputacja: +1/-0
Masz w systemie zainstalowany os-prober ? Jeśli nie to zainstaluj i zrób update-grub jako root.
IRC - #linuxiarze.pl w sieci freenode.net
Matrix - #linuxiarze.pl w sieci matrix.org

Offline studenciak_na_mincie

  • Newbie
  • *
  • Wiadomości: 34
  • Reputacja: +0/-0
Spróbuj zaktualizować GRUB-a oraz zaktualizować wpisy systemowe. Miałem podobnie podziałało, co do monitorów w tym momencie męczę się z tym samym problemem, i też nie mam pojęcia co to może być.
Pozdrawiam.

Offline daiwd2000

  • Newbie
  • *
  • Wiadomości: 4
  • Reputacja: +0/-0
Nie instalowałem os prober, ogólnie czysty system jedynie sterownik graficzny a co do update grub to robi się to w terminalu? Znalazłem jakieś komendy na forum do aktualizacji gruba lecz są one pod ubintu i u mnie koby się wykonały ale nic to nie zmieniło w liście systemów, a jest może jakiś program do pobrania na linuxa w którym będę mógł przywrócić windowsa so wyboru?

Offline robson75

  • Hero Member
  • *****
  • Wiadomości: 1437
  • Reputacja: +7/-0
  • Nie ufaj nikomu w sieci, nawet mi.
Nie instalowałem os prober, ogólnie czysty system jedynie sterownik graficzny a co do update grub to robi się to w terminalu? Znalazłem jakieś komendy na forum do aktualizacji gruba lecz są one pod ubintu i u mnie koby się wykonały ale nic to nie zmieniło w liście systemów, a jest może jakiś program do pobrania na linuxa w którym będę mógł przywrócić windowsa so wyboru?
Kolego, os-prober ma za zadanie wyszukać innych OS na dysku, a co do komend dla Ubuntu, to one jak najbardziej się sprawdzają również w LM, bo co jak co LM jest oparty na Ubuntu.
A paczkę os-prober zainstalujesz w ten sposób:
sudo apt install os-prober
Arch Linux Xfce+compiz - 64Bit Linux User #621110

Offline daiwd2000

  • Newbie
  • *
  • Wiadomości: 4
  • Reputacja: +0/-0
Dziękuje bardzo za pomoc, udało mi się przywrócić windowsa w menu wyboru systemu, jednak pojawił się kolejny problem, otóż Windows strasznie długo się uruchamia, w etapie ładowania potrafi 5 minut stać, nie mam dysku ssd jednak przed instalacja minta, Windows uruchamiał się w niecała minutę od włączenia, coś zostało uszkodzone w trakcie instalacji i czy jest możliwość naprawy tego? Czy zostaje tylko format?

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2509
  • Reputacja: +32/-8
Biorąc pod uwagę, że forum jest dla wszystkich użytkowników, a nie wyłącznie Twoim prywatnym supportem, to jeśli ktokolwiek będzie chciał skorzystać z porad, które tu się pojawią będzie miał misz-masz w głowie. Także te osoby, które Tobie chcą pomóc, jak również Ty sam. W jednym wątku bowiem zaczynasz już trzeci problem. Z czego jeden wydaje się być rozwiązany: brak automatycznego dołączenia innego systemu do wyświetlanych w GRUB wymaga instalacji os-prober i przebudowy GRUBa.
Pozostałe proponuję wyłączyć do dwu odrębnych wątków, przy czym problemu z długim startem Windows powinieneś chyba raczej poszukać na forach związanych z Windows, a nie forum linuksowym.

Offline TataPingu

  • Hero Member
  • *****
  • Wiadomości: 1457
  • Reputacja: +0/-0
Windows strasznie długo się uruchamia, w etapie ładowania potrafi 5 minut stać, nie mam dysku ssd jednak przed instalacja minta, Windows uruchamiał się w niecała minutę od włączenia, coś zostało uszkodzone w trakcie instalacji

Chłopie, NIC NIE ZOSTAŁO USZKODZONE, tylko ten muł Windows10 startuje "od początku", t.j. po całkowitym wyłączeniu kompa. To jest WINDOWSOWA RZECZYWISTOść...
- normalnie, tzn. w trakcie użytkowania tylko windy10, komp nie jest wyłączany, tylko "usypiany" i dlatego start jest stosunkowo szybki.

To tak, gwoli wyjaśnienia, ale wydaje mi się, jak już to Kolega @pavbaranov słusznie zauważył, co się tyczy windy, to nie tutaj...
- w necie znajdziesz niezliczoną ilość for dotyczących windziarskich problemów...