Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: ZTE MF821 nie działa pod Ubuntu 18.04  (Przeczytany 1444 razy)

Offline Tomo_HKS

  • Newbie
  • *
  • Wiadomości: 5
  • Reputacja: +0/-0
ZTE MF821 nie działa pod Ubuntu 18.04
« dnia: Styczeń 03, 2019, 07:42:39 pm »
Witam, po wpięciu wyżej wymienionego modemu, system pokazuje mi brak zasięgu, jak również nie mogę utworzyć nowego połączenia internetowego.Czy ktoś z Was orientuje się na czym polega problem?

Offline Piotr_1988

  • Full Member
  • ***
  • Wiadomości: 161
  • Reputacja: +1/-1
Odp: ZTE MF821 nie działa pod Ubuntu 18.04
« Odpowiedź #1 dnia: Styczeń 03, 2019, 08:28:06 pm »
Wcześniej już podłaczałeś ten modem pod swoim Ubuntu i działał? Czy też podłączasz swój modem pierwszy raz?

Ja pod Debianem by mi się modem łączył z netem musiałem skonfigurować ten plik: /etc/wvdial.conf
Fedora 32
CentOS 8

Offline Tomo_HKS

  • Newbie
  • *
  • Wiadomości: 5
  • Reputacja: +0/-0
Odp: ZTE MF821 nie działa pod Ubuntu 18.04
« Odpowiedź #2 dnia: Styczeń 03, 2019, 08:33:03 pm »
Powróciłem do Ubuntu po 3-4 latach, na wcześniejszej wersji internet działał.To jest świeża instalacja, próbuję podłączyć modem po raz pierwszy.

Offline Piotr_1988

  • Full Member
  • ***
  • Wiadomości: 161
  • Reputacja: +1/-1
Odp: ZTE MF821 nie działa pod Ubuntu 18.04
« Odpowiedź #3 dnia: Styczeń 03, 2019, 08:46:04 pm »
Może chodzić o konfigurację wvdial. Zawartość pliku konfiguracyjnego zależy od Twojej sieci i znajdziesz ją łatwo przez Google.

Ja mam internet w Play i np. mój plik wvdial.conf wygląda tak:

Cytuj
[Dialer play]
Modem = /dev/ttyUSB0
Baud = 57600
Init1 = ATH
Init2 = ATE1
Init3 = AT+CGDCONT=1,"IP","internet"
Dial Command = ATD
Phone = *99#
Stupid mode = yes
Username = "blank"
Password = "blank"
Auto DNS = yes

Wejdź na roota:
su
[wpisujesz hasło]
cd ~ [enter]
nano etc/wvdial.conf
[przepisujesz właściwą konfigurację, zapisujesz i powinnno działać]

Jeśli programy graficzne nie będą działać, z internetem połączysz się poleceniem: wvdial play (jeśli masz w Playu). Rozłączasz się poleceniem: killall pppd Te polecenie wydajesz z roota.
Fedora 32
CentOS 8

Offline Tomo_HKS

  • Newbie
  • *
  • Wiadomości: 5
  • Reputacja: +0/-0
Odp: ZTE MF821 nie działa pod Ubuntu 18.04
« Odpowiedź #4 dnia: Styczeń 03, 2019, 09:29:58 pm »
Próbowałem w google znależć ustawienia tego pliku dla sieci Plus, ale nie udało mi się.Mógłbyś wkleić je w w poście?

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2505
  • Reputacja: +32/-8
Odp: ZTE MF821 nie działa pod Ubuntu 18.04
« Odpowiedź #5 dnia: Styczeń 03, 2019, 09:32:47 pm »
Stop orkiestra.

@Tomo_HKS - Rozumiem, że uruchamiasz to na Ubuntu bez żadnych zmian. Co się dzieje po podpięciu modemu? Opisz i pokaż wyniki:
lsusb
dmesg | tail
systemctl status NetworkManager
systemctl status ModemManager
(jeśli w dwu ostatnich poleceniach Ubu stwierdzi, że nie ma takich usług, to wypróbuj z małymi literami zamiast wielkich; nie mam Ubu, mogą być jakieś różnice).

Przy okazji - jeśli szukałeś w Google :) to sporo jest informacji nt. uruchamiania tego modemu pod linuksem, w tym pod Ubuntu.

Offline Tomo_HKS

  • Newbie
  • *
  • Wiadomości: 5
  • Reputacja: +0/-0
Odp: ZTE MF821 nie działa pod Ubuntu 18.04
« Odpowiedź #6 dnia: Styczeń 03, 2019, 11:41:41 pm »
Pavbaranov dostałem taką informację zwrotną:
Cytuj
tomo@tomo-HP-Pavilion-dv6-Notebook-PC:~$ lsusb
Bus 002 Device 004: ID 148f:2000 Ralink Technology, Corp.
Bus 002 Device 003: ID e0ff:0002 
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 005: ID 19d2:0167 ZTE WCDMA Technologies MSM MF820 4G LTE
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 138a:0018 Validity Sensors, Inc. Fingerprint scanner
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
tomo@tomo-HP-Pavilion-dv6-Notebook-PC:~$ dmesg | tail
[ 7609.242360] usb-storage 3-2:1.5: USB Mass Storage device detected
[ 7609.242847] scsi host6: usb-storage 3-2:1.5
[ 7609.353184] qmi_wwan 3-2:1.4 wwp25s0u2i4: renamed from wwan0
[ 7610.268520] scsi 6:0:0:0: CD-ROM            L_T_E     USB SCSI CD-ROM  USB PQ: 0 ANSI: 0
[ 7610.269235] scsi 6:0:0:1: Direct-Access     ZTE      MMC Storage      2.31 PQ: 0 ANSI: 0
[ 7610.272013] sr 6:0:0:0: [sr1] scsi-1 drive
[ 7610.272439] sr 6:0:0:0: Attached scsi CD-ROM sr1
[ 7610.273085] sr 6:0:0:0: Attached scsi generic sg2 type 5
[ 7610.273915] sd 6:0:0:1: Attached scsi generic sg3 type 0
[ 7610.278506] sd 6:0:0:1: [sdb] Attached SCSI removable disk
tomo@tomo-HP-Pavilion-dv6-Notebook-PC:~$ systemctl status NetworkManager
● NetworkManager.service - Network Manager
   Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled; vendor p
   Active: active (running) since Thu 2019-01-03 21:31:54 CET; 2h 7min ago
     Docs: man:NetworkManager(8)
 Main PID: 741 (NetworkManager)
    Tasks: 4 (limit: 4599)
   CGroup: /system.slice/NetworkManager.service
           ├─741 /usr/sbin/NetworkManager --no-daemon
           └─959 /sbin/dhclient -d -q -sf /usr/lib/NetworkManager/nm-dhcp-helper

sty 03 23:27:45 tomo-HP-Pavilion-dv6-Notebook-PC NetworkManager[741]: <info>  [1
sty 03 23:37:25 tomo-HP-Pavilion-dv6-Notebook-PC NetworkManager[741]: <info>  [1
sty 03 23:37:26 tomo-HP-Pavilion-dv6-Notebook-PC NetworkManager[741]: <info>  [1
sty 03 23:38:13 tomo-HP-Pavilion-dv6-Notebook-PC NetworkManager[741]: <info>  [1
sty 03 23:38:13 tomo-HP-Pavilion-dv6-Notebook-PC NetworkManager[741]: <info>  [1
sty 03 23:38:28 tomo-HP-Pavilion-dv6-Notebook-PC NetworkManager[741]: <warn>  [1
sty 03 23:38:28 tomo-HP-Pavilion-dv6-Notebook-PC NetworkManager[741]: <info>  [1
sty 03 23:38:28 tomo-HP-Pavilion-dv6-Notebook-PC NetworkManager[741]: <info>  [1
sty 03 23:38:28 tomo-HP-Pavilion-dv6-Notebook-PC NetworkManager[741]: <info>  [1
sty 03 23:38:28 tomo-HP-Pavilion-dv6-Notebook-PC NetworkManager[741]: <info>  [1
log file: ystemctl status ModemManager

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2505
  • Reputacja: +32/-8
Odp: ZTE MF821 nie działa pod Ubuntu 18.04
« Odpowiedź #7 dnia: Styczeń 04, 2019, 12:22:11 am »
To jeszcze wynik ostatniego polecenia (ModemManager), o które prosiłem oraz info oraz dpkg -Si usb_modeswitch (może to być i usb-modeswitch; tak, czy inaczej chodzi o taką paczkę; możesz też przeglądnąć w jakimś GUI).
I jeszcze jedno, czy po odczekaniu chwili (powiedzmy z 30sek) od włożenia modemu nic się nie zmienia?

Twoje urządzenie jest wielofunkcyjne. Zawiera w sobie modem, ale również coś, co system widzi jako "napęd" (może to być jakaś pamięć masowa, może to być tylko dla niej jakiś hub; mniejsza o to). Do chwili, gdy nie przełączy się na "modem" nie połączysz się z siecią, bo komputer "nie wie" o tym, że w ogóle modem jest podpięty (bo widzi jako pamięć).
Spróbuj po włączeniu, odczekaniu kilku sekund wydać w konsoli polecenie:
eject(a jak nie to trzeba mu podać jakie urządzenie ma być wyłączone - opcje pod --help).
Być może w ten sposób uaktywni się modem.
Nie wiem, jak teraz wygląda GNOME w Ubu - jeśli gdzieś pojawia Ci się nowa ikonka urządzenia blokowego, to obadaj, być może pod jakimś PPM, albo w inny sposób można go "wysunąć" (powinno być takie słowo). Niestety z GNOME Ci nie pomogę, bo musiałbym to zainstalować (a i tak nie byłoby to to samo co w Ubu), a na samą myśl mam niestrawność :) Ktoś jednak na pewno tu GNOME używa i wie jak to wygląda w Ubu.

Offline robson75

  • Hero Member
  • *****
  • Wiadomości: 1436
  • Reputacja: +7/-0
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: ZTE MF821 nie działa pod Ubuntu 18.04
« Odpowiedź #8 dnia: Styczeń 04, 2019, 12:44:18 am »
Już było na tym forum na temat tego modemu, i kolega znalazł rozwiązanie, a konkretnie uruchamiał managera plików i w nim ten modem był widoczny jako dysk, to go odmontował i miał połączenie z siecią.
Arch Linux Xfce+compiz - 64Bit Linux User #621110