Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Instalacja środowiska Mate w Ubuntu z Gnome

Zaczęty przez BartoszXD, Listopad 21, 2018, 01:08:55 PM

Poprzedni wątek - Następny wątek

BartoszXD

Mam problem, ponieważ chciałem zainstalować środowisko Mate zamiast Gnome, ale nie chciałbym żeby dublowały się programy tzn. podwójny terminal, menedżer zadań i wiele innych. Może ktoś podpowie mi jak mądrze to zrobić  :)

TataPingu

@BartoszXD
- chcesz zupełnie "przejść" na MATE, czy tylko spowodować, by określone programy "pojawiały się" pod danym środowiskiem ?

BartoszXD

Chcę przejść zupełnie ale nie chcę mieć zdublowanych programów  :)

pavbaranov

Cytat: BartoszXD w Listopad 21, 2018, 03:53:37 PM
Chcę przejść zupełnie ale nie chcę mieć zdublowanych programów  :)
Zainstaluj MATE, odinstaluj GNOME oraz aplikacje, których nie chcesz/potrzebujesz. W czym masz problem?

TataPingu


[/quote]
Zainstaluj MATE, odinstaluj GNOME oraz aplikacje, których nie chcesz/potrzebujesz. W czym masz problem?
[/quote]

Z innymi dystrami byłoby to tak łatwe, jak pisze Kolega Pavbaranov. Z Ubuntu mam obawy.
Ale fakt, w pierwszym rzędzie powinieneś zainstalować sobie pełne MATE.

Najlepiej do tego celu użyć terminala i synaptica.
Wtypuj w terminalu:

sudo apt-get install mate

może być że zamiast "mate" powinieneś wtypować "mate-ubuntu", "mate-desktop", czy jakoś tak....
- od dłuższego czasu nie mam styczności z Ubuntu...

Co wtypować, zobaczysz najlepiej w synapticu. Przypuszczam, że nie ma go zainstalowanego w standardzie, więc w pierwszym rzędzie zainstaluj synaptic (w terminalu):

sudo apt-get install synaptic

a po instalacji:

sudo synaptic

Teraz możesz wyszukać wszystko z hasłem "mate-" no i oczywiście zainstalować.

Potem ew. dalej...

BartoszXD

Tylko jest taka kwestia - apt-get install mate-desktop-environment jeśli zainstaluję to no to będę miał samo środowisko Mate bez aplikacji od niego? A jak to apt-get install mate-desktop-environment-extras to razem z aplikacjami Mate?? :)

pavbaranov

Jest taka strona: https://packages.ubuntu.com - wpisujesz nazwę paczki i masz jakie ze sobą pociąga.

PomPom

Ogólnie najlepiej wywalić całkiem GNOME ze wszystkim... tylko zależności pewnie tak zadziałają, że będą resztki GNOME'a albo w ogóle system siądzie, bo pociągnie za dużo. Najlepsze wyjście i najprostsze to wgranie po prostu Ubuntu MATE.
Komputer - Card Reader | Gry - Xbox Series X | Użytkownik - zadowolony

robson75

Jak wywali całe Gnome wraz z zależnościami, to na bank będzie black screen
Arch Linux Xfce+compiz - 64Bit Linux User #621110

TataPingu

Cytat: Robert75 w Listopad 21, 2018, 06:29:40 PM
Jak wywali całe Gnome wraz z zależnościami, to na bank będzie black screen

I tego właśnie obawiam się przy Ubuntu...
- może być tak, że "wyrwie" mu pół systemu...

BartoszXD

To lepiej nie kombinować może tylko na czysto postawić ubuntu mate ;) ale dzięki za pomoc :)

BartoszXD

a tak jeszcze przy okazji żeby nie otwierać nowego tematu jak można uruchomić to takie stare gnome bez launchera?? :)

pavbaranov

W sposób opisany przeze mnie (czyli wpierw instalacja MATE, potem usunięcie GNOME3) - nie powinno być problemu. Spróbuj, skoro i tak się liczysz z wgraniem nowego Ubuntu od początku.
Dla instalacji/usunięcia możesz sobie zainstalować synaptic, bo będzie Ci łatwiej.

Ta sesja GNOME 3 nazywa się gnome-classic i powinna być dostępna z poziomu GDM.

BartoszXD

A tak jakoś jaśniej można jak uruchomić ten tryb gnome classic?? Kiedyś miałem dostępny na ekranie logowania ale teraz go nie ma jest tylko ubuntu i ubuntu wayland :)

pavbaranov

Wiem jedynie, że tak się to nazywa i od wersji 3.8 powinno być do uruchomienia z GDM. Nie mam też Ubuntu :)
W Ubu ta sesja to było też GNOME Flashback. Masz tu nieco więcej: https://www.debugpoint.com/2018/05/how-to-install-classic-gnome-flashback-in-ubuntu-18-04-lts/ Nie wiem, którą wersję Ubu masz, bo to się w różnych zmieniało. Widać - trzeba doinstalować paczkę.

Zobacz najnowsze wiadomości na forum