Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: Brak dźwięku - Mint 19  (Przeczytany 3340 razy)

Offline JarJar

  • Newbie
  • *
  • Wiadomości: 7
  • Reputacja: +0/-0
Brak dźwięku - Mint 19
« dnia: Listopad 11, 2018, 11:41:58 am »
Jestem totalnie zielony w użytkowaniu linuxa i chcę się go nauczyć dlatego postanowiłem przesiąść się z windowsa i zacząć od Minta. Problemem jak w temacie jest całkowity brak dźwięku w systemie. W alsamixer wygląda to tak:

https://imgur.com/a/hocDoAe

https://imgur.com/a/SIIPvIY

Do wyboru mam tylko te 2 "karty", przesuwanie suwaków przy włączonym sound test w terminalu nic nie zmienia.  Na dysku nie mam innych systemów tylko Linuxa Mint w takiej wersji:

https://imgur.com/a/jsl0ckf

Jeśli jest ktoś w stanie pomóc to chętnie przyjmę porady  :D
« Ostatnia zmiana: Listopad 11, 2018, 01:35:38 pm wysłana przez JarJar »

Online pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2694
  • Reputacja: +54/-38
Odp: Brak dźwięku - Mint 19
« Odpowiedź #1 dnia: Listopad 11, 2018, 01:09:59 pm »
Obawiam się, że tam gdzie powinny być jakieś "obrazki" nic nie widać - wgraj to poprawnie, chyba, że u mnie jest problem (ale wówczas na 2 przeglądarkach by istniał).

Offline PomPom

  • Hero Member
  • *****
  • Wiadomości: 1654
  • Reputacja: +2/-0
  • RAM RANCH REALLY ROCKS!
Odp: Brak dźwięku - Mint 19
« Odpowiedź #2 dnia: Listopad 11, 2018, 01:14:12 pm »
Na wszelki wypadek lepiej dawać linki do obrazków, bo bardzo często coś z nimi jest nie tak na forum.
Windows 10 | Arch Linux | Gentoo

Offline robson75

  • Hero Member
  • *****
  • Wiadomości: 1476
  • Reputacja: +9/-1
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: Brak dźwięku - Mint 19
« Odpowiedź #3 dnia: Listopad 11, 2018, 01:29:05 pm »
Po prostu trzeba dodać img (to ten kwadrat pod boldem), a nie wklejać jako link.
Arch Linux Xfce+compiz - 64Bit Linux User #621110

Offline JarJar

  • Newbie
  • *
  • Wiadomości: 7
  • Reputacja: +0/-0
Odp: Brak dźwięku - Mint 19
« Odpowiedź #4 dnia: Listopad 11, 2018, 01:36:33 pm »
Ups, przepraszam za niedopatrzenie, dodałem te bloki [img] ale widocznie coś nie wyszło tak jak trzeba. Post już poprawiony.
« Ostatnia zmiana: Listopad 11, 2018, 01:43:42 pm wysłana przez JarJar »

Offline PomPom

  • Hero Member
  • *****
  • Wiadomości: 1654
  • Reputacja: +2/-0
  • RAM RANCH REALLY ROCKS!
Odp: Brak dźwięku - Mint 19
« Odpowiedź #5 dnia: Listopad 11, 2018, 01:55:13 pm »
Po prostu trzeba dawać bezpośrednie linki, ale mniejsza z tym, skoro są normalne linki i już coś widać.
Kliknij na ikonkę dźwięku na panelu i wybierz preferencje dźwięku. Popróbuj w zakładce "Sprzęt" albo "Wyjście" czy coś tam da się zmienić i sprawdź, czy to daje dźwięk.
Windows 10 | Arch Linux | Gentoo

Offline JarJar

  • Newbie
  • *
  • Wiadomości: 7
  • Reputacja: +0/-0
Odp: Brak dźwięku - Mint 19
« Odpowiedź #6 dnia: Listopad 11, 2018, 02:20:19 pm »
Sytuacja wygląda tak:

https://imgur.com/JGy0jHx.png

Testu głośników nie słychać; wyjście mogę zmienić na wielokanałowe ale wtedy testu głośników nie ma, a w zakładce wyjście nie ma nic; na ustawieniu wyjście stereo zakładka wyjście wygląda tak:

https://imgur.com/6ZiuQRj.png

Przesuwanie suwaków nic nie zmienia, a złącza z analogowego nie da się zmienić.
« Ostatnia zmiana: Listopad 11, 2018, 02:24:01 pm wysłana przez JarJar »

Offline PomPom

  • Hero Member
  • *****
  • Wiadomości: 1654
  • Reputacja: +2/-0
  • RAM RANCH REALLY ROCKS!
Odp: Brak dźwięku - Mint 19
« Odpowiedź #7 dnia: Listopad 11, 2018, 02:29:37 pm »
https://github.com/heikomat/linux/tree/cx2072x/cx2072x_fixes_and_manual
Spróbuj tego.
Windows 10 | Arch Linux | Gentoo

Offline robson75

  • Hero Member
  • *****
  • Wiadomości: 1476
  • Reputacja: +9/-1
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: Brak dźwięku - Mint 19
« Odpowiedź #8 dnia: Listopad 11, 2018, 02:38:08 pm »
Ale u Ciebie jest coś za mało tych słupków z regulacją głośności przy poleceniu:
alsamixerU mnie wygląda to tak:


Ps:
A spróbuj wejść do Bios-u, i ustawić sound na enable.
« Ostatnia zmiana: Listopad 11, 2018, 02:42:21 pm wysłana przez Robert75 »
Arch Linux Xfce+compiz - 64Bit Linux User #621110

Offline JarJar

  • Newbie
  • *
  • Wiadomości: 7
  • Reputacja: +0/-0
Odp: Brak dźwięku - Mint 19
« Odpowiedź #9 dnia: Listopad 11, 2018, 03:21:34 pm »
Dobra to po kolei:

https://github.com/heikomat/linux/tree/cx2072x/cx2072x_fixes_and_manual
Spróbuj tego.

Zrobiłem całość i w tym ostatnim punkcie terminal wyrzuca, że nie znajduje pliku pulselog.txt więc nie wrzucę tu wyników z całej operacji ale ustawienia w daemon.conf na pewno zmienione. Niestety cała operacja nic nie zmieniła.

Ale u Ciebie jest coś za mało tych słupków z regulacją głośności przy poleceniu:
alsamixerU mnie wygląda to tak:


Ps:
A spróbuj wejść do Bios-u, i ustawić sound na enable.

U mnie też jest więcej suwaków i to wiele wiele więcej (przewijam je strzałkami) ale te suwaki przeważnie mają nazwy "codec....", i te opcje mam tylko na tej dziwnej "karcie", a nie na tej, którą system wykrywa jako Intel HDMI/DP LPE Audio. W biosie nie mam takich opcji, mam tylko możliwość zmiany języka i kolejności bootowania systemu.

EDIT: Sprawdziłem na słuchawkach, wszystko działa dokładnie tak samo jak na głośnikach czyli brak jakichkolwiek dźwięków.
« Ostatnia zmiana: Listopad 11, 2018, 03:26:18 pm wysłana przez JarJar »

Offline PomPom

  • Hero Member
  • *****
  • Wiadomości: 1654
  • Reputacja: +2/-0
  • RAM RANCH REALLY ROCKS!
Odp: Brak dźwięku - Mint 19
« Odpowiedź #10 dnia: Listopad 11, 2018, 03:42:28 pm »
A próbowałeś komendę z TL;DR? Bo to cały skrypt, który powinien na pewno ogarnąć to poprawnie, jeżeli po drodze coś poszło nie tak. Na forum Minta koleś pisał, że mu po tym zadziałało.
Windows 10 | Arch Linux | Gentoo

Online pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2694
  • Reputacja: +54/-38
Odp: Brak dźwięku - Mint 19
« Odpowiedź #11 dnia: Listopad 11, 2018, 03:58:47 pm »
A tak generalnie, to czego używasz? PulseAudio czy "czystej" ALSA?

Offline JarJar

  • Newbie
  • *
  • Wiadomości: 7
  • Reputacja: +0/-0
Odp: Brak dźwięku - Mint 19
« Odpowiedź #12 dnia: Listopad 11, 2018, 04:17:51 pm »
A próbowałeś komendę z TL;DR? Bo to cały skrypt, który powinien na pewno ogarnąć to poprawnie, jeżeli po drodze coś poszło nie tak. Na forum Minta koleś pisał, że mu po tym zadziałało.

Zrobiłem to teraz jeszcze raz komendą i wciąż nie działa. Jedyne co się zmieniło to, że w preferencjach dźwięku jak wybiorę wyjście wielokanałowe to mogę przeprowadzić test głośników i zmieniać suwaki w zakładce wejście.

A tak generalnie, to czego używasz? PulseAudio czy "czystej" ALSA?

A jak to sprawdzić i czym właściwie są PulseAudio i ALSA?  :P Niestety jestem totalnie początkujący, wcześniej całe życie na windowsach pracowałem.
« Ostatnia zmiana: Listopad 11, 2018, 04:19:48 pm wysłana przez JarJar »

Offline JarJar

  • Newbie
  • *
  • Wiadomości: 7
  • Reputacja: +0/-0
Odp: Brak dźwięku - Mint 19
« Odpowiedź #13 dnia: Listopad 11, 2018, 08:55:24 pm »
Doszedłem do jeszcze jednej rzeczy, która może być kluczowa:

https://imgur.com/emDWuKR.png

Czy to nie oznacza, że pulseaudio nie ma jakichś uprawnień?

Offline PomPom

  • Hero Member
  • *****
  • Wiadomości: 1654
  • Reputacja: +2/-0
  • RAM RANCH REALLY ROCKS!
Odp: Brak dźwięku - Mint 19
« Odpowiedź #14 dnia: Listopad 11, 2018, 09:12:15 pm »
sudo chown -R adrian:adrian /home/adrian
Windows 10 | Arch Linux | Gentoo