Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Problem po zainstalowaniu Linux na nowszym sprzęcie

Zaczęty przez sovtware, Lipiec 22, 2013, 12:56:45 AM

Poprzedni wątek - Następny wątek

sovtware

Witam

to mój sprzęt :



http://img838.imageshack.us/img838/1986/av4q.png" alt="av4q.png" class="bbcode_img" />



wspomnę że dysk mam 500 Gb

a bios zaktualizowany 2013 r.




mam problem i potrzebuję odpowiedzi w czym tkwi problem

chciałem zainstalować Sparky jak i również Linux Mint

instalacja idzie beż problemów ( jak i odpalenie systemów z live cd ) ale po jak uruchamiam laptopa po instalacji

niespodzianka

system mi nie odpala tak jakby nie było nagranego systemu o co chodzi ?

Napiszę że mam Ubuntu 12.04 ponieważ tylko ten system mi się odpala po zainstalowaniu

lecz chciałbym zmienić na te wyżej wymienione systemy ale nie mogę

jest możliwe aby np.: jądro systemu które jest w sparky 2.0 lub w Linux Mint LMDE

nie pracowało z takim sprzętem ?

Proszę o wskazówki z góry dziękuję

lub proszę o napisanie jaki mógłbym na takim sprzęcie mieć system ciągły

pavroo

LMDE i Spark 2.x posiadają jądra podobne numeracją do Ubuntu 12.04. Spróbuj Sparky 3.0 rc z jądrem 3.9.8. Poza tym daj więcej informacji o sprzęcie (hardinfo - summary).
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

sovtware

#2
Dobrze zobaczę czy Sparky 3.0 rc mi ruszy chodziarz szczerze wolałbym poczekać na wersję finalną a ona zapewne pojawi się w ciągu paru dni



tutaj podaję więcej informacji na temat Mojego sprzętu:



z9ie.png

pavroo

Problem prawdopodobnie wynika z nowego sprzętu, UEFI i Windows 8. W tym przypadku GRUB powinien być instalowany w GPT a Sparky i Mint LMDE (ostatnia wersja) instalują GRUB w MBR. Dlatego nie możesz uruchomić tych systemów po instalacji. Ubuntu rozwiązał ten problem, ja też szukam rozwiązania.
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

sovtware

#4
@pavroo nie wiem dokładnie ale chyba tak po faktycznie mam przystosowany laptop tylko pod Windows 8 inne nie mają sterowników pod sprzęt mimo że zainstaluję sprawdzałem no nic muszę wytrzymać te trudne chwile na Ubuntu i czekam na rozwiązanie tego problemu może już w Sparky 3.0 :) pozdrawiam

pavroo

W Sparky 3.0 na pewno jeszcze nie, może w którymś z następnych wydań.
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

sovtware

#6
No trudno więc będę patrzył i pilnował kolejnych wydań SParky jak i Minta LMDE może któraś inna dystrybucja pójdzie lecz boję się że nie ponieważ sabaylon prosi mnie o z formatowanie dysku SATA na jakieś inne niż są a tego nie umiem zrobić :]   dobrze najważniejsze że mam Ubuntu że nie muszę korzystać z Windowsa 8 w razie czego pavroo liczę na pomoc lub gdybyś znał jakąś dystrybucję która powinna mi się zainstalować i uruchamiać że mi napiszesz pozdrawiam

RaM

#7
jeżeli masz już zainstalowane ubuntu (razem z grub efi), to można próbować doinstalować na oddzielnej partycji inny system. oba systemy korzystać będą z tego samego swapa i gruba ubuntu. spróbuj doinstalować sparkiego. z debianem, to jest ten problem, że podmieni uuid swapa. w ubuntu trzeba będzie ręcznie naprawić to. ewentualnie instalować debiana bez swapa. po instalacji wracasz do ubuntu, updatujesz gruba i masz już system, z którego chciałeś korzystać. oczywiście instalując drugi system nie możesz nadpisać gruba ubuntu (w niektórych dystrybucjach jest opcja instalowania lub nieinstalowania gruba. jeżeli nie ma takiej możliwości instalujesz go gdziekolwiek).

Powodzenia.

sovtware

#8
@RaM dzikuje tak wanie mysle zrobic ale jak to mi nie pjdzie co teraz mysle

@pavroo pobieram Sparky 3.0 powinien mi ruszyc dlaczego tak mysle ?

poniewaz salix.os 14 instaluje GRUB w MBR i mi sie uruchamia wiec mysle ze jednak moze chodzic o kernel systemu napisze czy mi ruszylo

sovtware

#9
Zainstalowałem Sparky Ultra 3.0 lecz jednak to samo nie kasowałem systemu

włożyłem płytkę instalacyjną z Ubuntu 12.04 i zainstalowałem system obok Sparky z myślą że jak tu piszecie i nie raz na ircu byłem informowany o tym że Ubuntu odblokowuje Gruba i może uruchomi się Sparky ale niestety nic z tego trudno się pisze nic nie zrobię tylko muszę czekać na kolejne wersje Sparka gdzie będzie naprawiony ten problem i wtedy zainstalować na spokojnie i beż problemów więc w tej chwili wracam na Ubuntu lecz jestem zmuszony to tego przez mój sprzęt

dziękuje za pomoc i do usłyszenia

pavroo

Istnieje rozwiązanie tego problem (tymczasowe).

Po instalacji Sparka na dysku, uruchom z płyty Super Grub2 Disk:

http://www.supergrubdisk.org/super-grub2-disk/

Dzięki temu będziesz mógł zabootować Sparka z dysku.

W Sparku zainstaluj pakiet "grub-efi-amd64" oraz "efibootmgr", który usunie "grub-pc".

Następnie w konsoli:

Code:

grub-install /dev/sda
cp /boot/efi/boot/grub/grub.efi /boot/efi/shellx64.efi
modprobe efivars
efibootmgr -c -l '\efi\grub\grubx64.efi' -L GRUB


Reebot i... daj znać czy pomogło.
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

sovtware

#11
@pavroo system z Grub2 uruchamia sie normalnie nie ma problemow lecz po zainstalowaniu tych pakietow co wyzej wymieniles po uruchomieniu laptopa ladowanie i error nawet z Grub2 mi sie nie uruchamia

zrobilbym zdjecie i wstawil bym screena ale w tej chwili nie mam tel. z aparatem

sovtware

#12
@pavroo

mam już coś innego niż Ubuntu PcLinuxOs wydaje mi się że jest lepszy niż Ubunciak mimo że Lxde chodzi mi wolniej niż Unity instaluje Mate i na nim zostanę

mam prośbę jakbyś zrobił ten problem w Sparky proszę Cię byś mi dał znać będę czekał z niecierpliwością

by móc powrócić na Sparky w moim sprzęcie pozdrawiam i życzę miłego weekendu

Zobacz najnowsze wiadomości na forum