Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Problem po aktualizacji

Zaczęty przez łysy, Październik 11, 2018, 03:49:12 PM

Poprzedni wątek - Następny wątek

łysy

Witam po aktualizacji systemu laptop nie widzi mi wbudowanego modułu wifi,  Firefox nie chce się otworzyć i polecenie  " dodawanie/usuwanie oprogramowania " też się nie otwiera.
Mój system to Manjaro  4.14.54-1.
Co może być przyczyną?

robson75

Nie wiem jak Ty aktualizowałeś system, skoro u Ciebie jest dopiero jądro 4.14.54-1, a u mnie 4.14.74-1.
[robson@pc ~]$ uname -a
Linux pc 4.14.74-1-MANJARO #1 SMP PREEMPT Fri Oct 5 14:16:52 UTC 2018 x86_64 GNU/Linux
Arch Linux Xfce+compiz - 64Bit Linux User #621110

łysy

Koło zegarka pojawiła się ikona o dostępnej aktualizacji i później otwórz w terminalu ( jak dobrze pamiętam) i się zaktualizował

robson75

Nigdy nie aktualizuj systemu z poziomu pamac-a, tylko przez terminal:
sudo pacman -Syyuu
Arch Linux Xfce+compiz - 64Bit Linux User #621110

łysy

Koło zegarka jest nowa ikona i po kliknięciu na niego otwiera się wiadomość "błąd wczytywania pliku QML:qrc:/plasma/plasmoids/org.kde.plasma.networkmanagement " .............   A na samym końcu  " Nie ma takiego pliku ani katalogu "

robson75

#5
A to Ty masz Plasmę, sorry ale nie pomogę ponieważ nie znam tego środowiska.
Ale jedno mnie dziwi, dlaczego masz takie stare jądro?
Jedyne co Ci mogę doradzić to zmiana mirrora, bo wygląda na to że jest nieaktualny.
A więc wklepujesz do terminala:
sudo pacman-mirrors -f3
Następnie:
sudo pacman -Syy
I dopiero wtedy:
sudo pacman -Syyuu
No i oczywiście po zakończeniu aktualizacji, reboot.

I przeprowadź ta aktualizację po ludzku, przez terminal, i nie klikaj na żadne ikony.
Arch Linux Xfce+compiz - 64Bit Linux User #621110

pavbaranov

@Robert75 - Dlaczego proponujesz deaktualizację oprogramowania?
@łysy - Po aktualizacji mirrorów i ponownej aktualizacji oprogramowania (tak, pacman, a nie pamac/octopi), jeśli nadal będą występować błędy, to musisz cokolwiek więcej pokazać. Opis nie wystarcza. Nikt nie jest dr. House.

łysy

Wiem że z samych opisów ciężko,  ale w laptopie nie mam neta i ciężko jest wkleić jakiś zrzut ekranu itp. dla tego daje opisy pisząc na telefonie.

pavbaranov

Tak, tylko w takim przypadku, po prostu nie ma jak Ci pomóc. Co to bowiem znaczy?
Cytat: łysy w Październik 11, 2018, 03:49:12 PM
Witam po aktualizacji systemu laptop nie widzi mi wbudowanego modułu wifi,(...)
Wynik lspci pokazuje, że karty wifi nie ma? Jaka to karta? Itd. itp. Bez tego po prostu się nie da pomóc.
Co oznacza "po aktualizacji" systemu? Jak to pokazał @Robert75 albo ta aktualizacja, której dokonałeś była bardzo dawno temu (wersja 4.14.54 kernela pochodzi z początku drugiej dekady lipca 2018), albo nie została wykonana całkowicie (pacman/Arch i pochodne nie wspierają częściowej aktualizacji). Co zatem i kiedy zostało zaktualizowane?
Podłącz lapka do sieci przez kabel lub udostępnij mu połączenie komórkowe.

robson75

Cytat: pavbaranov w Październik 11, 2018, 07:19:01 PM
@Robert75 - Dlaczego proponujesz deaktualizację oprogramowania?
A w jakim wpisie ja proponowałem deaktualizacje oprogramowania?
Arch Linux Xfce+compiz - 64Bit Linux User #621110

pavbaranov

@Robert75 - W tym wątku w każdym, w którym proponujesz aktualizację :)

robson75

Arch Linux Xfce+compiz - 64Bit Linux User #621110

pavbaranov

@łysy - Na 99% dotknął Cię problem tzw. częściowej aktualizacji. Coś się nie zaktualizowało, albo nie do końca, albo zabrakło miejsca itp.
Jeśli nie przeczyściłeś jeszcze cache pacmana możesz spróbować:
1. sprawdzić to, co ostatnio zaktualizowałeś (masz w /var/log/pacman.log,
2. sprawdzić, czy masz dostępne stare wersje tych paczek w /var/cache/pacman/pkg,
3. jeśli tak, to mozolnie cofnąć wersje tych zaktualizowanych paczek do poprzednich wersji (np. z użyciem downgrade, jeśli masz zainstalowane).
Jeśli operacja się powiedzie, to przywrócona zostanie działająca wersja Manjaro i będziesz się mógł połączyć z internetem. Potem  zaktualizuj mirrory, o czym pisze @Robert75: https://linuxiarze.pl/forum/index.php/topic,3078.msg15957.html#msg15957. Sprawdź ilość dostępnego miejsca na dysku i - jeśli masz - spróbuj zaktualizować system wydając: pacman -Syu
Oczywiście prościej byłoby po prostu postarać się podłączyć jakoś lapka do sieci i zaktualizować - może się udałoby w ten sposób naprawić.

łysy

Po podpieciu neta kablem mirrory zaktualizowane,  a przy komendzie "pacman -Syyu " wyskakuje error .
Firefox dalej się nie otwiera

pavbaranov


Zobacz najnowsze wiadomości na forum