Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

[solved] Zawieszający się x serwer

Zaczęty przez mieczus, Wrzesień 04, 2018, 09:37:20 PM

Poprzedni wątek - Następny wątek

mieczus

Cześć,
Po upgradzie Lubuntu z 16.04 do 18.04 (wersja 32 bitowa) zaczęły mi się problemy z X serwerem (na wcześniejszej wersji tego nie było). Problemy polegają na tym, że X serwer się zawiesza: kursor się porusza, ale nie reaguje na kliknięcia oraz na klawiaturę. Radzę sobie poprzez restart X serwera z wykorzystaniem MagicKey, ale czasem to też nie pomaga i muszę restartować na cały komputer (działa komenda REISUB). Próbowałem szukać czegoś w logach, ale chyba nie szukam we właściwym miejscu, bo nic nie znalazłem :/
Proszę o pomoc lub wskazanie kierunku poszukiwań rozwiązania, bo problem jest upierdliwy (jest to mój główny i jedyny system).

Z góry dziękuję za pomoc.
Pozdrawiam,
Paweł

PomPom

Kiedy aktualizowałeś? Bo jeżeli zanim pojawiło się 18.04.1, to możliwe, że po prostu aktualizacja źle poszła. Są wgrane odpowiednie sterowniki do karty graficznej?
Komputer - Card Reader | Gry - Xbox Series X | Użytkownik - zadowolony

TataPingu

@mieczus
spróbuj tak (w terminalu):

sudo apt-get update

sudo apt-get dist-upgrade

sudo apt-get autoremove

i na końcu

sudo reboot

mieczus

#3
Cytat: Dziadek Starowinek w Wrzesień 04, 2018, 10:03:17 PM
Kiedy aktualizowałeś? Bo jeżeli zanim pojawiło się 18.04.1, to możliwe, że po prostu aktualizacja źle poszła. Są wgrane odpowiednie sterowniki do karty graficznej?

Ze 3 - 4 tygodnie temu - mam wersję 18.04.01
Do tej pory używałem sterowników X.org - spróbuję popracować na sterownikach Nvidii, może coś pomoże

Cytat: TataPingu w Wrzesień 05, 2018, 10:19:40 AM
@mieczus
spróbuj tak (w terminalu):
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get autoremove
i na końcu
sudo reboot

Wybacz, że nie napisałem, ale to było jedną z pierwszych czynności, które zrobiłem - mam wszystko aktualne.

Spróbuję zmienić sterownik karty graficznej - zobaczymy czy pomoże...

Na razie dziękuję za pomoc.

EDIT:
Faktycznie był to problem sterownika - próbowałem go wybrać w ustawieniach i mimo, że był widoczny nie chciał się odpalić. Pomogło jego odinstalowanie i ponowne zainstalowanie - teraz moje X'y działają jak potrzeba. Dziękuję za pomoc.

Zobacz najnowsze wiadomości na forum