Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Partycja "/" maksymalnie się zapełnia na świeżo zainstalowanym systemie!

Zaczęty przez AdiG, Styczeń 30, 2018, 09:41:06 PM

Poprzedni wątek - Następny wątek

AdiG

Witam serdecznie!

Mam problem z Mintem. Mianowicie ów problem zaczął się już jakieś 2 tygodnie temu, w pewnym momencie mój dysk zapełnił się maksymalnie, system zaczął wyrzucać komunikat, o małej ilości na dysku, Opera zaczęła odmawiać posłuszeństwa - komunikat, że nie mam wystarczających uprawnień do czegoś tam.
Co najdziwniejsze problem wystąpił na dwóch kompach: PC (Cinamon) i Netbooku (KDE). Postanowiłem przeinstalować system. Na PC zainstalowałem Ubuntu 16.04 LTS - partycja / ok 40 GB, partycja Home została po Mincie, na świeżo zainstalowanym systemie, po aktualizacji i doinstalowaniu kilku programów, problem znowu się pojawił, czyli: brak miejsca na dysku (ok 0,5 GB wolnego), zamykająca się Opera i komunikat o jakiś uprawnieniach.
Postanowiłem sformatować partycje linuksowe na obu komputerach i zainstalować wszystko na świeżo.
Ściągnąłem świeże .iso, zainstalowałem na PC Minta 18.3 z Cinamonem: moja partycja systemowa / to teraz ok. 45 GB, zaktualizowałem Minta; w zasobach oprogramowania zaznaczyłem: sylvia, xenial i romeo.
Od wczoraj Mint znów wywala komunikat o braku miejsca na partycji /
Próbowałem zrobić testy dysku SMARTem, ale się nie da.
Po kliknięciu PPM na dysk / w menedżerze plików, brak "Właściwości" dysku w celu sprawdzenia pojemności, ale po wejściu w / i zaznaczeniu wszystkich katalogów, wybraniu "właściwości", trochę to dla mnie dziwne i zdumiewające ???

Zawartość:
429.186 elementów (i 1.051 ukryte), łącznie 140,8 TB
(część zawartości jest nieczytelna)





Spotkał się już ktoś z Was z podobnym problemem/zjawiskiem?
Pozdrawiam!

PomPom

https://askubuntu.com/questions/911865/no-more-disk-space-how-can-i-find-what-is-taking-up-the-space

Może spróbuj tą metodą, co jest w najlepszej odpowiedzi. Pierwsze polecenie pokaże ile katalogi zajmują, a drugim podejrzysz jeszcze, który plik w dziwnie dużym katalogu jest spory. Zgaduję, że będzie to coś z logami miało wspólnego, ale lepiej sprawdzić.
Komputer - Card Reader | Gry - Xbox Series X | Użytkownik - zadowolony

AdiG

Dzięki za szybką odpowiedź.
Niestety mój angielski jest kiepski, no ale okey, mogłem się uczyć, a nie na wagary chodzić...  ;D

Po wpisaniu 1 komendy:
du -cha --max-depth=1 / | grep -E "M|G"

Wynik jest taki:
sudo du -cha --max-depth=1 / | grep -E "M|G"
19M /sbin
745M /lib
du: nie ma dostępu do '/run/user/1000/gvfs': Brak dostępu
37M /run
126M /boot
16M /bin
3,9M /lib32
422M /home
5,1G /usr
du: nie ma dostępu do '/proc/4456/task/4491/fd/121': Nie ma takiego pliku ani katalogu
du: nie ma dostępu do '/proc/7436/task/7436/fd/4': Nie ma takiego pliku ani katalogu
du: nie ma dostępu do '/proc/7436/task/7436/fdinfo/4': Nie ma takiego pliku ani katalogu
du: nie ma dostępu do '/proc/7436/fd/3': Nie ma takiego pliku ani katalogu
du: nie ma dostępu do '/proc/7436/fdinfo/3': Nie ma takiego pliku ani katalogu
32G /var
25M /etc
1,4M /dev
24G /media
61G /
61G razem


Po wpisaniu 2 komendy:
du -cha --max-depth=1 /var | grep -E "M|G"


sudo du -cha --max-depth=1 /var | grep -E "M|G"
12M /var/backups
340M /var/lib
1,8M /var/tmp
31G /var/log
6,3M /var/crash
174M /var/cache
32G /var
32G razem


W sumie wiemy już w których katalogach są te całe zajęte GIGABAJTY: w /var/log


Tylko co teraz mógłbym z tym zrobić? Jaka jest przyczyna takiego stanu rzeczy i jak ją wyeliminować...na doobre, żeby sytuacja się nie powtórzyła?

robson75

Nie wiem jak w mincie, bo ja używam Manjaro, no i w moim systemie uruchamiam managera plików jako root następnie wchodzę do /var/log/journal, i usuwam całą zawartość katalogu journal.
Arch Linux Xfce+compiz - 64Bit Linux User #621110

PomPom

https://sites.google.com/site/easylinuxtipsproject/bugs#TOC-The-size-of-the-log-files-in-var-log-gets-out-of-hand

Ogólnie wklepujesz podane tam komendy (punkt 17.). W jednym momencie zmieniasz treść pliku na podaną tam. Początkowe komendy mają na celu wskazanie, co może być winne tym grubym logom. Późniejsze ograniczają rozmiar logów, co powinno wyeliminować problem.
Komputer - Card Reader | Gry - Xbox Series X | Użytkownik - zadowolony

AdiG

Cytat: Robert75 w Styczeń 30, 2018, 11:39:12 PM
Nie wiem jak w mincie, bo ja używam Manjaro, no i w moim systemie uruchamiam managera plików jako root następnie wchodzę do /var/log/journal, i usuwam całą zawartość katalogu journal.

Robercie w Mincie nie mam takiego katalogu.

Cytat: Dziadek Starowinek w Styczeń 30, 2018, 11:56:29 PM
https://sites.google.com/site/easylinuxtipsproject/bugs#TOC-The-size-of-the-log-files-in-var-log-gets-out-of-hand

Ogólnie wklepujesz podane tam komendy (punkt 17.). W jednym momencie zmieniasz treść pliku na podaną tam. Początkowe komendy mają na celu wskazanie, co może być winne tym grubym logom. Późniejsze ograniczają rozmiar logów, co powinno wyeliminować problem.

Zanim zastosuje się do Twoich wskazówek Dziadku Starowinku...
Znalazłem 4 pliki .log w /var/log, które ważą w sumie 32 GB:
1. kern.log - 17.9 GB
2. kern.log.1 - 2.8 GB
3. syslog - 3.1 GB
4. syslog.1 - 8.2 GB

Czy ja je mogę po prostu wywalić?


PomPom

Tak, chociaż one się pewnie zrobią ponownie, bo coś zapełnia te logi, tj. coś jest nie tak z systemem. Metoda z linku powinna zapobiec dużym logom, ale coś nadal będzie nie tak. Lepiej jednak przejrzeć mały log, niż taki spuchnięty.
Jaki masz kernel? Może warto zmienić go na 4.13 (taki chyba jest teraz w Ubuntu 16.04). Aha, repozytorium romeo odznacz, bo nie zawiera ono stabilnego oprogramowania.
Komputer - Card Reader | Gry - Xbox Series X | Użytkownik - zadowolony

robson75

Arch Linux Xfce+compiz - 64Bit Linux User #621110

AdiG

Witam szanownych kolegów!

Wczoraj się jeszcze gorzej porobiło, padł system, po restarcie w ogóle odmówił współpracy, więc najprościej było zrobić reinstal.
Heh, ale obawiam się, że problem lada moment znów wystąpi, bo katalog /log ma już 23,5 GB, z czego kern.log i syslog mają po 11,5 GB objętości, czyli już spuchły na wstępie, tzn...
1. Zainstalowałem Minta.
2. Lekka konfiguracja wyglądu pulpitu.
Po tym /log był jeszcze szczupły jak modelki z Top Model  ;D
3. Następnie włączyłem sterowniki nvidia-384 i intel microcode w "Zarzązaniu sterownikami".
Wydaje mi się, że po tym właśnie logi zaczęły puchnąć.
4. Po restarcie zacząłem aktualizować Minta.
Apropos jądra, Mint 18.3 ma jądro 4.10. Jądro 4.13 specjalnie pominąłem, bo myślałem, że też będzie współodpowiedzialny za pojemność /log, w sumie pewnie jest, bo wczoraj na systemie ów jądro było, a w /log miałem 4 ciężkie pliki, których dziś nie ma (kern.log.1 i syslog.1).
Odnośnie repo Romeo to przed updatem włączyłem go niestety, po przeczytaniu twojego posta, wyłączyłem go...



PomPom

Te stery Nvidii są od razu dostępne? Czy dodałeś jakieś PPA? Wydaje mi się coś wersja zbyt nowa
Komputer - Card Reader | Gry - Xbox Series X | Użytkownik - zadowolony

AdiG

Cytat: Dziadek Starowinek w Styczeń 31, 2018, 08:44:25 PM
Te stery Nvidii są od razu dostępne? Czy dodałeś jakieś PPA? Wydaje mi się coś wersja zbyt nowa

Tak, są dostępne od razu w "Zarządzaniu sterownikami".


Zainstalowałem Stacer, wyczyściłem nim system. Partycja / i /var/log ładnie się opróżniły, ale po jakiś 2 godz. syslog i kern.log mają po 2 GB.
Ponad to w Stacer pokazuje mi duże obciążenie procesora, dla porównania w Monitorze systemu praca procesora jest kilkukrotnie mniejsza.


Może te sterowniki się jakoś gryzą, po włączeniu jednych, nie powinno się usunąć tych drugich?

PomPom

Po włączeniu jednych te drugie powinny nie działać.

https://sites.google.com/site/easylinuxtipsproject/bugs#TOC-The-size-of-the-log-files-in-var-log-gets-out-of-hand
Zrób komendy z tego linka, po "As emergency measure". Teraz można trochę te logi uspokoić, a później ew. patrzeć na ich powodem albo przeczekać (jak kto woli).
Komputer - Card Reader | Gry - Xbox Series X | Użytkownik - zadowolony

TataPingu

Jeśli logi zapychają Ci system, to je po prostu "wyłącz"

- z poziomu graficznego środowiska (już po zalogowaniu, ale w terminalu)

sudo service rsyslog stop

Jeśli chcesz wyłączyć logowanie już podczas każdego startu systemu to:

sudo systemctl disable rsyslog

Ponowne przywrócenie logowania podczas bootowania:

sudo systemctl enable rsyslog

Zobacz najnowsze wiadomości na forum