Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Czego mi brakuje w SparkyLinux

Zaczęty przez robson75, Wrzesień 04, 2017, 01:44:33 PM

Poprzedni wątek - Następny wątek

robson75

Zainstalowałem na VirtualBox-e SparkyLinux XFCE Rolling i jestem pod wielkim wrażeniem tegoż systemu, a to chyba że w repo posiada najnowsze pakiety programów.
Ale są dwie rzeczy których mi brak w Sparky.
Po pierwsze, brak mi ustawień Qt5 to jest narzędzie do konfiguracji programów Qt5, np. mi się podoba styl gtk2 który to odpowiada za ciemny motyw jak poniżej (chciałbym dodać że to narzędzie Qt5 jest dostępne na Manjaro XFCE)





Druga rzecz, to manager plików Thunar, ponieważ jest bardzo ubogi w różne funkcje postanowiłem zainstalować Caje która to jest bardziej rozbudowana i posiada wiele opcji. Ale jest problem z wyświetlaniem miniatur mimo że w ustawieniach zaznaczyłem aby były wyświetlane miniatury plików o wadze 1 GB to nadal nie widać zdjęcia wykonawcy tylko ikona systemowa.
W Manjaro XFCE te miniatury są wyświetlane:




Wiem że to są drobnostki ale dla mnie mają ogromne znaczenie.
Arch Linux Xfce+compiz - 64Bit Linux User #621110

pavroo

Możesz sprawdzić w Manjaro jak nazywa się pakiet dostarczający konfigurację ustawień qt5?
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

robson75

Nie wiem czy o to chodzi, ale ten pakiet się nazywa QT5CT.
Arch Linux Xfce+compiz - 64Bit Linux User #621110

pavroo

Qt5ct dodany do repo stable i testing.
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

gom1

@pavroo, podpowiesz co mogło być przyczyną?

Na jednym z kompów mam Sparky 5 (32-bity). Było na nim jądro Sparky w wersji 4.12.4. System nie chciał zaktualizować się do 4.13 twierdząc, że 4.12.4 jest najnowszą wersją. Dopiero ręczne pobranie *.deb i zainstalowanie ich przez dpkg pomogło. O co mu chodziło? Na innych komputerach aktualizacja poszła automatycznie. Tylko ten jeden nie chciał.
Wszędzie dobrze, ale w /home najlepiej

robson75

Cytat: pavroo w Wrzesień 05, 2017, 12:57:57 PM
Qt5ct dodany do repo stable i testing.
@pavroo A czy nie mógłbyś dodać tych pakietów do aktualizacji systemu, ponieważ z synaptica zainstalowałem większość pakietów z serii qt5, i nadal brak jest narzędzia konfiguracji qt5.
Arch Linux Xfce+compiz - 64Bit Linux User #621110

pavroo

W tej chwili nie jest to priorytetem, mam coś innego na warsztacie.

Jednak, w terminalu:
sudo apt update
sudo apt-cache policy qt5ct
qt5ct:
  Zainstalowana: (brak)
  Kandydująca:   0.33-1+b1
  Tabela wersji:
     0.33-1+b1 1001
       1001 https://sparkylinux.org/repo testing/main amd64 Packages

jest w repo, więc:
sudo apt install qt5ct
Po instalacji restart systemu.
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

pavroo

@gom1
CytatNa jednym z kompów mam Sparky 5 (32-bity). Było na nim jądro Sparky w wersji 4.12.4. System nie chciał zaktualizować się do 4.13 twierdząc, że 4.12.4 jest najnowszą wersją.
Sprawdź czy masz zainstalowany meta pakiet:
linux-image-sparky-686
lub dla wielordzeniowych maszyn:
linux-image-sparky-686-pae
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

robson75

Ok pavroo zainstalowane. Wielkie dzięki.
Arch Linux Xfce+compiz - 64Bit Linux User #621110

gom1

Cytat: pavroo w Wrzesień 05, 2017, 08:28:04 PM
Sprawdź czy masz zainstalowany meta pakiet:
linux-image-sparky-686
Tak, jest zainstalowany.
Cytatlub dla wielordzeniowych maszyn:
linux-image-sparky-686-pae
PAE jest dla wielordzeniowców? Wydawało mi się, że PAE dodaje możliwość obsługi większej pamięci RAM (>3GB) dla 32-bitowców.
Wszędzie dobrze, ale w /home najlepiej

pavroo

Jądro PAE daje obsługę procesorów wielordzeniowych oraz pamięci RAM > 4 GB.

Pokaż wyniki:
cat /etc/apt/sources.list.d/sparky-unstable.list
sudo apt update
apt-cache policy linux-image-sparky*
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

gom1


gom1@sparky-actina:~$ cat /etc/apt/sources.list.d/sparky-unstable.list
### sparky unstable repository
# deb https://sparkylinux.org/repo/ unstable main
# deb-src https://sparkylinux.org/repo/ unstable main
gom1@sparky-actina:~$ sudo apt update
Stary:1 http://www.deb-multimedia.org testing InRelease
Stary:2 http://ftp.debian.org/debian testing InRelease
Stary:3 http://security.debian.org testing/updates InRelease
Stary:4 https://sparkylinux.org/repo testing InRelease
Stary:5 https://liquorix.net/debian sid InRelease
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności
Odczyt informacji o stanie... Gotowe
All packages are up to date.
gom1@sparky-actina:~$ apt-cache policy linux-image-sparky*
linux-image-sparky-686:
  Zainstalowana: 4.12.4-1
  Kandydująca:   4.12.4-1
  Tabela wersji:
*** 4.12.4-1 100
        100 /var/lib/dpkg/status
Wszędzie dobrze, ale w /home najlepiej

pavroo

I tu jest problem:
cat /etc/apt/sources.list.d/sparky-unstable.list
### sparky unstable repository
# deb https://sparkylinux.org/repo/ unstable main
# deb-src https://sparkylinux.org/repo/ unstable main

Zmień wartości na (bez #):
deb https://sparkylinux.org/repo/ unstable main
deb-src https://sparkylinux.org/repo/ unstable main

następnie:
sudo apt update
sudo apt full-upgrade
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

gom1

#13
Tak, teraz jest OK. Tylko pytanie czemu akurat na tej maszynie jest inaczej niż na pozostałych? Ja się do repo nie dotykałem.

To mówisz, że do dwurdzeniowców zainstalować PAE?
Wszędzie dobrze, ale w /home najlepiej

pavroo

Cytatdo dwurdzeniowców zainstalować PAE?
Tak, 686 obsługuje tylko jeden rdzeń, więc nie wyciągniesz pełnej mocy maszyny.
CytatJa się do repo nie dotykałem.
Nie musiałeś, jeśli była aktualizacja pakietu 'sparky-apt' to repo unstable zostało ustawine na domyślne, czyli wyłączone.
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

Zobacz najnowsze wiadomości na forum