Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

aktualizacja.

Zaczęty przez Piejanto, Kwiecień 30, 2017, 07:39:37 PM

Poprzedni wątek - Następny wątek

Piejanto

mam wiadomość o aktualizacjach lecz po uruchomieniu procesu pokazuje mi się plansza " Błąd przygotowania operacji" z napisem:
- "nie udało się rozwiązać zależności gstreamer0.10-good-plugins: instalacja libsoup (2.58.0-1) uszkadza zależność 'libsoup-gnome' "

Ten komunikat mam na wszystkich trzech laptopach z Antergosem. Co robić?


robson75

A próbowałeś zrobić aktualizacje przez terminal, ponieważ instalacja z terminala daje więcej możliwości niż przez menadżera pakietów pamac-a.
sudo pacman -Syu
Arch Linux Xfce+compiz - 64Bit Linux User #621110

robson75

A jeżeli to nie pomoże spróbuj sforsować instalacje poleceniem:
sudo pacman -Syyuu --force
Arch Linux Xfce+compiz - 64Bit Linux User #621110

Piejanto

Pierwszego sposobu użułem już wcześniej. Nie pomogło. A oto co mi powiedziało po Twojej poradzie:

  sudo pacman -Syyuu --force
[sudo] hasło użytkownika jan:
:: Synchronizowanie baz danych z pakietami...
antergos                 146,4 KiB  2,38M/s 00:00 [######################] 100%
core                     124,4 KiB  2,13M/s 00:00 [######################] 100%
extra                   1707,6 KiB  4,72M/s 00:00 [######################] 100%
community                  3,8 MiB  3,02M/s 00:01 [######################] 100%
multilib                 175,6 KiB  1097K/s 00:00 [######################] 100%
:: Rozpoczynanie pełnej aktualizacji systemu...
rozwiązywanie zależności...
szukanie sprzecznych pakietów...
błąd:  nie udało się przygotować transakcji (nie udało się rozwiązać zależności)
:: gstreamer0.10-good-plugins: instalacja libsoup (2.58.0-1) zależność przerw 'libsoup-gnome'

robson75

#4
A próbowałeś odinstalować ten pakiet który blokuje aktualizacje, a potem go z powrotem zainstaluj.
Albo jeszcze inaczej zrób. W pamacu jest taka pozycja "ignorowanie aktualizacji", daje to możliwość wybranie pakietu którego nie chcesz zainstalować w tym przypadku pakiet blokujący aktualizacje. Może pomoże.


Arch Linux Xfce+compiz - 64Bit Linux User #621110

Piejanto

Dzięki za pomoc. Niestety. Za pomocą MC znalazłem pliki 'libsoup-gnome 2.4' oraz 'libsoup 2.4'. Następnie przeniosłem je za pomocą F6 z katalogu /usr/include/ do utworzonego zapasowego katalogu  w katalogu /home/ i uruchomiłem aktualizację. Komunikat mam w dalszym ciągu ten sam, mimo, że dwa pliki z nazwą 'libsoup-gnome 2.4' i 'libnsoup 2.4' już nie są w katalogu /usr/include lecz w katalogu /home/. Nie jest chyba możliwe, aby aktualizacja dotyczyła niewłaściwego katalogu?

Piejanto

#6
Wkleiłem na miejsce poprzednio usunięte pakiety. następnie wyłączyłem z aktualizacji pakiet 'libsoup 2.58.0-1' i poszło.  Dzięki za pomoc.

Ciekawa sprawa, bo mówiło, że 'libsoup 5.8.0-1' uszkadza pakiet 'libsoup 5.6.01', tymczasem u mnie w /usr/include/ jest pakiet 'libsoup 2.4'. Może to nie o te pakiety chodziło? Ale wyszukiwanie spod MC nie pokazało mi pakietów z innymi numeracjami.

Niezaktualizowany pakiet powoduje, że świeci mi się sygnalizacja aktualizacji na czerwono, a każda próba aktualizacji kończy się komunikatem :

"gstreamer0.10-good-plugins: instalacja libsoup (2.58.0-1) zależność przerw 'libsoup-gnome'"

I to denerwuje. Może z czasem coś poprawią?

robson75

Ja miałem identyczny problem tyle że w Manjaro Cinnamon. A konkretnie po zainstalowaniu Cinnamon-a wersji 16.10 (ponieważ wersja 17 w ogóle nie chciała się zainstalować) i po rozpoczęciu aktualizacji miałem problem z pakietem xorg-server (identyczny komunikat wyskakiwał jak Tobie), a jeszcze nie znałem na tyle systemu Manjaro żeby dostrzec w pamacu pozycje "ignorowane aktualizacje". odinstalowałem pakiet xorg-server i wtedy aktualizacja ruszyła z "kopyta". Ale cóż z tego skoro po zakończonej aktualizacji chcąc ponownie zainstalować pakiet xorg-server po prostu nie dało rady (a jak wiadomo xorg-server jest bardzo ważnym pakietem w systemie), i po restarcie system się nie odpalił. To postanowiłem zainstalować Manjaro XFCE 17 i po udanej aktualizacji zmieniłem środowisko graficzne na Cinnamon-a. I jestem zadowolony ponieważ wszystkie większe aktualizacje (średnio co 15 dni) przebiegają bez problemów.
Arch Linux Xfce+compiz - 64Bit Linux User #621110

Piejanto

Dzięki za odpowiedź. Ja chyba na razie się nie przesiądę na nic innego. To w końcu tylko jeden plik. Może go tam gdzieś poprawią i wtedy pójdzie. Już kiedyś miałem coś takiego, ze po kilku dniach aktualizacja ruszyła, więc może i teraz.  Ogólnie jestem bardzo zadowolony z Antergosa XFCE i mam go na dwu laptopach i netbooku, ale... dobrze wiedzieć, że Tobie sprawdza się Manjaro. Dzięki za przestrogę z usuwaniem ważnych plików.

robson75

@Piejanto Tobie też bym radził odinstalowanie pakietu gstreamer powodującego problemy z aktualizacją systemu. Dzisiaj ten wątek był obecny na Forum Manjaro.pl i został rozwiązany. Pozdrawiam.
          https://manjaro.pl/forum/topic/aktualizacja-systemu-problemy/#post-3947           
Arch Linux Xfce+compiz - 64Bit Linux User #621110

Piejanto

Dzięki za tradę. Tym bardziej aktualne, że pojawiły się nowe problemy. Otóż: jak już wcześniej wspomniałem, mam dwa laptopy i netbooka.
Na pierwszym laptopie Acer (starszym) nie aktualizują mi się cztery pozycje:
1/ antergos-keyring
2/antergos-mirrorlist
3/libsoup
4/pamac
(podobnie jest ze starym netbookiem Acer)

Za to na laptopie HP, prócz tych wyżej wymienionych czterech opornych plików mamy dodatkowo dziewięć z jakimiś błędami. Są to
5/imagemagick
6/net-snmp
7/pacaur
8/pepper-flash
9/perl
10/ perl-clone
11/ perl-dbi
12/ perl-html-parser
13/ perl-xml-libxml

Trochę mnie dziwi, że na tym samym systemie mam takie różne problemy z aktualizacją. Trochę się obawiam, bo sygnalizuje mi też niepoprawności w plikach aktualizacyjnych, ale spróbuję, jak radzisz.
Mam nadzieję, że Twoja rada zadziała. Dzięki. Pozdro.

Piejanto

Jeszcze jedno: koledze z manjaro tłumaczyłeś aby usunął pakiet gstreamer0.10.
U mnie jest jeden pakiet gstreamer i 11 pakietów gstreamer0.10 z różnymi dodatkami na końcu za liczbą dziesięć. To który mam odinstalować? Może polecieć po wszystkich? Dzięki.

robson75

#12
Pakiet gstreamer0.10 jest przestarzały i od dawna nie wspierany. Proponuje abyś odinstalował tylko pakiet gstreamer0.10 wraz z zależnościami, mimo że zostaniesz ostrzeżony że ten pakiet jest potrzebny. Gwarantuje Tobie że system będzie działał jak należy. No i w końcu aktualizacja ruszy z miejsca.

A co do pozostałych problemów, to odśwież bazę kluczy zaklęciem:
sudo pacman-key --refresh-keys

Powinno pomóc.

Jeszcze bym Tobie proponował odświeżyć mirrory:
           sudo pacman-mirrors -g && sudo pacman -Syyu   

I po tym zabiegu odśwież repozytoria:
sudo pacman -Syy
Arch Linux Xfce+compiz - 64Bit Linux User #621110

MSki

Ja wczoraj zainstalowałem Manjaro w wersji stable z 2017-06-20
https://distrowatch.com/table.php?distribution=manjaro
i po pewnych perturbacjach związanych z połączeniem się z serwerami (choć net działał) aktualizacja systemu przebiegła bez problemów opisywanych powyżej. Widać, że deweloperzy są bardzo czujni i wszystkie błędy naprawiają dość szybko.

Piejanto

Nie było mnie dość długo i miałem internet tylko przez Aero2. Nie było sensu wchodzić w aktualizacje. Po przyjeździe miałem znów sporo do aktualizowania,ale aktualizacja już w ogóle mi nie ruszała, na żadnym kompie. Nawet gdy chciałem zrobić tylko dla Wine, albo oddzielnie dla Chromium dostawałem informacje o problemie nie do przeskoczenia.
Jest tak:
Jak radziłeś usunąłem wszystko co miało w nazwie >gstreamer0.10< i wykonałem następnie wszystkie podane przez Ciebie zaklęcia. Następnie wykonałem wszystkie zaproponowane "magiczne zaklęcia" i uruchomiłem aktualizację. Poszło od ręki. Po aktualizacji otrzymałem komunikat o nieprawidłowym podpisie  a następnie ostrzeżenie co do Antegrosa tak, jak to opisałeś.   Na razie XFCE całkowicie mi wystarcza i nie chciałbym się przesiadać na inne desktopy.

Jeszcze pytanie:
Gdzie można się tego wszystkiego nauczyć? Ja jestem dość oporny bo mam już 67 lat, ale z Linuxem pracuję od czasów Mandrake 6.0 i jest to dla mnie najwygodniejszy system. Ostatnio próbowałem się nawet nawrócić na Windows 10 ale po prostu nie mam do Windowsa nerwów. Kiedyś Linux (Mandrake / Mandriva był mniej stabilny i musiałem więcej wiedzieć, a teraźniejsze Linuxy są stabilniejsze i pozapominałem prawie wszystko z tamtych lat, a niektóre rzeczy w ogóle przestały być potrzebne np. takie jam montowanie zewnętrznych drive'ów. Chciałbym poznać od wewnątrz Linuxa i jego strukturę ale nie mam pojęcia skąd czerpać wiedzę.

Zobacz najnowsze wiadomości na forum