Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

synaptic

Zaczęty przez urbek, Październik 26, 2016, 04:10:18 PM

Poprzedni wątek - Następny wątek

urbek

dość mało używam menadżera pakietów synaptic więc nie wiem nawet kiedy owy problem zaistniał, ale ostatnio chciałem z niego skorzystać i po wybraniu go z menu programów synaptic nie odpala a wywołany z konsoli ROOT odpala jak trzeba więc mniemam, że problem z uprawnieniami lub z uwierzytelnianiem i moja prośba o jakieś sugestie jak ten problem rozwiązać, bo choć mogę się bez tego obejść to lubię jak w moim systemie działa wszystko tak jak powinno :) mój Sparky jest ze środowiskiem XFCE.

urbek

Kiedyś na tym forum żadne pytanie nie pozostawało bez odpowiedzi i szkoda, że to już tak nie działa.

pavroo

Nic się nie zmieniło, tylko czasu brak.

Skopiuj /usr/share/applications/synaptic.desktop do ~HOME/.local/share/applications/synaptic.desktop
Wyedytuj skopiowany plik i zmień:
Exec=synaptic-pkexec
na:
Exec=gksu synaptic
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

urbek

Problem chyba jest poważniejszy, bo zauważyłem, że więcej funkcji wymagający uprawnień mi nie działa a mianowicie nie mogę zamontować innych partycji czy gparted itd

pavroo

#4
To wygląda na brak globalnych uprawnień, udostępnianych przez jakiś back-end polkit.
1. Jakie masz środowisko graficzne lub menadżera okien?
2. Pokaż wyniki poleceń:
apt-cache policy polkit*
apt-cache policy policykit*
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

urbek

wyniki poleceń:https://wklej.to/dnxwK środowisko XFCE. Dość długo byłem na samych repo debiana, ale ostatnio odblokowałem repo sparky zaktualizowałem wszystko i nie wiem czy to akurat wina problemów, ale teraz dopiero je zauważyłem i trzeba coś poradzić :)

pavroo

#6
Faktycznie, problem występuje w Xfce. Masz zainstalowany pakiet policykit-1-gnome i to powinno wystarczyć. Wygląda to na błąd pochodzący z Debiana, Sparkowe pliki nie ingerują w strefę uprawnień.

Tymczasowe rozwiązanie: zainstaluj np. lxsession, idź do ustawień Xfce-> Sesja i uruchamianie i zaznacz Lxpolkit aby uruchamiał się wraz ze startem systemu. Następnie reboot i powiedz czy pomogło.
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

pavroo

Problem nie występuje tylko w Xfce, ale we wszystkich pulpitach korzystających z 'policykit-1-gnome'. Wersja 0.105-4 powoduje błąd, o którym napisałeś. Wrzuciłem do repo Sparkowego wersję 0.105-5, która to naprawia. Zaktualizuj system i reboot.
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

urbek

teraz wszystko działa:) Dzięki za pomoc :) a tak przy okazji to jak zaznaczyłam polkit to odznaczyłem policykit  i zastanawiam się czy czegoś nie wyrzucić, żeby się nie dublowały niepotrzebne pakiety?

pavroo

policykit-1-gnome wystarczy, lxpolkit tylko będzie dublował uprawnienia, można odznaczyć.
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

pavroo

Część sparkowych pulpitów wymaga ręcznej poprawki http://sparkylinux.org/authentication-agent-issue/
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

Zobacz najnowsze wiadomości na forum