Linuxiarze.pl Forum

Dystrybucje Linux => Ubuntu, Kubuntu, Xubuntu, Lubuntu => Wątek zaczęty przez: ROTMOOSH w Maj 17, 2015, 11:27:39 pm

Tytuł: Xubuntu ma problem z wyłączaniem
Wiadomość wysłana przez: ROTMOOSH w Maj 17, 2015, 11:27:39 pm
witam, mam problem z wyłączaniem systemu
włącza się nie najgorzej, choć mogło by być sądzę lepiej. ale to co się dzieje przy wyłączaniu to już mordor. 10 minut czasem szybciej czasem dłużej.
sądziłem że coś siedzi na cach'u lecz po wyczyszczeniu komendą którą znalazłem w necie:

# echo 3> /proc/sys/vm/drop_caches

sprawa nadal się ma następująco:

# free -m
                   total       used       free     shared    buffers     cached
Mem:          3552       2891        660       1559          5       1793
-/+ buffers/cache:       1092       2459
Swap:         3689        350       3339

czy tak to powinno wyglądać? system niby minimalnie szybciej się restartuje ale nadal to trwa znacznie zbyt długo.

ma ktoś może pomysł co z tym zrobić?
korzystałem z tej instrukcji
http://404.g-net.pl/2013/01/czyszczenie-pamieci-podrecznej/

z góry dzięki za pomoc i sugestie
Tytuł: Odp: Xubuntu ma problem z wyłączaniem
Wiadomość wysłana przez: pavroo w Maj 18, 2015, 01:15:24 am
Witaj
1092 mb ramu to jak na Kubuntu i tak za dużo.
Pulpit KDE przeciętnie używa (bez dodatkowych usług) około 500 MB.
Podejrzyj jaki proces/procesy zabiera tak dużo mocy, np. poleceniem: top
Tytuł: Odp: Xubuntu ma problem z wyłączaniem
Wiadomość wysłana przez: ROTMOOSH w Maj 18, 2015, 07:27:58 am
dziś jest lepiej,
z włączoną przeglądarką terminalem i menadżerem plików jest jakoś 928mb jedzonego ramu. więc raczej nie jest źle (zobaczymy jak zacznę coś robić i odpalę octave) oczywiście chromium zżera najwięcej.
za to w cachu siedzi nadal przeszło 2 koła. nawet po czyszczeniu ww instrukcją.

top - 07:14:59 up 34 min,  3 users,  load average: 0,00, 0,18, 0,35
Tasks: 196 total,   1 running, 195 sleeping,   0 stopped,   0 zombie
%Cpu(s):  0,3 us,  0,3 sy,  0,0 ni, 99,5 id,  0,0 wa,  0,0 hi,  0,0 si,  0,0 st
KiB Mem:   3637360 total,  3116968 used,   520392 free,     7952 buffers
KiB Swap:  3778556 total,        0 used,  3778556 free.  2197564 cached Mem

czy to stan poprawny, czy niepotrzebnie panikuję?

no i co może powodować tak przeciągłe wyłączanie? a przy okazji też zamulanie systemu w czasie pracy?

Tytuł: Odp: Xubuntu ma problem z wyłączaniem
Wiadomość wysłana przez: lesio w Maj 19, 2015, 02:04:32 pm
Długotrwałe zamykanie systemu może powodować jakiś zawieszony lub "półzawieszony" proces. Kiedyś miałem taką przygodę z pulseaudio. Czy dźwięk działa prawidłowo?
Tytuł: Odp: Xubuntu ma problem z wyłączaniem
Wiadomość wysłana przez: ROTMOOSH w Maj 19, 2015, 04:10:39 pm
dźwięk działa prawidłowo, używam audacious  który jest raczej leciutki...
Tytuł: Odp: Xubuntu ma problem z wyłączaniem
Wiadomość wysłana przez: tomas w Czerwiec 18, 2015, 10:43:23 pm
witam,
Problem może leżeć w uszkozonym bugu czesto ten problem pojawiał sie w wcześniejszych wersjach ubuntu.
na początek sprubuj go zaktualizowac

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get autoremove

jeżeli to nie pomoże to mozesz sprobować zainstalowac recznie buga
    wget http://dl.dropbox.com/u/7244180/fix-slow-boot.sh
    sudo sh fix-slow-boot.sh

mam nadzieje ze choć troche pomogłem