Linuxiarze.pl Forum

Dystrybucje Linux => Sparky => Wątek zaczęty przez: sovtware w Luty 16, 2020, 05:13:14 pm

Tytuł: SprkyLinux KDE 5 Plazma
Wiadomość wysłana przez: sovtware w Luty 16, 2020, 05:13:14 pm
Czemu nikt mi nie napisał aby zainstalować SparkyLinux z Pulpitem KDE Plazma żyła złota nie przycina się nawet na chwilę a chodzi  bardzo szybko Jestem naprawdę bardzo pozytywnie zaskoczony
dziękuję Wszystkim osobom co pracują nad Sparky że jest :) to fakt jednak najlepszy system teraz mogę faktycznie polecić KDE 5 innym użytkownikom ale tylko właśnie w tym systemie mam nadzieję i wierzę w to że nic się tu nie zepsuje pozdrawiam

OpenSuse może pochodził dzień czy dwa góra cztery ok ale jak się przyciął to już 10 razy cza uruchamiać lapka i jeszcze na innym kernelu i bawić się by zaczął płynnie chodzić a tutaj wszystko hula !

 :) 8)

(https://i.imgur.com/8nFJRMj.png)

Jednak jak miałem zrezygnować z Plażmy tak zostaję :) jest to jednak dobry pulpit ( jak zwał tak zwał )

Jak ktoś chce wypróbować KDE 5 na swoim sprzęcie to tylko w Sparky nic a nic się nie przycina chodzi szybciej o dużo niż OpenSuse ( nie wiem jak inne ) mimo że używa podobnie ram
System wraz z Pulpitem godny polecenia Każdemu !
 

Zainstalowałem SparkyLInux MinimalGUI aktualizację potem co nie co skasowałem zainstalowałem KDE Standard potem zaś co nie co odinstalowałem zainstalowałem i koniec wszystko hula !  :o ( zdziwiony z tym co było na OpenSuse i Sabayon )
Tytuł: Odp: SprkyLinux KDE 5 Plazma
Wiadomość wysłana przez: pavbaranov w Luty 16, 2020, 05:35:03 pm
No to się zacznie, otóż KDE na pewno nie w takim systemie, który bierze paczki z Debiana Stable. Dlaczego? Krótko - brak wsparcia. W Debianie to raczej nie jest wspierane, a na bugs.kde.org odbijesz się z "unmaintained". Ba, bywa, że odbijesz się z czymś takim również, gdy będziesz miał KDE w wersji opartej o Debian Testing.
Oczywiście można żyć z niewspieranym środowiskiem (czyli tak na prawdę z połową - tą widoczną - systemu), ale po co sobie utrudniać życie?
Tytuł: Odp: SprkyLinux KDE 5 Plazma
Wiadomość wysłana przez: sovtware w Luty 16, 2020, 06:00:39 pm
Pożyjemy zobaczymy na 1 dzień jestem zadowolony zobaczymy po kilku aktualizacjach i po miesięcznym używaniu w razie czego możecie być pewni że się odezwę i napiszę że jest coś nie tak pozdrawiam
Tytuł: Odp: SprkyLinux KDE 5 Plazma
Wiadomość wysłana przez: pavbaranov w Luty 16, 2020, 06:26:45 pm
A już Ci mogę odpowiedzieć, że coś jest nie tak :) Plasma jest w Debianie (Stable/Testing) w wersji 5.14.5, KF5 5.54 (stable) i 5.62 (testing), Qt5 - 5.11 (stable) i 5.12 (testing). Obecne, wspierane wersje to odpowiednio: Plasma 5.18 (i okazjonalnie jeszcze 5.12), KF5 5.57, Qt5 5.12 i 5.14.
Od czasu wprowadzenia ww. wersji dokonano mnóstwo poprawek, w tym również zgłaszanych przez użytkowników Debiana. Bodaj 2 dni temu zgłoszony błąd (od użytkownika Debiana) w Plasma 5.17.5 spotkał się z krótkim: niewspierana dalej wersja.
Nie oznacza to, że Plasma w Debianie chodzi źle. Chodzi po prostu nie tak dobrze, jakby mogła. Zawiera (i będzie zawierać, bo łatki z nowszych wersji niekoniecznie dadzą się nałożyć) błędy, które zostały naprawione już dawno (np. Plasma z serii 5.14. straciła wsparcie ponad rok temu), dane wydanie KF5 traci wsparcie po miesiącu... Nie będziesz miał też wszystkich funkcjonalności, które zostały wprowadzone później. Działanie w sesji Wayland, a obecnie to już pomiędzy 5.14, a 5.18 raczej przepaść. Itd. itp.
Dlatego ośmielam się studzić zapał wszystkich, którzy polecają oprogramowanie, które dawno, dawno temu straciło wsparcie. Przy czym do samego Sparky nie mam absolutnie nic. To Debian ze swoich użytkowników robi sobie jaja.
Tytuł: Odp: SprkyLinux KDE 5 Plazma
Wiadomość wysłana przez: PomPom w Luty 16, 2020, 07:27:02 pm
Jak chodzi o KDE, to w większości zgadzam się z tym (chociaż dodałbym Archa):
https://kde.org/distributions

Kubuntu niby też ma starsze KDE, ale są PPA i wersja LTS korzysta również z Plasmy LTS (tak samo zresztą robi OpenSUSE Leap, gdzie jednak da się łatwo dograć najnowsze elementy z KDE). W Debianie to taka loteria i teraz może podziała fajnie, ale po aktualce testinga coś już będzie niefajnie. A Stable? A stable jest fajne do pierwszego upierdliwego buga, który nie zostanie naprawiony nigdy w tej wersji.
Tytuł: Odp: SprkyLinux KDE 5 Plazma
Wiadomość wysłana przez: pavbaranov w Luty 16, 2020, 08:21:37 pm
To już chyba od Kubuntu sensowniej jest używać KDE Neon. Też oparte o Ubuntu (tu LTS).
Tytuł: Odp: SprkyLinux KDE 5 Plazma
Wiadomość wysłana przez: sovtware w Luty 20, 2020, 09:56:21 am
Dziś aktualizacja do nowszej wersji plazmy i chodzi lepiej jak n opensuse

(https://i.imgur.com/EHZTB5J.png)
Tytuł: Odp: SprkyLinux KDE 5 Plazma
Wiadomość wysłana przez: pavbaranov w Luty 20, 2020, 10:04:40 am
5.17.x też już jest czasem przeszłym :)
Tytuł: Odp: SprkyLinux KDE 5 Plazma
Wiadomość wysłana przez: sovtware w Luty 20, 2020, 11:16:21 pm
Co Wy tak o tych numerkach system ma chodzić płynnie i dobrze a nie tak jak miałem np: w opensuse co chwila aktualizacje plazmy a system strasznie zamuliwszy jeżeli mam czekać dłużej na nowy numerek to wolę poczekać przynajmniej w Debianie nową plazmę puszczają już sprawdzoną i poprawioną by działała dobrze 
Tytuł: Odp: SprkyLinux KDE 5 Plazma
Wiadomość wysłana przez: pavbaranov w Luty 21, 2020, 12:28:07 am
To ja o tych numerkach. Odpowiedź jest prosta. W przypadku starych, niewspieranych, wersji Plasmy, oprogramowania KDE z problemem jaki napotkasz - zostajesz sam. Nikt Ci nie udzieli jakiejkolwiek pomocy. Błąd nie zostanie naprawiony.
"Zamulanie" OpenSUSE to jest zupełnie inny problem i nie jest on na 100% związany z wersją Plazmy.
Tytuł: Odp: SprkyLinux KDE 5 Plazma
Wiadomość wysłana przez: sovtware w Luty 21, 2020, 01:41:43 pm
Dobrze wszystko rozumiem z tym wsparciem
Ja chcę system który nie przycina się a działa dobrze
Manjaro miałem xfce nigdy do niego nie wrócę
po tym jak pokazywał mi sporo błędów przy aktualizacji do nowszej wersji
Sabayon strasznie długo aktualizuje się potrawi po aktualizacji
pokazać mi czarny ekran także próbowany na środowisku xfce
czysty Debian testing nie zainstaluję beż kabla do internetu
Sparky Linux podłączę do Wifi i mam Xubuntu mi się trochę znudził
szczególnie gdy po aktualizacji na 20.04 lts kiedy to skasował mi xfburn i aplet clock alarm i już tych pakietów nie było w repo OpenSuse nie chcę się powtarzać
Mam SparkyLinux teraz wiem że Debian jest najbardziej stabilnym systemem i naprawdę ciężko go popsuć jak robi się tylko same aktualizację nie wiem co bym mógł jeszcze wypróbować i zainstalować u siebie by nie było trudno a aby chodziło używam lapka tylko do internetu i do oglądania filmów może napiszecie mi na priv co mogę jeszcze spróbować i zobaczyć chodzi mi by była dystrybucja łatwa do zainstalowania i ciągła z pulpitem kde tylko SparkyLinux przyszedł mi do głowy więc nie śmiejcie się ze ze wsparciem mogę mieć problem komu to jak dobrze hula
już nie marudzę
Tytuł: Odp: SprkyLinux KDE 5 Plazma
Wiadomość wysłana przez: PomPom w Luty 21, 2020, 02:17:06 pm
Zepsuł mi się Debian, któremu dodałem podstawowe backporty - jądro, sterowniki nvidii (to idzie w parze) i libfreetype własnego autorstwa (backport, fkors). Ask me anything.

I tak męczymy, bo trochę wcześniej padło stwierdzenie, że Sparky z Plasmą jest najlepsze.
Tytuł: Odp: SprkyLinux KDE 5 Plazma
Wiadomość wysłana przez: Albedo 0.64 w Maj 13, 2020, 03:23:51 pm
No to się zacznie, otóż KDE na pewno nie w takim systemie, który bierze paczki z Debiana Stable. Dlaczego? Krótko - brak wsparcia. W Debianie to raczej nie jest wspierane, a na bugs.kde.org odbijesz się z "unmaintained". Ba, bywa, że odbijesz się z czymś takim również, gdy będziesz miał KDE w wersji opartej o Debian Testing.
Oczywiście można żyć z niewspieranym środowiskiem (czyli tak na prawdę z połową - tą widoczną - systemu), ale po co sobie utrudniać życie?

Sparky 6 korzysta z repo testing i ma możliwość włączenia repo sid. Repo stable jest w Sparky 5
Tytuł: Odp: SprkyLinux KDE 5 Plazma
Wiadomość wysłana przez: pavbaranov w Maj 13, 2020, 03:52:14 pm
@Albedo 0.64 - Dla kwestii świeżości, a w zasadzie wsparcia paczek KDE w Debian i pochodnych, wersja stable/testing/sid nie ma żadnego znaczenia. Najczęściej jest to wersja kompletnie niewspierana przez nikogo. Wina po stronie Debiana. Ani nie korzystają z Plasma LTS, ani z bieżących KF5, ani z bieżących "Aplikacji KDE". Jakakolwiek próba zgłoszenia błędu w Debianie skutkuje odesłaniem do bugs.kde.org. Zgłoszenie tu błędu skutkuje stwierdzeniem, że błąd został już dawno naprawiony - zainstaluj sobie nowszą wersję paczek.

Dla przykładu:
1. Wersje paczek kde-apps i porównanie z obecnie wspieranymi:
jessie - 4.14.2
stretch - 16.12.0
buster - 18.04.0
bullseye - 19.08.1
sid - 19.08.1
Obecna wersja: 20.04.0, a za 2 dni 20.04.1
Plazma:
jessie - 4.11.13
stretch - 5.8.6
buster - 5.14.5.1
bullseye - 5.17.5
sid - 5.17.5
Obecnie wspierane wersje: 5.18.5, 5.12 (jeszcze, ale tylko w zakresie poważnych poprawek), nadchodząca (czerwiec) - 5.19
KF5:
stretch - 5.28.0
buster - 5.54.0
bullseye - 5.62.0
sid - 5.62.0
experimental - 5.69.0
Obecna - 5.70, a w czerwcu 5.71 itd. co miesiąc.
Jeśli ktoś uważa, że wsparcie dla paczek umieszczanych w dowolnej gałęzi Debiana dla oprogramowania KDE istnieje, to się grubo myli. Aktualność nawet testing to od pół roku do tyłu, do dziewięciu miesięcy. Z SID - jak widać jest dokładnie tak samo, zatem nawet "włączenie repo sid" niczego nie zmieni. Debian jako platforma dla KDE do niczego się nie nadaje, chyba, że znajdziemy jakąś dystrybucję pochodną, która wykorzystując paczki bazowe Debiana będzie dostarczać własnych paczek KDE (kiedyś było coś takiego jaki siduction, ale tu ostatnie wydanie jest z 2018 r., niegdyś sami paczkowali KDE, jak teraz jest - nie wiem). Jeśli ktoś bardzo chce APTa i KDE, to powinien się skierować w stronę np. Kubuntu czy Neona i ogólnie ich pochodnych (zwłaszcza Neona, choć to dystrybucja dla deweloperów głównie).
Tytuł: Odp: SprkyLinux KDE 5 Plazma
Wiadomość wysłana przez: Albedo 0.64 w Maj 23, 2020, 04:41:14 pm
@pavbaranow: Zwróciłem jedynie uwagę, że post dotyczy Sparky 6 czyli Debiana Testing w kontekście Twoich dywagacji o wsparciu KDE w Debianie Stable.
Poza tym, nie ośmielam się dyskutować z Tobą na tematy, których nie znam. Ostatnio widziałem KDE w 2009 roku i już nie oglądam się w tamtą stronę.
Tytuł: Odp: SprkyLinux KDE 5 Plazma
Wiadomość wysłana przez: pavbaranov w Maj 24, 2020, 12:02:57 pm
@Albedo 0.64 - Tyle, że w przypadku Debiana, to w zasadzie nie ma znaczenia, która to gałąź. Zasadniczo i tak oferuje zawsze stare, bądź bardzo stare wersje tego oprogramowania, które najczęściej utracone już mają wsparcie w KDE, a w Debianie go też nie mają. Użytkownik pozostaje sam ze sobą i z programami, które może sobie patchować wyłącznie we własnym zakresie (jeśli jeszcze się da). Tu jednak sporo wiedzy trzeba mieć.
Swoją ścieżką, nieco mnie dziwi upór w Debianie, bo np. przynajmniej w zakresie Plazmy mogliby stosować wersje LTS i być może by użytkownicy przynajmniej tu mogli liczyć na jakieś wsparcie.
Aha - i by nie było niedopowiedzeń. KDE w Debianie działa. Działa tak jak każda odsłona tego oprogramowania w użytej w nim wersji. Problem leży wyłącznie w tym, że o ile w innych dystrybucjach można liczyć na to, że wraz z nowszymi wersjami jakieś błędy zostaną naprawione, że w ogóle te błędy można gdzieś zgłosić, by zostały naprawione, to w przypadku Debiana (dowolnej gałęzi praktycznie) takiej opcji nie ma.
Kiedyś były bodaj dwie dystrybucje oparte o Debiana (SID, jeśli pamiętam), które oferowały własne paczki KDE i one były zasadniczo na czasie. Jeśli to istnieje jeszcze i jest rozwijane, to zdecydowanie lepszy jest to chyba pomysł na "Debian" + KDE niż cokolwiek, co korzysta z debianowych paczek KDE.