Linuxiarze.pl Forum

Dystrybucje Linux => Sparky => Wątek zaczęty przez: dargaj0 w Kwiecień 04, 2019, 07:53:33 pm

Tytuł: [ROZWIĄZANY]Brak polskich zankow pomimo polskich ustawien jezyka i klawiatury
Wiadomość wysłana przez: dargaj0 w Kwiecień 04, 2019, 07:53:33 pm
Witam
Pomimo ustawien (nie mam n z kreska :) ) polskich znakow nie mam ich ( klawiatura pc 105 klawiszy polska) juklad klawiatury polski domyslne ustawienie dla ukladu klawiatury jezyk polski pl_PL.UTF-8 UTF-8


Tytuł: Odp: Brak polskich zankow pomimo polskich ustawien jezyka i klawiatury
Wiadomość wysłana przez: pavbaranov w Kwiecień 04, 2019, 08:23:37 pm
Gdzie nie masz tych znaków? W konsoli, czy w DE?
Tytuł: Odp: Brak polskich zankow pomimo polskich ustawien jezyka i klawiatury
Wiadomość wysłana przez: dargaj0 w Kwiecień 04, 2019, 09:15:32 pm
Wszedzie czyli np tutaj, w libre office w pasku przegladarki www ...
Tytuł: Odp: Brak polskich zankow pomimo polskich ustawien jezyka i klawiatury
Wiadomość wysłana przez: pavbaranov w Kwiecień 04, 2019, 09:20:47 pm
Sparky - to zmodyfikowany Debian. Brakuje Ci zatem po prostu paczek lokalizacyjnych. Natomiast jak to łatwo pociągnąć w Sparky to niech Paweł się wypowie, bo na 100% jest taka możliwość.
Tytuł: Odp: Brak polskich zankow pomimo polskich ustawien jezyka i klawiatury
Wiadomość wysłana przez: dargaj0 w Kwiecień 04, 2019, 09:57:13 pm
Dzieki, ale nie wiem jaki Pawel ? Jakis namiar ?
Tytuł: Odp: Brak polskich zankow pomimo polskich ustawien jezyka i klawiatury
Wiadomość wysłana przez: pavroo w Kwiecień 04, 2019, 11:22:34 pm
APTus posiada narzędzie do instalacji pakietów językowych, więc uruchom APTus : Menu-> System-> APTus
1. Odśwież listę pakietów: Akcesoria-> Refresh package list
2. System-> Install language packages -> Polish

Następnie w terminalu:
sudo dpkg-reconfigure localesi wybierz pl_PL UTF-8.
Po restarcie system powinien działać w języku polskim.
Tytuł: Odp: Brak polskich zankow pomimo polskich ustawien jezyka i klawiatury
Wiadomość wysłana przez: dargaj0 w Kwiecień 07, 2019, 09:51:33 am
Witam
Niestety podany sposob u mnie nie dziala.  Moze robie cos zle.
Mam nagrany filmik z moich poczynan ale nei mam go tutaj jak dodac.
Tytuł: Odp: Brak polskich zankow pomimo polskich ustawien jezyka i klawiatury
Wiadomość wysłana przez: pavbaranov w Kwiecień 07, 2019, 09:52:33 am
To może po prostu opisz? :)
Tytuł: Odp: Brak polskich zankow pomimo polskich ustawien jezyka i klawiatury
Wiadomość wysłana przez: lami07 w Kwiecień 07, 2019, 11:29:04 am
Z jakiego środowiska pulpitu korzystasz ?
Tytuł: Odp: Brak polskich zankow pomimo polskich ustawien jezyka i klawiatury
Wiadomość wysłana przez: dargaj0 w Kwiecień 07, 2019, 03:03:32 pm
LXDE
Tytuł: Odp: Brak polskich zankow pomimo polskich ustawien jezyka i klawiatury
Wiadomość wysłana przez: dargaj0 w Kwiecień 07, 2019, 03:05:21 pm
pavbaranov
Jakbys podal jakis namiar to bym wrzucil ten 12 MB filmik
Tytuł: Odp: Brak polskich zankow pomimo polskich ustawien jezyka i klawiatury
Wiadomość wysłana przez: dargaj0 w Kwiecień 07, 2019, 03:12:15 pm
Po wykonaniu
sudo dpkg-reconfigure locates
otwiera sie okno dzie zaznaczam krzyzykiem i sapacja pl_PL.UTF-8 wybierajac OK wyskakuje w terminali
aa_DJ.UTF-8... done
en_US.UTF-8...done
pl_PL.UTF-8...done
Generation complete.


a nie ma byc TYLKO pl_PL.UTF-8...done   ???



Tytuł: Odp: Brak polskich zankow pomimo polskich ustawien jezyka i klawiatury
Wiadomość wysłana przez: pavbaranov w Kwiecień 07, 2019, 03:51:51 pm
Nie, nie podam "namiaru" :) Po prostu pokaż co robisz. Jeśli chcesz, to wrzuć filmik na np. mega.nz albo "coś". Może ktoś zerknie.
Jeśli chodzi Ci o te bla_BLA.UTF-8 to generowane są takie, jakie są ustawione.
W pozostałej części pomogą Ci osoby, które są związane ze Sparky. Z mojej strony: może potrzebujesz ustawienia odpowiedniej klawiatury w DE. Polskie litery wyświetlają Ci się, ale nie potrafisz ich wprowadzić? Bo to 2 różne rzeczy.
Tytuł: Odp: Brak polskich zankow pomimo polskich ustawien jezyka i klawiatury
Wiadomość wysłana przez: robson75 w Kwiecień 07, 2019, 04:18:07 pm
Film także można wrzucić na YouTuba, i ewentualnie zapodać link na tym forumie.
Tytuł: Odp: Brak polskich zankow pomimo polskich ustawien jezyka i klawiatury
Wiadomość wysłana przez: dargaj0 w Kwiecień 07, 2019, 07:46:20 pm
Dokladnie tak jak mowisz, pavbaranov. Polskie litery wyswietlaja sie na ekranie ale ja nie umiem ich wprowadzic.
Mam Zwykla PC 105-klawiszowa (Intl)
Uklad klawiatury Polski
Klawisz ktory ma dzialac jak AltGr  Prawy Alt (Alt Gr)
Bez klawisza Compose
Tytuł: Odp: Brak polskich zankow pomimo polskich ustawien jezyka i klawiatury
Wiadomość wysłana przez: robson75 w Kwiecień 07, 2019, 10:57:33 pm
A spróbuj wklepać do terminala:
sudo locale-gen
Tytuł: Odp: Brak polskich zankow pomimo polskich ustawien jezyka i klawiatury
Wiadomość wysłana przez: dargaj0 w Kwiecień 08, 2019, 06:42:10 pm
wklepalem potwierdzilem haslem, przelecialo kilka/kilkanascie tysiecy linii, uruchomilem ponownie komputer i nadal nie moge wpisywac z klawiatury polskich znakow  :-[
Tytuł: Odp: Brak polskich zankow pomimo polskich ustawien jezyka i klawiatury
Wiadomość wysłana przez: dargaj0 w Kwiecień 08, 2019, 06:54:38 pm
Działa polecenie sudo setxkbmap pl, tzn polskie znaki już mam żźćńąęłó ale do restartu, potem bez polskich znaków.
Jaka jest tego przyczyna lub jak to wykonać na stałe ?
Tytuł: Odp: Brak polskich zankow pomimo polskich ustawien jezyka i klawiatury
Wiadomość wysłana przez: pavbaranov w Kwiecień 08, 2019, 08:34:06 pm
W "normalnych" (tzn. bez ułatwień) systemach - działać winno to tak: https://wiki.archlinux.org/index.php/Localization#Keyboard_layouts (https://wiki.archlinux.org/index.php/Localization#Keyboard_layouts)
Tytuł: Odp: Brak polskich zankow pomimo polskich ustawien jezyka i klawiatury
Wiadomość wysłana przez: dargaj0 w Kwiecień 08, 2019, 08:38:41 pm
Zamykam temat.
Problem rozwiązałem poprzez edycję pliku      /etc/X11/xorg.conf.d/00-keyboard.conf
linijka Option XkbLayout z „en” na „pl”