Linuxiarze.pl Forum

Dystrybucje Linux => Arch => Wątek zaczęty przez: Piejanto w Listopad 06, 2018, 10:01:17 pm

Tytuł: ROZWIĄZANY (na str.3) Problem z TV na Kaffeine
Wiadomość wysłana przez: Piejanto w Listopad 06, 2018, 10:01:17 pm
Od jakiegoś miesiąca, lub dwu, po aktualizacj Antergosa, nie mogę podnieść w Kaffeine okna
skanującego kanały televizyjne.
 Po przeinstalowaniu systemu na jednym z kompów, w ogóle nie daje się ustalić kanałów do przełączania.
Znaczy jest tak, że nie daje się sięgnąć buttonów "dodaj wybrane" oraz "zastosuj".
Tylko to jedno okno tak ma.
Tzn. dół tego okna niknie pod panelem tak głęboko, że nie da się tam sięgnąć. Obniżenie górnej krawędzi nie jest możliwe aby później paskiem podciągnąć całość. Dotyczy to tylko okna umożliwiającego skanowanie kanałów  i  dodawanie kanałów do wybranych. O ile button "dodaj wybrane" wystaje odrobinę ponad panel w XFCE (w KDE już go nie widać), o tyle button "zastosuj" (przy najwyżej podciągniętej górnej krawędzi tego okna, niknie pod dolną krawędzią ekranu.
Laptop, na którym system nie był przeinstalowany, ma w pamięci stare kanały, ale sygnalizuje tylko napisami, że kanał jest odtwarzany, jednak ekran pozostaje czarny.
Po zeskanowaniu kanałów działanie kończy się na przerzuceniu "znalezionych" do okna "wybranych",
ale nie można tego zatwierdzić buttonem "zastosuj", bo jest on pod dolnym poziomem ekranu.
Co robić?
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: pavbaranov w Listopad 06, 2018, 10:10:44 pm
Co zrobić? Więcej konkretów. Masz 3 komputery, jakaś sytuacja "po aktualizacji", jakiś komputer z KDE, jakiś z Xfce... Ze względu na to, że problem masz z rysowaniem okna, którego rozmiar przekracza rozmiar roboczy (widoczny na ekranie), to każda z tych sytuacji jest inna. Zatem - wpierw zdecyduj się, którą z nich chcesz w tym wątku rozwiązać, popraw tytuł wątku (bo nie dotyczy on TV w Kaffeine, a wyświetlania okna dialogowego). Drugi wątek możesz założyć dla innego środowiska.

Opisując przydadzą się pewne informacje, ale będą one znów zależne od tego, w jakim środowisku ów wygląd będziesz chciał poprawić.
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: TataPingu w Listopad 07, 2018, 08:52:15 am
@Piejanto
Kolega Povbaranov ma rację, w pierwszym rzędzie to problemy grafiki, a dokładnie menadżera okien...
- sprubój na którymś z systemów zainstalować inne środowisko, najlepiej Mate (stosunkowo dobrze dopracowany menadżer okien - Marco)
Po wystartowaniu Mate wybierz "Marco bez graficznych efektów" (czy coś w tym rodzaju).
Jeśli nadal wystąpią podobne problemy, wówczas musisz przeinstalować sterowniki grafiki
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: pavbaranov w Listopad 07, 2018, 11:50:46 am
@TataPingu - Dajmy spokój z instalowaniem jeszcze innego DE przez @Piejanto. On już ma 2 DE i na obu jest źle. Problem może w ogóle nie leżeć po stronie menedżera okien. Ze względu na sposób pisania aplikacji w Qt może to być również wadliwie napisana aplikacja (np. taką jest hybrid-encoder). Stawiam jednak na wadliwą konfigurację. Spróbujmy rozwiązać problem na którymś DE, które @piejanto w tym wątku wybierze (powiedzmy xfce), a dla drugiego (KDE) niech założy oddzielny bo inaczej będzie otrzymywać sprzeczne informacje przydatne dla każdego z tych DE i jednocześnie najprawdopodobniej nieadekwatne w drugim i mogące w nim wywołać problem.
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: TataPingu w Listopad 07, 2018, 12:04:28 pm
@povbaranov i @Piejanto
- fakt, to mogą być dziesiątki przyczyn.
W pierwszym rzędzie sugeruję, by stworzyć jakiegoś testowego usera, zameldować się na tym accouncie i spróbować wystartować tam "wadliwy" program.
Jeśli wszystko będzie OK, to mamy znak, że konfiguracja pod poprzednim userem była wadliwa i wystarczy ją tylko wywalić.
Jeśli zjawisko się powtórzy, to mamy znak, że coś "zgrzyta" w systemie...
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: pavbaranov w Listopad 07, 2018, 12:27:19 pm
A ja bym jeszcze poprosił o wynik polecenia inxi -Fxx (jeśli nie masz - doinstaluj). Najłatwiej Ci będzie zrobić to tak:
inxi -Fxx > wynik.txti umieścić tu zawartość pliku wynik.txt bądź go wstawić na jakiś pastebin.
Tytuł: Odp: Problem z TV na Kaffeine prawie ROZWIĄZANY
Wiadomość wysłana przez: Piejanto w Listopad 07, 2018, 08:52:28 pm
PROBLEM prawie ROZWIĄZANY

Jest tak:
Po raz kolejny przeinstalowałem Antergosa na netbooku. Wróciłem do pulpitu XFCE. uruchomiłem Kaffeine. Okno przeszukiwania kanałów w dalszym ciągu nie dawało się ustawić a button zmniejszania w prawym górnym rogu (kwadracik) nie działa.
Zeskanowałem kanały i ustawiłem panel w pionie, gdyż zasłaniał pole "dodaj wybrany".
Zaznaczyłem wybrane kanały i kliknąłem myszą w button "dodaj wybrany" ale pole zatwierdzające było poniżej dolnej krawędzi ekranu. Wtedy kliknąłem "ENTER"
Wszystkie kanały zagnieździły się w oknie do odtwarzania.

Czasem najgłupszy problem moe powstać w wyniku rutyny klikania myszą.
Dziękuję wszystkim, którzy chcioeli mi pomóc, a w szczególności Pawłowi.
Dziękuję i przepraszam.

Jeśli chodzi o HP, to w dalszym ciągu jest problem, gdyż okno w ogóle nie chce skanować kanałów, ale najbardziej zależało mi na odbiorze na netbooku.

Co do inxi, próbowałem z czystej ciekawości na HP. Wynik:
[root@piejanto jan]# inxi -Fxx
bash: inxi: nie znaleziono polecenia
[root@piejanto jan]#
[root@piejanto jan]# inxi -Fxx > wynik.txt
bash: inxi: nie znaleziono polecenia
[root@piejanto jan]# pacman inxi -Fxx > wynik.txt
błąd:  nie określono opcji (użyj -h, aby uzyskać pomoc)
[root@piejanto jan]#

Natomiast jeśli chodzi o HP. Odinstalowałem Kaffeine, zresetowałem komputer, a następne znów zainstalowałem Kaffeine. Niestety, ustawienia pozostają gdzieś w pamięci i po reinstalacji Kaffeine ma poprzednio zapamiętane ustawienia i zapamiętane kanały. Niczego się z tym chyba nie da zrobić, chyba, że reinstalować system, ale - jak to już mówiłem - najbardziej zależało mi na odbiorze TV na netbooku.

Dzięki Panowie
Dzięki Pawle
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: pavbaranov w Listopad 07, 2018, 09:30:42 pm
Ok, fajnie, że się udało, ale...
Na Twoim miejscu i tak zdiagnozowałbym przyczynę, albowiem to co zrobiłeś - aczkolwiek skuteczne - jest mało ergonomiczne :) Może się też zdarzyć, że coś innego będzie się źle wyświetlać, a problem prawdopodobnie tkwi w ustawieniach.
Zróbmy może tak - zajmijmy się tym HP tu obecnie.
Na czym polega problem już wiemy, ale do rozwiązania mamy zbyt mało informacji. Zatem:
1. Zrób to co pisał @TataPingu - zaloguj się na innym użytkowniku. Masz w Antergosie LightDM a on powinien oferować tzw. sesję Gościa - może być. Jeśli nie - to musisz założyć nowego użytkownika np. test. Sprawdź.
Jeśli będzie ok - problem leży w ustawieniach, jakie masz w swoim ~/.config/ - napisz i pomożemy.
Jeśli nie, to przejdź do poniższych punktów.
2. Podaj dane z:
inxi -FxxByć może inxi będziesz musiał doinstalować.
3. Podaj dane z:
env4. Podaj zawartość pliku:
cat ~/.config/Trolltech.conf5. Podaj zawartość pliku:
cat ~/etc/environment
To na początek.
W każdym przypadku - podaj nam jakie DE (KDE/Xfce) masz na tym HP (choć po powyższych danych powinniśmy już wiedzieć).
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: Piejanto w Listopad 08, 2018, 10:47:18 am
pavbaranov.
Dzięki za zaangażowanie. Jeśli chodzi o netbook, to aktualnie mam wszystko z najnowszej edycji. Czyli Antergos 18.11
Jeśli chodzi o polecenia:
[root@piejanto jan]# inxi -Fxx
System:
  Host: piejanto Kernel: 4.18.16-arch1-1-ARCH x86_64 bits: 64 compiler: gcc
  v: 8.2.1 Desktop: Xfce 4.12.4 tk: Gtk 2.24.32 wm: xfwm4 dm: LightDM
  Distro: Antergos Linux 16.9-ISO-Rolling
Machine:
  Type: Laptop System: Hewlett-Packard product: HP 15 Notebook PC
  v: 0974120000405F00000620180 serial: CND5111B6G Chassis: type: 10
  serial: N/A
  Mobo: Hewlett-Packard model: 2214 v: 57.54 serial: PEPYPC51T8FVU3
  UEFI: Insyde v: F.39 date: 05/26/2015
Battery:
  ID-1: BAT1 charge: 32.8 Wh condition: 32.8/41.4 Wh (79%) volts: 17.0/14.8
  model: COMPAL PABAS0241231 serial: 0000 status: Full
CPU:
  Topology: Quad Core model: Intel Pentium N3540 bits: 64 type: MCP
  arch: Silvermont rev: 8 L2 cache: 1024 KiB
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 17332
  Speed: 500 MHz min/max: 500/2666 MHz Core speeds (MHz): 1: 810 2: 588
  3: 577 4: 533
Graphics:
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0f31
  Device-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT
  620M/625M/630M/720M]
  driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:1140
  Display: x11 server: X.Org 1.20.3 driver: intel,nouveau
  unloaded: fbdev,modesetting,vesa alternate: nv resolution: 1366x768~60Hz
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:0f04
  Sound Server: ALSA v: k4.18.16-arch1-1-ARCH
Network:
  Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter
  driver: rtl8723be v: kernel port: 2000 bus ID: 02:00.0 chip ID: 10ec:b723
  IF: wlp2s0 state: up mac: 34:68:95:81:aa:2f
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169
  v: 2.3LK-NAPI port: 1000 bus ID: 04:00.0 chip ID: 10ec:8136
  IF: enp4s0 state: down mac: 5c:b9:01:b5:3c:38
Drives:
  Local Storage: total: 713.12 GiB used: 94.76 GiB (13.3%)
  ID-1: /dev/mmcblk0 model: SA16G size: 14.48 GiB serial: 0x42314d5a
  ID-2: /dev/sda vendor: HGST (Hitachi) model: HTS541075A9E680
  size: 698.64 GiB speed: 3.0 Gb/s serial: JD120A1W1GYS5K
Partition:
  ID-1: / size: 682.54 GiB used: 94.66 GiB (13.9%) fs: ext4 dev: /dev/sda3
  ID-2: /boot size: 239.9 MiB used: 96.5 MiB (40.2%) fs: ext4 dev: /dev/sda2
  ID-3: swap-1 size: 3.75 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4
Sensors:
  System Temperatures: cpu: 39.0 C mobo: 37.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 169 Uptime: 30m Memory: 3.74 GiB used: 917.8 MiB (24.0%)
  Init: systemd v: 239 Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23
  running in: xfce4-terminal inxi: 3.0.26
[root@piejanto jan]#
[root@piejanto jan]# env
XDG_MENU_PREFIX=xfce-
LANG=pl_PL.UTF-8
DISPLAY=:0.0
QT_STYLE_OVERRIDE=gtk
EDITOR=/usr/bin/nano
COLORTERM=truecolor
MOZ_PLUGIN_PATH=/usr/lib/mozilla/plugins
XDG_VTNR=7
SSH_AUTH_SOCK=/tmp/ssh-90QAarxuVSdv/agent.572
HG=/usr/bin/hg
GLADE_CATALOG_PATH=:
XDG_SESSION_ID=1
XDG_GREETER_DATA_DIR=/var/lib/lightdm-data/jan
USER=jan
GLADE_MODULE_PATH=:
DESKTOP_SESSION=xfce
LC_COLLATE=pl_PL.UTF-8
PWD=/home/jan
HOME=/root
BROWSER=/usr/bin/chromium
SSH_AGENT_PID=573
XDG_SESSION_TYPE=x11
XDG_DATA_DIRS=/usr/local/share:/usr/share
XDG_SESSION_DESKTOP=xfce
GLADE_PIXMAP_PATH=:
GTK_MODULES=canberra-gtk-module:canberra-gtk-module
MAIL=/var/spool/mail/jan
VTE_VERSION=5402
SHELL=/bin/bash
TERM=xterm-256color
XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0
XDG_CURRENT_DESKTOP=XFCE
SHLVL=3
XDG_SEAT=seat0
WINDOWID=50331651
GDMSESSION=xfce
LOGNAME=jan
DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
XDG_RUNTIME_DIR=/run/user/1000
XAUTHORITY=/home/jan/.Xauthority
XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session0
XDG_CONFIG_DIRS=/etc/xdg
PATH=/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl
SESSION_MANAGER=local/piejanto:@/tmp/.ICE-unix/556,unix/piejanto:/tmp/.ICE-unix/556
_=/usr/bin/env

[jan@piejanto ~]$ cat ~/.config/Trolltech.conf
[Qt%20Plugin%20Cache%204.8.false]
usr\lib\qt4\plugins\inputmethods\libqimsw-multi.so=40807, 0, x86_64 linux g++-4 full-config, 2017-11-14T08:42:06
usr\lib\qt4\plugins\iconengines\libqsvgicon.so=40807, 0, x86_64 linux g++-4 full-config, 2017-11-14T08:42:06
usr\lib\qt4\plugins\imageformats\libqgif.so=40807, 0, x86_64 linux g++-4 full-config, 2017-11-14T08:42:06
usr\lib\qt4\plugins\imageformats\libqico.so=40807, 0, x86_64 linux g++-4 full-config, 2017-11-14T08:42:06
usr\lib\qt4\plugins\imageformats\libqjpeg.so=40807, 0, x86_64 linux g++-4 full-config, 2017-11-14T08:42:07
usr\lib\qt4\plugins\imageformats\libqmng.so=40807, 0, x86_64 linux g++-4 full-config, 2017-11-14T08:42:06
usr\lib\qt4\plugins\imageformats\libqsvg.so=40807, 0, x86_64 linux g++-4 full-config, 2017-11-14T08:42:06
usr\lib\qt4\plugins\imageformats\libqtiff.so=40807, 0, x86_64 linux g++-4 full-config, 2017-11-14T08:42:06

[Qt%20Factory%20Cache%204.8]
com.trolltech.Qt.QInputContextFactoryInterface%3A\usr\lib\qt4\plugins\inputmethods\libqimsw-multi.so=2017-11-14T08:42:06, imsw-multi
com.trolltech.Qt.QIconEngineFactoryInterfaceV2%3A\usr\lib\qt4\plugins\iconengines\libqsvgicon.so=2017-11-14T08:42:06, svg, svgz, svg.gz
com.trolltech.Qt.QIconEngineFactoryInterface%3A\usr\lib\qt4\plugins\iconengines\libqsvgicon.so=2017-11-14T08:42:06
com.trolltech.Qt.QImageIOHandlerFactoryInterface%3A\usr\lib\qt4\plugins\imageformats\libqgif.so=2017-11-14T08:42:06, gif
com.trolltech.Qt.QImageIOHandlerFactoryInterface%3A\usr\lib\qt4\plugins\imageformats\libqico.so=2017-11-14T08:42:06, ico
com.trolltech.Qt.QImageIOHandlerFactoryInterface%3A\usr\lib\qt4\plugins\imageformats\libqjpeg.so=2017-11-14T08:42:07, jpeg, jpg
com.trolltech.Qt.QImageIOHandlerFactoryInterface%3A\usr\lib\qt4\plugins\imageformats\libqmng.so=2017-11-14T08:42:06, mng
com.trolltech.Qt.QImageIOHandlerFactoryInterface%3A\usr\lib\qt4\plugins\imageformats\libqsvg.so=2017-11-14T08:42:06, svg, svgz
com.trolltech.Qt.QImageIOHandlerFactoryInterface%3A\usr\lib\qt4\plugins\imageformats\libqtiff.so=2017-11-14T08:42:06, tiff, tif
[jan@piejanto ~]$

cat: /home/jan/etc/environment: Nie ma takiego pliku ani katalogu
[jan@piejanto ~]$

Teraz muszę lecieć do roboty, ale po powrocie przypomnę sobie, jak się sprawdza wersje pulpitu. Narazie.
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: TataPingu w Listopad 08, 2018, 11:11:52 am
@Piejanto
A sprawdziłeś w pierwszej kolejności pod innym userem (użytkownikiem), czy wadliwy (u Ciebie) program dobże funkcjonuje ?
- od tego powinieneś zacząć, bo może być tak, że tylko pod Twoim accountem "skićkana" jest konfiguracja "Kaffeiny"

A plik(i) konfiguracyjne powinien być pod:

/home/twójaccount/.config/kaffeine

ewentualnie w:

/home/twójaccount/.kaffeine

Nie wiem dokładnie gdzie, bo akurat nie mam tego programu w użyciu, jednak o ile sobie dobrze przypominam, jest to program pod KDE, więc pliki konfiguracyjne mogą (ale nie muszą) znajdować się ew. pod którymś z:

/home/twójaccount/.kde/.... itd

lub:

/home/twójaccount/.kde4/.... itd
Tytuł: Odp: Problem z TV na Kaffeine prawie ROZWIĄZANY
Wiadomość wysłana przez: Albedo 0.64 w Listopad 08, 2018, 12:57:01 pm
PROBLEM prawie ROZWIĄZANY

Natomiast jeśli chodzi o HP. Odinstalowałem Kaffeine, zresetowałem komputer, a następne znów zainstalowałem Kaffeine. Niestety, ustawienia pozostają gdzieś w pamięci i po reinstalacji Kaffeine ma poprzednio zapamiętane ustawienia i zapamiętane kanały. Niczego się z tym chyba nie da zrobić, chyba, że reinstalować system, ale - jak to już mówiłem - najbardziej zależało mi na odbiorze TV na netbooku.


Prawie czyni wielką różnicę. Reinstalacja programu nie usuwa plików konfiguracyjnych z katalogu użytkownika dlatego nic ci to nie dało. Znajdź ukryte katalogi i pliki Kaffeine (te z kropką z przodu) w swoim katalogu domowym i je wykasuj. Po uruchomieniu programu Kaffeine utworzy sobie nowe z konfiguracją domyślną.
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: pavbaranov w Listopad 08, 2018, 01:49:14 pm
1. Pliki konfigurujące Plasmę są w ~/.config/. W tym przypadku to ~/.config/kaffeinerc. Zawartość tego pliku nic nam jednak nie powie, albowiem on kompletnie nie odpowiada za ustawienia dotyczące menedżera okien.
@Piejanto
2. DE już mamy - nie trudź się.
3. Jaki motyw używasz w Xfce?
4. Sprawdź, czy masz zainstalowane kde-gtk-config - jeśli nie spróbuj zainstalować i zobacz, czy coś to zmienia. Podobnie paczka breeze-gtk. Jeśli nic nie zmieniło - usuń.
5. Istnieje prawdopodobieństwo, że kaffeine chce użyć KDialog, którego nie znajduje i w jego miejsce używa (lepiej, lub gorzej) jakiegoś okna dialogowego generowanego przez Gtk. Znów - spróbuj zainstalować kdialog i sprawdź.
6. Masz hybrydową grafikę w tym komputerze i nie mogę się dopatrzeć której karty obecnie używasz, ale to jest prawdopodobnie Intel na xf86-video-intel (to ostatnie na pewno).
7. Pokaż mi jeszcze proszę jakie paczki z grup: plasma, kf5, kf5-aids, qt masz zainstalowane - ogólne polecenie:
pacman -Qg grupagdzie "grupa" jw.
Jeśli te proste zabiegi nie pomogą, to będziemy ustawiać nieco inaczej.

PS: Robimy lekki porządek w systemie. Czy na pewno jest Ci potrzebne jeszcze Qt4?
pacman -Qi qt4
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: Piejanto w Listopad 08, 2018, 03:55:14 pm
Dla mnie nie ulega wątpliwości, że okno do skanownia kanałów tv w Kaffeine jest felerne. Ważne aby wiedzieć, że w końcowym etapie nie należy szukać buttonu "OK" czy "zastosuj" aby weń kliknąć myszą, lecz po prostu należy wówczas kliknąć "enter".
Problem raczej nie dotyczy wielu osób, gdyż zdecydowana większość ogląda tv na televizjonach. Ja się uparłem, że nie będę dokładał do oglądania cudzych reklam i televizjona nie nabyłem. No, ale lubię sobie czasem obejrzeć coś popularnonaukowego na "Fokusie" lub innym programie na tyle ambitnym aby puszczać jedynie programy w stylu "powiedz większą liczbę".

Natomiast - w wyniku naszej tutaj walki o panowanie nad systemem - pomyślałem sobie, jak pozbyć się katalogów, w które uparcie trafia Kaffeine po przeinstalowaniu.
Ciekawi mnie też DLACZEGO, po "wielkiej aktualizacji" nagle okno przestało reagować na polecenie skanowania kanałów. DLACZEGO pokazuje, że kanał jest odtwarzany, a ekran pozostaje czarny?
Jak już rzekłem, teraz to już nie jest "palący problem" ale zwukła ciekawość.

Na HP mam w repozytorium Kaffeine 2.0.15-1 Ale po reinstalacji włązi w "stare buty", być może z tego samego wydania.
Sprawdziłem na netbooku po wczorajszej reinstalacji systemu, i jest Kaffeine w tej samej wersji. Wróciłem do pulpitu XFCE, gdyż KDE jest dla mnie zbyt uporządkowany i - jako furiat - nie mam do niego po prostu cierpliwości.
 
Na HP wersja Antergosa
[root@piejanto jan]# uname -a
Linux piejanto 4.18.16-arch1-1-ARCH #1 SMP PREEMPT Sat Oct 20 22:06:45 UTC 2018 x86_64 GNU/Linux
[root@piejanto jan]# cat /etc/issue
Antergos Linux \r (\l)
[root@piejanto jan]# pacman -Qi qt4
Nazwa                 : qt4
Wersja                : 4.8.7-26
Opis                  : A cross-platform application and UI framework
Architektura          : x86_64
Adres url             : http://www.qt.io
Licencje              : GPL3  LGPL  FDL  custom
Grupy                 : Brak
Dostarcza             : Brak
Zależy od             : sqlite  ca-certificates  fontconfig  libgl  libxrandr
                        libxv  libxi  alsa-lib  xdg-utils  hicolor-icon-theme
                        desktop-file-utils  libmng  dbus
Opcjonalne zależności : postgresql-libs: PostgreSQL driver
                        libmariadbclient: MariaDB driver
                        unixodbc: ODBC driver
                        libfbclient: Firebird/iBase driver [zainstalowano]
                        libxinerama: Xinerama support [zainstalowano]
                        libxcursor: Xcursor support [zainstalowano]
                        libxfixes: Xfixes support [zainstalowano]
                        icu: Unicode support [zainstalowano]
                        sni-qt: StatusNotifierItem (AppIndicators) support
Wymagany przez        : libqzeitgeist  phonon-qt4  pyqt4-common
Opcjonalny dla        : avahi  suil
Komfliktuje z         : qt
Zastępuje             : qt<=4.8.4
Rozmiar po instalacji : 86,11 MiB
Autor pakietu         : Felix Yan <felixonmars@archlinux.org>
Data zbudowania       : pon, 22 paź 2018, 23:10:59
Data zainstalowania   : wto, 30 paź 2018, 00:17:04
Powód zainstalowania  : Zależność innego pakietu
Skrypt instalacyjny   : Nie
Potwierdzone przez    : Podpis

[root@piejanto jan]#
[root@piejanto jan]# pacman -Qg plasma
plasma libksysguard
[root@piejanto jan]# pacman -Qg kf5
kf5 attica
kf5 kactivities
kf5 karchive
kf5 kauth
kf5 kbookmarks
kf5 kcmutils
kf5 kcodecs
kf5 kcompletion
kf5 kconfig
kf5 kconfigwidgets
kf5 kcoreaddons
kf5 kcrash
kf5 kdbusaddons
kf5 kdeclarative
kf5 kglobalaccel
kf5 kguiaddons
kf5 ki18n
kf5 kiconthemes
kf5 kio
kf5 kitemviews
kf5 kjobwidgets
kf5 knewstuff
kf5 knotifications
kf5 knotifyconfig
kf5 kpackage
kf5 kparts
kf5 kpty
kf5 kservice
kf5 ktextwidgets
kf5 kwallet
kf5 kwidgetsaddons
kf5 kwindowsystem
kf5 kxmlgui
kf5 purpose
kf5 solid
kf5 sonnet
kf5 threadweaver
[root@piejanto jan]#
[root@piejanto jan]# pacman -Qg kf5-aids
kf5-aids kjs

[root@piejanto jan]# pacman -Qg qt
qt qt5-base
qt qt5-declarative
qt qt5-location
qt qt5-multimedia
qt qt5-script
qt qt5-sensors
qt qt5-serialport
qt qt5-speech
qt qt5-svg
qt qt5-webchannel
qt qt5-webengine
qt qt5-webkit
qt qt5-x11extras
qt qt5-xmlpatterns
[root@piejanto jan]#
Teraz spróbuję sposobu z dodatkowym userem
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: Piejanto w Listopad 08, 2018, 04:22:45 pm
Albedo
Sprawdziłęm "katalogi z kropką na początku" w moim katalogu. Znalazłem pozostałości po programie Tvtime (/.tvtime ), który kiedyś próbowałem wrzucić jako alternatywę Kaffeine. Oczywiście wywaliłem. Sprawdziłem też pliki z kropką na początku i też nie ma niczego co by wyglądało w swojej szarości jak [.kaffeine]
Niestety nie widzę niczego, co by wyglądało jak /.kaffeine albo jak .kaffeine albo coś w tym rodzaju. To się może zresztą jakoś inaczej nazywać. Znalazłem  ~/.config/vlc ale niczego, co by przypominało Kaffeine.

TataPingu

Nie wpadłem na to. Faktycznie. Nowemu użytkownikowi Kaffeine powinno pozwolić przeskanować programy. Spróbuję. 
Choćby dla zasady. Muszę tylko trochę ogarnąć, gdzie, co i jak.

Jak już wspominałem - na dwu wcześniej omawianych maszynkach (ACER-y netbook i laptop) TV na Kaffeine już działa. Zatem obecna robota jest pracą ze wszech miar poznawczą, choć niekoniecznie dla mnie nieodzowną.

Spróbuję teraz z tym nowym userem.
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: pavbaranov w Listopad 08, 2018, 04:27:09 pm
Poproszę o resztę z tego o co pytałem.

PS: Jeśli chodzi o Qt4, to sprawdź sobie to co widzi jako "wymagany przez" czy dalej z tego korzystasz/potrzebujesz. To na inny wątek.
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: Piejanto w Listopad 08, 2018, 08:03:09 pm
TataPingu
Wpisałem mu [adduser imię] zresztą... Proszsz
[root@piejanto jan]# adduser tom
bash: adduser: nie znaleziono polecenia

No, to mu wpisałem [useradd] i dodał nowego użytkownika. Teraz szukam GDZIE? jest ten cholerny nowy użytkownik. A jest napewno bo:
[root@piejanto jan]# useradd tom
useradd: user 'tom' already exists

pavbaranov
wykonam wszystko jak każesz, ale dziś już padłem. Dobrej nocy.

Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: TataPingu w Listopad 08, 2018, 11:13:55 pm
@Piejanto
Po kolei,
- w nawiązaniu do konfiguracyjnego pliku Kaffeiny, to powinien znajdować się pod:

/home/twójaccount/.kde/share/apps/kaffeine

lub

/home/twójaccount/.kde4/share/apps/kaffeine

Co do testowego usera tom, to problemem może być, że podczas tworzenia nowego usera nie przyporządkowałeś go do żadnej grupy.

Najlepiej gdybyś to zrobił jakimś graficznym GUI i wciągnął usera tom do tych samych grup w których Ty jesteś.

W terminalu można to tak osiągnąć (wciągasz toma do grupy users):

sudo adduser tom users

Na pewno musiałbyś go jeszcze wciągnąć do grupy video i innych.
Najlepiej zerknij do pliku /etc/group w jakich Ty jesteś grupach i toma również tam wciągnij

sudo adduser tom video

itd.

Po wszystkim najlepiej wystartuj ponownie PCta
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: pavbaranov w Listopad 09, 2018, 08:13:09 am
@TataPingu - plik konfiguracyjny kaffeine jest w ~/.config/kaffeinerc. Plik ten nie posiada żadnych ustawień dotyczących wyświetlania okien tej aplikacji (jak zresztą żaden plik, żadnej aplikacji KDE, albowiem aplikacje to oddają to menedżerom okien).

@Piejanto - prawdopodobnie nie musisz tworzyć nawet żadnego użytkownika, bo jeśli w Antergosie sesja gościa nie została usunięta, to LightDM, którego używasz oferuje ją domyślnie. Sprawdź, czy w Ekranie logowania nie masz oprócz Twojego użytkownika sesji "Gość/Guest".
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: TataPingu w Listopad 09, 2018, 09:13:08 am
@pavbaranov
- może tam również, tam nie zaglądałem.
Pofatygowałem się wczoraj i spojrzałem na znajomym PC-cie (zdalnie, t.j. remote), na którym ten program jest używany, gdzie znajdują się te pliki. Właśnie tam je znalazłem.
Czym "sterują" i jakiej wersji kaffeine dotyczą, tego nie analizowałem. Na pewno był tam też plik z naniesionymi kanałami.

@Piejanto
Osobiścieie, podobnie, jak Ty, TV oglądam (jeśli w ogóle oglądam!) na swojej stacjonarce. Używam do tego celu programu MythTV. Ma to określone powody, mam zainstalowaną Sat-TV z 2 satelitami (2 x LNB), więc nie każdy program nadaje się do odbioru. Program jest jednak bardzo skomplikowany w początkowej fazie konfiguracji, więc nie polecam.
Zanim jednak do tego doszedłem, potestowałem kilka programów, które umożliwiają odbiór TV pod linuksem.
Piszesz w którymś momencie, że znalazłeś konfiguracyjny plik "tvtime". Program jest bardzo dobry, ale przeznaczony jest do odbioru analogowej TV.
W tym miejscu dochodzę do sedna, jaki masz odbiornik TV, w postaci karty, USB, analogowy (w niektórych regionach jeszcze możliwy taki dbór TV - po kablu), czy już cyfrowy ?
Wychodzę z założenia, że raczej już cyfrowy i jest to USB do odbioru DVB-C, lub DVB-T.

Jeśli tylko oglądasz TV, to również dobrym (i bardzo prostym) programem jest "me-tv" (Me-TV). Wiem, kaffeine jest bardzo fajnym programem, ale niekiedy sprawia kłopoty.
Właściwie to TV można odbierać nawet VLC, czy SMPlayerem (MPlayer), jedynie za pomocą w-scan (w terminalu man w-scan) trzeba przygotować im listę kanałów.
Dobrym rozwiązaniem może być też kodi, który posiada również interfejs TV.
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: pavbaranov w Listopad 09, 2018, 11:03:50 am
@TataPingu - @Piejanto ma Antergosa (czyli Archa w zasadzie). Kaffeine jest tu w wersji opartej o KF5 od długiego czasu. Lokalizacje, które podajesz pewnie w istocie zawierają listę stacji, niemniej jednak taka jak ~/.kde w Archu w ogóle nie istnieje, a w ~/.kde4/ zasadniczo są trzymane tylko "pliki zgodności" z aplikacjami, które mają jeszcze coś wspólnego z KDE4 lub są tu pliki pozostawione po starszych wersjach programów.
Podstawowy plik, w którym kaffeine (2.0.15, a taką wersję winien @Piejanto mieć) trzyma swoje ustawienia w pliku ~/.config/kaffeinerc. Listy stacji TV nie wygeneruję dla niego, ale prawdopodobnie szukać jej można w ~/.local/share/coś. Przynajmniej tak winno być. Jeśli nie, to w istocie jest w ~/.kde4/apps/.
Zasadniczy jednak problem @Piejanto polega na tym, że jedno z okien dialogowych Kaffeine nie mieści się u @Piejanto na wyświetlanym pulpicie w Xfce.

Sam plik kaffeinerc ma mniej więcej taką zawartość (komentarze moje po #):
[DVB] # To sekcja dot. DVB i nie wiem, czy te AAAAitd. w każdym przypadku wyglądają tak samo oraz co znaczą
ChannelViewState=AAAA/wAAAAAAAAABAAAAAQAAAAABAAAAAAAAAAAAAAAAAAAAAAAAAMgAAAACAQEAAQAAAAAAAAAAAAAAAGT/////AAAAgQAAAAAAAAACAAAAZAAAAAEAAAAAAAAAZAAAAAEAAAAAAAAD6AAAAABk
LastChannel=
TabSplitterState=AAAA/wAAAAEAAAACAAAAkgAAAAAB/////wEAAAABAA==

[KFileDialog Settings] # Tu jest wyłącznie lista ostatnio otwieranych plików bądź lokalizacji
Recent Files[$e]=
Recent URLs[$e]=

[MainWindow] # Dotyczy wyglądu okna głównego programu
DisplayMode=0
StartupDisplayMode=0

[MediaObject] # Dotyczy sposobu odtwarzania o ile wiem
AutoResizeFactor=0
Deinterlace=0
LongSkipDuration=60
ShortSkipDuration=15
Volume=96

[libVlc] # Ustawienia dla biblioteki libvlc
Arguments=--no-video-title-show

Nic więcej tu nie ma i nie znalazłem też precyzyjnego opisu co jeszcze mogłoby by być. Niemniej jednak na pewno nie ma tu miejsca na ustawienia wielkości okien dialogowych, którego to ustawienia zresztą Xfce i tak by nie zinterpretował.

MeTV @Piejanto już próbował, ale niestety u niego z jakichś powodów to nie działa. Być może to kwestia jakichś bibliotek, które w Archu są po prostu zbyt nowe (wszak to program, który w tej wersji, która dostępna jest w AUR pochodzi z 2014 r, a ostatni commit, jaki nakłada jest ze stycznia 2016 i nie tylko on jest mało istotny, albowiem większość commitów od wersji 1.4.0 dotyczy jakichś usprawnień w zakresie tłumaczeń; samo MeTV opiera się natomiast na libvlc, które w Archu również jest w wersji z VLC 3.x, podczas, gdy MeTV było opracowywane z uwzględnieniem wersji 2.x tej biblioteki; wprawdzie widzę, że jakieś zmiany do PKGBUILDu są wprowadzane, ale z komentarzy wynika, że w Archu ta aplikacja działa raczej po macoszemu). Tematu jednak nie drążyliśmy.
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: TataPingu w Listopad 09, 2018, 12:41:56 pm
@pavbaranov
No właśnie, m. in. z takich powodów doradzam użytkownikom pokroju @Piejanto (w niczym mu nie ujmując) coś, może i nie tak aktualnego, ale bardziej stabilnego i pewnego.

Prawdopodobnie na jakimś "lts"-ie nie miałby tych kłopotów...

Oczywiście, teraz jestem świadom, jak wygląda jego sytuacja i chyba lepiej będzie "uratować", albo "wyprostować" mu OSa, niż wgrywać na czysto jakiegoś LTSa

Tylko na jak długo?
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: pavbaranov w Listopad 09, 2018, 01:11:42 pm
@TataPingu - A LTS na jak długo? 3-5 lat? A potem? W przypadku oprogramowania, które jest tu istotne (Kaffeine, KF5, Qt5) dodatkowym bonusem używania LTS jest brak jakiegokolwiek wsparcia od kogokolwiek w przypadku problemów z wersjami tego oprogramowania zainstalowanymi na takim LTS.

Arch/Antergos jest doprawdy w miarę bezproblemowy, ale pod warunkiem, że go się właściwie skonfiguruje. Skupmy się na tym. Zakładając, że kaffeine jest prawidłowo napisane (a nie mam prawa sądzić inaczej), to nie ma na stałe "wbitej" wielkości okien dialogowych. Niestety nie wiem czy są one z KDE, czy z Xfce (może jakiś zrzut ekranu mógłby coś podpowiedzieć, zwłaszcza okna "Otwórz" bo w obu przypadkach diametralnie się różni); nie bardzo też wiem jak to sprawdzić.
Problem zatem leży najprawdopodobniej albo w braku jakiejś paczki (np. kdialog), albo w braku odpowiedniego "silnika" dla wyświetlania aplikacji Qt5/KF5 w środowisku Gtk, albo na niewłaściwym skonfigurowaniu tych aplikacji w Xfce.

Zdaje się, że w Xfce jest jeszcze dostępne takie ustawienie: Programy -> Ustawienia -> Ustawienia Qt5. Może coś tutaj można jeszcze pokombinować.
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: TataPingu w Listopad 09, 2018, 01:28:39 pm
@pavbaranov
Te 5 lat można używać, a potem....
- i tu już czysto teoretyzuję (ale na podstawie moich doświadczeń!), najczęściej sprzęt jest na tyle "przestarzały", że większość użytkowników i tak decyduje się na nowy...
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: pavbaranov w Listopad 09, 2018, 02:05:09 pm
@TataPingu - I tak bym się nie zgodził na bez żadnego wsparcia: program (kaffeine) oraz dwie podstawowe biblioteki, na których jest oparty: KF5 (wsparcie wynosi w zasadzie miesiąc), Qt5 (najdłuższe bodaj 18 miesięcy dla wersji LTS). Komu zgłosisz problem (nie mówię o jakiejś kwestii związanej z bezpieczeństwem), gdy coś się zawali? Debianowi? (K)Ubuntu? Mint? Sorry, ale oni się po prostu na tym nie znają, nie prowadzą tych źródeł, a i w Qt i w KDE odpowiedzią będzie: zainstaluj współczesne oprogramowanie, albowiem to, w którym zgłaszasz błąd nie jest wspierane (i to jest słuszne stwierdzenie). Jestem również prawie pewny, że nie otrzymasz nigdzie wsparcia na żadnym forum takiego LTSa.
Zresztą @Piejanto wybrał sobie już system. Spróbujmy go naprawić.
I sorry za OT.
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: TataPingu w Listopad 09, 2018, 03:23:11 pm
@pavbaranov
We wszystkim się z Tobą Kolego zgadzam, tylko...
- tak wygląda to z "naszej" strony...

Nie wiem na ile miałeś doświadczeń z "użytkownikami" PC-tów, ale ja takowe mam już prawie 30 lat.
I to nie tylko linuks...
- DOS-WIN, OS2, Win95, 2000 i późniejsze.
O takich rzeczach, jak różnego typu serwery nie wspominam.

Większość z nich cechowało: "jak najmniej obsługi, ale wszystko ma chodzić!"

Zresztą, to nie ja wpadłem na "pomysł" LTSów, to "praktyka" użytkowników "wymusiła" tworzenie czegoś takiego. Zwykłych Kowalskich nie interesują "wsparcia, bezpieczeństwo" itp., sprzęt ma funkcjonować i koniec.

Szczerze powiedziawszy, to wiem, że większość z tych, którym kiedyś tam przygotowałem PCty nie pofatyguje się nawet do aktualizacji systemu, a co dopiero mówić o jakichś upgradach, czy zmianie OSa na aktualny.
Ba, znam takich, którzy do dzisiaj "siedzą" jeszcze na SuSE 10.2 !
- "peryferie działają, programy chodzą to po co mam zmieniać?", to ich "motto"...
Nie "uszczęśliwiam", więc nikogo na siłę (jak M$ i sółka)...
Jedyne co, to informuję o zagrożeniu, ale decyzja należy do użytkownika...

Przy takim postępowaniu użytkowników, raz skonfigurowany system działa bez problemu...

I o dziwo, wszystkie historie o potencjalnych "zagrożeniach" nie znalazły jakoś miejsca...
- już od dłuższego czasu rozmyślam postawić jakiś "przestarzały" system i trochę go potestować pod kątem tych "zagrożeń"...
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: Piejanto w Listopad 09, 2018, 06:17:37 pm
TataPingu.

Mam dwa odbiorniki (modemy) Overmax OV-TN-01A i OV-TN-01B. Oba chodzą na tym samym firmwsare. Obecne wersje Antergosa zawierają już firmware do tych obu modemów, więc po zainstalowaniu Antergosa nie miewam już problemu z wklepaniem obsługi. Kaffeine znajduje je oba natychmiast i bez problemów. Muszę tylko zmienić pole przeszukiwania na "Automatyczny" i "naziemny" sam się ustawia. Następnie trzeba iść do okna "Kanały" i owo właśnie okno jest felerne, ale - jakem to już przez przypadek ustalił - wystarczy po "dodaniu wybranych" przyklepać je "Enterem".
Niestety maszynka której najczęściej używam, ma tylko 2GB operacyjnej i KDE ładuje mi się tydzień. Ponadto, jak już mówiłem, KDE, to nie jest pulpit dla furiatów i nie mam do niego cierpliwości. Dlatego wróciłem do XFCE. 
Wielkość ekranu netbooka, wcale mi nie przeszkadza, gdyż tv leci mi zazwyczaj w tle, a gdy trzeba oglądać, (popularnonaukowe) wtedy i tak muszę oglądać z odległości cca 50 cm, bo przyu większej odległości tracę ostrość widzenia.
Odbieram naziemną w Łodzi z użyciem firmowej antenki, gdyż nadajnik mam o kilometr na kominie elektrowni, a  gdy pojadę pod Jarocin, tam mam regularną antenę i też pięknie.
Kiedyś też używałem HP do oglądania TV, ale - jak już opowiadałem - zasięg komórkowy dla Aero2 (na wyjeździe) mam tylko w kuchni od strony północnej, zaś antenę i zasięg televizyjny mam w pokoju od strony południowej. W tej sytuacji, pracuję i korzystam z internetu w kuchni, a gdy słyszę. że leci coś ciekawego w TV, idę do pokoju, więc HP nie wymaga koniecznie odbioru televizyjnego, choć przyznam, że nie przeszkadzałoby mi, gdyby miał.  No, ale to już dążenie do luxusu.
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: pavbaranov w Listopad 09, 2018, 06:45:05 pm
@Piejanto - Janek, skoro się już objawiłeś, to:
1. inxi - po prostu zainstaluj, jest w repozytorium i podaj te wyniki, o które prosiłem.
2. Zrób też to: https://linuxiarze.pl/forum/index.php/topic,3140.msg16496.html#msg16496 (https://linuxiarze.pl/forum/index.php/topic,3140.msg16496.html#msg16496) - pkt. 4 i 5.
3. Pokaż wynik: lspci -vnnn | perl -lne 'print if /^\d+\:.+(\[\S+\:\S+\])/' | grep VGA4. Masz aktualnie zainstalowane qt5ct?
5. Motyw Xfce.
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: Piejanto w Listopad 09, 2018, 07:08:50 pm
pavbaranov

qt5ct zainstalowałem, jak kazałeś.
Teraz to o co prosiłeś. Longiem:
[root@piejanto jan]# env
XDG_MENU_PREFIX=xfce-
LANG=pl_PL.UTF-8
DISPLAY=:0.0
QT_STYLE_OVERRIDE=gtk
EDITOR=/usr/bin/nano
COLORTERM=truecolor
MOZ_PLUGIN_PATH=/usr/lib/mozilla/plugins
XDG_VTNR=7
SSH_AUTH_SOCK=/tmp/ssh-uGRmn2th2sOv/agent.785
HG=/usr/bin/hg
GLADE_CATALOG_PATH=:
XDG_SESSION_ID=1
XDG_GREETER_DATA_DIR=/var/lib/lightdm-data/jan
USER=jan
GLADE_MODULE_PATH=:
DESKTOP_SESSION=xfce
LC_COLLATE=pl_PL.UTF-8
PWD=/home/jan
HOME=/root
BROWSER=/usr/bin/chromium
SSH_AGENT_PID=790
XDG_SESSION_TYPE=x11
XDG_DATA_DIRS=/usr/local/share:/usr/share
XDG_SESSION_DESKTOP=xfce
GLADE_PIXMAP_PATH=:
GTK_MODULES=canberra-gtk-module:canberra-gtk-module
MAIL=/var/spool/mail/jan
VTE_VERSION=5402
SHELL=/bin/bash
TERM=xterm-256color
XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0
XDG_CURRENT_DESKTOP=XFCE
SHLVL=3
XDG_SEAT=seat0
WINDOWID=39845891
GDMSESSION=xfce
LOGNAME=jan
DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
XDG_RUNTIME_DIR=/run/user/1000
XAUTHORITY=/home/jan/.Xauthority
XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session0
XDG_CONFIG_DIRS=/etc/xdg
PATH=/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl
SESSION_MANAGER=local/piejanto:@/tmp/.ICE-unix/726,unix/piejanto:/tmp/.ICE-unix/726
_=/usr/bin/env
[root@piejanto jan]#
**********************************
[jan@piejanto ~]$ cat ~/.config/Trolltech.conf
[Qt%20Plugin%20Cache%204.8.false]
usr\lib\qt4\plugins\inputmethods\libqimsw-multi.so=40807, 0, x86_64 linux g++-4 full-config, 2017-11-14T08:42:06
usr\lib\qt4\plugins\iconengines\libqsvgicon.so=40807, 0, x86_64 linux g++-4 full-config, 2017-11-14T08:42:06
usr\lib\qt4\plugins\imageformats\libqgif.so=40807, 0, x86_64 linux g++-4 full-config, 2017-11-14T08:42:06
usr\lib\qt4\plugins\imageformats\libqico.so=40807, 0, x86_64 linux g++-4 full-config, 2017-11-14T08:42:06
usr\lib\qt4\plugins\imageformats\libqjpeg.so=40807, 0, x86_64 linux g++-4 full-config, 2017-11-14T08:42:07
usr\lib\qt4\plugins\imageformats\libqmng.so=40807, 0, x86_64 linux g++-4 full-config, 2017-11-14T08:42:06
usr\lib\qt4\plugins\imageformats\libqsvg.so=40807, 0, x86_64 linux g++-4 full-config, 2017-11-14T08:42:06
usr\lib\qt4\plugins\imageformats\libqtiff.so=40807, 0, x86_64 linux g++-4 full-config, 2017-11-14T08:42:06

[Qt%20Factory%20Cache%204.8]
com.trolltech.Qt.QInputContextFactoryInterface%3A\usr\lib\qt4\plugins\inputmethods\libqimsw-multi.so=2017-11-14T08:42:06, imsw-multi
com.trolltech.Qt.QIconEngineFactoryInterfaceV2%3A\usr\lib\qt4\plugins\iconengines\libqsvgicon.so=2017-11-14T08:42:06, svg, svgz, svg.gz
com.trolltech.Qt.QIconEngineFactoryInterface%3A\usr\lib\qt4\plugins\iconengines\libqsvgicon.so=2017-11-14T08:42:06
com.trolltech.Qt.QImageIOHandlerFactoryInterface%3A\usr\lib\qt4\plugins\imageformats\libqgif.so=2017-11-14T08:42:06, gif
com.trolltech.Qt.QImageIOHandlerFactoryInterface%3A\usr\lib\qt4\plugins\imageformats\libqico.so=2017-11-14T08:42:06, ico
com.trolltech.Qt.QImageIOHandlerFactoryInterface%3A\usr\lib\qt4\plugins\imageformats\libqjpeg.so=2017-11-14T08:42:07, jpeg, jpg
com.trolltech.Qt.QImageIOHandlerFactoryInterface%3A\usr\lib\qt4\plugins\imageformats\libqmng.so=2017-11-14T08:42:06, mng
com.trolltech.Qt.QImageIOHandlerFactoryInterface%3A\usr\lib\qt4\plugins\imageformats\libqsvg.so=2017-11-14T08:42:06, svg, svgz
com.trolltech.Qt.QImageIOHandlerFactoryInterface%3A\usr\lib\qt4\plugins\imageformats\libqtiff.so=2017-11-14T08:42:06, tiff, tif
[jan@piejanto ~]$
**********************************
[jan@piejanto ~]$ cat ~/etc/environment
cat: /home/jan/etc/environment: Nie ma takiego pliku ani katalogu
[jan@piejanto ~]$
[root@piejanto jan]# inxi -Fxx
System:
  Host: piejanto Kernel: 4.18.16-arch1-1-ARCH x86_64 bits: 64 compiler: gcc
  v: 8.2.1 Desktop: Xfce 4.12.4 tk: Gtk 2.24.32 wm: xfwm4 dm: LightDM
  Distro: Antergos Linux 16.9-ISO-Rolling
Machine:
  Type: Laptop System: Hewlett-Packard product: HP 15 Notebook PC
  v: 0974120000405F00000620180 serial: CND5111B6G Chassis: type: 10
  serial: N/A
  Mobo: Hewlett-Packard model: 2214 v: 57.54 serial: PEPYPC51T8FVU3
  UEFI: Insyde v: F.39 date: 05/26/2015
Battery:
  ID-1: BAT1 charge: 32.9 Wh condition: 32.9/41.4 Wh (79%) volts: 16.9/14.8
  model: COMPAL PABAS0241231 serial: 0000 status: Full
CPU:
  Topology: Quad Core model: Intel Pentium N3540 bits: 64 type: MCP
  arch: Silvermont rev: 8 L2 cache: 1024 KiB
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 17332
  Speed: 527 MHz min/max: 500/2666 MHz Core speeds (MHz): 1: 500 2: 500
  3: 823 4: 705
Graphics:
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0f31
  Device-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT
  620M/625M/630M/720M]
  driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:1140
  Display: x11 server: X.Org 1.20.3 driver: intel,nouveau
  unloaded: fbdev,modesetting,vesa alternate: nv resolution: 1366x768~60Hz
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:0f04
  Sound Server: ALSA v: k4.18.16-arch1-1-ARCH
Network:
  Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter
  driver: rtl8723be v: kernel port: 2000 bus ID: 02:00.0 chip ID: 10ec:b723
  IF: wlp2s0 state: up mac: 34:68:95:81:aa:2f
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169
  v: 2.3LK-NAPI port: 1000 bus ID: 04:00.0 chip ID: 10ec:8136
  IF: enp4s0 state: down mac: 5c:b9:01:b5:3c:38
Drives:
  Local Storage: total: 713.12 GiB used: 94.93 GiB (13.3%)
  ID-1: /dev/mmcblk0 model: SA16G size: 14.48 GiB serial: 0x42314d5a
  ID-2: /dev/sda vendor: HGST (Hitachi) model: HTS541075A9E680
  size: 698.64 GiB speed: 3.0 Gb/s serial: JD120A1W1GYS5K
Partition:
  ID-1: / size: 682.54 GiB used: 94.83 GiB (13.9%) fs: ext4 dev: /dev/sda3
  ID-2: /boot size: 239.9 MiB used: 96.5 MiB (40.2%) fs: ext4 dev: /dev/sda2
  ID-3: swap-1 size: 3.75 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4
Sensors:
  System Temperatures: cpu: 39.0 C mobo: 38.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 172 Uptime: 2h 54m Memory: 3.74 GiB used: 1.80 GiB (48.1%)
  Init: systemd v: 239 Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23
  running in: xfce4-terminal inxi: 3.0.26
[root@piejanto jan]#
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: Piejanto w Listopad 09, 2018, 07:19:29 pm
Jeśli chodzi o:
"PS: Jeśli chodzi o Qt4, to sprawdź sobie to co widzi jako "wymagany przez" czy dalej z tego korzystasz/potrzebujesz. To na inny wątek."

NIe wiem, co to jest i do czego służy :   libqzeitgeist ;  phonon-qt4 ; pyqt4-common

[root@piejanto jan]# pacman -Qi qt4
Nazwa                 : qt4
Wersja                : 4.8.7-26
Opis                  : A cross-platform application and UI framework
Architektura          : x86_64
Adres url             : http://www.qt.io
Licencje              : GPL3  LGPL  FDL  custom
Grupy                 : Brak
Dostarcza             : Brak
Zależy od             : sqlite  ca-certificates  fontconfig  libgl  libxrandr
                        libxv  libxi  alsa-lib  xdg-utils  hicolor-icon-theme
                        desktop-file-utils  libmng  dbus
Opcjonalne zależności : postgresql-libs: PostgreSQL driver
                        libmariadbclient: MariaDB driver
                        unixodbc: ODBC driver
                        libfbclient: Firebird/iBase driver [zainstalowano]
                        libxinerama: Xinerama support [zainstalowano]
                        libxcursor: Xcursor support [zainstalowano]
                        libxfixes: Xfixes support [zainstalowano]
                        icu: Unicode support [zainstalowano]
                        sni-qt: StatusNotifierItem (AppIndicators) support
Wymagany przez        : libqzeitgeist  phonon-qt4  pyqt4-common
Opcjonalny dla        : avahi  suil
Komfliktuje z         : qt
Zastępuje             : qt<=4.8.4
Rozmiar po instalacji : 86,11 MiB
Autor pakietu         : Felix Yan <felixonmars@archlinux.org>
Data zbudowania       : pon, 22 paź 2018, 23:10:59
Data zainstalowania   : wto, 30 paź 2018, 00:17:04
Powód zainstalowania  : Zależność innego pakietu
Skrypt instalacyjny   : Nie
Potwierdzone przez    : Podpis

Nie wiem, co to jest i do czego służy :   libqzeitgeist ;  phonon-qt4 ; pyqt4-common
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: Piejanto w Listopad 09, 2018, 07:24:11 pm
TataPingu

"~/.local/share/coś. Przynajmniej tak winno być."

Jest:

  ~/.local/share/kaffeine/     a tam:
config.dvb
epgdata.dvb
playlistK4
scanfile.dvb
sqlite.db     (jest na czerwono i nie wiem co to znaczy)

Spróbuję wszystkie szare pozycje wywalić i zostawię tylko ostatnią, czerwoną.
Zobaczymy, co się stanie.
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: pavbaranov w Listopad 09, 2018, 07:40:41 pm
Ok, poprawka:
cat /etc/environment
Spróbuj zainstalować kdialog - może to coś da.

Jeśli chodzi o paczki z qt4, to możesz prawdopodobnie wszystko wywalić. Qt4, python-qt4, pyqt4-common raczej do niczego Ci nie jest potrzebne podobnie libqzeitgeist (to w ogóle jakaś staroć chyba). Oczywiście trzeba być ostrożnym. W razie czego - osobny wątek, choć temat sam wywołałem.

@TataPingu - wiem, że to próba jakiegoś obejścia, ale i tak nie zmieni to wielkości okna.
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: Piejanto w Listopad 09, 2018, 07:51:56 pm
TataPingu

  Spróbowałem, ale okno głupiało
Wywaliłem też ten czerwony

sqlite.db

I wtedy stał się cud
 Kaffeine zachowało się tak jakby dopiero co było zainstalowane. Nie widziało "utrządzenia" wszedłem w "ustawienia televizji" i wrzuciłem mu "automatyczne przeszukiwanie"
Następnie przeszedłem do "kanały" i kazałem przeskanować
Przeskanował i "dodałem wybrane"
Uwaga:
To okno widać w całości i działa poprawnie. Widać dolne buttony [cancel] oraz [OK]
kliknąłem myszą [OK]
wszystko zagnieździło się na swoich miejscach
po kliknięciu w kanał z listy programów odtwarza bezproblemowo.
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: Piejanto w Listopad 09, 2018, 07:54:09 pm
pavbaranov

[root@piejanto jan]# cat /etc/environment
#
# This file is parsed by pam_env module
#
# Syntax: simple "KEY=VAL" pairs on separate lines
#
QT_STYLE_OVERRIDE=gtk
# >>>>BEGIN ADDED BY CNCHI INSTALLER<<<< #
BROWSER=/usr/bin/chromium
EDITOR=/usr/bin/nano
# >>>>>END ADDED BY CNCHI INSTALLER<<<<< #
[root@piejanto jan]#
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: pavbaranov w Listopad 09, 2018, 07:59:02 pm
@Piejanto - skoro działa, to już obojętne.
@TataPingu - jesteś wielki; nie przyszłoby mi do głowy, że lista stacji może mieć wpływ na wyświetlanie okien w Xfce...
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: TataPingu w Listopad 09, 2018, 11:05:36 pm
@Piejanto
- no to się cieszę, że udało się rozwiązać problem.
Poza tym, jeśli piszesz, że z innym OSem miałeś problemy z uruchomieniem sprzętu TV, to faktycznie, powinieneś, tak, jak to sugeruje Kolega @pavbaranov,
pozostać przy archu. Widzę, że w razie czego, jest w stanie udzielić Ci pomocy, czy dorady.

@pavbaranov
- masz rację, teoretycznie to wbrew logice, ale jednak "zadziałało"

Dlatego dobrze jest mieć "testowego" usera w "zapasie", bo trwa to kilka chwil i jesteś w stanie stwierdzić, czy to tylko wadliwa konfiguracja pod userem, ew. pod systemem (w /etc), czy w ogóle, jakiś błąd systemu....
- jak wcześniej wspominałem, w pierwszym rzędzie sprawdzam usera, jeśli błąd występuje nadal, to sprawdzam konfigurację programu pod systemem, tz. wyinstalowywuję całkowicie dany program (z remove) i ponownie go instaluję.

Jeśli błąd nadal się pojawia, to można być pewnym, że to coś w systemie...
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: Piejanto w Listopad 10, 2018, 09:50:09 am
pavbaranov
Nieporozumienie z tym oknem.
TataPingu mnie skierował do katalogu ~/home/.local/share/kaffeine
W tym katalogu były pliki:
config.dvb
epgdata.dvb
playlistK4
scanfile.dvb
sqlite.db     (jest na czerwono i nie wiem co to znaczy)

gdy wszystkie usunąłem, program Kaffeine zaczął działać prawidłowo na HP.
Przypomnę, że na HP Kaffeine przestało działać po "wielkiej aktualizacji. (podobnie jak na netbooku).

Natomiast na netbook reinstalowałem cały system trzy razy i feler okna (tylko tego jednego okna) w Kaffeine nie zniknął. Został jedynie ominięty. Jeśli ktoś nie wpadnie na pomysł aby przyklepać kanły "enterem", to w dalszym ciągu nie dostanie się myszą do buttonu "OK".

TataPingu
Z testowego usera nie skorzystałem, gdyż nie mogłem go znaleźć.
Wpisałem w konsoli [ #useradd tom ] i katalog został założony, natomiast za Chiny Ludowe nie mogłem go znaleźć. Dlatego od razu poszedłem do ~/home/.local/share/kaffeine i stamtąd wyrzuciłem zawartość.
Po tej czynności program Kaffeine wrócił do normalności. Dzięki.

No, ale ja mam już problem z głowy.
Hłe, hłe...
Miałbym.. Bo laptop ACER znów nie chce aktualizować, mimo, że był aktualizowany prawie codziennie za pomocą [pacman -Syu]. 
Spróbuję sam rozwiązać problem, zaglądając do pacman.confu
Znajomość z Wami to przyjemność.
Pozdrowienia.

PS
dziś znów spróbowałem aktualizować ACERA (laptopa). Po wklepaniu [pacman -Syu]
pokazał mnóstwo pozycji do aktualizowania a w pewnym momencie pokazał BŁĄD czerwonymi na białej planszy. po kliknięciu w podobny sposób pokazała się informacja :

"program xfconfd nie jest uruchomiony (problem z konfiguracją D-Bus)
zmienna środowiska $XDG_CONFIG_DIRS jest nieprawidłowa (musi zawierać "/etc") lub program xfce4-session nie został prawidłowo zainstalowany"

Po tym komunikacie powtórnie uruchomiłem [pacman -Syu] i... aktualizacja ruszyła !
plików do aktualizacji było o połowę mniej i wszystko się zakończyło pomyślnie. ZDUMIENIE.
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: pavbaranov w Listopad 10, 2018, 10:52:10 am
Tak, jak powtarzam od początku - zbyt wiele komputerów, zbyt wielki misz-masz w tym wszystkim, stąd nieporozumienia.

Rozwiązanie doraźne dla netbooka (przynajmniej z Kaffeine będziesz mógł korzystać) - przekopiuj z HP listę stacji do netbooka.

Testowy user. Raz jeszcze: w przypadku LightDM (a tego używasz jako menedżera logowania), domyślnie istnieje udostępniona sesja gościa (guest), która jest dostępna z ekranu logowania właśnie. Jeśli w Anergosie niczego nie zmienili w tym zakresie, to masz ją dostępną. Jeśli nie, to bardzo prosto ją udostępnić. Nie musisz tworzyć żadnego nowego, testowego użytkownika nawet. Różnica będzie taka, że sesja ta nie jest zapisywana, ale zobaczyć jak działa to nieszczęsne okno w Kaffeine bez problemów zobaczysz.
Sprawdź. Jeśli nie masz udostępnionej sesji gościa - daj znać, to ją dodamy.
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: Piejanto w Listopad 10, 2018, 11:12:40 am
pavbaranov

no, założyłem gdzieś tego "nowego usera" ale przy logowaniu się nie pojawia i nie mogłem go znaleźć.

jest tak:

[root@piejanto jan]# useradd tom
useradd: user 'tom' already exists
[root@piejanto jan]#

Znaczy, że jest. Ale, prawdę mówiąc, chyba nie będzie mi potrzebny. Jestem chyba za cienki aby umieć go wykorzystać. To nieszczęsne okno,  tylko na netbooku się wygłupia. Może to kwestia jego starości?

Ale skoro chcesz mnie jeszcze czegoś nauczyć, chętnie skorzystam. Opowiedz mi zatem, jak uruchomić tego "nowego usera imieniem "tom".
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: pavbaranov w Listopad 10, 2018, 11:40:29 am
@Piejanto - W ekranie logowania powinieneś mieć "Gość/Guest". Nie chodzi o nowego usera nawet. Jeśli go nie masz, to interesuje Cię plik /etc/lightdm/lightdm.conf odszukaj sekcję [SeatDefaults], pośród ustawień powinieneś zobaczyć:
allow-guest=cośW miejscu "coś" masz wpisać "true", czyli:
allow-guest=truePrawdopodobnie można to też zrobić narzędziem dm-tool - sprawdź sobie:
dm-tool --helpOd tej chwili powinna Ci się pojawić możliwość logowania się na sesję gościa. Mam nadzieję, że w lightDM nie ma ustawienia ograniczającego ilość możliwych użytkowników do określonego PID. Nie mam obecnie lightDM, może ktoś inny tu ma większą wiedzę.
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: Piejanto w Listopad 10, 2018, 12:02:55 pm
Znalazłem.
U mnie jest to sekcja [Seat:*]

mam wpisane [ allow-guest=true ]

ale nie mam ekranu logowania.
pokazuje się tylko na początku przez moment plansza Antergosa, a później już ładowanie systemu pokazuje plymouth
i od razu mam mój pulpit XFCE
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: pavbaranov w Listopad 10, 2018, 12:22:47 pm
Bo masz autologin prawdopodobnie. Wyloguj się ze swojej sesji, powinien Ci się ukazać ekran logowania i tam dostępny winien być zarówno Jan, jak i Gość/Guest (ten drugi nie powinien potrzebować hasła, a jeśli, to pewnie guest).
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: Piejanto w Listopad 10, 2018, 02:08:09 pm
No, faktycznie. Jakbyś przy tym był.

Teraz problem jest jeszcze ciekawszy, bo ten ON "tom" chce żeby podać hasło do logowania, a ja nie ustaliłem hasła dla niego, no, i on rżnie głupa i nie chce się dać zalogować.
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: pavbaranov w Listopad 10, 2018, 02:19:03 pm
Bo w istocie - tak jak to zrobiłeś - nie da się (tj. nie tak się "ustawia" brak hasła do logowania).
Masz sesję gościa - sprawdź na niej.
Nie masz, to dla "tom" ustaw dowolne hasło i spróbuj.
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: Piejanto w Listopad 10, 2018, 02:27:50 pm
No, ba. Tylko jak to dowolne hasło ustawić? Pokazuje mi się plakietka do wyboru "jan" lub "tom" i dalej "hasło" do "jana" znam, a do "tom" nie mam jak wejść, bo mi gada, "uf, och. to się nie da zrobić". może mu po prostu wpisze na konsoli [ #userdel tom ] i po zawodach?  Hmmm...  u-SERDEL. Tes pieknie.
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: pavbaranov w Listopad 10, 2018, 03:05:19 pm
# passwd tomAle z sesją "gościa" to jesteś uparty :)
Tytuł: Odp: Problem z TV na Kaffeine
Wiadomość wysłana przez: Piejanto w Listopad 10, 2018, 03:22:15 pm
pavbaranov
O! Qrdę... jakie to proste.
Co do sesji gościa, to chyba nawet nie o upartość chodzi. Ja po prostu obawiam się, że to wszystko pozapominam.
Dotychczasowe rozmowy z Tobą, TatąPingu. i Sir_Lucjanem sobie już opracowałem, wyrzucając wszystko, co było zbędne, a zostawiając treść i polecenia. Zrobił mi się z tego podręcznik, na wypadek wypadku.
Jestem sam, więc drugi użytkownik jest mi właściwie zbędny.
Ten użytkownik "testowy" mnie zaciekawił, ale, jak już mówiłem, prawdopodobnie pozapominam, że w ogóle jest taka możliwość. - A może będę pamiętał? No, nie wiadomo. W razie czego, to zawsze mogę ustanowić nowego użytkownika. Na razie wszystko, czego potrzebuję, pięknie funkcjonuje. W sumie głównie dzięki Tobie.
Szczerze podziwiam Twoją anielską cierpliwość do mnie. Wszyscy wcześniej odpadli (podczas tej nieszczęsnej aktualizacji), a Tyś pozostał i zwyciężyłeś. Chwała Ci za to.
Pozdrawiam Ciebie i Twoją Żonę, i życzę Wam aby się Wam pięknie wiodło.
Trzymajcie się i ... do następnego.
Ufffff...