Linuxiarze.pl Forum

Dystrybucje Linux => Ubuntu, Kubuntu, Xubuntu, Lubuntu => Wątek zaczęty przez: wesiora999 w Wrzesień 23, 2017, 12:30:54 pm

Tytuł: Problem z Codeblocks' em
Wiadomość wysłana przez: wesiora999 w Wrzesień 23, 2017, 12:30:54 pm
Witam! W momencie w którym chce skompilować napisany program pojawia się komunikat "error: obj/Debug/main.o: Nie ma takiego pliku ani katalogu; error: no input files". Nie wiem jak rozwiązać ten problem. W momencie gdy wykonuje update (apt-get update) na końcu wyświetla się komunikat "W: The repository 'http://ppa.launchpad.net/damien-moore/codeblocks-stable/ubuntu zesty Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Nie udało się pobrać http://ppa.launchpad.net/damien-moore/codeblocks-stable/ubuntu/dists/zesty/main/binary-i386/Packages  404  Not Found
E: Nie udało się pobrać niektórych plików indeksu, zostały one zignorowane lub użyto ich starszej wersji.
Być może gdzieś tu leży problem. Z góry dziękuje za pomoc.
Tytuł: Odp: Problem z Codeblocks' em
Wiadomość wysłana przez: lesio w Wrzesień 23, 2017, 05:21:45 pm
Czy wykonywałeś upgrade ubuntu z poprzedniej wersji (np. z xenial)?
Tytuł: Odp: Problem z Codeblocks' em
Wiadomość wysłana przez: wesiora999 w Wrzesień 24, 2017, 09:30:23 pm
Tak wykonałem upgrade do najnowszej wersji (czyli do Xubuntu 17.04) Oto wynik z "lsb_release -a" i "uname -romi"

$ lsb_release -a
No LSB modules are available.
Distributor ID:   Ubuntu
Description:   Ubuntu 17.04
Release:   17.04
Codename:   zesty

$ uname -romi
4.10.0-35-generic i686 i686 GNU/Linux

Po wykonaniu "apt-get update" wyświetla się komunikat:

Błąd:9 http://ppa.launchpad.net/damien-moore/codeblocks-stable/ubuntu zesty/main i386 Packages
  404  Not Found
Tytuł: Odp: Problem z Codeblocks' em
Wiadomość wysłana przez: lesio w Wrzesień 25, 2017, 07:16:31 am
No i w tym właśnie tkwi problem. Wykonany został upgrade systemu operacyjnego, ale CodeBlocks jest na razie tylko dla poprzedniej jego wersji. Pozostaje poczekać. Na razie nie używam ubuntu i nie potrafię powiedzieć, jak skutecznie zainstalować stary pakiet, by nie naruszyć spójności systemu (zwykle w takich sytuacjach praktykuje się odinstalowanie pakietu i zainstalowanie bezpośrednio paczki "deb" z pominięciem ustawiania repozytoriów, ale to tylko moja sugestia).