Linuxiarze.pl Forum

Dystrybucje Linux => Ubuntu, Kubuntu, Xubuntu, Lubuntu => Wątek zaczęty przez: terefenk w Sierpień 28, 2017, 06:35:21 pm

Tytuł: Instalacja (uruchamianie plików o rozszrzerzeniu sh.
Wiadomość wysłana przez: terefenk w Sierpień 28, 2017, 06:35:21 pm
Witam. Obsługuję konto firmowe w PKO SA. Do podpisywania dyspozycji wymagana jest instalacja komponentu systemowego ComarchCryptoProvider-installer.sh - Linux (x32). Można go pobrać ze strony internetowej banku. Niestety pomimo różnych prób nie udaje mi się go uruchomić. Na forach internetowych znalazłem różne sposoby jego uruchamiania, Np. na stronie o adresie podano 2 sposoby uruchamiania na przykładzie pliku ubumatic.sh:
1-szy sposób
klikasz dwukrotnie w plik ubumatic.sh i wybierasz "Uruchom".
2-gi sposób
wchodzisz do katalogu gdzie go rozpakowałeś i pod prawym klawiszem masz "Uruchom w Terminalu", jak już masz otwarty Terminal wydajesz w nim polecenie
./ubumatic.sh
i uruchamia się skrypt.
Po wykonaniu pierwszego sposobu ukazuje się przez kilka sekund kręcące się kółeczko złączone ze strzałką myszki, po czym znika i dalej nic się nie dzieje.
Podobnie dzieje się po wykonaniu 2 sposobu-terminal się nie otwiera więc wpisanie w nim podanego polecenia nie jest możliwe.

Na stronie o adresie http://artziom.pl/uruchamianie-plikow-rozszerzeniem-sh/ podano podobny sposób:

   1. Zapisujemy plik *.sh w wybranym miejscu, w moim przypadku będzie to pulpit.
   2.  Uruchamiamy Terminal i za pomocą komendy wchodzimy do folderu w którym znajduje się nasz plik.
    cd Pulpit/
    3. Następnie musimy zezwolić na wykonywanie pliku jako programu
    chmod +x nazwa_pliku.sh
    Teraz możemy uruchomić nasz plik za pomocą komendy
    ./nazwa_pliku.sh
   
Po wykonaniu poleceń wskazanych w pkt.1-3 w terminalu ukazują się następujące zapisy:
mikolaj@mikolaj-AMILO-PRO-V8010:~$ cd Pulpit
mikolaj@mikolaj-AMILO-PRO-V8010:~/Pulpit$ chmod +x ComarchCryptoProvider-installer.sh
mikolaj@mikolaj-AMILO-PRO-V8010:~/Pulpit$ ./ComarchCryptoProvider-installer.sh
Verifying archive integrity...  100%   All good.
Uncompressing ComarchCryptoProvider  100% 
ComarchCryptoProvider installer
Usage: ComarchCryptoProvider-installer {install|remove}
mikolaj@mikolaj-AMILO-PRO-V8010:~/Pulpit$

i  w końcowym efekcie po wejściu na stronę internetową Banku PKO SA ukazuje się informacja o treści: Komponent do podpisu jest nie zainstalowany. Czy zainstalować?
Będę wdzięczny za zainteresowanie się tym wątkiem i wskazanie sposobu rozwiązania przedstawionego w nim problemu.
Tytuł: Odp: Instalacja (uruchamianie plików o rozszrzerzeniu sh.
Wiadomość wysłana przez: gom1 w Sierpień 28, 2017, 06:39:51 pm
Usage: ComarchCryptoProvider-installer {install|remove}
Na moje oko tutaj masz właśnie (p)odpowiedź, czyli:
./ComarchCryptoProvider-installer.sh install
Tytuł: Odp: Instalacja (uruchamianie plików o rozszrzerzeniu sh.
Wiadomość wysłana przez: terefenk w Sierpień 29, 2017, 02:32:13 pm
Po uruchomieniu podanego polecenia w terminalu otrzymuję następujący komunikat:mikolaj@mikolaj-AMILO-PRO-V8010:~/Pobrane$ sudo ./ComarchCryptoProvider-installer.sh install
[sudo] hasło użytkownika mikolaj:
Verifying archive integrity...  100%   All good.
Uncompressing ComarchCryptoProvider  100% 
You are root, ok
Please first install packages containing libraries listed below:

   libpng12.so.0

Mój problem i prośba o podpowiedź -  jak zainstalować pakiet libpng12.so.0?
Tytuł: Odp: Instalacja (uruchamianie plików o rozszrzerzeniu sh.
Wiadomość wysłana przez: gom1 w Sierpień 29, 2017, 02:45:44 pm
Na początek odśwież repozytoria:
sudo apt-get updatepotem zaktualizuj system:
sudo apt-get upgradena koniec wyszukaj pakiet:
sudo apt-cache search libpng12i zainstaluj to, co znajdzie.

Spoiler (Rozwiń)
sudo apt-get install libpng12-0
Tytuł: Odp: Instalacja (uruchamianie plików o rozszrzerzeniu sh.
Wiadomość wysłana przez: terefenk w Wrzesień 01, 2017, 09:25:27 pm
Wygląda na to, że niczego nie udało się znależć. Tak wygląda informacja z terminalu po zastosowaniu podanej propozycji:
mikolaj@mikolaj-AMILO-PRO-V8010:~$ sudo apt-cache search libpng12
[sudo] hasło użytkownika mikolaj:
mikolaj@mikolaj-AMILO-PRO-V8010:~$
Tytuł: Odp: Instalacja (uruchamianie plików o rozszrzerzeniu sh.
Wiadomość wysłana przez: Sajmon w Wrzesień 02, 2017, 05:58:45 am
A co pokazuje

apt-cache search libpng
Tytuł: Odp: Instalacja (uruchamianie plików o rozszrzerzeniu sh.
Wiadomość wysłana przez: terefenk w Wrzesień 02, 2017, 07:42:20 am
mikolaj@mikolaj-AMILO-PRO-V8010:~$ apt-cache search libpng
libpng-dev - PNG library - development (version 1.6)
libpng-tools - PNG library - tools (version 1.6)
libpng16-16 - PNG library - runtime (version 1.6)
fp-units-gfx - Free Pascal - graphics-library units dependency package
fp-units-gfx-3.0.2 - Free Pascal - graphics-library units
libpng++-dev - C++ interface to the PNG (Portable Network Graphics) library
libpng-sixlegs-java - Sixlegs Java PNG Decoder
libpng-sixlegs-java-doc - Documentation for Sixlegs Java PNG Decoder
libpnglite-dev - lightweight C library for loading and writing PNG images
libpnglite0 - lightweight C library for loading and writing PNG images
pngquant - PNG (Portable Network Graphics) image optimising utility
ruby-oily-png - native mixin to speed up ChunkyPNG
tkpng - PNG photo image support to Tcl/Tk
Tytuł: Odp: Instalacja (uruchamianie plików o rozszrzerzeniu sh.
Wiadomość wysłana przez: gom1 w Wrzesień 02, 2017, 08:28:41 am
Wersja 1.6 też da radę. Zainstaluj libpng16-16:
sudo apt-get install libpng16-16
Tytuł: Odp: Instalacja (uruchamianie plików o rozszrzerzeniu sh.
Wiadomość wysłana przez: terefenk w Wrzesień 02, 2017, 05:50:19 pm
Próba zainstalowania wersji libpng16-16 dała następujący wynik:
mikolaj@mikolaj-AMILO-PRO-V8010:~$ sudo apt-get install libpng16-16
[sudo] hasło użytkownika mikolaj:
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
libpng16-16 is already the newest version (1.6.28-1).
Następujące pakiety zostały zainstalowane automatycznie i nie są już więcej wymagane:
  hyphen-en-ca hyphen-en-gb hyphen-en-us hyphen-pl libreoffice-help-en-gb
  libreoffice-help-en-us libreoffice-help-pl libreoffice-l10n-en-gb
  libreoffice-l10n-en-za libreoffice-l10n-pl linux-headers-4.10.0-19
  linux-headers-4.10.0-19-generic linux-image-4.10.0-19-generic
  linux-image-extra-4.10.0-19-generic mythes-en-au mythes-en-us mythes-pl
Aby je usunąć należy użyć "sudo apt autoremove".
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.
mikolaj@mikolaj-AMILO-PRO-V8010:~$
 
Tytuł: Odp: Instalacja (uruchamianie plików o rozszrzerzeniu sh.
Wiadomość wysłana przez: Sajmon w Wrzesień 02, 2017, 06:23:25 pm
I co już działa Tobie ten skrypt sh?
Tytuł: Odp: Instalacja (uruchamianie plików o rozszrzerzeniu sh.
Wiadomość wysłana przez: terefenk w Wrzesień 02, 2017, 08:41:05 pm
Niestety nie. Tak wygląda uruchomienie skryptu.
mikolaj@mikolaj-AMILO-PRO-V8010:~/Pulpit$ sudo ./ComarchCryptoProvider-installer.sh
[sudo] hasło użytkownika mikolaj:
Verifying archive integrity...  100%   All good.
Uncompressing ComarchCryptoProvider  100% 
ComarchCryptoProvider installer
Usage: ComarchCryptoProvider-installer {install|remove}
mikolaj@mikolaj-AMILO-PRO-V8010:~/Pulpit$

Po zalogowaniu się na stronie internetowej Banku w dalszym ciągu otrzymuje komunikat z informacją, że wymagany komponent nie jest zainstalowany oraz z pytaniem, czy chcę go zainstalować. W tej sytuacji zwrócę się z prośbą o pomoc do informatyków z PKO SA. Dziękuję za zainteresowanie sie zgłoszonym problemem i udzieloną pomoc. Pozdrawiam!
Tytuł: Odp: Instalacja (uruchamianie plików o rozszrzerzeniu sh.
Wiadomość wysłana przez: gom1 w Wrzesień 02, 2017, 09:29:43 pm
Znowu zapomniałeś o opcji "install" :-)
Tytuł: Odp: Instalacja (uruchamianie plików o rozszrzerzeniu sh.
Wiadomość wysłana przez: terefenk w Wrzesień 03, 2017, 12:14:46 pm
Fakt,zapomniałem o dodaniu install. Po dodaniu otrzymuję, co następuje:
mikolaj@mikolaj-AMILO-PRO-V8010:~/Pulpit$ sudo ./ComarchCryptoProvider-installer.sh install
Verifying archive integrity...  100%   All good.
Uncompressing ComarchCryptoProvider  100% 
You are root, ok
Please first install packages containing libraries listed below:

   libpng12.so.0
mikolaj@mikolaj-AMILO-PRO-V8010:~/Pulpit$
Jak widać znów pojawia się krzyk o instalację  pakietu, którego już wcześniej nie udało się znaleźć.
Tytuł: Odp: Instalacja (uruchamianie plików o rozszrzerzeniu sh.
Wiadomość wysłana przez: gom1 w Wrzesień 03, 2017, 12:23:11 pm
Jutro postawię Lubuntu w wirtualce i spróbuję odtworzyć problem. Na Sparky 5 skrypt uruchamia się bez problemów - nawet pomimo braku biblioteki o którą prosi Lubuntu.
Tytuł: Odp: Instalacja (uruchamianie plików o rozszrzerzeniu sh.
Wiadomość wysłana przez: Sajmon w Wrzesień 03, 2017, 12:44:07 pm
 A czy można prosić jeszcze o wynik tej komendy

find / -name libpng12.so.0 2>/dev/null -exec ls -l {} \;
Tytuł: Odp: Instalacja (uruchamianie plików o rozszrzerzeniu sh.
Wiadomość wysłana przez: pavroo w Wrzesień 03, 2017, 12:46:15 pm
Nie napisałeś jaka to wersja Ubuntu.
Jednak po numerze wersji libpng16 wnioskuję, że zesty, a w repo zesty nie ma libpng12-0.
W takim wypadu ręcznie pobierz i zainstaluj pakiet libpng12-0 z repo trusty lub xenial:
https://packages.ubuntu.com/search?keywords=libpng12&suite=default&section=all&arch=any&searchon=names
Tytuł: Odp: Instalacja (uruchamianie plików o rozszrzerzeniu sh.
Wiadomość wysłana przez: terefenk w Wrzesień 03, 2017, 12:47:43 pm
Dziękuję!
Tytuł: Odp: Instalacja (uruchamianie plików o rozszrzerzeniu sh.
Wiadomość wysłana przez: gom1 w Wrzesień 04, 2017, 08:58:43 am
Kurczę, nie mam dobrych wieści. Tzn. zainstalowałem Lubuntu 17.04 w wersji 32-bitowej i uruchomiłem skrypt, ale wszystko poszło sprawnie, bez monitu o bibliotekę libpng w wersji 1.2. Tak jak na Sparky wystarczyła do tego wersja 1.6.

Spróbuj jak radzi @pavroo.
Tytuł: Odp: Instalacja (uruchamianie plików o rozszrzerzeniu sh.
Wiadomość wysłana przez: terefenk w Wrzesień 04, 2017, 02:29:49 pm
Oto rezultat wykonania polecenia sudo find / -name libpng12.so.0 2>/dev/null -exec ls -l {} \;

mikolaj@mikolaj-AMILO-PRO-V8010:~$ sudo find / -name libpng12.so.0 2>/dev/null -exec ls -l {} \;
[sudo] hasło użytkownika mikolaj:
mikolaj@mikolaj-AMILO-PRO-V8010:~$

Tytuł: Odp: Instalacja (uruchamianie plików o rozszrzerzeniu sh.
Wiadomość wysłana przez: Armalat w Wrzesień 04, 2017, 04:31:49 pm
https://packages.ubuntu.com/search?suite=trusty&arch=any&mode=exactfilename&searchon=contents&keywords=libpng12.so.0
Stamtąd możesz pobrać
Tytuł: Odp: Instalacja (uruchamianie plików o rozszrzerzeniu sh.
Wiadomość wysłana przez: terefenk w Wrzesień 04, 2017, 08:08:33 pm
To wynik wykonania polecenia: find / -name libpng12.so.0 2>/dev/null -exec ls -l {} \;
mikolaj@mikolaj-AMILO-PRO-V8010:~$ sudo find / -name libpng12.so.0 2>/dev/null -exec ls -l {} \;
[sudo] hasło użytkownika mikolaj:
mikolaj@mikolaj-AMILO-PRO-V8010:~$
Tytuł: Odp: Instalacja (uruchamianie plików o rozszrzerzeniu sh.
Wiadomość wysłana przez: terefenk w Wrzesień 04, 2017, 10:06:28 pm
Pobrałem ze stron wskazanych przez pawroo i Armalata pakiet libpng_1.2.50-1ubuntu2.14.04.2.debian.tar.bz2.
Zapisałem go w katalogu Pobrane. Udało mi się go rozpakować poleceniem tar -xvjf libpng_1.2.50-1ubuntu2.14.04.2.debian.tar.bz2.
Niestety próba jego kompilacji poleceniem ./ configure kończy się wyświetleniem komunikatu o treści:
mikolaj@mikolaj-AMILO-PRO-V8010:~/Pobrane$ ./configure
bash: ./configure: Nie ma takiego pliku ani katalogu
Prośba o pomoc w rozwiązaniu problemu możliwie w sposób krok po kroku.
Przy okazji informacja: korzystam z Lubuntu 17.04. Druga informacja - w Synaptic Menedżer Pakietów znajduje się pakiet libpng16-16, co wskazywałoby że został on zainstalowany.
Tytuł: Odp: Instalacja (uruchamianie plików o rozszrzerzeniu sh.
Wiadomość wysłana przez: pavroo w Wrzesień 04, 2017, 10:37:50 pm
Pakiet 'libpng16' to nie to samo co 'libpng12', więc nie jest zainstalowany.
Nie pobieraj paczki z archiwami do kompilacji, pobierz paczkę deb dla twojego systemu: i386 jeśli 32 bity lub amd64 jeśli 64 bity.
Nastepnie w katalogu z pobranym debem otwórz terminal i wydaj polecenie:
sudo dpkg -i nazwa-pakietu.debpodając pełną nazwę deba wraz z wersją.
Jeśli instalacja się nie powiedzie, wtedy:
sudo apt update
sudo apt install -f
Tytuł: Odp: Instalacja (uruchamianie plików o rozszrzerzeniu sh.
Wiadomość wysłana przez: terefenk w Wrzesień 05, 2017, 06:27:37 pm
Udało się! Wrzuciłem poszukiwanie  pliku libpng12-0_1.2.50-1ubuntu2.14.04.2_i386.deb do googla, który na stronie https://packages.ubuntu.com/trusty/i386/libpng12-0/download zawiera informację o możliwości pobrania żądanego plik z podkatalogu pool/main/libp/libpng/ poprzez kliknięcie na link: security.ubuntu.com/ubuntu. W efekcie daje to możliwość pobrania i automatycznej jego instalacji poprzez instalator pakietów GDebi. Dziękuję wszystkim za cierpliwość i pomoc. Pozdrawiam!