Linuxiarze.pl Forum

Dystrybucje Linux => Ubuntu, Kubuntu, Xubuntu, Lubuntu => Wątek zaczęty przez: Czesław w Maj 23, 2017, 07:51:58 am

Tytuł: [Solved]fslint - może ktoś mi wytłumaczy ...
Wiadomość wysłana przez: Czesław w Maj 23, 2017, 07:51:58 am
... o co chodzi.
puchacz@puchacz-desktop:~$ sudo apt-get install fslint
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
fslint is already the newest version (2.44-2).
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 8 nieaktualizowanych.
puchacz@puchacz-desktop:~$ fslint
Nie odnaleziono polecenia 'fslint', czy chodziło ci o:
 Polecenie 'ftlint' z pakietu 'freetype2-demos' (universe)
 Polecenie 'nslint' z pakietu 'nslint' (universe)
fslint: nie znaleziono polecenia
puchacz@puchacz-desktop:~$
Tytuł: Odp: fslint - może ktoś mi wytłumaczy ...
Wiadomość wysłana przez: MSki w Maj 23, 2017, 08:36:15 am
Może najpierw powinieneś odświeżyć i zaktualizować system (?).
Mnie (w Ubu-MATE) w Synapticu program fslint zainstalował się bez problemu i z polską wersją.
Tytuł: Odp: fslint - może ktoś mi wytłumaczy ...
Wiadomość wysłana przez: lesio w Maj 23, 2017, 09:07:50 am
Sprawdź przy użyciu jakiegoś menadżera pakietów (np. synaptic), jakie pliki zostały zainstalowane w ramach pakietu fslint
Tytuł: Odp: fslint - może ktoś mi wytłumaczy ...
Wiadomość wysłana przez: MSki w Maj 23, 2017, 09:37:46 am
Ale przecież Terminal jasno informuje, że 8 pakietów jest niezaktualizowanych;
"Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
fslint is already the newest version (2.44-2).
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 8 nieaktualizowanych."
...i  że jest nowa wersja fslint.
Dlatego (wydaje mi się że) trzeba najpierw uaktualnić system, a dopiero później instalować fslint, bo w przeciwnym wypadku instalacja programu się nie odbędzie.
Doświadczyłem tego na różnych systemach spod znaku pingwina.
Tytuł: Odp: fslint - może ktoś mi wytłumaczy ...
Wiadomość wysłana przez: pavroo w Maj 23, 2017, 11:21:26 am
Instalacja każdego pakietu wymaga odświeżenia listy pakietów przed instalacją:
sudo apt-get updateTeraz możesz instalować nowy pakiet:
sudo apt-get install fslint
Dobrą praktyką jest również regularna aktualizacja całego systemu.
Tytuł: Odp: fslint - może ktoś mi wytłumaczy ...
Wiadomość wysłana przez: Czesław w Maj 23, 2017, 07:40:56 pm
Problem rozwiązany. Trzeba wystukać polecenie
sudo fslint-guiDziała nawet po polsku.