Linuxiarze.pl Forum

Dystrybucje Linux => Arch => Wątek zaczęty przez: Piejanto w Maj 08, 2022, 07:02:36 PM

Tytuł: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Maj 08, 2022, 07:02:36 PM
Mam dwa laptopy z Archem. Oba przestały mi sie aktualizować. Myślałem, że to przejściowe, ale mijają tygodnie, a problem nie znika. Jest tak :

pacman -Syu filesystem
:: Synchronizowanie baz danych z pakietami...
core                      156,2 KiB  398 KiB/s 00:00 [----------------------------] 100%
extra                    1702,0 KiB  1261 KiB/s 00:01 [----------------------------] 100%
community                  6,6 MiB  1332 KiB/s 00:05 [----------------------------] 100%
multilib                  173,9 KiB  644 KiB/s 00:00 [----------------------------] 100%
storm-os                  14,4 KiB  40,0 KiB/s 00:00 [----------------------------] 100%
chaotic-aur              1745,9 KiB  399 KiB/s 00:04 [----------------------------] 100%
ostrzeżenie: filesystem-2021.12.07-1 jest w najnowszej wersji -- ponowne instalowanie
:: Rozpoczynanie pełnej aktualizacji systemu...
rozwiązywanie zależności...
szukanie sprzecznych pakietów...
ostrzeżenie: wykryto cykl zależności:
ostrzeżenie: smbclient zostanie zainstalowane przed zależnościami cifs-utils
ostrzeżenie: wykryto cykl zależności:
ostrzeżenie: mesa zostanie zainstalowane przed zależnościami libglvnd
ostrzeżenie: wykryto cykl zależności:
ostrzeżenie: harfbuzz zostanie zainstalowane przed zależnościami freetype2
ostrzeżenie: wykryto cykl zależności:
ostrzeżenie: lib32-mesa zostanie zainstalowane przed zależnościami lib32-libglvnd
ostrzeżenie: wykryto cykl zależności:
ostrzeżenie: lib32-harfbuzz zostanie zainstalowane przed zależnościami lib32-freetype2

Pakiety (237) alsa-card-profiles-1:0.3.51-1  archlinux-keyring-20220424-1
              archlinux-wallpaper-1.6.1-2  at-spi2-core-2.44.1-1  audit-3.0.8-1
              bind-9.18.2-1  brotli-1.0.9-8  btrfs-progs-5.17-1
              ca-certificates-mozilla-3.78-1  chaotic-mirrorlist-20220504-2
              cifs-utils-6.15-1  clutter-gst-3.0.27-4  coin-or-cbc-2.10.8-1
              coin-or-cgl-0.60.6-1  coreutils-9.1-1  curl-7.83.0-1  dav1d-1.0.0-1
              elementary-icon-theme-7.0.0-1  elfutils-0.187-1  ell-0.50-1
              enchant-2.3.3-1  evolution-data-server-3.44.1-1  exiv2-0.27.5-3
              faudio-22.05-1  ffmpeg-2:5.0-7  ffmpeg4.4-4.4.1-5  ffmpegthumbs-22.04.0-1
              firefox-100.0-1  firefox-i18n-en-gb-100.0-1  flameshot-11.0.0-5
              fluidsynth-2.2.7-1  freetype2-2.12.1-1  fribidi-1.0.12-1  gavl-1.4.0-6
              gd-2.3.3-4  geoip-database-20220419-1  gimp-2.10.30-3  git-2.36.1-1
              glib2-2.72.1-1  glib2-docs-2.72.1-1  glibmm-2.66.4-1  glslang-11.9.0-1
              glu-9.0.2-3  gnome-desktop-1:42.1-1  gnome-desktop-common-1:42.1-1
              gnumeric-1.12.52-1  gnupg-2.2.35-1  gnutls-3.7.4-2  goffice-0.10.52-1
              gspell-1.10.0-2  gst-libav-1.20.2-1  gst-plugins-bad-1.20.2-1
              gst-plugins-bad-libs-1.20.2-1  gst-plugins-base-1.20.2-1
              gst-plugins-base-libs-1.20.2-1  gst-plugins-good-1.20.2-1
              gst-plugins-ugly-1.20.2-1  gstreamer-1.20.2-1  gstreamer-vaapi-1.20.2-1
              gtk-theme-elementary-7.0.0-1  gtk-update-icon-cache-1:4.6.3-1
              gtk3-1:3.24.33-3  gtkmm3-3.24.6-1  gvfs-1.50.1-1  gvfs-mtp-1.50.1-1
              gvfs-nfs-1.50.1-1  gvfs-smb-1.50.1-1  gwenview-22.04.0-1  harfbuzz-4.2.1-1
              harfbuzz-icu-4.2.1-1  hplip-1:3.22.4-1  htop-3.2.0-1  hwdata-0.359-1
              iana-etc-20220427-1  imagemagick-7.1.0.33-1  imlib2-1.9.0-3
              iproute2-5.17.0-3  iwd-1.27-1  jansson-2.14-2  jasper-2.0.33-2
              jdk-openjdk-18.0.1.1.u2-1  jre-openjdk-18.0.1.1.u2-1
              jre-openjdk-headless-18.0.1.1.u2-1  json-c-0.16-1
              kaccounts-integration-22.04.0-1  kdegraphics-mobipocket-22.04.0-1
              kitty-terminfo-0.25.0-2  lib32-curl-7.83.0-1  lib32-faudio-22.05-1
              lib32-freetype2-2.12.1-1  lib32-glib2-2.72.1-1  lib32-glu-9.0.2-3
              lib32-harfbuzz-4.2.1-1  lib32-libcap-2.64-1  lib32-libelf-0.187-1
              lib32-libglvnd-1.4.0-2  lib32-libnl-3.6.0-1  lib32-libtiff-4.3.0-2
              lib32-libx11-1.8-1  lib32-libxcb-1.15-1  lib32-libxcursor-1.2.1-1
              lib32-mesa-22.0.3-1  lib32-opencl-mesa-22.0.3-1  lib32-sdl2-2.0.22-1
              lib32-systemd-250.5-1  lib32-vulkan-icd-loader-1.3.209-1
              lib32-vulkan-radeon-22.0.3-1  lib32-zlib-1.2.12-1  libaio-0.3.113-1
              libappindicator-gtk3-12.10.0.r296-2  libavif-0.10.1-1  libbsd-0.11.6-2
              libcap-2.64-1  libcap-ng-0.8.3-1  libdbusmenu-glib-16.04.0-5
              libdbusmenu-gtk3-16.04.0-5  libelf-0.187-1  libglvnd-1.4.0-2
              libgudev-237-2  libhandy-1.6.2-1  libindicator-gtk3-12.10.1-10
              libinih-55-2  libinput-1.20.1-1  libkdcraw-22.04.0-1  libkexiv2-22.04.0-1
              libmanette-0.2.6-3  libmbim-1.26.4-1  libmm-glib-1.18.8-1  libnice-0.1.19-1
              libnl-3.6.0-3  libnotify-0.7.11-2  libopenmpt-0.6.3-1  libopenraw-0.3.1-1
              libpgm-5.3.128-2  libphonenumber-1:8.12.47-1  libpipeline-1.5.6-1
              libqmi-1.30.6-1  libqrtr-glib-1.2.2-2  libreoffice-fresh-7.3.3-2
              librsvg-2:2.54.1-1  libsasl-2.1.28-1  libseccomp-2.5.4-1
              libshout-1:2.4.6-1  libspeechd-0.11.1-3  libtorrent-rasterbar-1:2.0.6-1
              libx11-1.8-1  libxcb-1.15-1  libyuv-r2322+3aebf69d-1  linux-5.17.5.arch1-1
              linux-headers-5.17.5.arch1-1  luajit-2.1.0.beta3.r404.g3ee3c9cf-1
              luit-20220111-1  mesa-22.0.3-1  mesa-vdpau-22.0.3-1  minizip-1:1.2.12-2
              modemmanager-1.18.8-1  mpg123-1.29.3-2  nano-6.3-1  ncdu-2.1.2-1
              ncurses-6.3-3  ndctl-73-1  nss-3.78-1  okular-22.04.0-1  oniguruma-6.9.8-1
              openal-1.22.0-1  opencl-mesa-22.0.3-1  openconnect-1:9.01-1
              openssl-1.1.1.o-1  opusfile-0.12-2  ostree-2022.3-1  pacman-contrib-1.5.1-1
              pacman-mirrorlist-20220501-1  parted-3.5-1  pciutils-3.8.0-1  pcre2-10.40-1
              perl-file-listing-6.15-1  perl-http-daemon-6.14-1  perl-libwww-6.60-1
              phodav-2.5-2  pipewire-1:0.3.51-1  pkcs11-helper-1.29.0-1
              polkit-gnome-0.105-9  poppler-22.05.0-1  poppler-glib-22.05.0-1
              poppler-qt5-22.05.0-1  postgresql-libs-14.2-1  protobuf-3.20.1-1
              python-click-8.1.3-1  python-dnspython-1:2.2.1-1  python-markdown-3.3.7-1
              python-more-itertools-8.12.0-2  python-packaging-21.3-1
              python-psutil-5.9.0-2  python-pygments-2.12.0-1
              python-setuptools-1:59.6.0-1  python-typing_extensions-4.2.0-1
              qt5-base-5.15.3+kde+r145-1  rsync-3.2.4-1  samba-4.16.1-2  sdl2-2.0.22-1
              shaderc-2022.1-3  signon-kwallet-extension-22.04.0-1  simple-scan-42.1-1
              simplescreenrecorder-0.4.4-1  smbclient-4.16.1-2  sqlite-3.38.4-1
              systemd-250.5-1  systemd-libs-250.5-1  systemd-resolvconf-250.5-1
              systemd-sysvcompat-250.5-1  thunar-4.16.11-2  thunar-archive-plugin-0.5.0-2
              ttf-fira-code-6.2-2  unrar-1:6.1.7-1  virtualbox-guest-utils-6.1.34-2
              virtualbox-host-dkms-6.1.34-2  vlc-3.0.17.4-3  vpnc-1:0.5.3.r506.r204-1
              vulkan-icd-loader-1.3.209-1  vulkan-radeon-22.0.3-1  webkit2gtk-2.36.1-1
              wine-7.7-1  wireless-regdb-2022.04.08-1  wvstreams-4.6.1-18
              xcb-proto-1.15-1  xdg-desktop-portal-1.14.4-1  xfce4-settings-4.16.2-2
              xfce4-terminal-1.0.2-1  xmlsec-1.2.34-1  xorg-xauth-1.1.2-1
              xorgproto-2022.1-1  xplc-0.3.13-10  zenity-3.42.1-1  zlib-1:1.2.12-2
              zsh-5.8.1-2  zxing-cpp-1.3.0-1  filesystem-2021.12.07-1

Do pobrania:              231,38 MiB
Do zainstalowania:      3334,49 MiB
Zmiana po aktualizacji:  -15,22 MiB

:: Kontynuować instalację? [T/n] T
:: Pobieranie pakietów...
libreoffice-fresh-7....  138,3 MiB  1436 KiB/s 01:39 [----------------------------] 100%
mesa-22.0.3-1-x86_64      12,5 MiB  1380 KiB/s 00:09 [----------------------------] 100%
vlc-3.0.17.4-3-x86_64      11,7 MiB  1679 KiB/s 00:07 [----------------------------] 100%
lib32-mesa-22.0.3-1-...    10,8 MiB  1623 KiB/s 00:07 [----------------------------] 100%
ffmpeg-2:5.0-7-x86_64      10,7 MiB  1316 KiB/s 00:08 [----------------------------] 100%
ffmpeg4.4-4.4.1-5-x86_64    8,4 MiB  1143 KiB/s 00:07 [----------------------------] 100%
opencl-mesa-22.0.3-1...    7,6 MiB  1063 KiB/s 00:07 [----------------------------] 100%
lib32-opencl-mesa-22...    7,3 MiB  1338 KiB/s 00:06 [----------------------------] 100%
git-2.36.1-1-x86_64        6,1 MiB  1278 KiB/s 00:05 [----------------------------] 100%
mesa-vdpau-22.0.3-1-...    3,2 MiB  1067 KiB/s 00:03 [----------------------------] 100%
imagemagick-7.1.0.33...    2,8 MiB  1263 KiB/s 00:02 [----------------------------] 100%
elementary-icon-them...    2,6 MiB  1765 KiB/s 00:02 [----------------------------] 100%
lib32-vulkan-radeon-...  1877,8 KiB  1865 KiB/s 00:01 [----------------------------] 100%
vulkan-radeon-22.0.3...  1796,2 KiB  1580 KiB/s 00:01 [----------------------------] 100%
poppler-22.05.0-1-x86_64 1535,9 KiB  1414 KiB/s 00:01 [----------------------------] 100%
coin-or-cbc-2.10.8-1...  930,5 KiB  1007 KiB/s 00:01 [----------------------------] 100%
openconnect-1:9.01-1...  848,4 KiB  1601 KiB/s 00:01 [----------------------------] 100%
dav1d-1.0.0-1-x86_64      565,1 KiB  1079 KiB/s 00:01 [----------------------------] 100%
hwdata-0.359-1-any        473,5 KiB  1127 KiB/s 00:00 [----------------------------] 100%
poppler-glib-22.05.0...  280,0 KiB  1218 KiB/s 00:00 [----------------------------] 100%
libyuv-r2322+3aebf69...  270,6 KiB  827 KiB/s 00:00 [----------------------------] 100%
poppler-qt5-22.05.0-...  224,0 KiB  957 KiB/s 00:00 [----------------------------] 100%
gd-2.3.3-4-x86_64        154,2 KiB  946 KiB/s 00:00 [----------------------------] 100%
unrar-1:6.1.7-1-x86_64    134,5 KiB  820 KiB/s 00:00 [----------------------------] 100%
python-markdown-3.3....  132,3 KiB  812 KiB/s 00:00 [----------------------------] 100%
gspell-1.10.0-2-x86_64    123,0 KiB  354 KiB/s 00:00 [----------------------------] 100%
libavif-0.10.1-1-x86_64  115,7 KiB  301 KiB/s 00:00 [----------------------------] 100%
vpnc-1:0.5.3.r506.r2...    96,7 KiB  658 KiB/s 00:00 [----------------------------] 100%
gtk-theme-elementary...    73,1 KiB  430 KiB/s 00:00 [----------------------------] 100%
libinih-55-2-x86_64        15,4 KiB  203 KiB/s 00:00 [----------------------------] 100%
chaotic-mirrorlist-2...    3,0 KiB  5,60 KiB/s 00:01 [----------------------------] 100%
Total (31/31)            231,4 MiB  1369 KiB/s 02:53 [----------------------------] 100%
(237/237) sprawdzanie kluczy w bazie                  [----------------------------] 100%
pobieranie potrzebnych kluczy...
:: Zaimportować klucz PGP 0706B90D37D9B881, "Nico Jensch <dr460nf1r3@chaotic.cx>"? [T/n] T
:: Zaimportować klucz PGP 0F65C7D881506130, "Maxime Gauduin <alucryd@archlinux.org>"? [T/n] T
(237/237) sprawdzanie spójności pakietów              [----------------------------] 100%
błąd:  chaotic-mirrorlist: podpis od "Nico Jensch (Chaotic-AUR) <dr460nf1r3@garudalinux.org>" posiada nieznane zaufanie
:: Plik /var/cache/pacman/pkg/chaotic-mirrorlist-20220504-2-any.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
błąd:  elementary-icon-theme: klucz "95220BE99CE6FF778AE0DC670F65C7D881506130" jest nieznany
:: Zaimportować klucz PGP 95220BE99CE6FF778AE0DC670F65C7D881506130? [T/n] T
:: Plik /var/cache/pacman/pkg/elementary-icon-theme-7.0.0-1-any.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
:: Plik /var/cache/pacman/pkg/libinih-55-2-x86_64.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
:: Plik /var/cache/pacman/pkg/gtk-theme-elementary-7.0.0-1-any.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
błąd:  nie udało się dokonać transakcji (Niepoprawny lub uszkodzony pakiet)
Wystąpiły błędy, nie zaktualizowano żadnego pakietu.


*****************

Dziękuję za pomoc
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Maj 08, 2022, 08:11:22 PM
Aktualizacja na Asusie, za pomocą Octopi wygląda tak:

:: Synchronizing package databases...
 core                  156.2 KiB   176 KiB/s 00:01 [####################] 100%
 extra                1702.0 KiB   592 KiB/s 00:03 [####################] 100%
 community               6.6 MiB   863 KiB/s 00:08 [####################] 100%
 chaotic-aur          1745.9 KiB   777 KiB/s 00:02 [####################] 100%
:: Starting full system upgrade...
:: Replace sdl with community/sdl12-compat? [Y/n] Y
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: harfbuzz will be installed before its freetype2 dependency
warning: dependency cycle detected:
warning: mesa will be installed before its libglvnd dependency
warning: dependency cycle detected:
warning: smbclient will be installed before its cifs-utils dependency

Packages (142) aarch64-linux-gnu-gcc-12.1.0-1  alsa-card-profiles-1:0.3.51-1
               archlinux-keyring-20220424-1  audit-3.0.8-1  bison-3.8.2-4
               brotli-1.0.9-8  btrfs-progs-5.17-1
               ca-certificates-mozilla-3.78-1  calligra-3.2.1-33
               chaotic-mirrorlist-20220504-2  cifs-utils-6.15-1
               clutter-gst-3.0.27-4  curl-7.83.0-1  dav1d-1.0.0-1
               elementary-icon-theme-7.0.0-1  elfutils-0.187-1
               enchant-2.3.3-1  exiv2-0.27.5-3  ffmpeg-2:5.0-7
               ffmpeg4.4-4.4.1-5  firefox-100.0-1  firefox-i18n-pl-100.0-1
               fluidsynth-2.2.7-1  freetype2-2.12.1-1
               gambas3-gb-image-3.17.2-2  gambas3-gb-settings-3.17.2-2
               gambas3-runtime-3.17.2-2  gavl-1.4.0-6  gd-2.3.3-4
               gimp-2.10.30-3  git-2.36.1-1  glew-2.2.0-3  glibmm-2.66.4-1
               glu-9.0.2-3  gnome-desktop-1:42.1-1
               gnome-desktop-common-1:42.1-1  gnupg-2.2.35-1  gnutls-3.7.4-2
               gspell-1.10.0-2  gst-plugins-bad-1.20.2-1
               gst-plugins-bad-libs-1.20.2-1  gst-plugins-base-1.20.2-1
               gst-plugins-base-libs-1.20.2-1  gst-plugins-good-1.20.2-1
               gstreamer-1.20.2-1  gtk3-1:3.24.33-3  gtkmm3-3.24.6-1
               harfbuzz-4.2.1-1  harfbuzz-icu-4.2.1-1
               haskell-bz2-1.0.1.0-152  htop-3.2.0-1  hwdata-0.359-1
               iana-etc-20220427-1  imagemagick-7.1.0.33-1  imlib2-1.9.0-3
               iproute2-5.17.0-3  jansson-2.14-2  jasper-2.0.33-2
               jsoncpp-1.9.5-2  libappindicator-gtk3-12.10.0.r296-2
               libavif-0.10.1-1  libbsd-0.11.6-2  libdbusmenu-glib-16.04.0-5
               libdbusmenu-gtk3-16.04.0-5  libelf-0.187-1  libglvnd-1.4.0-2
               libgudev-237-2  libindicator-gtk3-12.10.1-10  libinih-55-2
               libmanette-0.2.6-3  libmm-glib-1.18.8-1  libnice-0.1.19-1
               libnl-3.6.0-3  libnotify-0.7.11-2  libopenmpt-0.6.3-1
               libpipeline-1.5.6-1  libreoffice-fresh-7.3.3-2
               libsasl-2.1.28-1  libseccomp-2.5.4-1  libshout-1:2.4.6-1
               libsynctex-2022.62885-1  libtorrent-rasterbar-1:2.0.6-1
               libx11-1.8-1  libxcb-1.15-1  libyuv-r2322+3aebf69d-1
               linux-5.17.5.arch1-1  linux-headers-5.17.5.arch1-1
               linux-lts-tkg-bmq-5.15.36-256
               linux-lts-tkg-bmq-headers-5.15.36-256
               luajit-2.1.0.beta3.r404.g3ee3c9cf-1  luit-20220111-1
               marble-common-22.04.0-2  mesa-22.0.3-1  minizip-1:1.2.12-2
               mpg123-1.29.3-2  ncurses-6.3-3  ndctl-73-1  nss-3.78-1
               oniguruma-6.9.8-1  openal-1.22.0-1  opencv-4.5.5-5
               openssl-1.1.1.o-1  pacman-contrib-1.5.1-1
               pacman-mirrorlist-20220501-1  pciutils-3.8.0-1  pcre2-10.40-1
               picom-9.1-3  polkit-gnome-0.105-9  poppler-22.05.0-1
               poppler-glib-22.05.0-1  poppler-qt5-22.05.0-1
               protobuf-3.20.1-1  python-dnspython-1:2.2.1-1
               python-markdown-3.3.7-1  python-more-itertools-8.12.0-2
               python-packaging-21.3-1  python-setuptools-1:59.6.0-1
               qtermwidget-1.1.0-1  sdl-1:1.2.15+r406+gf1caf909-1 [removal]
               sdl12-compat-1.2.52-2  sdl2-2.0.22-1  shaderc-2022.1-3
               smbclient-4.16.1-2  sqlite-3.38.4-1  systemd-250.5-1
               systemd-libs-250.5-1  systemd-sysvcompat-250.5-1
               thunar-4.16.11-2  thunar-archive-plugin-0.5.0-2
               unrar-1:6.1.7-1  vim-8.2.4827-1  vim-runtime-8.2.4827-1
               vlc-3.0.17.4-3  vulkan-headers-1:1.3.212-1
               vulkan-icd-loader-1.3.209-1  xcb-proto-1.15-1
               xfce4-settings-4.16.2-2  xmlsec-1.2.34-1  zlib-1:1.2.12-2
               zoom-5.10.4-1  zsh-5.8.1-2  zxing-cpp-1.3.0-1

Total Download Size:   1065.05 MiB
Total Installed Size:  3097.11 MiB
Net Upgrade Size:         6.25 MiB

:: Proceed with installation? [Y/n] Y
:: Retrieving packages...
 zoom-5.10.4-1-x86_64  166.1 MiB   575 KiB/s 04:56 [####################] 100%
 linux-5.17.5.arc...    75.2 MiB   490 KiB/s 02:37 [####################] 100%
 libreoffice-fres...   138.3 MiB   610 KiB/s 03:52 [####################] 100%
 linux-lts-tkg-bm...   130.5 MiB   604 KiB/s 03:41 [####################] 100%
 firefox-100.0-1-...    62.9 MiB   729 KiB/s 01:28 [####################] 100%
 calligra-3.2.1-3...    57.9 MiB   621 KiB/s 01:35 [####################] 100%
 marble-common-22...    45.3 MiB   571 KiB/s 01:21 [####################] 100%
 aarch64-linux-gn...    44.6 MiB   470 KiB/s 01:37 [####################] 100%
 linux-lts-tkg-bm...    31.9 MiB   591 KiB/s 00:55 [####################] 100%
 linux-headers-5....    25.9 MiB   614 KiB/s 00:43 [####################] 100%
 opencv-4.5.5-5-x...    25.8 MiB   380 KiB/s 01:09 [####################] 100%
 gimp-2.10.30-3-x...    20.0 MiB   716 KiB/s 00:29 [####################] 100%
 mesa-22.0.3-1-x86_64   12.5 MiB   485 KiB/s 00:26 [####################] 100%
 vlc-3.0.17.4-3-x...    11.7 MiB   490 KiB/s 00:24 [####################] 100%
 ffmpeg-2:5.0-7-x...    10.7 MiB   529 KiB/s 00:21 [####################] 100%
 ffmpeg4.4-4.4.1-...     8.4 MiB   480 KiB/s 00:18 [####################] 100%
 gtk3-1:3.24.33-3...     7.7 MiB   426 KiB/s 00:18 [####################] 100%
 systemd-250.5-1-...     7.2 MiB   663 KiB/s 00:11 [####################] 100%
 smbclient-4.16.1...     6.7 MiB   743 KiB/s 00:09 [####################] 100%
 vim-runtime-8.2....     6.7 MiB   460 KiB/s 00:15 [####################] 100%
 git-2.36.1-1-x86_64     6.1 MiB   598 KiB/s 00:10 [####################] 100%
 gavl-1.4.0-6-x86_64     4.1 MiB   739 KiB/s 00:06 [####################] 100%
 openssl-1.1.1.o-...     3.6 MiB   323 KiB/s 00:11 [####################] 100%
 imagemagick-7.1....     2.8 MiB   514 KiB/s 00:06 [####################] 100%
 gnutls-3.7.4-2-x...     2.8 MiB   695 KiB/s 00:04 [####################] 100%
 elementary-icon-...     2.6 MiB   350 KiB/s 00:08 [####################] 100%
 libtorrent-raste...     2.5 MiB   588 KiB/s 00:04 [####################] 100%
 gnupg-2.2.35-1-x...     2.3 MiB   427 KiB/s 00:06 [####################] 100%
 zsh-5.8.1-2-x86_64      2.2 MiB   487 KiB/s 00:05 [####################] 100%
 gst-plugins-bad-...     2.1 MiB   716 KiB/s 00:03 [####################] 100%
 gst-plugins-base...     2.1 MiB   762 KiB/s 00:03 [####################] 100%
 libx11-1.8-1-x86_64     2.0 MiB  1048 KiB/s 00:02 [####################] 100%
 vim-8.2.4827-1-x...     2.0 MiB   985 KiB/s 00:02 [####################] 100%
 protobuf-3.20.1-...  2036.9 KiB   875 KiB/s 00:02 [####################] 100%
 gst-plugins-good...  2009.7 KiB   385 KiB/s 00:05 [####################] 100%
 exiv2-0.27.5-3-x...  1882.5 KiB   909 KiB/s 00:02 [####################] 100%
 gstreamer-1.20.2...  1819.9 KiB   763 KiB/s 00:02 [####################] 100%
 sqlite-3.38.4-1-...  1760.2 KiB   929 KiB/s 00:02 [####################] 100%
 nss-3.78-1-x86_64    1558.5 KiB   661 KiB/s 00:02 [####################] 100%
 poppler-22.05.0-...  1535.9 KiB   678 KiB/s 00:02 [####################] 100%
 gtkmm3-3.24.6-1-...  1445.4 KiB   645 KiB/s 00:02 [####################] 100%
 thunar-4.16.11-2...  1232.5 KiB   305 KiB/s 00:04 [####################] 100%
 gst-plugins-bad-...  1189.8 KiB   406 KiB/s 00:03 [####################] 100%
 ncurses-6.3-3-x86_64 1169.7 KiB   416 KiB/s 00:03 [####################] 100%
 pcre2-10.40-1-x86_64 1139.5 KiB   432 KiB/s 00:03 [####################] 100%
 curl-7.83.0-1-x86_64 1134.0 KiB   636 KiB/s 00:02 [####################] 100%
 iproute2-5.17.0-...  1072.0 KiB   636 KiB/s 00:02 [####################] 100%
 archlinux-keyrin...  1051.1 KiB   518 KiB/s 00:02 [####################] 100%
 glibmm-2.66.4-1-...  1027.0 KiB   232 KiB/s 00:04 [####################] 100%
 libxcb-1.15-1-x86_64  998.9 KiB   383 KiB/s 00:03 [####################] 100%
 harfbuzz-4.2.1-1...   974.5 KiB   493 KiB/s 00:02 [####################] 100%
 btrfs-progs-5.17...   937.4 KiB   299 KiB/s 00:03 [####################] 100%
 vulkan-headers-1...   887.0 KiB   408 KiB/s 00:02 [####################] 100%
 xfce4-settings-4...   865.7 KiB   395 KiB/s 00:02 [####################] 100%
 sdl2-2.0.22-1-x86_64  849.9 KiB   640 KiB/s 00:01 [####################] 100%
 bison-3.8.2-4-x86_64  769.8 KiB   273 KiB/s 00:03 [####################] 100%
 libmm-glib-1.18....   709.2 KiB   745 KiB/s 00:01 [####################] 100%
 xmlsec-1.2.34-1-...   698.4 KiB   598 KiB/s 00:01 [####################] 100%
 libopenmpt-0.6.3...   696.0 KiB   260 KiB/s 00:03 [####################] 100%
 zxing-cpp-1.3.0-...   670.1 KiB   708 KiB/s 00:01 [####################] 100%
 systemd-libs-250...   625.2 KiB   495 KiB/s 00:01 [####################] 100%
 openal-1.22.0-1-...   580.3 KiB   490 KiB/s 00:01 [####################] 100%
 elfutils-0.187-1...   569.5 KiB   690 KiB/s 00:01 [####################] 100%
 gambas3-runtime-...   566.9 KiB   703 KiB/s 00:01 [####################] 100%
 dav1d-1.0.0-1-x86_64  565.1 KiB   539 KiB/s 00:01 [####################] 100%
 python-setuptool...   562.9 KiB   804 KiB/s 00:01 [####################] 100%
 imlib2-1.9.0-3-x...   552.4 KiB   556 KiB/s 00:01 [####################] 100%
 libelf-0.187-1-x...   536.1 KiB   490 KiB/s 00:01 [####################] 100%
 freetype2-2.12.1...   498.4 KiB   531 KiB/s 00:01 [####################] 100%
 firefox-i18n-pl-...   489.8 KiB   141 KiB/s 00:03 [####################] 100%
 hwdata-0.359-1-any    473.5 KiB   247 KiB/s 00:02 [####################] 100%
 brotli-1.0.9-8-x...   462.8 KiB   768 KiB/s 00:01 [####################] 100%
 gnome-desktop-co...   460.1 KiB   799 KiB/s 00:01 [####################] 100%
 mpg123-1.29.3-2-...   435.9 KiB   557 KiB/s 00:01 [####################] 100%
 libnl-3.6.0-3-x86_64  406.6 KiB   711 KiB/s 00:01 [####################] 100%
 iana-etc-2022042...   392.1 KiB   533 KiB/s 00:01 [####################] 100%
 glew-2.2.0-3-x86_64   390.9 KiB   756 KiB/s 00:01 [####################] 100%
 audit-3.0.8-1-x86_64  383.4 KiB   826 KiB/s 00:00 [####################] 100%
 libglvnd-1.4.0-2...   352.1 KiB   611 KiB/s 00:01 [####################] 100%
 ca-certificates-...   344.9 KiB   802 KiB/s 00:00 [####################] 100%
 gst-plugins-base...   334.8 KiB   519 KiB/s 00:01 [####################] 100%
 ndctl-73-1-x86_64     329.1 KiB   545 KiB/s 00:01 [####################] 100%
 luajit-2.1.0.bet...   319.2 KiB   580 KiB/s 00:01 [####################] 100%
 libnice-0.1.19-1...   309.3 KiB   243 KiB/s 00:01 [####################] 100%
 python-dnspython...   309.0 KiB   813 KiB/s 00:00 [####################] 100%
 poppler-glib-22....   280.0 KiB   759 KiB/s 00:00 [####################] 100%
 libyuv-r2322+3ae...   270.6 KiB   710 KiB/s 00:00 [####################] 100%
 haskell-bz2-1.0....   263.9 KiB   382 KiB/s 00:01 [####################] 100%
 fluidsynth-2.2.7...   254.9 KiB   294 KiB/s 00:01 [####################] 100%
 jasper-2.0.33-2-...   249.0 KiB  86.6 KiB/s 00:03 [####################] 100%
 poppler-qt5-22.0...   224.0 KiB   626 KiB/s 00:00 [####################] 100%
 oniguruma-6.9.8-...   216.9 KiB   295 KiB/s 00:01 [####################] 100%
 qtermwidget-1.1....   211.6 KiB   628 KiB/s 00:00 [####################] 100%
 picom-9.1-3-x86_64    166.8 KiB   217 KiB/s 00:01 [####################] 100%
 libbsd-0.11.6-2-...   166.4 KiB   260 KiB/s 00:01 [####################] 100%
 gd-2.3.3-4-x86_64     154.2 KiB   204 KiB/s 00:01 [####################] 100%
 jsoncpp-1.9.5-2-...   151.4 KiB   333 KiB/s 00:00 [####################] 100%
 shaderc-2022.1-3...   148.5 KiB   429 KiB/s 00:00 [####################] 100%
 libsasl-2.1.28-1...   145.5 KiB   495 KiB/s 00:00 [####################] 100%
 htop-3.2.0-1-x86_64   143.3 KiB   444 KiB/s 00:00 [####################] 100%
 glu-9.0.2-3-x86_64    142.8 KiB   541 KiB/s 00:00 [####################] 100%
 unrar-1:6.1.7-1-...   134.5 KiB   404 KiB/s 00:00 [####################] 100%
 python-markdown-...   132.3 KiB   464 KiB/s 00:00 [####################] 100%
 vulkan-icd-loade...   128.3 KiB   484 KiB/s 00:00 [####################] 100%
 sdl12-compat-1.2...   125.4 KiB   442 KiB/s 00:00 [####################] 100%
 gspell-1.10.0-2-...   123.0 KiB   129 KiB/s 00:01 [####################] 100%
 libavif-0.10.1-1...   115.7 KiB   237 KiB/s 00:00 [####################] 100%
 clutter-gst-3.0....   114.4 KiB   131 KiB/s 00:01 [####################] 100%
 xcb-proto-1.15-1-any  112.7 KiB   333 KiB/s 00:00 [####################] 100%
 gnome-desktop-1:...   112.3 KiB   293 KiB/s 00:00 [####################] 100%
 pciutils-3.8.0-1...   102.3 KiB   236 KiB/s 00:00 [####################] 100%
 zlib-1:1.2.12-2-...    90.4 KiB   169 KiB/s 00:01 [####################] 100%
 cifs-utils-6.15-...    89.0 KiB   248 KiB/s 00:00 [####################] 100%
 libseccomp-2.5.4...    88.1 KiB   307 KiB/s 00:00 [####################] 100%
 python-more-iter...    73.7 KiB   267 KiB/s 00:00 [####################] 100%
 libdbusmenu-glib...    70.0 KiB   282 KiB/s 00:00 [####################] 100%
 libshout-1:2.4.6...    69.8 KiB   124 KiB/s 00:01 [####################] 100%
 polkit-gnome-0.1...    64.6 KiB   391 KiB/s 00:00 [####################] 100%
 python-packaging...    60.2 KiB   320 KiB/s 00:00 [####################] 100%
 enchant-2.3.3-1-...    54.8 KiB   363 KiB/s 00:00 [####################] 100%
 libnotify-0.7.11...    53.4 KiB   324 KiB/s 00:00 [####################] 100%
 libmanette-0.2.6...    53.2 KiB   375 KiB/s 00:00 [####################] 100%
 libappindicator-...    52.0 KiB   364 KiB/s 00:00 [####################] 100%
 libsynctex-2022....    51.8 KiB   322 KiB/s 00:00 [####################] 100%
 jansson-2.14-2-x...    51.7 KiB   342 KiB/s 00:00 [####################] 100%
 libgudev-237-2-x...    44.6 KiB   328 KiB/s 00:00 [####################] 100%
 thunar-archive-p...    42.9 KiB   425 KiB/s 00:00 [####################] 100%
 libdbusmenu-gtk3...    38.6 KiB   294 KiB/s 00:00 [####################] 100%
 pacman-contrib-1...    38.5 KiB   296 KiB/s 00:00 [####################] 100%
 libpipeline-1.5....    33.5 KiB   353 KiB/s 00:00 [####################] 100%
 gambas3-gb-image...    32.5 KiB   182 KiB/s 00:00 [####################] 100%
 luit-20220111-1-...    29.9 KiB   270 KiB/s 00:00 [####################] 100%
 libindicator-gtk...    28.5 KiB   297 KiB/s 00:00 [####################] 100%
 minizip-1:1.2.12...    27.1 KiB   163 KiB/s 00:00 [####################] 100%
 alsa-card-profil...    27.0 KiB   186 KiB/s 00:00 [####################] 100%
 libinih-55-2-x86_64    15.4 KiB   157 KiB/s 00:00 [####################] 100%
 gambas3-gb-setti...    11.8 KiB  82.2 KiB/s 00:00 [####################] 100%
 harfbuzz-icu-4.2...     7.6 KiB   103 KiB/s 00:00 [####################] 100%
 pacman-mirrorlis...     7.5 KiB   110 KiB/s 00:00 [####################] 100%
 systemd-sysvcomp...     5.6 KiB  63.5 KiB/s 00:00 [####################] 100%
 chaotic-mirrorli...     3.0 KiB  6.32 KiB/s 00:00 [####################] 100%
 Total (141/141)      1065.1 MiB   559 KiB/s 32:31 [####################] 100%
error: failed retrieving file 'linux-5.17.5.arch1-1-x86_64.pkg.tar.zst' from mirror.osbeck.com : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
(141/141) checking keys in keyring                 [####################] 100%
(141/141) checking package integrity               [####################] 100%
error: libinih: signature from "Maxime Gauduin <alucryd@gmail.com>" is marginal trust
:: File /var/cache/pacman/pkg/libinih-55-2-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: elementary-icon-theme: signature from "Maxime Gauduin <alucryd@gmail.com>" is marginal trust
:: File /var/cache/pacman/pkg/elementary-icon-theme-7.0.0-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.
Press any key to continue...
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Maj 08, 2022, 08:14:29 PM
Janek - masz wciąż ten sam problem. Głównie z chaotic-aur. O kluczach tu:
https://aur.chaotic.cx/. Oprócz tego widzę problem z kluczami Archa. Bez aktualizacji, ale z zsynchronizowanymi repozytoriami zainstaluj archlinux-keyring. Winno pomóc.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: robson75 w Maj 12, 2022, 12:16:51 PM
Najprawdopodobniej, to repo stormos gryzie się z repo chaotic-aur. Weź na próbę za#uj repo stormos w pacman.conf, i wtedy przeprowadź pełną aktualizacje systemu. A jak wszystko będzie ok to proponowałbym pozbycie się tego repa stormos z pacman.conf, bo więcej masz przez nie problemów niż pożytku.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Maj 12, 2022, 11:49:01 PM
Robert - z całym szacunkiem, ale nic się nie gryzie, bo gryźć nie może. Brak prawidłowo dodanych kluczy. Ale ile razy ten sam problem można wałkować?
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: robson75 w Maj 13, 2022, 01:09:32 AM
Cytat: pavbaranov w Maj 12, 2022, 11:49:01 PMRobert - z całym szacunkiem, ale nic się nie gryzie, bo gryźć nie może.
Dajmy na to że w repo stormos są te same paczki co w chaotic-aur, i np. jakaś paczka zostanie szybciej zaktualizowana przez chaotic, a u Janka w pacman.conf jest najpierw dodane repo stormos a dopiero na samym końcu chaotic. To podczas aktualizacji są sprawdzane na samym początku klucze ze stormos, i stąd te błędy podczas aktualizacji.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Maj 13, 2022, 02:25:33 PM
Robert problem jest tu:
Cytat: Piejanto w Maj 08, 2022, 07:02:36 PMpobieranie potrzebnych kluczy...
:: Zaimportować klucz PGP 0706B90D37D9B881, "Nico Jensch <dr460nf1r3@chaotic.cx>"? [T/n] T
:: Zaimportować klucz PGP 0F65C7D881506130, "Maxime Gauduin <alucryd@archlinux.org>"? [T/n] T
(237/237) sprawdzanie spójności pakietów              [----------------------------] 100%
błąd:  chaotic-mirrorlist: podpis od "Nico Jensch (Chaotic-AUR) <dr460nf1r3@garudalinux.org>" posiada nieznane zaufanie
:: Plik /var/cache/pacman/pkg/chaotic-mirrorlist-20220504-2-any.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
błąd:  elementary-icon-theme: klucz "95220BE99CE6FF778AE0DC670F65C7D881506130" jest nieznany
:: Zaimportować klucz PGP 95220BE99CE6FF778AE0DC670F65C7D881506130? [T/n] T
:: Plik /var/cache/pacman/pkg/elementary-icon-theme-7.0.0-1-any.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
:: Plik /var/cache/pacman/pkg/libinih-55-2-x86_64.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
:: Plik /var/cache/pacman/pkg/gtk-theme-elementary-7.0.0-1-any.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
błąd:  nie udało się dokonać transakcji (Niepoprawny lub uszkodzony pakiet)
Wystąpiły błędy, nie zaktualizowano żadnego pakietu.
Nie ma to nic wspólnego z tym, co opisujesz. Poprawne rozwiązanie - prawidłowy import kluczy z chaotic-aur oraz z samego Archa. Jeśli klucze będą prawidłowo dodane, to problem, który Janek opisuje nie ma prawa zaistnieć niezależnie od tego, czy ta sama paczka będzie w jednym, czy w większej ilości repo, albowiem konkretna paczka jest podpisana konkretnym podpisem. I to właśnie o ten podpis jest lokalna baza GPG. Jeśli podpis jest - paczka zostanie zainstalowana. Jeśli jego nie ma, jest wadliwy - nie zostanie zainstalowana.
Niepoprawne rozwiązanie - usunąć w pacman.conf sprawdzanie kluczy, czyli "Never" :D To jednak każdy robi na własne ryzyko. 
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Maj 16, 2022, 01:37:34 AM
Panowie
Przecież nie tak dawno aktualizowałem keyring. Poza tym kiedy mnie pyta, czy zaimportować klucz, to mu kazałem zaimportować. Kiedyś podobny problem miałem tylko na starym Acerze ze StormOS-em. Robson radził aby przenieść wpis [chaotic-aur] na koniec [pacman.conf] i to wtedy pomogło. Teraz ten wpis jest już na końcu i niżej nie ma sensu go przenosić. Na Asusie ArchLinux-em nie miałem z tym problemów aż do teraz. Niczego nie zmieniałem i problem pojawił się jak diabeł z pudełka.
 Obecnie zarówno StormOS jak i ArchLinux pokazują podobny problem. Początkowo myślałem, że to wina transferu, ale obecnie transfer mam bardzo dobry a problem nie znika.
Octopi mi pokazuje, że Archlinux-keyring mam zainstalowany.

Dziś zrobiłem
pak -Sc
a następnie
pak -Syu --disable-download-timeout

Po ściągnięciu około 1490 MiB rozpoczeła się aktualizacja zakończona następującymi komunikatami:
*************8
błąd:  libinih: podpis od "Maxime Gauduin <alucryd@gmail.com>" posiada zaufanie krańcowe
:: Plik /var/cache/pacman/pkg/libinih-55-2-x86_64.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
błąd:  elementary-icon-theme: podpis od "Maxime Gauduin <alucryd@gmail.com>" posiada zaufanie krańcowe
:: Plik /var/cache/pacman/pkg/elementary-icon-theme-7.0.0-1-any.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
błąd:  nie udało się dokonać transakcji (Niepoprawny lub uszkodzony pakiet)
Wystąpiły błędy, nie zaktualizowano żadnego pakietu.

*******************************
PS. przepraszam, za opóźnione reakcje, ale mam parę kłopotów i rzadziej siadam do kompa.

Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Maj 16, 2022, 08:33:56 AM
Janku, jakby to Ci powiedzieć: wiesz swoje... Błąd:
Cytat: Piejanto w Maj 16, 2022, 01:37:34 AMbłąd:  libinih: podpis od "Maxime Gauduin <alucryd@gmail.com>" posiada zaufanie krańcowe
:: Plik /var/cache/pacman/pkg/libinih-55-2-x86_64.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
błąd:  elementary-icon-theme: podpis od "Maxime Gauduin <alucryd@gmail.com>" posiada zaufanie krańcowe
:: Plik /var/cache/pacman/pkg/elementary-icon-theme-7.0.0-1-any.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Oba błędy są związane z:
1. dodaniem nieoficjalnego repozytorium alucryd: https://wiki.archlinux.org/title/Unofficial_user_repositories#alucryd
2. brakiem dodanych do bazy kluczy GPG klucza Maxime Gauduina, a jak widać paczki te muszą być podpisane.
Klucz Maxine winien znajdować się w systemie i być dostarczony wraz z archlinux-keyring, ale go nie ma, a przynajmniej nie ma dla paczek z alucryd.
Należy go dodać.
Klucz jest tu: https://archlinux.org/people/trusted-users/#alucryd
O dodawaniu kluczy przez pacmana: https://wiki.archlinux.org/title/Pacman/Package_signing#Adding_unofficial_keys
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Maj 18, 2022, 02:23:11 AM
Czy to może być związanie z doinstalowaniem trybu ciemnego do FF przez Stylus?

Może coś ze soba nie współpracuje?

Dlaczego to mi się zaczęło dziać jednocześnie na obu kompach? Na Acerze ze StormOS-em i na Asusie z Archem?

Ale dlaczego też jeszcze gorsze rzeczy dzieją mi sie również na Acerze ze StormOS-em? Dziś spróbowałem go zajśc z flanki poprzez doinstalowanie Octopi. Okazalo się, że  nie mam Auracle-git. Wrzuciłem polecenie [pak -SA chaotic-aur/auracle-git]

 pak -SA chaotic-aur/auracle-git
Używana jest konfiguracja użytkownika: /home/jan/.config/pak/pak.conf

:: Uruchamianie aktualizacji systemu...
Sprawdzanie...

***************************88 mnóstwo ściagania i komunikat

Do pobrania:              188,40 MiB
Do zainstalowania:       4513,97 MiB
Zmiana po aktualizacji:    -3,86 MiB

*************************  kazałem kontynuować. Nastapiło działanie a na koniec komunikaty:

pobieranie potrzebnych kluczy...
:: Zaimportować klucz PGP 0F65C7D881506130, "Maxime Gauduin <alucryd@archlinux.org>"? [T/n] T
:: Zaimportować klucz PGP 0706B90D37D9B881, "Nico Jensch <dr460nf1r3@chaotic.cx>"? [T/n] T
(330/330) sprawdzanie spójności pakietów               [----------------------------] 100%
błąd:  libinih: klucz "95220BE99CE6FF778AE0DC670F65C7D881506130" jest nieznany
:: Zaimportować klucz PGP 95220BE99CE6FF778AE0DC670F65C7D881506130? [T/n] T
:: Plik /var/cache/pacman/pkg/libinih-55-2-x86_64.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
błąd:  chaotic-keyring: podpis od "Nico Jensch (Chaotic-AUR) <dr460nf1r3@garudalinux.org>" posiada nieznane zaufanie
:: Plik /var/cache/pacman/pkg/chaotic-keyring-20220514-1-any.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
błąd:  chaotic-mirrorlist: podpis od "Nico Jensch (Chaotic-AUR) <dr460nf1r3@garudalinux.org>" posiada nieznane zaufanie
:: Plik /var/cache/pacman/pkg/chaotic-mirrorlist-20220504-2-any.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
:: Plik /var/cache/pacman/pkg/elementary-icon-theme-7.0.0-1-any.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
:: Plik /var/cache/pacman/pkg/gtk-theme-elementary-7.0.0-1-any.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
błąd:  nie udało się dokonać transakcji (Niepoprawny lub uszkodzony pakiet)
Wystąpiły błędy, nie zaktualizowano żadnego pakietu.

***************************
Qrdę... a było tak pięknie.

Mirrory mam oczywiście zaktualizowane.

Nie działa mi programy/system/dodawnie/usuwanie oprogramowania. Nie zgłasza też nowych aktualizacji. Dlatego chciałem doinstalować Octopi, ale to jest mozliwe po pełnej aktualizacji. To samo tyczy archlinux-keyring. I w ten sposób koło się zamyka.
Jutro powalczę jeszcze z Asusem, na którym jest Arch.

Pozdro.
 

Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Maj 18, 2022, 07:35:24 AM
Cytat: Piejanto w Maj 18, 2022, 02:23:11 AMCzy to może być związanie z doinstalowaniem trybu ciemnego do FF przez Stylus?
Nie
Cytat: Piejanto w Maj 18, 2022, 02:23:11 AMMoże coś ze soba nie współpracuje?
Nie
Cytat: Piejanto w Maj 18, 2022, 02:23:11 AMDlaczego to mi się zaczęło dziać jednocześnie na obu kompach? Na Acerze ze StormOS-em i na Asusie z Archem?
Bo masz dodane repozytoria nieoficjalne, które są kategorii "signed" (czyli oferują podpisane paczki), a nie masz dodanych kluczy pakujących, lub masz je dodane źle (nie wiem, który raz już to samo).
Cytat: Piejanto w Maj 18, 2022, 02:23:11 AMAle dlaczego też jeszcze gorsze rzeczy dzieją mi sie również na Acerze ze StormOS-em? Dziś spróbowałem go zajśc z flanki poprzez doinstalowanie Octopi. Okazalo się, że  nie mam Auracle-git. Wrzuciłem polecenie [pak -SA chaotic-aur/auracle-git]
Naucz się używać pak. Po wpisaniu bez żadnej komendy - otrzymujesz krótką pomoc. Polecenie, które wydajesz jest lekko bez sensu.
Cytat: Piejanto w Maj 18, 2022, 02:23:11 AMbłąd:  libinih: klucz "95220BE99CE6FF778AE0DC670F65C7D881506130" jest nieznany
Dodaj klucz jw.
Cytat: Piejanto w Maj 18, 2022, 02:23:11 AMbłąd:  chaotic-keyring: podpis od "Nico Jensch (Chaotic-AUR) <dr460nf1r3@garudalinux.org>" posiada nieznane zaufanie
Znów klucze. Tym razem z chaotic-aur. Jeśli są dodane, a nie są rozpoznawane - dodaj ręcznie.
Dopóki nie zrobisz porządku z kluczami lub na trwale nie zrezygujesz z ich sprawdzania - nie zainstalujesz żadnej paczki.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: robson75 w Maj 18, 2022, 12:08:52 PM
Janek chaotic-keyring masz nieaktualny, bo 4 dni temu była aktualizacja paczki, weź ją pobierz chaotic-keyring i zaktualizuj przez pacman -U.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Maj 18, 2022, 01:10:22 PM
Aha - i pokaż: pak -Qi archlinux-keyring (ogólnie to samo do wszystkich paczek *-keyring).
Oprócz tego co pisał Robert możesz wykonać:
sudo pacman -Sy chaotic-keyring archlinux-keyringKoniecznie przez pacman - wyłącznie instalacja pojedynczych paczek.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Maj 19, 2022, 12:07:30 AM
oto mój obecny (przed wszystkimi próbami naprawy) keyring

Używana jest konfiguracja użytkownika: /home/jan/.config/pak/pak.conf

Nazwa                 : archlinux-keyring
Wersja                : 20220423-1
Opis                  : Arch Linux PGP keyring
Architektura          : any
Adres url             : https://gitlab.archlinux.org/archlinux/archlinux-keyring/
Licencje              : GPL3
Grupy                 : Brak
Dostarcza             : Brak
Zależy od             : Brak
Opcjonalne zależności : Brak
Wymagany przez        : chaotic-keyring  pacman
Opcjonalny dla        : Brak
Konfliktuje z         : Brak
Zastępuje             : Brak
Rozmiar po instalacji : 1489,49 KiB
Autor pakietu         : Christian Hesse <eworm@archlinux.org>
Data zbudowania       : sob, 23 kwi 2022, 00:10:12
Data zainstalowania   : nie, 24 kwi 2022, 00:30:36
Powód zainstalowania  : Zależność innego pakietu
Skrypt instalacyjny   : Tak
Potwierdzone przez    : Podpis

Zaraz będę walczył dalej

Ściągnąłem z [https://gitlab.archlinux.org/archlinux/archlinux-keyring/] trzy paczki
archlinux-keyring-master.zip
keyring-master.zip
chaotic-keyring-20220514-1-any.pkg.tar.zst

rozpakowałem dwie pierwsze paczki i wszedłem do trzeciej a tam rozpakowałem [usr] co dało rozpakowany katalog
 [usr] a w nim podkatalog [share] i w podkatalogu share kolejny podkatalog [pacman], a w podkatalogu [pacman] kolejny podkatalog [keyrings]
W podkatalogu [keyrings] mamy pliki
chaotic.gpg
chaotic-revoked
chaotic-trusted

Nie bardzo wiem, od której paczki zacząć upgrade, żeby nie skrewić.
Czy powinienem coś budować? nie widzę tu PKGBUILD-a
w sumie mam trzy rozpakowane paczki
archlinux-keyring-master
keyring-master
usr

Co do używania [pak] to wiem o tym i wyszło mi że instalowanie z AUR to [-SA] a informacja o pakiecie, to [-SI]
A jeśli chodzi o zastosowany przeze mnie [pak -Sc] przed próbą aktualizacji, to dlatego, żeby usunąć ewentualne śmieci, przed poleceniem [pak -Syu]


Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Maj 19, 2022, 07:12:04 AM
Janek - najwyższa pora zmienić albo system, albo zasady gry.
Paczka archlinux-keyring - przestarzała.
Napiszę raz jeszcze, ale doprawdy ostatni raz, bowiem cholernie irytuje mnie jak ktoś z uporem nie czyta tego co się do niego pisze.
Masz 2 możliwości instalacji, stosujesz do tego pacman, a nie pak.
1. sudo pacman -Sy archlinux-keyring chaotic-keyring albo
2. ściągasz (a już zdaje się, że masz ściągnięte) paczki na dysk i pak -U ścieżka/archlinux-keyring-itd W miejscu "itd" wciskasz TAB i Ci samo rozwinie.
I kończmy tę epopeję, którą odbywamy z regularnością bodaj raz na miesiąc.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: robson75 w Maj 19, 2022, 12:50:19 PM
Janek po jakiego groma rozpakowujesz paczki już gotowe do instalacji?
Po pobraniu ich na dysk, uruchamiasz menadżera plików, wchodzisz do pobrane, klikasz na okno PPM i wybierasz otwórz w terminalu. Następnie wpisujesz sudo pacman -U lub pak -U, i klawiszem TAB ( nad CAPS-lockiem) uzupełniasz.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Maj 19, 2022, 04:32:02 PM
Robert - nie wiem co on pobrał i skąd, ale tam są jakieś paczki *.zip. Teoretycznie pacman i takie jest w stanie obsłużyć, ale z nazw wynika, że to nie są paczki Archa.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: robson75 w Maj 19, 2022, 05:22:15 PM
Cytat: pavbaranov w Maj 19, 2022, 04:32:02 PMRobert - nie wiem co on pobrał i skąd, ale tam są jakieś paczki *.zip. Teoretycznie pacman i takie jest w stanie obsłużyć, ale z nazw wynika, że to nie są paczki Archa.
Main God, rzeczywiście, jakieś zipy.
Janek paczki się pobiera z głównej strony Archa, a nie z jakiegoś githuba.
Ale przecież Paweł podał Ci najprostsze rozwiązanie
sudo pacman -Sy archlinux-keyring chaotic-keyringTo ja nie wiem po kiego Ty tak kombinujesz.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Maj 20, 2022, 12:34:41 AM
@pavbaranov

Dziekuję i przepraszam.
Może faktycznie jestem takim "entuzjastą skrzypiec bez, ale słuchu".
Z Linuxa, już raczej nie zrezygnuję bo... qrdę.. jestem jego entuzjastą.
A że może go nie ogarniam, to zgoda. Tylko czy głupi nie ma prawa do Księżyca?

Niestety, jest tak, że mnie System jest potrzebny głównie do obsługi moich drobnych potrzeb i lubie, gdy to on jest moim narzędziem a nie ja narzedziem jego. Dlatego zrezygnowałem z Windows, a - szczerze mówiąc - jak patrzę na MAC-a córki to i tam system rządzi.
Arch-a może nie ogarniam, ale wolę nawet przeinstalowywać System (tak było z Mandrake i Mandriva), niż kompletną zależność.
Wyprowadziłeś mi kiedyś Antergosa z takiego DOŁU, że do dziś nie wierzę, że to się stało naprawdę. I to tylko na podstawie moich zeznań. Wdzięczność.
Bardzo bym nie chciał wracać do debianowskich systemów.
Było przecież bardzo dobrze. Robiłem prawie codziennie aktualizacje zarówno mirrorów jak i Systemu. Widziałem, ze aktualizacje dotyczą również keyringów.
Skąd zatem nieaktualne keyringi?
Dbałem o to, jak o higienę i jestem - prawdę mówiąc - zaskoczony.

Pozdrowienia.
Godz 00,36. Dzień się zaledwie zaczął, a już jestem padnięty.

Dzięki i do następnego.


Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Maj 20, 2022, 11:54:11 PM
@robson75

Faktycznie. Robert, ja ostatnio przyjeżdżam padnięty.
Paweł i Ty macie to wszystko obcykane.
Ja po prostu zrobiłem [-Qi] i mi wyszedł taki adres.
Jest tak, że jak już "wiem wszystko", a System działa bezbłędnie, to skupiam się na innej robocie i mi wiedza zanika jak kurze wizja, gdy nie kręci łbem.
Dzięki za zwrócenie uwagi.
Dziś nieco wcześniej siadłem i mniej mi się mieni w ślipiach. Spróbuję.
Dzięki.
************************
Już wiem, dlaczego zgłupiałem. Sprawdziłem w Octopi te keyringi i tam je chciałem aktualizaować, a Octopi mi rzekło, że tylko pełna aktualizacja i mnie wywaliło.

Okazuje się, że polecenie [sudo pacman -Sy archlinux-keyring chaotic-keyring] juz miałem w swoim samouczku, ale nie wiem, jak to się stało, że go nie znalazłem. Jakaś ślepota. Przepraszam.

Teraz z kolei, aktualizacja poszła ale pokazały się errory i znów nie mam Wi-Fi
************
=> dkms install --no-depmod rtl8821ce/1.0.5.r130.gca204c6 -k 5.15.36-256-tkg-bmq
Error! Bad return status for module build on kernel: 5.15.36-256-tkg-bmq (x86_64)
Consult /var/lib/dkms/rtl8821ce/1.0.5.r130.gca204c6/build/make.log for more information.
==> WARNING: `dkms install --no-depmod rtl8821ce/1.0.5.r130.gca204c6 -k 5.15.36-256-tkg-bmq' exited 10
==> dkms install --no-depmod rtl8821ce/1.0.5.r130.gca204c6 -k 5.17.9-arch1-1
Error! Bad return status for module build on kernel: 5.17.9-arch1-1 (x86_64)
Consult /var/lib/dkms/rtl8821ce/1.0.5.r130.gca204c6/build/make.log for more information.
********************************
Kiedyś Robert mi poradził wrzucić jakiś LTS i Wi-Fi wróciło, ale chciałbym abyście Panowie popatrzyli na powyższe,
żebym znowu czegoś nie skaszanił.

W moim samouczku miałem :
wpisz
sudo pacman -S linux-lts linux-lts-headers
A po instalacji wykonujesz tą komendę
sudo grub-mkconfig -o /boot/grub/grub.cfg

Zrobiłem ale nie zadziałało.


PS
Ze StormOS-em  upgrade keyringów się nie udało.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Maj 21, 2022, 07:48:13 AM
Z całego postu istotna informacja jest taka, że info dlaczego nie buduje się moduł zawarte jest w:
Cytat: Piejanto w Maj 20, 2022, 11:54:11 PMConsult /var/lib/dkms/rtl8821ce/1.0.5.r130.gca204c6/build/make.log for more information.
Być może, jeśli to pokażesz, to nas oświeci (choć wątpię).

I powiem tak: z całym szacunkiem dla Ciebie, ale nie radzisz sobie z nieoficjalnymi repozytoriami - wywal te wszystkie repo od stormosa itp. Nie rozróżniasz, że kernel pn. linux, a jakiś linux-tkg-bmq to dwa różne kernele (przebudowanie GRUBa dla linux, nie uczyni tego automatycznie i magicznie dla tego drugiego). Zainstaluj sobie linux-zen oraz linux. Ten pierwszy jako podstawowy, bo zwykle się lepiej sprawdza. Drugi do awaryjnego stosowania. Resztę kerneli wywal. Przebuduj GRUBa.

Polecenie, ktore podajesz na końcu (przebudowanie GRUB) nie ma nic wspólnego ze zbudowaniem modułu dkms, a tu jest problem. Temat również tutaj był już z Tobą wałkowany i to bodaj nie raz, a zatem przeglądnij wątki.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: robson75 w Maj 21, 2022, 12:27:50 PM
Tak, zgadza się proponowałem Ci instalacje kernela LTS, ale jak był w wersji 5.10, a teraz jest już wersja 5.15 która to nie posiada modułów rtl8821ce. Tak jak pisał Paweł w innym wątku, weź zainstaluj linux 5.17 który to ma wbudowane rtl8821ce, a linux-tkg-bmq weź usuń, bo z tego co widzę to w repo chaotic-aur jest wersja 5.15.36, a jest już dostępna 5.15.41. Oczywiście po każdej instalacji oraz usunięciu kernela trzeba przeładować GRUB-a.

EDIT.
I po sprawdzeniu config linux 5.17 jest ten moduł
CONFIG_RTL8821AE=mWięc nie powinno być problemu.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: ciubaka w Maj 22, 2022, 10:29:30 AM
Janku, może moja podpowiedź coś Ci pomoże. Ja co prawda mam "prawie koszernego" Archa, tyle że z chaotic-aur. I też po ponad miesięcznym niezaglądaniu żądał ode mnie kluczy, i też je zakwestionował. System zaktualizowałem bez żadnych problemów przy pomocy tak nielubianego tutaj Pamac. Działa, piszę z niego, Pak i Octopi mówią, że nie ma nic do zrobienia.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Maj 22, 2022, 10:41:55 AM
Ok, jedna uwaga na marginesie. Klucze wygasają. Dodatkowo są nowi TU/DEV, starzy odchodzą. Klucze się zmieniają. Aktualizując system, jeśli widzimy jakąś paczkę *-keyring, warto jest przerwać aktualizację, za pomocą pacman (nie, żadnych innych wynalazków - ma byc pacman tylko i wyłącznie) zainstalować ową paczkę *-keyring bez aktualizacji całego systemu, czyli:
pacman -Sy cośtam-keyringi dopiero później puścić aktualizację systemu. Zwykle aktualizacja systemu odbywa się w kolejności alfabetycznej, a zatem może się zdarzyć, że paczka *-keyring zawierająca klucze jakiejś paczki będzie aktualizowana po niej. I stąd problemy.
Na marginesie muszę pogadać z Damianem, czy paka da się tak usprawnić, by po wykryciu *-keyring aktualizował ją w pierwszej kolejności, a dopiero potem przeprowadzał aktualizację systemu.

EDIT:
Facet jest super. Przynajmniej wersja pak-git już obsługuje tę funkcjonalność. Niebawem pewnie trafi pod strzechy, czyli w "stabilnego" pak.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Maj 24, 2022, 12:47:12 PM
@pavbaranov, @robson75, @ciubaka

@pavbaranov
Dzięki. Jasne, że sobie nie radzę, dlatego właśnie bywam tutaj. Niestety, zmiany w Linuxie mnie zaskakują ale dotychczas zawsze @Linuxiarze.pl mnie wyprowadzali na prostą, a czytanie Waszych porad daje mi wrażenie, że jestem mądrzejszy. I faktycznie, dopóki, coś mocniej nie tąpnie, to daje sobie radę.

@ciubaka
Z tym Pamacem, też miałem kilka pozytywnych zdarzeń i chyba powinienem do niego wrócić. Dzięki za przypomnienie.

@robson75
Spróbuje zrozumieć, to co mi napisałeś i spróbuję powalczyć w tym kierunku. Obawiam się, że swoim zwyczajem zacznę kopać głębiej niż należało i coś schrzanię. Dlatego zarchiwizuję najpierw wszystkie cenniejsze pozycje nim zabiorę się za "naprawę".
W ostateczności przeinstaluję System. Dotychczasowe porady od Was powinny mi pozwolić na powrót do tej konfiguracji, która mi bardzo odpowiada.

Dzięki za pomoc i za cierpliwość.

PS.
@ciubaka
Właśnie czytałem opinię @pavbaranov m.in. o Pamacu i nie była to dobra opinia. Teraz mam zaklopkę i się waham. Pamaców jest kilka. Jest Pamac-classic, Pamac-AUR, Pamac-aur-git...  Którego ewentualnie powinienem analizować?


 
 




Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: robson75 w Maj 24, 2022, 02:55:38 PM
Jeżeli pamac, to tylko pamac-classic, jest najmniej problematyczny.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Maj 24, 2022, 03:10:11 PM
Niemniej jednak, jedyna - bodaj - nakładka na pacmana, która poradzi sobie z problemem Janka, którym męczy mniej więcej raz na miesiąc, czy dwa, to obecna wersja pak. Tylko ona wymusza instalację *-keyring przed instalacją innych paczek.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: robson75 w Maj 24, 2022, 04:11:26 PM
Cytat: pavbaranov w Maj 24, 2022, 03:10:11 PMNiemniej jednak, jedyna - bodaj - nakładka na pacmana, która poradzi sobie z problemem Janka, którym męczy mniej więcej raz na miesiąc, czy dwa, to obecna wersja pak. Tylko ona wymusza instalację *-keyring przed instalacją innych paczek.
Tylko że Janek musiałby zaktualizować pak, bo prawdopodobnie nie był aktualizowany od wieków.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: nycko w Maj 24, 2022, 05:28:06 PM
Janie zapisz w "notatkach" i wykonaj
cd /tmp && wget "https://raw.githubusercontent.com/polaur/new-branded/master/pak-git/PKGBUILD" && makepkg -fsirNa pytanie czy zastąpić pak przez pak-git odpowiedz T,

Zaktualizuj system pak -Syu i błagam rób to przynajmniej raz w tygodniu.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Maj 26, 2022, 12:38:35 AM
@robson75
Też myślałem o [pamac-clasic] Zawsze wybieram clasic, ale zapytałem dla porządku.
Spróbuję przez Octopi.

@pavbaranov
Qrdę... o PAK-u nie pomyślałem. Jakoś tak wydawało mi sie, że skoro robię [pak -Syu] top mi sie aktualizuje wszystko.

@nycko
Robiłem [pak -Syu] codziennie. Wszystko było pięknie. Faktem jest że kompa ze StormOS-em zostawiłem na dwa tygodnie, ale StormOS, akurat jest najmniejszym problemem. Istotniejszy jest Arch, bo tutaj mam prawie wszystko. Już zarchiwizowałem i chcoałem pobrać Anarchy ISO i natknąłem się na taką informację:

"Ostatnia aktualizacja: 8th kwiecień 2022, 12:31 am
Pobierz Anarchy Linux
Anarchy Linux nie jest już rozwijany.
Ostatnia dostępna wersja z 2020 roku."

Aż mi się nie chce wierzyć.

OK mam to już zapisane o pak-git. Dzięki za naukę. Wykonuję.
Wyszło na koniec tak :
****************************
==> Instalowanie pakietu pak-git za pomocą pacman -U...
[sudo] hasło użytkownika jan:
wczytywanie pakietów...
rozwiązywanie zależności...
szukanie sprzecznych pakietów...
:: pak-git konfliktuje z pak. Usunąć pak? [t/N] t

Pakiety (2) pak-1:5.2-1 [usunięcie]  pak-git-1:5.4.1.r1.g921d26a-1

Do zainstalowania:       0,15 MiB
Zmiana po aktualizacji:  0,00 MiB

:: Kontynuować instalację? [T/n] T
(1/1) sprawdzanie kluczy w bazie                   [######################] 100%
(1/1) sprawdzanie spójności pakietów               [######################] 100%
(1/1) wczytywanie listy plików                     [######################] 100%
(1/1) sprawdzanie konfliktów plików                [######################] 100%
(2/2) sprawdzanie dostępnego miejsca na dysku      [######################] 100%
:: Przetwarzanie zmian pakietu...
(1/1) usuwanie pak                                 [######################] 100%
(1/1) instalowanie pak-git                         [######################] 100%
Opcjonalne zależności dla pak-git
    asp: to download PKGBUILDs of official packages
    auracle-git: (AUR) to manage AUR packages [zainstalowano]
    namcap: to validate built packages
    reflector: to keep mirrorlist up to date [zainstalowano]
    subversion: to check upstream for updated -svn packages
    fzf: to display all data about installed packages
    downgrade: (AUR) to downgrade packages
    libnotify: to display desktop notifications [zainstalowano]
:: Uruchamianie po-transakcji...
(1/1) Arming ConditionNeedsUpdate...
****************************************************************************

 następnie zresetowałem kompa i na wszelki wypadek wpisałem [pak -Syu]
zaczęło się dziać.  Poszła wielka aktualizacja, ale jak mnie zapytało gdzie cośtam zapisać to podałem home/jan i to chyba nie była dobra odpowiedź. Nie mogę zacytować, bo poszło tak wysoko, że już nie pokazuje.
Ale poczułem potęgę.
Qrdę... wszystkim się chwalę że jestem linuxiarzem, a po prawdzie tom zwykły v-ce pierdoła. Przepraszam za tę impresję.
Arch, to jednak formuła jeden.
Zrobię teraz reset. Jeśli się nie odezwę, to znaczy, że coś zawaliłem.
WRÓĆ...
Jakby co mam jeszcze ACER-a ze StormOS-em i na dodatek z czynnym Wi-Fi.
Jego też przećwiczę poleceniem
[cd /tmp && wget "https://raw.githubusercontent.com/polaur/new-branded/master/pak-git/PKGBUILD" && makepkg -fsir]
Dzięki. Panowie.

*********************************po resecie.

System nie padł. Padłem ja.

Do następnego.







Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Maj 26, 2022, 02:00:14 AM
Już wiem o co chodziło. chodziło o [digikam-git] wywaliłem za pomoca Octopi i zrobiłem [pak -Syu]
Powiedziało : :Nie ma nic do zrobienia".
Jeszcze tylko to Wi-Fi i byłbym szczęśliwy.
Próbowałem przeinstalowac sterownik za pomocą polecenia
[pak -Sa rtl8821ce-dkms-git]
Nic to tym razem nie dało.
Wywaliłem linux-lts zostało linux-lts-headers. Wywalić?

Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Maj 26, 2022, 08:04:12 AM
Janek:
1. pak ułatwia to, z czym masz problem dopiero od wersji z 22.05.
2. Masz obecnie już zainstalowanego pak-git - nie musisz robić tego, co podaje @nycko.
3. Jeśli pak zapytał by podać jakąś ścieżkę do czegoś, to na 99,99% była to instalacja czegoś z AUR i pytało, gdzie pobrać źródła.
4. Od czasu do czasu, gdy tutaj: https://forum.archlinux.org.pl/viewtopic.php?pid=7591 będą się pojawiać nowe informacje o nowej wersji pak, będziesz musiał zrobić aktualizację pak-git: pak -SP new-branded/pak-git bo z automatu Ci to się nie zaktualizuje.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: robson75 w Maj 26, 2022, 12:00:06 PM
Cytat: Piejanto w Maj 26, 2022, 02:00:14 AMJeszcze tylko to Wi-Fi i byłbym szczęśliwy.
Próbowałem przeinstalowac sterownik za pomocą polecenia
[pak -Sa rtl8821ce-dkms-git]
Nic to tym razem nie dało.
Wywaliłem linux-lts zostało linux-lts-headers. Wywalić?
Janek do cholery, wywal linux-lts-headers
pacman -Rns linux-lts-headersI zainstaluj
pacman -Sy linux linux-headerssudo grub-mkconfig -o /boot/grub/grub.cfgRestart kompa, i Wi-Fi powinno być.
Być może że rtl8821ce-dkms-git już nie będziesz potrzebował, to też go wywal
pacman -Rns rtl8821ce-dkms-git
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Maj 27, 2022, 08:46:08 PM
Dziś usiadłem do StormOS-a

Zrobiłem (mam to zapisane i bede robił przynajmniej raz w tygodniu jeśli wyjdę z obecnej zapaści)

cd /tmp && wget "https://raw.githubusercontent.com/polaur/new-branded/master/pak-git/PKGBUILD" && makepkg -fsir

następnie

pak -Syu
*******************

Poszła aktualizacja, ale jakas taka mała na 150 pare MiB. Pokazało mi natomiast, że
mam niezainstalowane [auracle-git]

Powiedziałem aby PAK zainstalował auracle-git i wtedy mi odpowiedziało, że potrzebna jest pełna aktualizacja. Tyle tylko, że tym razem tej pełnej aktualizacji jest 1445 MiB. i na dodatek wiem jak sie ona skończy.
Nie mam na StormOS Octopi, bo nie sądziłem, że się aż tak wywalę.

Prawdopodobnie będę przeinstalowywał StormOS-a, bo tylko z nim funkcjonuje mi na Acerze jasność ekranu.
Asus z Archem doszedł do siebie po wszystkich zalecanych przez Was zabiegach, z wyjątkiem Wi-Fi.
Wi-Fi nie ma i juz.

Dzięki za pomoc.


Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Maj 27, 2022, 09:49:29 PM
@pavbaranov

Przepraszam Pawle, że dopiero dziś odpowiadam na :
"Z całego postu istotna informacja jest taka, że info dlaczego nie buduje się moduł zawarte jest w:

    Cytat: Piejanto w Maj 20, 2022, 09:54:11 PM
    Consult /var/lib/dkms/rtl8821ce/1.0.5.r130.gca204c6/build/make.log for more information.

Być może, jeśli to pokażesz, to nas oświeci (choć wątpię)."

Gdzieś mi to przepadło i dopiero dzisiaj, gdy czytam Wasze odpowiedzi, dostrzegłem to pytanie. Zrobiłem zrzut ekranu na poziomie /rtl8821ce/ a dalej nie ma
/1.0.5.r130.gca204c6/build/make.log

Qrdę... zrobiłem zrzut ekranu z moim Midnight Commanderem, ale nie wiem jak załączyć. Klikam prawym w [załącz obraz] wybieram z ekranu ten zrzut i nic się nie dzieje.
W każdym razie w /var/lib/dkms/rtl8821ce

/1.0.5r100g18c1f60
/1.0.5r116g14b536f
/1.0.5r127g897e7c4
/1.0.5r134gdce62b9
~kernel-5.13.13-arch1-1-_x86_64
~kernel-5.15.43-1-lts-x86_64
~kernel-5.17.9-arch1-1-x86_64
********************************


natomiast nie ma [/1.05.r130.gca204c6] o którym mówiłeś

więcej jest w /1.0.5r134gdce62b9/build i zrobiłem też zrzut ekranu, ale... no właśnie... jak to tutaj zamieścić?



Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: robson75 w Maj 28, 2022, 11:41:44 AM
Cytat: Piejanto w Maj 27, 2022, 08:46:08 PMWi-Fi nie ma i juz.
A czy jesteś pewien że odpaliłeś system z kernela linux?
Bo z Twojego opisu wynika że miałeś tam zainstalowane 2 LTS, linux-lts oraz linux-lts-tkg-bmq, powinieneś oba usunąć. Bo prawdopodobnie system Ci startuje z jakiegoś LTS-a.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Maj 29, 2022, 01:45:20 PM
Janek - niestety nikt nie siedzi przy Tobie i tego, co tam robisz i masz nie widzi. Po kolei:
1. Od kernela 5.2 sterownik do RTL8821CE winien być w samym kernelu i nazywa się RTW88. Do jego działania musisz mieć jednak zainstalowaną paczkę linux-firmware.
Czy jest w danym kernelu wbudowana obsługa sprawdzisz wpisując:
zgrep RTW88 /proc/config.gzJeśli w odpowiedzi otrzymasz:
CONFIG_RTW88 is not setto nie ma tej obsługi; każdy inny wynik winien wskazywać, na to, że kernel obsługuje tę kartę wifi.
2. W przeszłości sygnalizowano, że na kernelach >=5.9 RTW88 nie działa poprawnie, sugerując m.in. instalację rtl8821ce, co łączyć się mogło z zablokowaniem modułu RTW88 w kernelu. Sprawdź, czy masz plik /etc/modprobe.d/blacklist.conf i jego zawartość. Sprawdź zresztą zawartość wszelkich plików conf w tym katalogu i czy nie występuje w nich taka linia:
blacklist rtw88_8821ceTo blokuje moduł w kernelu odpowiadzialny za sterownik do Twojej karty.
3. Zdecyduj się na jakiś jeden kernel (tymczasowo odinstaluj inne). Zdecyduj się, czy chcesz mieć RTW88 czy rtl8821ce. W pierwszym przypadku - nie budujesz paczki rtl8821ce-dkms-git i ją powinieneś usunąć z systemu. Reszta podpowiedzi w pkt. 1 i 2.
W drugim przypadku w pierwszej kolejności musisz poprawnie zbudować paczkę rtl8821ce-dkms-git. Jeśli będzie się wadliwie budować, to dostaniesz informację o tym, tak jak poprzednio. W takim przypadku zawartość logu (zasadniczo to pewnie ostatnich 10 linijek wystarczy), które musisz tu wkleić jeśli chcesz pomocy (nie, nie żadne zrzuty ekranu - to jest tekstówka, a zatem możesz zrobić copy&paste).

PS: IMO powinieneś sobie zrobić jakiś porządek z tym sytemem, bo jakoś mi się wydaje, że masz tam sporo namieszanego (w sensie jakieś przypadkowe rzeczy, które są podróżą z przeszłości - kiedyś działały, teraz już niekoniecznie, a uniemożliwiają działanie). Na przyszłość - zapisuj sobie każdą ingerencję (Twoją) w system, którą robisz z palca i w przestrzeni roota (czyli wszędzie oprócz /home/) - będzie łatwiej i Tobie i nam.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Czerwiec 02, 2022, 12:07:02 AM
@robson75

Robson JESTEŚ WIELKI !!!

miałem usuniętego [linux-lte] boś mi kiedyś kazał ale... [linux-lts-tkg-bmq] był !!

Usunąłem i zrestartowałem kompa. Miałem pietra, bo znów szukał tego elteesa do uruchomienia, ale mu przestawiłem na początku przed ładowaniem i ruszył prawdziwy ARCH. Później wkleiłem mu polecenie :
[sudo grub-mkconfig -o /boot/grub/grub.cfg]
i znów zrestarowałem. Tym razem start poszedł już bezproblemowo

Po restarcie ( już po tym pierwszym) od razu pokazało mi się Wi-Fi. MAM Wi-Fi !!
Aha... [pacman -Sy linux linux-headers] tego nie musiałem robić bo miałem zainstalowane. Pokazało mi Octopi.
Teraz sobie Wasze uwagi pokopiuję i będe o tyle mądrzejszy. Przed usunięciem tego LTS-a BMQ zrobiłem aktualizację systemu i i wszystko się pięknie zaktualizowało.
Poprzednio aktualizowałem codziennie  [pak -m] oraz [pak -Syu] Od czasu do czasu robiłem [pak -Sc]. Teraz wiem, że mam do aktualizowania parę rzeczy więcej i mam nadzieję, ze już nie będę Wam, Panowie, zawracał głów.

@robson75
@pavbaranov
@ciubaka
@nycko
i Wszystkim innym, którzy tutaj zajrzeli
DZIĘKUJĘ.

PS
Jeśli chodzi o StormOS-a, to go chyba po prostu przeinstaluję od nowa, bo na tamtym kompie niewiele mam, a już wiem co mam zrobić jak system stanie i jak zainstalować [chaotic-aur] i [pak]
DZIĘ-KU-JĘ

Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: robson75 w Czerwiec 02, 2022, 03:00:26 PM
Janek, jeżeli masz problemy z zapamiętaniem komendy
sudo grub-mkconfig -o /boot/grub/grub.cfgTo wystarczy zainstalować paczkę update-grub (jest w repo chaotic).
I po każdej instalacji lub usunięciu kernela, wystarczy wykonać komendę
sudo update-grubTo jest to samo co
sudo grub-mkconfig -o /boot/grub/grub.cfg
A tak w ogóle, to ja czułem w kościach że system Ci się uruchamia z LTS-a, bo niemożliwością było by żeby na kernelu linux nie było Wi-Fi.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Czerwiec 02, 2022, 11:39:46 PM
@robson75

Dzięki Robert. Bo to jest tak, że jak mi się coś zawala i mi podpowiadacie, to na koniec, ja już prawie wszystko wiem. Tyle, że później nadchodzi "czas pokoju" w mojej bańce wiadomości sublimują w kierunku nicości. Ja sobię te Wasze uwagi kopiuję, porządkuję i mam. Ale, jak sam zauważyłeś w rozmowie ze mną panta rhei.
Wyciągam jedną z drugą poradę, i dryfuję w zupełnie nieznane zaułki.
A co do LTS.
Gdy mi kazałeś wyrzucić linux-lts, to ja to zrobiłem. Nawet wcześniej podpatrzyłem jak się ładuje i faktycznie zaczynał z LTS. Tyle tylko, że ten komunikat u mnie jest drobnym maczkiem i zaledwie przez chwilę. Po usunięciu linux-lts byłem spokojny. W Octopi widziałem, że jest zainstalowany linux-lts-tkg-bmq ale nawet mi przez myśl nie przeszło, że to też jest jakiś system, więc bałem się usunąć.

A teraz moje wrażenia z nowego Wi-Fi. Jeśli to nie jest wina plam na Słońcu, to jest to ogromy krok wstecz w stosunku do sterownika instalowanego z zewnątrz.
Mam w zasięgu trzy modemo-routery. Córka moja pracuje często on-line, więc dla pewności ma dwa i ja mam jeden, bo zabieram gdy wyjeżdżam. Na wszystkich jest fatalnie. Inne urządzenia pracują względnie dobrze, na tych modemo-routerach, a mój Asus po aktualizacji fatalnie. Tak ale jeszcze nie miałem, ale spotkałem się na Forum, że ktoś też nie był zachwycony. Może Arch jeszcze dopracuje ten sterownik rtl8821ce, ale na razie jest koszmarnie. Boję się cokolwiek robić, bo albo  nie łączy, albo jak połączy, to muli i co parę minut po prostu rwie łączność i sygnalizuje, że jestem w trybie off.  Gdy piszę ten text, dwa razy już mnie rozłączył i połączył. zasięg sygnału jest strasznie nierówny ze wszystkich trzech modemo-routerów. Od jednej kreski z ledwością, do pięciu kresek na krótko i znów spadek. Inne urządzenia, a may tu dwa smartfony, tablet i dwa laptopy poza tym Asusem (jeden z kulawym StormOS-em) chodzą całkiem poprawnie. Tylko Asus jest przetrącony. Aż się boję robić aktualizację przez Wi-Fi. Chyba ją wykonam po kablu.
Ale i tak się cieszę, że mnie wyprowadziliście na prostą.
Zdaję sobie sprawę, że gdy się denerwuję, to umyka mi trochę treści, bo przeskakuję napisane linijki, ale trudno mi nad tym zapanować. Jak już jestem na prostej, to wracam na spokojnie i odkrywam, com skaszanił.
Dzięki Robert za pomoc. Zajrzę jeszcze parę razy tutaj. Gdybyś miał jakiś pomysł
co do tego "jądrowego" sterownika, będę wdzięczny za wpis.
Obecnie nawet FaceBoka przeglądam ze smartfona, bo z Asusa się po prostu nie da. Przeważnie zaczyna się od komunikatu, że nie znaleziono strony.
Hłe, hłe... tyle się napisałem, a nie wiem, czy mi to ine przepadnie podczas wysyłania. Ale przed wysłaniem skopiuję sobie, com napisał.
Pozdrowienia.

PS.
Tym razem akurat poszło ładnie i bezproblemowo. Może się to ustabilizuje. Wczoraj było  jeszcze gorzej, bo w ogóle nie chciał łączyć nawet z modemo-routerem. Dziś łączy i nie żąda hasła.


 


 
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: robson75 w Czerwiec 03, 2022, 02:18:35 AM
Janek, nie używam Wi-Fi bo mam PC, ale na Twoim miejscu bym sprawdził iwd i zainstalował tą paczkę, następnie uruchom usługę
systemctl enable iwd.serviceRestart kompa.
Być może to coś da, ale na pewno warto spróbować.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Czerwiec 03, 2022, 09:41:54 AM
Cytat: Piejanto w Czerwiec 02, 2022, 11:39:46 PMJeśli to nie jest wina plam na Słońcu, to jest to ogromy krok wstecz w stosunku do sterownika instalowanego z zewnątrz.
Mam w zasięgu trzy modemo-routery. Córka moja pracuje często on-line, więc dla pewności ma dwa i ja mam jeden, bo zabieram gdy wyjeżdżam. Na wszystkich jest fatalnie. Inne urządzenia pracują względnie dobrze, na tych modemo-routerach, a mój Asus po aktualizacji fatalnie. Tak ale jeszcze nie miałem, ale spotkałem się na Forum, że ktoś też nie był zachwycony. Może Arch jeszcze dopracuje ten sterownik rtl8821ce, ale na razie jest koszmarnie.
1. Nie masz teraz rtl8821ce, a RTW88.
2. Arch nie rozwija RTW88 - to robi facet z Realteka.
3. To co piszesz (rwanie połączenia) jest/bywa ponoć normalną przypadłością RTW88 na niektórych kartach.
4. Jeśli Ci rwie się na RTW88, to zainstaluj ponownie rtl8821ce-dkms-git, zablokuj RTW88 (jeśli okaże się konieczne).
5. Piszesz, że masz 3 routery. Być może o 2 za dużo. Nie wiem, czy one pracują w jednej sieci, czy w trzech, ale w pierwszym przypadku w istocie może być tak, że na jednym będzie o wiele lepiej.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Czerwiec 03, 2022, 12:09:16 PM
@pavbaranow
@robson75

próbowałem wyrzucać rtl8875ce ale mi pokazało:
# pcman -Rns rtl8821ce-dkms-git           
zsh: correct 'pcman' to 'pacman' [nyae]?

wiec, zostało po staremu.

Teraz jestem na kablu i chcę zrobić aktualizacje. Zobacze, czy bedzie komunikat [depmod rtl8821]

nie bardzo wiem jak zablokować RTW88

Jeśli chodzi o trzy routery, to miałem je i przedtem. Nie bardzo mi wychodzi wyrzucanie córki z domu razem ze sprzętem, bo jest ona pyskata.
Mój modemo-router ma swoja nazwę i jest całkowicie odrębną jednostką od dwu pozostałych modemo-routerów mojej córki.
Przechodzwenie z routera na router też nie stanowi, żadnego problemu z wyjątkiem podkradania sobie kilobajtów. taka ilość modemów jest szczególnie przydatna, gdy kończą się zasoby na jednej karcie, bo można przejść bezproblemowo na kartę w innym modemie, bez konieczności zawieszania pracy. No i jak już mówiłem, nie było dotychczas z tym problemów i obecnie tylko Asus mi robi internetowe afronty.
Zrobię aktualizację i zaraz tutaj wracam.


Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Czerwiec 03, 2022, 12:24:57 PM
@pavbaranov; @robson75

Była maleńka aktualizacyjka. Teraz [pak] jakoś inaczej pokazuje i poprzedni sposób wydawał mi się lepszy.

nie było informacji [depmod rtl8821ce] ale przy takich maleńkich aktualizacjach chyba jej nie miewałem i wczesniej.

Sprawdziłem w Octopi i mam zainstalowany pakiet rtl8821ce-dkms-git

Natomiast
[rtw88-dkms-git] nie jest zainstalowany

Zrobiłem czyszczenie [pak -Sc]

zrestartuję i spróbuję jak będzie z tym moim Wi-Fi
***********************************************************************
JESTEM NA Wi-Fi

Chyba wszystko wróciło do normy. Jak na razie chodzi bardzo ładnie chociaż pokazuje spore skoki transferu. Ale nie schodzi poniżej trzeciej kreski.  Faktem jest, że jestem w pokoiku z routero-modemem, ale też zaraz po odzyskaniu Wi-Fi nawet nie widział routera, a jak zobaczył to kazał wpisywać hasło, a po wpisaniu hasła i tak nie łączył. Na drugi dzień już łączył z routerem ale nie łączył z Internetem, a teraz jest zdecydowanie lepiej. Może to trzeba było "ujeździć" ?
Teraz jest jak za starych dobrych czasów.
Wielkie Wam dzięki, Panowie.
PS
Dam znać, jak to działa wieczorem, w pokoju, przez ścianę z routerem.
Pozdrowienia.



 






Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: robson75 w Czerwiec 03, 2022, 04:02:36 PM
Cytat: Piejanto w Czerwiec 03, 2022, 12:09:16 PMpróbowałem wyrzucać rtl8875ce ale mi pokazało:
# pcman -Rns rtl8821ce-dkms-git           
zsh: correct 'pcman' to 'pacman' [nyae]?

wiec, zostało po staremu.
Bo zrobiłeś literówkę, nie pcman tylko pacman.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Czerwiec 04, 2022, 12:02:35 AM
@robson75

Aaaaaaa widzisz. Faktycznie. Widocznie tak miało być i święci anieli czuwali żebym nie usunął, bo akurat to polecenie [pcman -Rns rtl8821ce-dkms-git]
 przekopiowałem od Ciebie i wkleiłem.
Teraz do kompa siadłem o godz 23,30. Bardzo ładnie mnie połączyło z moim routerem, po czym wywaliło i zaczęło kręcić, że łączy. Przeszedłem na router córki. To samo. Połączyło i wywaliło. Przeszedłem na router "awaryjny". On ma tylko 3G i to samo.
Tyle, że pokazywał połączenie. Napisałem, wiec do Was pięknie wszystko opisując, i kliknąłem "wyślij wiadomość" i w tym momencie mi wszystko przepadło.
Poszedłem do pokoju z routerem ale nie było poprawy Wi-Fi.
Podłączyłem kabel i własnie klepię do Was ten text.

Teraz spróbuję porady:

[systemctl enable iwd.service] i zrestartuję system, jak przykazałeś.

Do następnego

*************************************************
polecenie i odpowiedź:
systemctl enable iwd.service                         (06-04 00:08)
Failed to enable unit: Unit file iwd.service does not exist.




Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: robson75 w Czerwiec 04, 2022, 12:38:46 AM
Cytat: Piejanto w Czerwiec 04, 2022, 12:02:35 AMpolecenie i odpowiedź:
systemctl enable iwd.service                         (06-04 00:08)
Failed to enable unit: Unit file iwd.service does not exist.
Czasami jest tak, że po instalacji jakiejś paczki trzeba zamknąć terminal, i uruchomić go ponownie aby aktywować usługę.

EDIT.
A czy w ogóle zainstalowałeś paczkę iwd?
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Czerwiec 05, 2022, 11:26:07 PM
@robson75

Qurde... teraz dopiero zainstalowałem [iwd]. Myślałem, że on tam gdzieś jest. Bożżżżż... ale ze mnie głąb.

Dobra. Zrobię najpierw to [systemctl enable iwd.service]
**************************************************************************
Zrobiłem [systemctl enable iwd.service] i zrestartowałem Asusa. Wskazałem mu sieć do połączenia. Zażądał hasła. Połączył pięknie i wydaje mi się, ze o to właśnie chodziło. Jak na razie ŁĄCZY JAK ZA STARYCH DOBRYCH CZASÓW !!!

Popróbowałem łączenia z różnymi miejscami jak FB, Twitter, i moje konto i po prostu śmiga.
*****************************
*****************************
Qrdę...  Początki były piękne ale... Znów zaczęło się rwanie mojej sieci. Przeszedłem na sieć córki, i znów musiałem się zalogować hasłem. Jest jakby lepiej, ale był moment zaniku. Czyli jest tak, że na początku śmiga, a później się coś zatyka. Drugiej sieci mojej córki (3G) w ogóle nie widzi
No... i sieć mojej córki też chyba pada. Teraz próbuję wysłać to pisanie i kicha. Chyba wiem dlaczego kiedyś nie umiałem wysłać print scrina .
Teraz zachowuje sie dokładnie jak wtedy. Ptrzed chwilą się dowiedziałem, ze zostałem rozłączony i teraz znów pokazuje sieć. Może połączy z Internetem?
Jutro jeszcze opowiem jak jest.
Trzymaj się mocno, Robson. DZIĘKI.




Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: robson75 w Czerwiec 06, 2022, 12:57:35 AM
To weź uruchom jeszcze
systemctl enable wpa_supplicant.serviceTym razem bez instalacji, bo domyślnie jest w systemie.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Czerwiec 06, 2022, 02:45:57 PM
Sterowniki Realtek lubią robić problemy. Wpierw podsumujmy, co wiemy, bo to już 4 strona tej epopei.
1. Zasadniczo komputer łączy się z siecią przez wifi.
2. Kompletnie losowo wifi zostaje rozłączone.

Po pierwsze - tuż po rozłączeniu sprawdź dziennik i ostatnie w nim figurujące wpisy. Szukaj tych, które będą mieć w sobie "wlan0". W szczególności sprawdź, czy nie masz takich informacji:
wlan0: deauthenticating from MAC by local choice (reason=3)lub:
ieee80211 phy0: wlan0: No probe response from AP xx:xx:xx:xx:xx:xx after 500ms, disconnectinglub:
ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x02000020 DMADBG_7=0x0000a400
wlp1s0: authenticate with 56:e7:ee:7b:55:bc
wlp1s0: send auth to 56:e7:ee:7b:55:bc (try 1/3)
wlp1s0: send auth to 56:e7:ee:7b:55:bc (try 2/3)
wlp1s0: send auth to 56:e7:ee:7b:55:bc (try 3/3)
wlp1s0: authentication with 56:e7:ee:7b:55:bc timed out
Wszystkie tego typu rzeczy są znane i można znaleźć na to rozwiązanie.
Sprawdź siłę sygnału, poprawność skonfigurowania routera. Spróbuj zmienić kanał. Sam piszesz, że w domu masz 3 routery być może po prostu jest "za gęsto" i wzajem sobie przeszkadzają.
Pokaż:
inxi -Nxx
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Czerwiec 06, 2022, 04:44:02 PM
@pavbaranov
Kiedyś mogło być za gęsto bo dwa routery stały obok siebie i faktycznie czasem sie nieco "splątywały". Obecnie dzieli je odległość ok 3 m. Stoją w pokoju, gdzie modemy najlepiej odbierają Internet. Ponadto, do czasu tej ostatniej aktualizacji nie było problemów. Czasem bywa, że są jakieś zakłócenia (jakieś burze magnetyczne na Słońcu) i to od razu widać po Internecie mobilnym, ale i po tym kablowym. Miałem kiedyś i pamiętam. Jak już mówiłem, wszystkie pozostałe urządzenia hulają bez zmian, tylko Asus zgłupiał po tej aktualizacji.

@robson75 ; @pavbaranov

Panowie, dziś w nocy myśl przyszła mi taka, że może Wi-Fi ma zbyt wielką czułość.
Kiedyś, gdy miałem fatalny transfer i w związku z tym zrywało mi aktualizację,
Robert mi podpowiedział, żebym wpisywał
[--disable-download-timeout] i to było genialne posunięcie, które do dziś stosuję.

Otóż, zauważyłem, że Wi-Fi zrywa mi się nagle i zaraz później zaczyna się łączyć.
Być może chodzi o to, iż ustawiony jest zbyt krótki czas na łączenie i każdy drobny zanik na modemie rozłącza i wyrzuca połączenie z kompem??
Bo tak to mi wygląda.
Bo czasem nawet nie rozłącza z routerem, a pokazuje off line.
Zatem czy nie dałoby się wejść gdzieś do zapisów konfiguracji połączenia i tam
pogmerać aby wydłużyć mu te milisekundy na sekundy?

Jutro wyjeżdżam na trzy dni i w dodatku bez kompa, więc nie będę się mógł doczekać odpowiedzi. Ale dziesiątego wracam i zaraz się odezwę.

@pavbaranov
To co ostatnio napisałeś, zdaje się, też sugeruje, że to może być kwestia ustawień czasowych. Jak już donosiłem, dzieje się to wyłącznie na Asusie po aktualizacji. Nawet Acer ze StormOS-em nieaktualizowanym bo mu się wszystko pochrzaniło, więc, nawet na tym Acerze Wi-Fi hula bezproblemowo i ciekaw jestem nawet kiedy mi się posypie żeby mnie zmobilizować do reinstalacji StormOS-a.

Reasumując: - podejrzewam ustawienia czasowe o zbytnią wrażliwość.

Dzięki i do następnego.

PS.
Myślałem też o tym aby odinstalować [rtl8821ce-dkms-git], restart komputra, a następnie ponowne zainstalowanie. Ale samemu trochę się boję podjąć decyzję.
Co o tym Panowie sądzicie?






 


Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Czerwiec 06, 2022, 05:30:43 PM
Janek - błagam - Ty już nie kombinuj co to jest. Zrób to, o co proszę, pójdziemy w jakiś sposób do przodu.
A modemy 3 metry od siebie - jak sądzę po opisie albo radiowe (wątpię), albo mobline - to jest dość średni pomysł.
W przypadku sieci mobilnej, dosłownie wszystko może być przyczyną rwania się transmisji. Wpierw jednak to, co wyżej napisałem.
I tylko to sądzimy. Dopóki nie zdiagnozuje się problemu, to zmienianie wszystkiego na łapu-capu jest najgorszym pomysłem, jaki może chodzić po głowie. A jak na razie, to czysta behawiorystyka bez ani jednego konkretu.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Czerwiec 14, 2022, 12:31:51 AM
@pavbaranov

OK. Ale ja jestem przekonany, że po aktualizacji sterownik jest zbyt czuły.
Wszystkie inne sprzęty mi chodzą jak trzeba. jeśli przeniosę modemo-routera na drugą stronę mieszkania, to zyskam góra dwa metry, a będzie stał od strony bloków z żelbetonowymi ścianami. Kiedyś już próbowałem i odbiór mam najlepszy właśnie od strony północnej. Ściana nie jest zbrojona i jest mniej drzew niż od strony podwórza, osłoniętego ze wszystkich stron blokami i przed oknem wysokie drzewa. 
Widzę jak działa modem na routerze. Gdy przygaśnie dioda na modemie, to natychmiast mi się rwie połączenie. Ale tylko na moim Asusie. Inne sprzęty działają i ten też kiedyś tak działał.
Dlatego wywnioskowałem, że należy zmniejszyć czułość na "dziurę" w transmisji Wi-Fi.
Dziś zaktualizowałem Keyringi, zaktualizowałem Mirrory i zaktualizowałem System.
Podczas aktualizacji pokazało mi [--depmod rtl8821ce] czyli wszystko jak za starych dobrych czasów. Obecnie siedzę oczywiście na kablu.
Wszystko jest tak jak było z wyjątkiem wrażliwości połączenia.
Jest zbyt wrażliwe i wyrzuca mnie przy najdrobniejszej przerwie, po czym łączy, bo te przerwy są milisekundowe. Zatem zrywa i łączy, zrywa i łączy, zrywa i łączy...  i tak dookoła Wojciechu.
 W pokoiku z modemo-routerami pracuje codziennie moja córka, on-line. Poza pokojem z modemo-routerami bawimy się internetem na tablecie, i na smartfonach i jest bardzo dobre połączenie. Owszem, bywały momenty, że się cośtam zrywało, ale podobnie było, gdyśmy mieli Internet z kablówki i jeden router Wi-Fi

Dlatego proszę o radę w kwestii zmniejszenia wrażliwości Wi-Fi
ale TYLKO NA MOIM ASUSIE.
Jestem przekonany, że podczas aktualizacji, coś się przestawiło i można to odkręcić.

Dziś już nie dam rady powalczyć ze zmianą lokalizacji tego mojego modemo-routera. Jutro spróbuję, ale uczynię to bez przekonania. W pokoiku z modemo-routerami pracuje codziennie moja córka, on-line. Zresztą... na początek mogę spróbować wyłączyć dwa pozostałe modemo-routery i sprawdzić co będzie się działo. Jutro napiszę.

Do jutra.
Qrdę nie mogłem się powstrzymać... jest godzina 01,09 i przeszedłem na Wi-Fi. Siedzę w pokoju z dwoma modemo-routerami. Jak na razie Wi-Fi działa bardzo pięknie, chociaż pokazuje spore skoki. Od full do dwu kresek, ale nie spada poniżej i na razie nie rozłącza.
Jak pisałem jestem po aktualizacji Keyringów, Mirrorów i Systemu. Jutro sprawdzę z jednym modemo-routerem. 

PS
W blokach zazwyczaj jest tak, że się ma sąsiadów z obu boków przez ścianę, z góry przez sufit i z dołu przez podłogę. I wszyscy mają Wi-Fi. Odlegości mogą być nawet mniejsze niż 3 metry. U mnie akurat parter, więc spod podłogi odpada. 
Dobra. Jutro wyłączę dwa routery i spróbuję z jednym.
 
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Czerwiec 15, 2022, 01:25:52 AM
@pavbaranov

Przeniosłem modemo-router do swojego pokoju. Jest lepiej ale też o tej porze (jest godz. 01,20) sygnał mam zawsze stabilniejszy i silniejszy. 
Pokazuje mi spore skoki mocy sygnału, ale jak na razie, nie zrywa połączenia.
Spróbuję jutro wczesnym popołudniem i dam znać.

Zastanawiałem się też, czy nie spróbować sterownika RTW88 ale odradzałeś, więc jest ten rtl8821ce-dkms-git. 
Hmmmm... no, teraz działa wzorowo. Ale to noc.
Dzięki ogromne.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Czerwiec 15, 2022, 10:40:20 PM
@pavbaranov

Wygląda na to, że miałeś rację. Po przeniesieniu modemo-routera do mojego pokoju, Wi-Fi działa znacznie lepiej. Są skoki transmisji ale nie zrywa. Znalazłem modemowi miejsce przy niezbrojonej ścianie. Chodzi. Wczorajszej nocy zaryzykowałem jeszcze aktualizację i momentami transfer przekraczał 3MiB.Poprzednio się to nie zdarzało.

Panowie, dziękuję serdecznie za wszystkie rady i wyprowadzenie mnie z dołka.
A przede wszystkim za anielską cierpliwość, jaką mi okazaliście po raz kolejny.

Wszystkim kolegom
Serdecznie dziękuję.
 


 
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Czerwiec 16, 2022, 12:55:23 PM
Janek - lepsze jest wrogiem dobrego. Widzialne skoki natężenia sieci mogą wynikać z bardzo wielu czynników. Mogą być zarówno po stronie komputera, po stronie routera, jak i samej sieci. Niemniej jednak jedna uwaga. Routery - jeśli nie zmieniałeś ich ustawień - mogą mieć ustawioną tę samą częstotliwość, w dodatku nadawać na tym samym kanale itd. W takim przypadku więcej routerów w stosunkowo niewielkiej odległości od siebie będzie sobie przeszkadzać. Sprawdź ustawienia tych routerów jeśli musisz ich mieć aż trzy, poustawiaj tak, by nie zachodziła interferncja. Aha - ich instrukcja obsługi Twoim dobrym przyjacielem jest.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Czerwiec 20, 2022, 11:26:13 PM
@pavbaranov

Teraz jest dobrze. tak jak kazałeś przeniosłem modemo-router i hula mi Wi-Fi jak za starych dobrych czasów, a może nawet momentami lepiej.

Mam jeszcze pytanie. Po ostatnich naukach dodałem sobie obowiązek aktualizacji Keyringów.

Teraz średnio co dwa dni robię aktualizację w następującej kolejności:

1/ sudo pacman -Sy archlinux-keyring chaotic-keyring
2/ pak -m
3/ pak -Syu

Robert mi kiedyś nadał polecenie [pacman -Sy chaotic-keyring chaotic-mirrorlist] i chyba tego będę używał, tylko czy najpierw to, a potem [pak -Syu] czy odwrotnie?

Od czasu do czasu [pak -Sc] żeby nie było śmieci.
Czy to jest właściwa kolejność? Kiedyś robiłem najpierw [pak -Syu] bo wiem że aktualizacje muszą być całościowe. Czy Keyringów i mirrorów nie potrzeba traktować jako aktualizacji?

I jeszcze: - Dziś wykazało mi aktualizacje z AUR i z POLAUR.
Powiedziało mi, że aktualizować będzie w kolejności alfabetycznej.
Przyklepałem "T' ale z duszą na ramieniu. Po czym poznać, że może być alfabetycznie albo, że nie może być alfabetycznie?


Dzięki za odpowiedź i w ogóle dzięki za wszystko.








Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Czerwiec 21, 2022, 07:26:45 AM
Janek - znów kombinujesz, a miernie Ci to idzie.
Wklep sobie: systemctl --user enable --now pak-checkupdates.timer
 systemctl --user enable --now pak-auracle.timer
Od tej chwili pak będzie dokonywał sprawdzenia, czy jest jakaś aktualizacja z repozytoriów lub z AUR i jeśli tak się zdarzy masz wydać wyłącznie jedno polecenie:
pak -SyuKoniec filozofii.
Instalowanie za każdym razem paczek z keyringami, osobnym poleceniem, gdy potem wydajesz polecenie aktualizujące cały system ma bardzo mało sensu.
Wydać polecenie pak -m jest sens, gdy zainstaluje Ci się paczka archlinux-mirrorlist (mniej więcej raz na miesiąc).
Pak dokonuje instalacji paczek z AUR/POLAUR w kolejności alfabetycznej. I tak robi zawsze. Tu oznacza, że w kolejności alfabetycznej będą one kompilowane. Z uwagi na jakieś upstreamowe zamiary w przyszłym pacmanie Damian zrezygnował z komplikowania tego skryptu (szkoda pracy, sam go w tym utwierdzałem). Natomiast taki sposób kompilacji (alfabetycznie) nie zawsze będzie prawidłowy i pozwoli na zbudowanie paczki. Wówczas trzeba to zrobić w sposób ręczny, analizując informacje w AUR, czy w POLAUR.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: nycko w Czerwiec 21, 2022, 09:03:14 AM
Cytat: pavbaranov w Czerwiec 21, 2022, 07:26:45 AMInstalowanie za każdym razem paczek z keyringami, osobnym poleceniem, gdy potem wydajesz polecenie aktualizujące cały system ma bardzo mało sensu.
Tym bardziej, że specjalnie pod Ciebie aktualny pak robi to automatycznie: jeśli znajdzie jakiekolwiek keyrings do aktualizacji, to wybierze je w pierwszej kolejności, a potem resztę. Czyli jeśli używasz pak, wywal z notatek
sudo pacman -Sy archlinux-keyring chaotic-keyring i już nie stosuj. Samo pak -Syu wystarczy do wszystkiego.

Cytat: pavbaranov w Czerwiec 21, 2022, 07:26:45 AMWydać polecenie
pak -m jest sens, gdy zainstaluje Ci się paczka archlinux-mirrorlist (mniej więcej raz na miesiąc).
Jest to dobra praktyka i Jan powinien tak postępować, chociaż jednak pak -m nie potrzebuje żadnego mirrorlist, ponieważ bierze pośrednio wyniki z https://archlinux.org/mirrors/status/
Co więcej, po każdym pak -m należy bezwzględnie wykonać pak -Syyu (podwójne y), inaczej można (choć nie trzeba) nabawić się bólu głowy.

Cytat: pavbaranov w Czerwiec 21, 2022, 07:26:45 AMPak dokonuje instalacji paczek z AUR/POLAUR w kolejności alfabetycznej. I tak robi zawsze. Tu oznacza, że w kolejności alfabetycznej będą one kompilowane. Z uwagi na jakieś upstreamowe zamiary w przyszłym pacmanie Damian zrezygnował z komplikowania tego skryptu (szkoda pracy, sam go w tym utwierdzałem). Natomiast taki sposób kompilacji (alfabetycznie) nie zawsze będzie prawidłowy i pozwoli na zbudowanie paczki. Wówczas trzeba to zrobić w sposób ręczny, analizując informacje w AUR, czy w POLAUR.
Sytuacja, kiedy budowanie paczek z AUR/POLAUR alfabetycznie powoduje problemy jest tak mało prawdopodobna, że wręcz nie warto się tym przejmować. Jednak dobrze, że u Ciebie Janie komunikat wzbudził ciekawość, bo taki był właśnie jego cel.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Czerwiec 21, 2022, 10:37:19 PM
@pavbaranov
I to jest dla mnie wiedza bardzo cenna. Jeśli chodzi o Mirrory, to trudniej jest mi pamiętać żeby raz na miesiąc aktualizować, niż robić to przy okazji aktualizacji całościowej. Po prostu się boję, że zostanę z aktualizacją Mirrorów w rzyci i się mi System rozleci. Ale dobrze. Zastosuję się. Raz na miesiąc Mirrory
Jeśli chodzi o Keyringi, to też uważałem, że się aktualizują razem z Systemem, gdy polecam [pak -Syu]. Sam widziałem czasem że lecą aktualizacje Keyringów i... się schrzaniło.
Cytat:
"(...)Natomiast taki sposób kompilacji (alfabetycznie) nie zawsze będzie prawidłowy i pozwoli na zbudowanie paczki. Wówczas trzeba to zrobić w sposób ręczny, analizując informacje w AUR, czy w POLAUR. "
No... i właśnie to jest dla mnie rafa.

@nycko
Niby wszystko jasne, ale muszę sobie wklepać jakieś przypominanie, żeby nie zapomnieć o aktualizacjach "sporadycznych" a koniecznych.
Jak już mówiłem aktualizacje przez [pak -Syu] robiłem praktycznie codziennie. No.... czasem się zdarzyło, że nieco dłuższe były odstępy, ale to tylko wtedy, gdy wyjeżdżam na skraj zasięgu i transfer jest bardzo zły, w granicach poniżej 250 MiB. Wprawdzie dodaję wtedy [--disable-download-timeout] ale czasem i tak traci kontakt.
I właśnie teraz problem:
Czy jeśli np. dwa tygodnie nie aktualizowałem, to czy aktualizować osobno Keyrngi i Mirrory? - Czy jak zwykle lecieć całością [pak -Syu]? Bo o ile dobrze pamiętam, to właśnie ten ostatni kłopot wynikł po dłuższym nieaktualizowaniu. Ale wtedy jeszcze  nie miałem na dodatek [pak-git]. Hmmm... no, tak muszę jeszcze pamiętać o aktualizacji Pak-a...

Dzięki Panowie.
Te dzisiejsze rady i polecenia dodałem sobie do nauk i się będę tego trzymał.

PS.
@robson75
Zrezygnowałem z tego adresu do Mirrorów, który mi kiedyś nadałeś, bo zacząłem zapominać o wpisywaniu przed aktualizacją. Może powinienem jednak wrócić?
Mam tę poradę i sposób wykonania, ale czy to jeszcze aktualne?

 
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: robson75 w Czerwiec 21, 2022, 10:46:00 PM
Cytat: Piejanto w Czerwiec 21, 2022, 10:37:19 PMZrezygnowałem z tego adresu do Mirrorów, który mi kiedyś nadałeś, bo zacząłem zapominać o wpisywaniu przed aktualizacją. Może powinienem jednak wrócić?
Mam tę poradę i sposób wykonania, ale czy to jeszcze aktualne?
Jak najbardziej aktualne, jadę na tym serwerze od kilku miesięcy, i zero problemów
Server = https://mirror.f4st.host/archlinux/$repo/os/$arch
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Czerwiec 21, 2022, 11:16:35 PM
@robson75
No, dobra, to wracam do tego servera. Kłopot tylko taki, że za każdym razem trzeba go wklepać, ale jeśli to raz na miesiąc, to dam rade.

@nycko
Cytat:
"(...Co więcej, po każdym pak -m należy bezwzględnie wykonać pak -Syyu (podwójne y), inaczej można (choć nie trzeba) nabawić się bólu głowy."

I tutaj może jest kot pogrzebany? Akurat tego [pak -Syyu] nie robiłem.
Po prostu nie wiedziałem, do czego to jest potrzebne.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: nycko w Czerwiec 21, 2022, 11:29:31 PM
Cytat: Piejanto w Czerwiec 21, 2022, 11:16:35 PM@nycko
Cytat:
"(...Co więcej, po każdym pak -m należy bezwzględnie wykonać pak -Syyu (podwójne y), inaczej można (choć nie trzeba) nabawić się bólu głowy."

I tutaj może jest kot pogrzebany? Akurat tego [pak -Syyu] nie robiłem.
Po prostu nie wiedziałem, do czego to jest potrzebne.

Można też sudo pacman -Syyu, bo to samo robi. Chociaż moje jest krótsze do wpisania.

Najważniejsze, robisz pak -Syu i nie martwisz się o keyringi od dzisiaj.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: robson75 w Czerwiec 22, 2022, 12:03:46 AM
Cytat: Piejanto w Czerwiec 21, 2022, 11:16:35 PMKłopot tylko taki, że za każdym razem trzeba go wklepać, ale jeśli to raz na miesiąc, to dam rade.
Janek to Ci to jeszcze raz wytłumaczę o co chodzi.
Po aktualizacji pacman-mirrorlist nic się nie zmienia w pliku /etc/pacman.d/mirrorlist, tylko zmienia się /etc/pacman.d/mirrorlist.pacnew.
A serwer siedzi w pliku mirrorlist, więc nic nie musisz robić.
Oczywiście też nie możesz wykonywać polecenia
pak -m
bo ta komenda nadpisuje plik /etc/pacman.d/mirrorlist.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Czerwiec 22, 2022, 12:51:37 AM
Cytat: Piejanto w Czerwiec 21, 2022, 10:37:19 PMJeśli chodzi o Keyringi, to też uważałem, że się aktualizują razem z Systemem, gdy polecam [pak -Syu]. Sam widziałem czasem że lecą aktualizacje Keyringów i... się schrzaniło.
Nie czytasz tego co Ci piszemy. Obecna wersja pak wpierw robi aktualizację keyring, a dopiero potem leci cała reszta. Nie powinno być takich problemów, jak z "gołym" pacmanem. Masz zrobić aktualizację paka i potem jedynie - gdy trzeba - pak -Syu Kiedy? Masz opisane wyżej.
CytatCytat:
"(...)Natomiast taki sposób kompilacji (alfabetycznie) nie zawsze będzie prawidłowy i pozwoli na zbudowanie paczki. Wówczas trzeba to zrobić w sposób ręczny, analizując informacje w AUR, czy w POLAUR. "
No... i właśnie to jest dla mnie rafa.
Pomijając fakt, że nie powinna taka kompilacja sprawić problemów, to zawsze powtarzam: AUR jest dla tych, którzy wiedzą o co tu chodzi. Jeśli nie wiesz - nie korzystaj. Trudno - znajdziesz zamiennik. Albo będzie w chaotic-aur.
CytatCzy jeśli np. dwa tygodnie nie aktualizowałem, to czy aktualizować osobno Keyrngi i Mirrory? - Czy jak zwykle lecieć całością [pak -Syu]? Bo o ile dobrze pamiętam, to właśnie ten ostatni kłopot wynikł po dłuższym nieaktualizowaniu.
Janek - doprawdy nie wiem jak Ci to napisać już 100 raz. Ze względu na Twój problem z kompletnym nierozumieniem systemu, Damian dorobił kod paka i w tej chwili przy pełnej aktualizacji pak wpierw (przed innymi paczkami) aktualizuje keyringi. I koniec, bo już mam dość bicia tej piany. Zbyt wiele razy to samo, to samo, to samo... I nie trafia.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Czerwiec 22, 2022, 11:29:54 PM
@pavbaranov
No, tak prawda. pisaliście na temat nowego PAK-a, ale ja byłem jeszcze pod działaniem starego paka. Zauważyłem, że jest inaczej, ale początek leci tak szybko, że nie miałem sposobności się przyjrzeć, co tam "stoi napisane".
Może faktycznie powinienem odinstalować AUR i pozostać przy Chaotic-aur... Jeśli Chaotic-aur nie stwarza takiego zagrożenia, to ja chętnie. Muszę sprawdzić tylko, co ja mam u siebie z AUR, a co z Chaotic-aur. Nie jestem pewien np. skąd jest Zoom. Ja Zoom-a nie używam, ale trzymam na wypadek, gdyby córka musiała skorzystać.

OK. już rozumiem z tymi Keyringami. Leci to na początku, tylko, że nie mogłem się przyjrzeć

@robson75
Teraz rozumiem. Byłem po prostu zbyt akuratny, a niedouczony.

Wynika to z faktu, że powinienem śledzić rozwój programów, a nie śledzę z dwóch powodów.
1/ głównie zajmuję się innymi rzeczami, a do kompa siadam, gdy mam coś do sprawdzenia lub napisania
2/ mam kłopot z czytaniem angielszczyzny, a córka (anglistka) mi tez nie pomaga, bo ona nie kuma komputrowych określeń.

Zatem, o różnych newsach dowiaduję się od Was dopiero gdy mi się coś posypie.

Najważniejsza dla mnie aktualność, to to, że w zasadzie teraz powinno mi wystarczyć polecenie [pak -Syu]

Dzięki za pomoc.
Skopiowałem sobie, jak zwykle te nauki od Was i teraz muszę powyrzucać stare (nieaktualne). Jest tego sporo. Ale na szczęście po polsku i za to Wam dziękuję.

Pozdrowienia serdeczne.
 
PS
Tak będzie:
Robię aktualizację PAK-a
 następnie [pak -Syu]
O Keyringi się nie martwię,
a Mirrory raz na miesiąc, bez używania PAK-a tylko za pomocą Pacmana

Tak zrozumiałem.







Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Czerwiec 23, 2022, 12:16:46 AM
Cytat: Piejanto w Czerwiec 22, 2022, 11:29:54 PMTak będzie:
Robię aktualizację PAK-a
 następnie [pak -Syu]
O Keyringi się nie martwię,
a Mirrory raz na miesiąc, bez używania PAK-a tylko za pomocą Pacmana

Tak zrozumiałem.
NIE!!! Jedyne, co masz robić, to: pak -Syu I doprawdy nie wiem, jak to jaśniej napisać.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Czerwiec 23, 2022, 12:31:29 AM
@pavbaranov

Qrdę... właśnie do tego sam przed chwilą doszedłem i wszedłem tutaj aby zmodyfikować poprzednią moją odpowiedź.

Jasna sprawa. Przecież kiedyś widziałem, że PAK mi aktualizował PAK-a.
Tylko, że to było przed zmianą na PAK-GIT.
Jasna sprawa, że nie tylko System jest aktualizowany ale
- jak nam mówi instrukcja po wklepaniu [pak] - są aktualizowane zainstalowane pakiety.

Reasumując:
co parę dni robię aktualizację
[ pak -Syu ]     
i o Keyringi się nie martwię
raz na miesiąc robię aktualizację Mirrorów za pomocą Pacman-a
I... co jakiś czas sobie czyszczę kompa za pomocą [pak -Sc]

Dzięki. Mam to.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Czerwiec 23, 2022, 08:43:42 AM
Praktycznie każdą zainstalowaną paczkę *-git musisz aktualizować sam. W przypadku tych paczek rolą ich opiekuna jest stworzenie prawidłowego PKGBUILDu. Zasadniczo robi się to raz. Dopiero gdy upstream coś zmieni robi się nowy. Ze względu na to, że pkgver takiej paczki jest generowany w chwili jego budowy jest on inny niż ten, który jest w repozytorium. Jednocześnie w samym repozytorium źródeł mogą zachodzić zmiany. Paczki *-git to wyższa szkoła jazdy, bowiem to do użytkownika należy sprawdzanie repozytorium źródeł, ocena, czy coś, a jeśli tak to co, zostało zmienione i wówczas podjęcie decyzji o aktualizacji lub nie.
Nie wiem jaką wersję pak-git masz, ale jeśli sprzed dokonania zmian przez @nycko, to ów pak-git, który jest zainstalowany u Ciebie całkiem możliwe, że jest po prostu starszą wersją niż jego ostatnie wydanie. Z Twoją wiedzą sugerowałbym zainstalowanie pak w miejsce pak-git.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Czerwiec 24, 2022, 12:04:28 AM
@pavbaranov

No tak, ale np. kiedyś instalowałem coś za pomocą Octopi (chyba pasjansa) i tam proces PKGBUILD-u włączył się automatycznie. To czy ja mogę używać Octopi, do np. aktualizacji pak-git?
Poprzednio miałem paka-a i właśnie wtedy, po aktualizacji zrobiła mi się kaszana.
Czy można zaufać procesowi aktualizacji, jaki uzyskujemy za pomocą Octopi?
Ja się nie upieram przy pak-git, ale jak na razie działa po prostu pięknie. Jeśli uważasz, ze bezpieczniejszy będzie dla mnie pak, to oczywiście przejdę na zwykłego pak-a. Tyle tylko, że Octopi nie pokazuje zwykłego paka-a, a pak-git jest. To może łatwiej mi będzie aktualizować pak-git? 
Jeśli chodzi o pak-git, to mam wersję 1:5.4.1rlg921d26a-1
Tak mi pokazuje Octopi.

Dzięki.


Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: nycko w Czerwiec 24, 2022, 12:21:02 AM
Octopi faktycznie pokazuje pak-git, ale z AUR, bo zupełnie przypadkiem ktoś tam umieścił zupełnie inny program o tej samej nazwie. Jeśli używasz pak, czy pak-git do aktualizacji, to bezpieczniej dla Ciebie będzie używać tylko paka i wywalić octopi, bo tylko wprowadza u Ciebie zamęt.

A powrót do zwykłego pak uzyskasz wykonując
pak -SP new-branded/pak
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Czerwiec 26, 2022, 01:41:46 AM
@nycko

Dżezusie!.. Kiedyś byłem zagubiony i bezradny, teraz jestem bezradny i zagubiony...
Przecież wrzucając polecenie [pak] dostaję całkiem podobne instrukcje. To idzie z [paka-a] czy z [pak-gita-a]?
Ten [pak-git] działa całkiem nieźle i w dodatku właśnie. od Was dostałem nań namiar z instrukcją aby to zainstalować. Sam bym przecież na to nie wpadł i to jest PEWNIK.
Dobra... Wierzę Ci ale... zaczekam jeszcze, co powiedzą @pavbaranov i @robson75

Przypomnienie:
Maj 24, 2022, 05:28:06 PM
Ostatnia edycja: Maj 24, 2022, 06:07:22 PM by nycko
Janie zapisz w "notatkach" i wykonaj
Kod [Zaznacz]
cd /tmp && wget "https://raw.githubusercontent.com/polaur/new-branded/master/pak-git/PKGBUILD" && makepkg -fsir
Na pytanie czy zastąpić pak przez pak-git odpowiedz T,
*******************
A tak nawiasem mówiąc, sądzę, że ten [pak-git] mógł rozwiązać problem. Ale może to tylko wrażenie. W każdym razie chyba właśnie od jego zainstalowania, zacząłem znów wychodzić  na prostą.

Aha... no i chyba wiem dlaczego @pavbaranov mówił o aktualizacji Keyringów przez [pak-a], a ja tego nie widzę podczas aktualizacji przez [pak-git].
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Czerwiec 26, 2022, 08:16:20 AM
Janku - nie kombinuj. W Twoim przypadku - obecnie - pak, a nie pak-git. Chyba, że się zobowiążesz do opieki we własnym zakresie nad pak-git.
A twórcy pak należy raczej wierzyć i ufać.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: nycko w Czerwiec 26, 2022, 08:28:34 AM
Janie pak i pak-git z POLAUR to ten sam program. I w tej chwili są takie same i robią to samo, i tak samo,

Jak Ci wygodniej to dalej używaj tego do aktualizacji pak-git
https://raw.githubusercontent.com/polaur/new-branded/master/pak-git/PKGBUILD" && makepkg -fsir recznie raz w miesiącu albo jak coś przestanie działać.

Chociaż generalnie wygodniej jest po prostu wrócić do pak
pak -SP new-branded/pak by się sam aktualizowal.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Czerwiec 28, 2022, 12:17:36 AM
@pavbaranow
Tak jest.

@nycko
Teraz jasne. Będzie tak jak mi powiedzieliście, ale mam wrażenie, że jednak pak-git się przydał w pewnym momencie, bo coś się wtedy ruszyło. Może to tylko wrażenie.
Hmmmm... mam wewnętrzne opory przed zmianami, ale... zrobię to.

Dzięki
********************************************************8

ZROBIŁEM, to ale nie obyło się bez przygód Nie musiałem odinstalowywać pak-git, bo oczywiście zapytało mnie czy odinstalować ale..
Nim do tego doszło wykazało mi błąd i się zorientowałem, że to błąd czasowy, bo przekroczył czas przewidziany na cośtam.
Następnym razem dopisałem mu do polecenia

pak -SP new-branded/pak --disable-download-timeout

i poszło. Tyle tylko, że na końcu, znów mi pokazało BŁĄD ale jak sprawdziłem, to pak-git jest odinstalowany, a pak działa
Skpiowałem całość ale chodzi o końcówkę. O co chodzi?
Mnie się wydaje, że na końcu chodzi właśnie o owo [--disable-download-timeout] - mam rację?

W SKRÓCIE BYŁO TAK:
                          pak -SP new-branded/pak --disable-download-timeout   (06-28 01:30)

:: pak konfliktuje z pak-git. Usunąć pak-git? [t/N] t
Pakiety (2) pak-git-1:5.4.1.r1.g921d26a-1 [usunięcie]  pak-1:5.5.2-1
Do zainstalowania:       0,15 MiB
Zmiana po aktualizacji:  0,00 MiB

:: Kontynuować instalację? [T/n] T
(1/1) sprawdzanie kluczy w bazie                   [######################] 100%
(1/1) sprawdzanie spójności pakietów               [######################] 100%
(1/1) wczytywanie listy plików                     [######################] 100%
(1/1) sprawdzanie konfliktów plików                [######################] 100%
(2/2) sprawdzanie dostępnego miejsca na dysku      [######################] 100%
:: Przetwarzanie zmian pakietu...
(1/1) usuwanie pak-git                             [######################] 100%
(1/1) instalowanie pak                             [######################] 100%
Opcjonalne zależności dla pak
    asp: to download PKGBUILD's of official packages
    auracle-git: (AUR) to manage AUR packages [zainstalowano]
    namcap: to validate built packages
    reflector: to keep mirrorlist up to date [zainstalowano]
    subversion: to check upstream for updated -svn packages
    fzf: to display all data about installed packages
    downgrade: (AUR) to downgrade packages
    libnotify: to display desktop notifications [zainstalowano]
:: Uruchamianie po-transakcji...
(1/1) Arming ConditionNeedsUpdate...
                                                                                 I TUTAJ NA KOŃCU :

błąd: Błędna składnia ==> repozytorium/pakiet. Sprawdź, czy pakiet istnieje w POLAUR
        ********************************************************************************************************
i to chyba właśnie chodzi o to [--disable-download-timeout]
Hłe, hłe...     


POZDROWIENIA

Wszystko teraz działa dobrze i jest na swoim miejscu.
Pierwsze dwie próby zainstalowania [pak-a] były błędne, gdyż był "błąd czasu pobierania"
Ale teraz działa wszystko prawidłowo.




 
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Lipiec 18, 2022, 01:14:13 AM
Gdy robiłem aktualizację 16 lipca otrzymałem następujący komunikat:

==> ERROR: Missing 5.15.55-1-lts kernel modules tree for module rtl8821ce/1.0.5.r134.gdce62b9.

Linux-LTS mam odinstalowany.

Dziś po aktualizacji dostałem komunikat:

==> dkms install --no-depmod rtl8821ce/1.0.5.r134.gdce62b9 -k 5.18.12-arch1-1
Error! Bad return status for module build on kernel: 5.18.12-arch1-1 (x86_64)
Consult /var/lib/dkms/rtl8821ce/1.0.5.r134.gdce62b9/build/make.log for more information.
==> WARNING: `dkms install --no-depmod rtl8821ce/1.0.5.r134.gdce62b9 -k 5.18.12-arch1-1' exited 10

Po restarcie Wi-Fi działa normalnie
Nie wiem, czy powinienem się przejmować?
Co ewentualnie powinienem zrobić?
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Lipiec 25, 2022, 03:19:19 PM
Pokaż: pacman -Qs linux-Na temat drugiego pytania - cóż - masz tam napiszne: sprawdź /var/lib/dkms/rtl8821ce/1.0.5.r134.gdce62b9/build/make.log - Bez tego co tam jest napisane tylko wróżka stwierdzi, o co chodzi.
No, chyba, że przyjmujesz wersję: skoro działa, to nie ma się czym przejmować.
Zupełnie inna sprawa, obawiam się, że masz bardzo pomieszane w systemie.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Lipiec 25, 2022, 10:36:39 PM
@pavbaranov

Chyba nie mam wyjścia i muszę przyjąć taką wersję, jak zasugerowałeś.
Tym bardziej, że następne aktualizacje już mi nie wywalają niczego takiego. Obecnie znów jestem pod dziadowskim, transferem, ale na szczęście nie pojawiły mi się większe aktualizacje, jak poniżej 100 MiB. Ale i tak wpisuję sakramentalne [--disable-download-timeout], bo bez tego nawet na drobiazgach się potyka.
Nie wiem dlaczego mi się pomieszało, bo przecież robię dość regularne czyszczenie [pak -Sc]. Od poprzedniego czasu nie aktualizowałem keyringów, ale jeszcze nie minął miesiąc. A jeśli chodzi o mirrory, to widziałem, że się aktualizowały.
Tyle tylko potrafię zrobić. Nawet faktycznie się zastanawiałem, na temat zmiany systemu, ale - prawdę mówiąc - żal mi się rozstawać z Archem, głównie dlatego, że świetnie dział Midnight Commander, a jak próbowałem coś zrobić za pomocą MC u syna (ma w dalszym ciągu Mint-a), to tamten MC nie daje pełni praw do wprowadzania zmian. Dlatego, jak mi tutaj coś wymyślicie do zmiany, to daję radę wypełniać Wasze polecenia.
Jeśli chodzi o pacman -Qs linux to :

pacman -Qs linux-                                    (07-25 22:40)
local/aarch64-linux-gnu-binutils 2.38-1
    A set of programs to assemble and manipulate binary and object files for the
    ARM64 target
local/aarch64-linux-gnu-gcc 12.1.0-1
    The GNU Compiler Collection - cross compiler for ARM64 target
local/aarch64-linux-gnu-glibc 2.35-1
    GNU C Library ARM64 target
local/aarch64-linux-gnu-linux-api-headers 5.18-1
    Kernel headers sanitized for use in userspace (aarch64-linux-gnu)
local/archlinux-keyring 20220713-1
    Arch Linux PGP keyring
local/cpupower 5.18-1 (linux-tools)
    Linux kernel tool to examine and tune power saving related features of your
    processor
local/libaio 0.3.113-1
    The Linux-native asynchronous I/O facility (aio) library
local/linux-api-headers 5.17.5-2
    Kernel headers sanitized for use in userspace
local/linux-firmware 20220708.be7798e-1
    Firmware files for Linux
local/linux-firmware-whence 20220708.be7798e-1
    Firmware files for Linux - contains the WHENCE license file which documents
    the vendor license details
local/linux-headers 5.18.13.arch1-1
    Headers and scripts for building modules for the Linux kernel
local/linux-lts-headers 5.15.55-1
    Headers and scripts for building modules for the LTS Linux kernel
local/linux-lts-tkg-bmq-headers 5.15.36-256
    Headers and scripts for building modules for the Linux-tkg kernel
local/skypeforlinux-stable-bin 8.86.0.407-1
    Skype for Linux - Stable/Release Version
local/util-linux-libs 2.38-1
    util-linux runtime libraries




Dzięki, że się odezwałeś. Pozdrowienia dla Ciebie i Twoich

Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Lipiec 26, 2022, 11:47:05 AM
Jak widać:
Cytat: Piejanto w Lipiec 25, 2022, 10:36:39 PMlocal/linux-lts-headers 5.15.55-1
    Headers and scripts for building modules for the LTS Linux kernel
local/linux-lts-tkg-bmq-headers 5.15.36-256
    Headers and scripts for building modules for the Linux-tkg kernel
nagłówki LTSów masz :)
Czy ten komputer ma 64-bitowy procesor ARM lub robisz na taki procesor jakieś paczki? Bo jeśli nie, to po co instalowałeś coś z rodziny aarch64? I takich kwiatków w Twoim systemie jest pewnie sporo więcej. Dlatego napisałem wcześniej, że masz w nim nieporządek. Potem masz takie efekty, które opisujesz tu dość regularnie.
Gwoli ścisłości przełącznik "-Sc" służy wyłącznie usunięciu nieużywanych (starych) kopii zainstalowanych programów z cache pacmana.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Sierpień 02, 2022, 12:52:25 AM
@pavbaranov

Żadnych paczek nie robię. A jeśli robię to całkowicie nieświadomie.
Po prostu czasem łażę po internecie a czasem coś napiszę na LibreOffice.
Jaki ma procesor? ... muszę sprawdzić.
Usunąłem linux-lts bo mi kazał @robson75, ale różne inne "headersy" itp. pozostały, bo nie wiem, czy przypadkiem tam nie ma czegoś potrzebnego ?
Nie mam pojęcia, co powinienem wyrzucić ? - Niestety jestem wieśniakiem nieobytym.
Jutro wejdę do biosa i sprawdzę, co on tam ma w bebechach, bo dziś już padam. Zrobiłem aktualizację dość potężną (NERWY) i nawet transfer nie był zły (ok. 1500 MiB/sek. cud jakiś).
Po resecie wszystko działa pięknie.

Dzięki, za pomoc.


Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: D35CART35 w Sierpień 02, 2022, 07:11:42 AM
inxi -Fazy powie Ci wszystko
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Sierpień 03, 2022, 10:09:11 PM
@pavbaranov

Dzięki za podpowiedź. Wiedziałem, że nie potrzeba wchodzić w BIOS-a, ale nie pamiętałem polecenia bo byłem już skołowany.
Później przypomniałem sobie o poleceniu [lscpu]
No i mi wyświetliło tak:

Architektura:                x86_64
  Tryb(y) pracy CPU:         32-bit, 64-bit
  Rozmiary adresów:          39 bits physical, 48 bits virtual
  Kolejność bajtów:          Little Endian
CPU:                         8
  Lista aktywnych CPU:       0-7
ID producenta:               GenuineIntel
  ID producenta BIOS-u:      Intel(R) Corporation
  Nazwa modelu:              Intel(R) Core(TM) i5-8265U CPU @ 1.60GHz
    Nazwa modelu wg BIOS:    Intel(R) Core(TM) i5-8265U CPU @ 1.60GHz To Be Fill
                             ed By O.E.M. CPU @ 1.5GHz
    Rodzina CPU wg BIOS:     205
    Rodzina CPU:             6
    Model:                   142
    Wątków na rdzeń:         2
    Rdzeni na gniazdo:       4
    Gniazd:                  1
    Wersja:                  12
    Skalowanie MHz CPU:      30%
    CPU max MHz:             3900,0000
    CPU min MHz:             400,0000
    BogoMIPS:                3601.00
*********************************************************
Jest tego jeszcze cała strona, ale chyba już nie jest takie ważne jak to wyżej.
**********************************************************************************
NATOMIAST
wynik inxi -Fazy:


inxi -Fazy                                  (08-03 21:49)
zsh: correct 'inxi' to 'init' [nyae]?
*******************************************

Myślę, że to może być literówka bo oznacza mi [inxi] na czerwono.


Dzięki.


PS. Znów mam problem z Wi-Fi ale tym razem to chyba jest na linii modem-router.
Stało się to podczas jednej nieprzerywanej sesji. Nagle przestał odbierać Internet mimo, że pokazywał zalogowanie na routerze. Widzi router ale nie łączy z Internetem. Moja córka miała coś podobnego z MAC-iem. Wszystkie inne urządzenia działają z tym modemo-routerem OK, tylko mój ASUS na kablu. Ale to już nie jest problem ARCH-a i po przyjeździe do Łodzi będę musiał wejść do routera i tam pogmerać. W Łodzi mam jakieś notatki na ten temat.


Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: robson75 w Sierpień 03, 2022, 11:21:55 PM
Cytat: Piejanto w Sierpień 03, 2022, 10:09:11 PMinxi -Fazy                                  (08-03 21:49)
zsh: correct 'inxi' to 'init' [nyae]?

Myślę, że to może być literówka bo oznacza mi [inxi] na czerwono.
Aby wykonywać komendy związane z inxi, trzeba go najpierw zbudować lub zainstalować (jest w repo chaotic).
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Sierpień 04, 2022, 11:29:40 AM
Paczki *-aarch64 do niczego Ci nie są potrzebne. Paczki linux-headers mają sens wyłącznie dla tej samej wersji kernela, którą masz w systemie zainstalowaną. Co tam jest? Cóż, najogólniej mówiąc: rzeczy niezbędne dla innych paczek, by mogły zostać zbudowane jakieś moduły kernela itp. To, że masz ww. paczki niczego nie zmienia w pracy systemu, jednakże biorąc pod uwagę, że masz słabe (w tej chwili) połączenie z netem, w przypadku jakiejś aktualizacji niepotrzebnie dodatkowo są ściągane (bo i tak leżą odłogiem).
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Sierpień 04, 2022, 11:47:03 PM
@pavbaranov

Qrdę.... jasne... Trzeba zbudować. Zawsze o tym, nie tyle zapominam, ile nie wiem, co ja mam i co do czego.
No pewnie! Nie mam [inxi] a wydaję mu polecenia. Bożżżż.. wybacz.
Dobra. Ale czy wynik [lscpu] wystarczył? czy powinienem jednak instalować [inxi]. Czy do czegoś jeszcze może mi się przydać [inxi].
Pytam, bo dojrzewam. Chyba.

Aha... co do Wi-Fi. Dziś postanowiłem usunąć i powtórnie zainstalować sterownik rtl8821ce itd. Ale ...
nim się do tego zabrał, poleciłem [pak -m] (bo to akurat miesiąc mija od poprzedniego aktualizowania).
Następnie poleciłem [pak -Syu] i zresetowałem kompa.
Następnie odłączyłem kabel od modemo-routera i... MAM Wi-Fi !!!

Bez odinstalowania rtl8821ce i bez powtórnego instalowania. NIe wiem co to było za zawirowanie, ale i czy to jednorazowa naprawa, ale chodzi pięknie. Na razie.

**************************************
PS.
Rozumiem, że wynik polecenia [lscpu] wystarczył.
Paczki , cytuję: -  "Paczki *-aarch64 do niczego Ci nie są potrzebne.". Czy te paczki mogę usunąć za pomocą Octopi, czy potrzeba to zrobić w inny sposób?


Pozdrowienia.
 

Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Sierpień 05, 2022, 09:45:09 AM
1. lscpu oczywiście wystarcza.
2. inxi przydaje się, gdy masz komuś podać info o sprzęcie. Nie jest to jedyne narzędzie, ale po prostu wygodne.
3. Paczki możesz odinstalować w dowolny sposób.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Sierpień 05, 2022, 02:48:01 PM
@pavbaranov

OK. Znaczy, że w zasadzie [inxi] raczej mi się nie przyda.

A co do Wi-Fi. Wczoraj to był jakiś cud. Dziś uruchomiłem kompa i znów nie mogę się połączyć. Tym razem już całkowicie. Tzn. Przedtem było tak, że wołał hasła do połączenia, ale tego hasła nie przekazywał?.. albo nie zapisywał?... nie wiadomo.
Teraz widzi mój modemo-router, ale "kręci połączenie" i nie łączy, a nawet nie pokazuje okna do wpisania hasła. Ostatnie łączenie, pokazuje mi sprzed 13 godzin, czyli to po aktualizacji. Spróbuję jeszcze powalczyć.
Pozostałe sprzęty nie mają problemu z Wi-Fi.

Dzięki.

Wyrzuciłem stare połączenie i restartowałem kompa. Kazałem mu się połączyć z wykrytym modemo-routerem i tym razem pokazał okno do wpisania hasła, ale po wpisaniu nie połączył, tylko znów wyświetlił okno do wpisania hasła.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Sierpień 05, 2022, 07:58:32 PM
Niestety, Wi-Fi nie działa.
Ciekawa sprawa, bo w końcu wyrzuciłem sterownik [rtl8821ce-dkms-git] i po restarcie on w dalszym ciągu się zachowuje tak, jakby chciał się łączyć z Wi-Fi. nawet po połączeniu kablowym (!) chce się łączyć z Wi-Fi i muszę mu wyłączyć [Sieć]. Po odłączeniu kabla próbuje się łączyć ale nie przyjmuje hasła.

Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Sierpień 05, 2022, 10:00:35 PM
Przypomniałem sobie,że do aktualizacji mirrorów miałem nie używać PAK-a.
Dziś wydałem polecenie [reflector --verbose --latest 5 --sort rate --save /etc/pacman.d/mirrorlist]
Teraz chyba powinno być dobrze?
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: pavbaranov w Sierpień 06, 2022, 10:33:57 AM
Janek - załóż wątek z trudnościami w połączeniu się z modemem. Tak na szybko - masz tam 2 sterowniki do swojej karty.
INXI przyda Ci się (a raczej nam).
Dlaczego niby paka nie używać do aktualizacji mirrorów? Robię to od lat i nie ma z tym żadnego problemu.
Tytuł: Odp: Znów problem z aktualizacją
Wiadomość wysłana przez: Piejanto w Sierpień 10, 2022, 12:06:46 AM
@pavbaranov

Też o tym myślałem, ale u mnie to wszystko jest pomieszane i poprzegniatane jak ciasto u piekarzy. 

Ponadto, zrobiłem jak pomyślałem. Usunąłem [rtl8821ce-dkms-git]. następnie, żeby tam nic nie zostało) zrobiłem [pak -Sc]
Zrobiłem aktualizację systemu i mi pokazało :

==> ERROR: Missing 5.15.59-2-lts kernel modules tree for module rtl8821ce/1.0.5.r140.gbe733dc.

To pomyślałem sobie, że teraz należy wgrać od nowa sterownik. Ale już się nie ładowałem w tego LTS-a, bo mi @robson75 kiedyś mówił, że nowy już nie ma sterownika, więc nie szukałem starego.

Wrzuciłem polecenie [pak -Sa rtl8821ce-dkms-git]. Zaszumiało i zainstalowało.

Zresetowałem kompa i... mam Wi-Fi

Dzięki Wam, Panowie.

Już myślałem, że będę się musiał pożegnać z Archem, ale widać jeszcze nie pora
Uffff

Dzięki wielkie