Linuxiarze.pl Forum

Dystrybucje Linux => Ubuntu, Kubuntu, Xubuntu, Lubuntu => Wątek zaczęty przez: rejbus w Listopad 29, 2018, 09:43:43 pm

Tytuł: brak internetu Lenovo Legion y530
Wiadomość wysłana przez: rejbus w Listopad 29, 2018, 09:43:43 pm
Witam,
 
Mam taki problem, zainstalowałem ubuntu Pop! OS na swoim laptopie i nie chodzi mi w ogóle internet wi-fi czy po kablu. Nie wiem o co chodzi, dodam, że na ubuntu 18.04 też nie mogłem się połączyć. Proszę o pomoc bo nie mam pomysłu jak to naprawić.

Tytuł: Odp: brak internetu Lenovo Legion y530
Wiadomość wysłana przez: pavbaranov w Listopad 29, 2018, 09:50:16 pm
A po tak dogłębnym przedstawieniu problemu my nie wiemy jak Ci pomóc.
Tytuł: Odp: brak internetu Lenovo Legion y530
Wiadomość wysłana przez: PomPom w Listopad 29, 2018, 09:55:11 pm
To nowy laptop, nie? Spróbuj Ubuntu lub Pop_OS!, ale w wersji 18.10.
Ew. też to w terminalu:
sudo tee /etc/modprobe.d/blacklist-ideapad.conf <<< "blacklist ideapad_laptop"
Tytuł: Odp: brak internetu Lenovo Legion y530
Wiadomość wysłana przez: rejbus w Listopad 29, 2018, 10:14:20 pm
pavbaranov nie wiem jakie mogę wam przedstawić za informację, które byłby pomocne. Jak byś mógł mi napisać byłbym Ci wdzięczny. PomPom wpisywałem w terminalu sudo tee /etc/modprobe.d/blacklist-ideapad.conf <<< "blacklist ideapad_laptop"
wyskakuje mi, że nie widzi takiej komendy. Ubuntu miałem przed Pop OS! tam też nie mogłem się połączyć z internetem, jeszcze do tego problemu z grafiką dlatego przeszedłem na Pop OS!.  Komputer jest nowy ma 3 tygodnie
Tytuł: Odp: brak internetu Lenovo Legion y530
Wiadomość wysłana przez: pavbaranov w Listopad 29, 2018, 10:19:13 pm
1. Jakiekolwiek, podstawowe informacje o tym co tam w bebechach jest. Przecież samochodu nie naprawiasz dzwoniąc do mechanika i mówiąc: "samochód mi nie jeździ" :)
2. Co to znaczy: "nie mogę się połączyć z internetem"? Pojęcie jest mocno niejednoznaczne.
Tytuł: Odp: brak internetu Lenovo Legion y530
Wiadomość wysłana przez: rejbus w Listopad 29, 2018, 10:48:01 pm
Procesor:Intel Core i7-8750H
Pamięć:16 GB
Dysk SSD M.2 PCIe:250 GB
Grafika:NVIDIA GeForce GTX 1050, + Intel UHD Graphics 630
Chipset Intel HM370.

Problem jest taki, po zalogowaniu chcę włączyć sieć niestety  gdy wciskam włącz wi-fi w prawym górnym rogu to nic się nie dzieje, z poziomu ustawień też nie reaguję. Hot spota telefonicznego też nie widzi. Natomiast gdy podłączam kabel to wyskakuję ikonka łączenie po czym otrzymuję komunikat Activation of network connection failed.
Tytuł: Odp: brak internetu Lenovo Legion y530
Wiadomość wysłana przez: pavbaranov w Listopad 29, 2018, 11:05:15 pm
Taaa.... i na pytanie "jaki to samochód?" otrzymałem odpowiedź: "niebieski" :)
Rozumiem, że podajesz nam to z jakiegoś innego komputera itp. a zatem na uruchomionym linuksie wydaj komendy (w terminalu/konsoli):
lspci > lspci.txtsystemctl status NetworkManager.service > nm.txtZawartość plików wrzuć na jakiś serwis typu pastebin.
Czy instalując linuksa miałeś włączoną kartę wifi? Z liveISO był/jest połączenie z siecią? To jest dual-boot z jakimś Windows?
Tytuł: Odp: brak internetu Lenovo Legion y530
Wiadomość wysłana przez: rejbus w Listopad 30, 2018, 10:02:17 am
ok dzięki,
przesyłam
lspci : https://pastebin.pl/view/3b6d520f
nm :  https://pastebin.pl/view/d55af9fb

Miałem włączoną kartę sieciową. Instalowałem z bootowalnego pendrive. Zainstalowałem na wydzielonej przestrzeni, Pop! OS jest zainstalowany obok Windowsa 10, dodam, że na Windowsie chodzi internet. 
Tytuł: Odp: brak internetu Lenovo Legion y530
Wiadomość wysłana przez: pavbaranov w Listopad 30, 2018, 11:20:20 am
Na pendrive (liveusb) masz połączenie z netem?
Możesz jeszcze pokazać wynik polecenia: lsmod
Przy okazji - 2 instrukcje instalacji Ubuntu >18.04 na tym komputerze:
https://forums.lenovo.com/t5/Gaming-Laptops-Knowledge-Base/Installing-Ubuntu-18-xx-on-the-Legion-Y530/ta-p/4187251 (https://forums.lenovo.com/t5/Gaming-Laptops-Knowledge-Base/Installing-Ubuntu-18-xx-on-the-Legion-Y530/ta-p/4187251)
https://github.com/kfechter/LegionY530Ubuntu (https://github.com/kfechter/LegionY530Ubuntu)
Z pierwszej wynika, że aby mieć wifi trzeba usunąć z podniesionych modułów ineapad_laptop (od Step 12). Dlaczego jednak po kablu nie podnosi, to zagadka i całkiem możliwe, że mimo usunięcia tego modułu nadal nic nie uzyskasz.
Tytuł: Odp: brak internetu Lenovo Legion y530
Wiadomość wysłana przez: rejbus w Listopad 30, 2018, 06:04:05 pm
oki, przesyłam plik lsmod : https://pastebin.pl/view/76478195
Sprawdziłem internet działa z liveusb. pavbaranov proponowałbyś usunąć Pop! OS i na nowo zainstalować ubuntu ?
Tytuł: Odp: brak internetu Lenovo Legion y530
Wiadomość wysłana przez: pavbaranov w Listopad 30, 2018, 07:00:42 pm
Cóż... wygląda, że owego ideapad_laptop nie masz podniesionego. Odpowiednie moduły dotyczące wifi podniesione są. Dlaczego się nie łączy??? Ot, pytanie.
Internet na liveusb działa i po kablu i bez niego?
Jeśli tak - sprawdź co jest podniesione na liveusb (lsmod) i porównaj z tą listą, którą wrzuciłeś. Podnieś brakujące moduły i sprawdź.
Spróbuj uruchomić kernel jako fallback o ile masz coś takiego do wyboru w GRUB.

IMO jedyne co przemawia za Ubuntu w stosunku do POP! to większa społeczność Ubuntu, która może niechętnie patrzeć na "obcy fork" (lub po prostu nie wiedzieć czym się różnią obie). Generalnie jest to to samo. Różnicy w zakresie połączenia z netem mieć nie będziesz miał.
Tytuł: Odp: brak internetu Lenovo Legion y530
Wiadomość wysłana przez: rejbus w Listopad 30, 2018, 10:07:14 pm
pavbaranov chciałem Ci bardzo podziękować za pomoc !! :) ostatecznie udało mi się naprawić problem z internetem, działa już. Zostałem na Pop! OS jeszcze tylko naprawie gruba i będzie git. Jeszcze raz dzięki.
Tytuł: Odp: brak internetu Lenovo Legion y530
Wiadomość wysłana przez: pavbaranov w Listopad 30, 2018, 11:15:14 pm
Nie ma sprawy, ale przydałoby się, abyś napisał jakich modułów mu brakowało (bo chyba o to chodzi). Ktoś będzie mógł z tego skorzystać.
Tytuł: Odp: brak internetu Lenovo Legion y530
Wiadomość wysłana przez: rejbus w Grudzień 02, 2018, 06:58:03 pm
sprawdziłem moduły i wszystko było ok. Natomiast na spokojnie przeszedłem proces, który jest opisany na forum lenovo, i nagle zadziałało (nie wiem jak to się stało, ponieważ wcześniej dwa razy to robiłem i nie pomogło w ogóle).