Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Ostatnie wiadomości

Strony: [1] 2 3 ... 10
1
Arch / Odp: Menadżer pakietów w trybie graficznym
« Ostatnia wiadomość wysłana przez pavbaranov dnia Dzisiaj o 02:16:21 am »
Dziwny problem i wygląda na jakiś problem z octopi/octopi-notifier. Jeśli wystąpi ponownie, to masz proste rozwiązanie:
pak -Q nazwa_paczki i sprawdź w jakich wersjach masz w systemie. Jeśli te, które podaje do aktualizacji octopi, to należałoby problem zgłosić. Inna sprawa, że mieszasz menedżery paczek.
PS: Dobra rada: uruchom sobie notyfikacje o nowych paczkach w pak i będzie po kłopocie.
2
Arch / Odp: Menadżer pakietów w trybie graficznym
« Ostatnia wiadomość wysłana przez robson75 dnia Czerwiec 21, 2021, 06:11:41 pm »
Weź wykonaj polecenie
pak -mpacman -Syu
3
Arch / Odp: Menadżer pakietów w trybie graficznym
« Ostatnia wiadomość wysłana przez Piejanto dnia Czerwiec 21, 2021, 05:26:23 pm »
FAŁSZYWY ALARM.
WYCOFUJĘ PONIŻSZE. PO RESECIE OCTOPI ZGŁOSIŁO SIĘ NA ZIELONO.


Mam Archa XFCE na laptopie Asus

Po wierzgnięciu Pamaca mam zainstalowane Octopi. Do dziś było OK, ale właśnie dziś po aktualizacji (bardzo niewielkiej)  robionej Pacmanem i Pak-iem, Octopi pokazuje mi, że jest aktualizacja.
Bardzo niewielka bo 6 pakietów ma 00,0 B (??), ale jest i świeci mi się na czerwono.
Dlatego robiłem aktualizację mirrorów Reflectorem, ale Reflector pokazywał mi ostrzeżenia, że pobieranie w dwóch przypadkach się nie powiodło, bo został przekroczony czas oczekiwania.
No, to  zaktualizowałem mirrory poleceniem [pak -m --disable-download-timeout] i mi powiedział, że zaktualizowano.
Następnie poleciłem[pacman -Sy] i następnie [pacman -Su]. Aktualizacja przebiegła pomyślnie ale Octopi świeci mi na czerwono. Pomyślałem, że może w tzw. międzyczasie, coś się pojawiło, więc zrobiłem następną aktualizację [pak -Syu --disable-download-timeout].
Po aktualizacji Pak-iem mam informację, że nie ma nic do zrobienia, a Octopi twierdzi coś innego.

 Octopi świeci na czerwono i pokazuje 6 plików do aktualizacji. Wygląda to tak :

informacja Pak-a :

pak -Syu --disable-download-timeout         

:: Synchronizowanie baz danych z pakietami…
 core is up to date
 extra is up to date
 community is up to date
 chaotic-aur is up to date
:: Rozpoczynanie pełnej aktualizacji systemu…
 nie ma nic do zrobienia


informacja Octopi :

chaotic-mirrorlist-20210620-1
graphviz-2.47.3-1
libconfig-1.7.3-1
libhandy-1.2.3-1
libva-2.12.0-1
qt5-base-5.15.2+kde+r199-1


W zasadzie niby nic, ale niepokoi.
Czy powinienem przyklepywać aktualizację Octopi, czy ignorować?

FAŁSZYWY ALARM. PO RESECIE OCTOPI ZGŁOSIŁO SIĘ NA ZIELONO.



4
Arch / Odp: Octopi jak zainstalować?
« Ostatnia wiadomość wysłana przez Piejanto dnia Czerwiec 20, 2021, 11:53:51 pm »
@robson75

I teraz poszło. Dzięki za cierpliwość, Robert.

Zdrowia.


PS
Po wyrzuceniu wszystkiego co niepotrzebne, poszła aktualizacja na 183 pozycje.
Bez Octopi-dev nie dałbym sobie rady.
5
Arch / Odp: Octopi jak zainstalować?
« Ostatnia wiadomość wysłana przez robson75 dnia Czerwiec 20, 2021, 10:12:23 pm »
Weź wklep w terminal
pacman -Sy chaotic-keyring chaotic-mirrorlistpacman -Sy octopi-dev
6
Arch / Odp: Octopi jak zainstalować?
« Ostatnia wiadomość wysłana przez Piejanto dnia Czerwiec 20, 2021, 07:39:06 pm »
@robson75

Chciałem wywalić to całe [lib32] bo tutaj jest mi jeszcze mniej potrzebne niż na Asusie. Ale nie wiem, czy można to zrobić ręcznie poprzez Midnight Commandera, a za pomocą Octopi wywaliłem, jak kazałeś wszystko, co zaczynało się od [lib32]. Ręcznie nie wiem, czy trafię do wszystkiego.
Dalej chciałem postępować tak jak w Asusie przy poprzednim problemie. Ale tam zainstalowałem Octopi za pomocą tego durnego programu pt.: [Pakiety], którego tutaj nie mam.
7
Arch / Odp: Octopi jak zainstalować?
« Ostatnia wiadomość wysłana przez Piejanto dnia Czerwiec 20, 2021, 07:23:45 pm »
@robson75
do zainstalowania czegokolwiek on woła synchronizacji i aktualizacji. A tego własnie zrobić nie mogę.

tu ostatnia próba:

# pacman -Sy octopi-dev
:: Synchronizowanie baz danych z pakietami…
 core is up to date
 extra is up to date
 community               5,6 MiB   156 KiB/s 00:37 [######################] 100%
 chaotic-aur          1139,4 KiB   105 KiB/s 00:11 [######################] 100%
rozwiązywanie zależności…
szukanie sprzecznych pakietów...

Pakiety (3) alpm_octopi_utils-dev-1.0.2-6  qtermwidget-0.17.0-2
            octopi-dev-0.12.0-3

Do pobrania:        1,44 MiB
Do zainstalowania:  6,33 MiB

:: Kontynuować instalację? [T/n] T
:: Pobieranie pakietów…
 alpm_octopi_util...    19,5 KiB  21,0 KiB/s 00:01 [######################] 100%
 octopi-dev-0.12....  1455,1 KiB   162 KiB/s 00:09 [######################] 100%
 Total (2/2)          1474,6 KiB   146 KiB/s 00:10 [######################] 100%
(3/3) sprawdzanie kluczy w bazie                   [######################] 100%
pobieranie potrzebnych kluczy…
:: Zaimportować klucz PGP 0706B90D37D9B881, "Pedro Henrique Lara Campos <root@pedrohlc.com>"? [T/n] T
(3/3) sprawdzanie spójności pakietów               [######################] 100%
błąd:  octopi-dev: klucz "45ECA705E3897524654A37880706B90D37D9B881" jest nieznany
:: Zaimportować klucz PGP 45ECA705E3897524654A37880706B90D37D9B881? [T/n] T
błąd:  klucz "45ECA705E3897524654A37880706B90D37D9B881" nie może zostać sprawdzony zdalnie
:: Plik /var/cache/pacman/pkg/octopi-dev-0.12.0-3-x86_64.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
błąd:  nie udało się dokonać transakcji (Niepoprawny lub uszkodzony pakiet (podpis PGP))
Wystąpiły błędy, nie zaktualizowano żadnego pakietu.
8
Arch / Odp: Octopi jak zainstalować?
« Ostatnia wiadomość wysłana przez Piejanto dnia Czerwiec 20, 2021, 07:06:13 pm »
@robson75

No tak. Tylko,  że ja już w tym miejscu byłem kilka godzin temu.
I nie wiem jak te wszystkie niepotrzebne rzeczy pousuwać bez Octopi.
Już zahasztagowałem nawet
[Include] i następny wers w [pacman.conf] i ściągnąłem nawet /Pobrane/octopi-5b8dfb0388aeb471bb4ab5652a651ec1345a1ed5.tar.gz  i rozpakowałem i próbowałem zainstalować, ale on mi gada,  że trzeba zrobić aktualizację, a aktualizacja nie jest możliwa i mamy "RING" zamknięty.  Aktualnie jest tak:

# pacman -Syu chaotic-keyring
:: Synchronizowanie baz danych z pakietami…
 core is up to date
 extra                1565,2 KiB  59,1 KiB/s 00:26 [######################] 100%
 community               5,6 MiB   103 KiB/s 00:55 [######################] 100%
 chaotic-aur          1139,4 KiB  65,0 KiB/s 00:18 [######################] 100%
:: Rozpoczynanie pełnej aktualizacji systemu…
:: Zastąpić libcanberra-pulse przez extra/libcanberra? [T/n] T
rozwiązywanie zależności…
szukanie sprzecznych pakietów...
błąd:  nie udało się przygotować transakcji (nie udało się rozwiązać zależności)
:: instalacja libelf (0.185-1) uszkodzi zależności 'libelf=0.184' wymagane przez lib32-libelf

9
Arch / Odp: Octopi jak zainstalować?
« Ostatnia wiadomość wysłana przez robson75 dnia Czerwiec 20, 2021, 06:42:45 pm »
Janek, do cholery jasnej. Wystarczy wklepać w terminalu
pacman -Syu chaotic-keyringI proponuje instalację octopi-dev, bo została naprawiona opcja instalacja pakietów lokalnych.
pacman -Sy octopi-dev
10
Arch / Octopi jak zainstalować? ROZWIĄZANY
« Ostatnia wiadomość wysłana przez Piejanto dnia Czerwiec 20, 2021, 06:18:16 pm »
Na netbooku Acer mam Archa. Niedawno miałem problem z aktualizacją na Asusie i udało się kolegom mnie wyprowadzić na prostą. No to pomyślałem, że netbooka sam pokonam. Bo też się nie chce aktualizować.
Niestety.
Na netboku nie mam /menu/system/Pakiety, a [dodawanie/usuwanie oprogramowania] czyli Pamac już nie działa.
Chciałem doinstalować Octopi, bo ładnie mi działa na Asusie, ale za Chiny Ludowe nie umiem tego zrobić. Doszedłem do momentu jak niżej i nie wiem, co dalej:
*****************8
pacman -S octopi
rozwiązywanie zależności…
szukanie sprzecznych pakietów...

Pakiety (3) alpm_octopi_utils-1.0.2-3  qtermwidget-0.17.0-2  octopi-0.11.0-2

Do pobrania:        1,65 MiB
Do zainstalowania:  6,24 MiB

:: Kontynuować instalację? [T/n] T
:: Pobieranie pakietów…
 alpm_octopi_util...    19,4 KiB  3,67 KiB/s 00:05 [######################] 100%
 qtermwidget-0.17...   238,2 KiB   109 KiB/s 00:02 [######################] 100%
 octopi-0.11.0-2-...  1435,0 KiB   137 KiB/s 00:10 [######################] 100%
 Total (3/3)          1692,7 KiB  91,3 KiB/s 00:19 [######################] 100%
(3/3) sprawdzanie kluczy w bazie                   [######################] 100%
(3/3) sprawdzanie spójności pakietów               [######################] 100%
błąd:  alpm_octopi_utils: podpis od "Nico Jensch <dr460nf1r3@garudalinux.org>" posiada nieznane zaufanie
:: Plik /var/cache/pacman/pkg/alpm_octopi_utils-1.0.2-3-x86_64.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
błąd:  octopi: podpis od "Nico Jensch <dr460nf1r3@garudalinux.org>" posiada nieznane zaufanie
:: Plik /var/cache/pacman/pkg/octopi-0.11.0-2-x86_64.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
błąd:  nie udało się dokonać transakcji (Niepoprawny lub uszkodzony pakiet (podpis PGP))
Wystąpiły błędy, nie zaktualizowano żadnego pakietu.
*****************
No, i po ambicjach.
Strony: [1] 2 3 ... 10