Linuxiarze.pl Forum

Interfejs graficzny => Xfce => Wątek zaczęty przez: zxcvt w Wrzesień 27, 2017, 10:24:08 pm

Tytuł: .xsession-errors
Wiadomość wysłana przez: zxcvt w Wrzesień 27, 2017, 10:24:08 pm
Witam

Używam Debian Stretch z xfce na laptopie. Czy można zignorować to co znajduje się w pliku .xsession-errors? Pojawiają się tam błędy, jednak nie zauważyłem, żeby coś nie działało. Szukałem w internecie informacji o błędach które tam mam, jednak niewiele znalazłem. Wydaje mi się, że niektóre rzeczy nie są błędami, a mianowicie:
Xsession: X session started for ...,
dużo wpisów zaczynających się od dbus-update-activation-environment: setting,
localuser:zxcvt being added to access control list,
OpenGL version: 3,
/usr/bin/x-session-manager: X server already running on display :0,
xfce4-session-Message: SSH authentication agent is already running.
Czy mam rację, że to nie są błędy i można to zignorować?


Są też rzeczy które chyba są błedami, lecz czy da się coś z tym zrobić i czy skoro nie widzę, żeby coś nie działało czy jest konieczne, aby coś z tym robić?
gpgconf: warning: can not open config file /home/zxcvt/.gnupg/gpg-agent.conf: Nie ma takiego pliku ani katalogu
gpg-agent[1122]: WARNING: "--write-env-file" is an obsolete option - it has no effect
gpg-agent: a gpg-agent is already running - not starting a new one
(xfce4-session:1105): xfce4-session-WARNING **: gpg-agent returned no PID in the variables
** (wrapper-1.0:1175): WARNING **: No outputs have backlight property

trochę linijek zaczynających się od (wrapper-2.0:tu różne cyfry): Gtk-WARNING **: Theme parsing error, a na końcu: is deprecated and shouldn't be used anymore. It will be removed in a future version

linijki: (wrapper-2.0:tu różne cyfry): Gtk-WARNING **: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget

(redshift-gtk:1170): Gdk-CRITICAL **: gdk_window_thaw_toplevel_updates: assertion 'window->update_and_descendants_freeze_count > 0' failed

(xfce4-terminal:1290): Gdk-CRITICAL **: gdk_window_get_window_type: assertion 'GDK_IS_WINDOW (window)' failed

spowodowane podłączeniem pendrive:
thunar-volman: Nieobsługiwany typ urządzenia USB „usb”.
thunar-volman: Nieobsługiwany typ urządzenia USB „usb-storage”.
thunar-volman: Nieznany typ urządzenia blokowego „disk”.
jednak pendrive działa.

Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

(Thunar:1126): GLib-GIO-CRITICAL **: g_file_hash: assertion 'G_IS_FILE (file)' failed

(Thunar:1126): GLib-GIO-CRITICAL **: g_file_query_info_async: assertion 'G_IS_FILE (file)' failed

(Thunar:1126): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

(gimp-2.8:1570): GLib-GObject-WARNING **: g_object_set_valist: object class 'GeglConfig' has no property named 'cache-size'

dużo linijek typu: (gimp-2.8:1570): GEGL-gegl-operation.c-WARNING **: Cannot change name of operation class 0x55BD356DBDC0 from "gimp:point-layer-mode" to "gimp:dissolve-mode", z małymi różnicami

dużo linijek: libpng warning: iCCP: known incorrect sRGB profile.

Czy te błędy da się naprawić? Czy zignorowanie ich nie spowoduje jakichś złych konsekwencji? Czy trzeba coś z tym robić skoro nie widzę, żeby coś nie działało (ale może coś nie działa, tylko akurat coś czego nie używam i dlatego tego nie widzę)?

Pozdrawiam