Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Debian9 - problem z instalacją PHP

Zaczęty przez slavo_s2k, Wrzesień 18, 2022, 05:24:57 PM

Poprzedni wątek - Następny wątek

slavo_s2k

Postawiłem VM z Debian9 (potrzebuję do uruchomienia własnej instacji SuplaSripts) i napotykam problem z uruchomiem PHP. Postępuję zgodnie z tym opisem , zatrzymuje się na etapie, że po wpisaniu

echo "deb https://packages.sury.org/php/ $(lsb_release -sc) main" | sudo tee /etc/apt/sources.list.d/php.list

i następnie

sudo apt update
mam taki problem:

Hit:1 http://security.debian.org/debian-security stretch/updates InRelease
Ign:2 http://ftp.us.debian.org/debian stretch InRelease         
Hit:3 http://ftp.us.debian.org/debian stretch Release           
Ign:4 https://packages.sury.org/php stretch InRelease
Err:5 https://packages.sury.org/php stretch Release
  403  Forbidden
Reading package lists... Done
E: The repository 'https://packages.sury.org/php stretch Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

i dalej:

sudo apt install php7.4
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package php7.4
E: Couldn't find any package by glob 'php7.4'
E: Couldn't find any package by regex 'php7.4'

Niestety próbowałem wielu opisów, zawsze z podobnym skutkiem, nie jestem zbyt mocny z linux-a , ale nie rozumiem dlaczego taka teoretycznie prosta rzecz mi nie wychodzi :(

PomPom

Nie wychodzi, bo dodane repozytorium sury nie obsługuje już Debiana 9. Użyj Debiana 11.
Komputer - Card Reader | Gry - Xbox Series X | Użytkownik - zadowolony

sovtware

użyj minimum 10 Debiana lub tą wersję co Kolega wyżej napisał 11 ponieważ  9 już nie jest wspierana

Zobacz najnowsze wiadomości na forum