Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Znów problem z aktualizacją

Zaczęty przez Piejanto, Maj 08, 2022, 07:02:36 PM

Poprzedni wątek - Następny wątek

robson75

Cytat: Piejanto w Czerwiec 21, 2022, 10:37:19 PMZrezygnowałem z tego adresu do Mirrorów, który mi kiedyś nadałeś, bo zacząłem zapominać o wpisywaniu przed aktualizacją. Może powinienem jednak wrócić?
Mam tę poradę i sposób wykonania, ale czy to jeszcze aktualne?
Jak najbardziej aktualne, jadę na tym serwerze od kilku miesięcy, i zero problemów
Server = https://mirror.f4st.host/archlinux/$repo/os/$arch
Arch Linux Xfce+compiz - 64Bit Linux User #621110

Piejanto

#61
@robson75
No, dobra, to wracam do tego servera. Kłopot tylko taki, że za każdym razem trzeba go wklepać, ale jeśli to raz na miesiąc, to dam rade.

@nycko
Cytat:
"(...Co więcej, po każdym pak -m należy bezwzględnie wykonać pak -Syyu (podwójne y), inaczej można (choć nie trzeba) nabawić się bólu głowy."

I tutaj może jest kot pogrzebany? Akurat tego [pak -Syyu] nie robiłem.
Po prostu nie wiedziałem, do czego to jest potrzebne.

nycko

Cytat: Piejanto w Czerwiec 21, 2022, 11:16:35 PM@nycko
Cytat:
"(...Co więcej, po każdym pak -m należy bezwzględnie wykonać pak -Syyu (podwójne y), inaczej można (choć nie trzeba) nabawić się bólu głowy."

I tutaj może jest kot pogrzebany? Akurat tego [pak -Syyu] nie robiłem.
Po prostu nie wiedziałem, do czego to jest potrzebne.

Można też sudo pacman -Syyu, bo to samo robi. Chociaż moje jest krótsze do wpisania.

Najważniejsze, robisz pak -Syu i nie martwisz się o keyringi od dzisiaj.
GitLab = users/nycko123/projects | GitHub = nycko123 | AUR = packages/?SeB=m&K=nycko123

robson75

Cytat: Piejanto w Czerwiec 21, 2022, 11:16:35 PMKłopot tylko taki, że za każdym razem trzeba go wklepać, ale jeśli to raz na miesiąc, to dam rade.
Janek to Ci to jeszcze raz wytłumaczę o co chodzi.
Po aktualizacji pacman-mirrorlist nic się nie zmienia w pliku /etc/pacman.d/mirrorlist, tylko zmienia się /etc/pacman.d/mirrorlist.pacnew.
A serwer siedzi w pliku mirrorlist, więc nic nie musisz robić.
Oczywiście też nie możesz wykonywać polecenia
pak -m
bo ta komenda nadpisuje plik /etc/pacman.d/mirrorlist.
Arch Linux Xfce+compiz - 64Bit Linux User #621110

pavbaranov

Cytat: Piejanto w Czerwiec 21, 2022, 10:37:19 PMJeśli chodzi o Keyringi, to też uważałem, że się aktualizują razem z Systemem, gdy polecam [pak -Syu]. Sam widziałem czasem że lecą aktualizacje Keyringów i... się schrzaniło.
Nie czytasz tego co Ci piszemy. Obecna wersja pak wpierw robi aktualizację keyring, a dopiero potem leci cała reszta. Nie powinno być takich problemów, jak z "gołym" pacmanem. Masz zrobić aktualizację paka i potem jedynie - gdy trzeba - pak -Syu Kiedy? Masz opisane wyżej.
CytatCytat:
"(...)Natomiast taki sposób kompilacji (alfabetycznie) nie zawsze będzie prawidłowy i pozwoli na zbudowanie paczki. Wówczas trzeba to zrobić w sposób ręczny, analizując informacje w AUR, czy w POLAUR. "
No... i właśnie to jest dla mnie rafa.
Pomijając fakt, że nie powinna taka kompilacja sprawić problemów, to zawsze powtarzam: AUR jest dla tych, którzy wiedzą o co tu chodzi. Jeśli nie wiesz - nie korzystaj. Trudno - znajdziesz zamiennik. Albo będzie w chaotic-aur.
CytatCzy jeśli np. dwa tygodnie nie aktualizowałem, to czy aktualizować osobno Keyrngi i Mirrory? - Czy jak zwykle lecieć całością [pak -Syu]? Bo o ile dobrze pamiętam, to właśnie ten ostatni kłopot wynikł po dłuższym nieaktualizowaniu.
Janek - doprawdy nie wiem jak Ci to napisać już 100 raz. Ze względu na Twój problem z kompletnym nierozumieniem systemu, Damian dorobił kod paka i w tej chwili przy pełnej aktualizacji pak wpierw (przed innymi paczkami) aktualizuje keyringi. I koniec, bo już mam dość bicia tej piany. Zbyt wiele razy to samo, to samo, to samo... I nie trafia.

Piejanto

#65
@pavbaranov
No, tak prawda. pisaliście na temat nowego PAK-a, ale ja byłem jeszcze pod działaniem starego paka. Zauważyłem, że jest inaczej, ale początek leci tak szybko, że nie miałem sposobności się przyjrzeć, co tam "stoi napisane".
Może faktycznie powinienem odinstalować AUR i pozostać przy Chaotic-aur... Jeśli Chaotic-aur nie stwarza takiego zagrożenia, to ja chętnie. Muszę sprawdzić tylko, co ja mam u siebie z AUR, a co z Chaotic-aur. Nie jestem pewien np. skąd jest Zoom. Ja Zoom-a nie używam, ale trzymam na wypadek, gdyby córka musiała skorzystać.

OK. już rozumiem z tymi Keyringami. Leci to na początku, tylko, że nie mogłem się przyjrzeć

@robson75
Teraz rozumiem. Byłem po prostu zbyt akuratny, a niedouczony.

Wynika to z faktu, że powinienem śledzić rozwój programów, a nie śledzę z dwóch powodów.
1/ głównie zajmuję się innymi rzeczami, a do kompa siadam, gdy mam coś do sprawdzenia lub napisania
2/ mam kłopot z czytaniem angielszczyzny, a córka (anglistka) mi tez nie pomaga, bo ona nie kuma komputrowych określeń.

Zatem, o różnych newsach dowiaduję się od Was dopiero gdy mi się coś posypie.

Najważniejsza dla mnie aktualność, to to, że w zasadzie teraz powinno mi wystarczyć polecenie [pak -Syu]

Dzięki za pomoc.
Skopiowałem sobie, jak zwykle te nauki od Was i teraz muszę powyrzucać stare (nieaktualne). Jest tego sporo. Ale na szczęście po polsku i za to Wam dziękuję.

Pozdrowienia serdeczne.
 
PS
Tak będzie:
Robię aktualizację PAK-a
 następnie [pak -Syu]
O Keyringi się nie martwię,
a Mirrory raz na miesiąc, bez używania PAK-a tylko za pomocą Pacmana

Tak zrozumiałem.








pavbaranov

Cytat: Piejanto w Czerwiec 22, 2022, 11:29:54 PMTak będzie:
Robię aktualizację PAK-a
 następnie [pak -Syu]
O Keyringi się nie martwię,
a Mirrory raz na miesiąc, bez używania PAK-a tylko za pomocą Pacmana

Tak zrozumiałem.
NIE!!! Jedyne, co masz robić, to: pak -Syu I doprawdy nie wiem, jak to jaśniej napisać.

Piejanto

@pavbaranov

Qrdę... właśnie do tego sam przed chwilą doszedłem i wszedłem tutaj aby zmodyfikować poprzednią moją odpowiedź.

Jasna sprawa. Przecież kiedyś widziałem, że PAK mi aktualizował PAK-a.
Tylko, że to było przed zmianą na PAK-GIT.
Jasna sprawa, że nie tylko System jest aktualizowany ale
- jak nam mówi instrukcja po wklepaniu [pak] - są aktualizowane zainstalowane pakiety.

Reasumując:
co parę dni robię aktualizację
[ pak -Syu ]     
i o Keyringi się nie martwię
raz na miesiąc robię aktualizację Mirrorów za pomocą Pacman-a
I... co jakiś czas sobie czyszczę kompa za pomocą [pak -Sc]

Dzięki. Mam to.

pavbaranov

Praktycznie każdą zainstalowaną paczkę *-git musisz aktualizować sam. W przypadku tych paczek rolą ich opiekuna jest stworzenie prawidłowego PKGBUILDu. Zasadniczo robi się to raz. Dopiero gdy upstream coś zmieni robi się nowy. Ze względu na to, że pkgver takiej paczki jest generowany w chwili jego budowy jest on inny niż ten, który jest w repozytorium. Jednocześnie w samym repozytorium źródeł mogą zachodzić zmiany. Paczki *-git to wyższa szkoła jazdy, bowiem to do użytkownika należy sprawdzanie repozytorium źródeł, ocena, czy coś, a jeśli tak to co, zostało zmienione i wówczas podjęcie decyzji o aktualizacji lub nie.
Nie wiem jaką wersję pak-git masz, ale jeśli sprzed dokonania zmian przez @nycko, to ów pak-git, który jest zainstalowany u Ciebie całkiem możliwe, że jest po prostu starszą wersją niż jego ostatnie wydanie. Z Twoją wiedzą sugerowałbym zainstalowanie pak w miejsce pak-git.

Piejanto

@pavbaranov

No tak, ale np. kiedyś instalowałem coś za pomocą Octopi (chyba pasjansa) i tam proces PKGBUILD-u włączył się automatycznie. To czy ja mogę używać Octopi, do np. aktualizacji pak-git?
Poprzednio miałem paka-a i właśnie wtedy, po aktualizacji zrobiła mi się kaszana.
Czy można zaufać procesowi aktualizacji, jaki uzyskujemy za pomocą Octopi?
Ja się nie upieram przy pak-git, ale jak na razie działa po prostu pięknie. Jeśli uważasz, ze bezpieczniejszy będzie dla mnie pak, to oczywiście przejdę na zwykłego pak-a. Tyle tylko, że Octopi nie pokazuje zwykłego paka-a, a pak-git jest. To może łatwiej mi będzie aktualizować pak-git? 
Jeśli chodzi o pak-git, to mam wersję 1:5.4.1rlg921d26a-1
Tak mi pokazuje Octopi.

Dzięki.



nycko

Octopi faktycznie pokazuje pak-git, ale z AUR, bo zupełnie przypadkiem ktoś tam umieścił zupełnie inny program o tej samej nazwie. Jeśli używasz pak, czy pak-git do aktualizacji, to bezpieczniej dla Ciebie będzie używać tylko paka i wywalić octopi, bo tylko wprowadza u Ciebie zamęt.

A powrót do zwykłego pak uzyskasz wykonując
pak -SP new-branded/pak
GitLab = users/nycko123/projects | GitHub = nycko123 | AUR = packages/?SeB=m&K=nycko123

Piejanto

#71
@nycko

Dżezusie!.. Kiedyś byłem zagubiony i bezradny, teraz jestem bezradny i zagubiony...
Przecież wrzucając polecenie [pak] dostaję całkiem podobne instrukcje. To idzie z [paka-a] czy z [pak-gita-a]?
Ten [pak-git] działa całkiem nieźle i w dodatku właśnie. od Was dostałem nań namiar z instrukcją aby to zainstalować. Sam bym przecież na to nie wpadł i to jest PEWNIK.
Dobra... Wierzę Ci ale... zaczekam jeszcze, co powiedzą @pavbaranov i @robson75

Przypomnienie:
Maj 24, 2022, 05:28:06 PM
Ostatnia edycja: Maj 24, 2022, 06:07:22 PM by nycko
Janie zapisz w "notatkach" i wykonaj
Kod [Zaznacz]
cd /tmp && wget "https://raw.githubusercontent.com/polaur/new-branded/master/pak-git/PKGBUILD" && makepkg -fsir
Na pytanie czy zastąpić pak przez pak-git odpowiedz T,
*******************
A tak nawiasem mówiąc, sądzę, że ten [pak-git] mógł rozwiązać problem. Ale może to tylko wrażenie. W każdym razie chyba właśnie od jego zainstalowania, zacząłem znów wychodzić  na prostą.

Aha... no i chyba wiem dlaczego @pavbaranov mówił o aktualizacji Keyringów przez [pak-a], a ja tego nie widzę podczas aktualizacji przez [pak-git].

pavbaranov

Janku - nie kombinuj. W Twoim przypadku - obecnie - pak, a nie pak-git. Chyba, że się zobowiążesz do opieki we własnym zakresie nad pak-git.
A twórcy pak należy raczej wierzyć i ufać.

nycko

Janie pak i pak-git z POLAUR to ten sam program. I w tej chwili są takie same i robią to samo, i tak samo,

Jak Ci wygodniej to dalej używaj tego do aktualizacji pak-git
https://raw.githubusercontent.com/polaur/new-branded/master/pak-git/PKGBUILD" && makepkg -fsir recznie raz w miesiącu albo jak coś przestanie działać.

Chociaż generalnie wygodniej jest po prostu wrócić do pak
pak -SP new-branded/pak by się sam aktualizowal.
GitLab = users/nycko123/projects | GitHub = nycko123 | AUR = packages/?SeB=m&K=nycko123

Piejanto

#74
@pavbaranow
Tak jest.

@nycko
Teraz jasne. Będzie tak jak mi powiedzieliście, ale mam wrażenie, że jednak pak-git się przydał w pewnym momencie, bo coś się wtedy ruszyło. Może to tylko wrażenie.
Hmmmm... mam wewnętrzne opory przed zmianami, ale... zrobię to.

Dzięki
********************************************************8

ZROBIŁEM, to ale nie obyło się bez przygód Nie musiałem odinstalowywać pak-git, bo oczywiście zapytało mnie czy odinstalować ale..
Nim do tego doszło wykazało mi błąd i się zorientowałem, że to błąd czasowy, bo przekroczył czas przewidziany na cośtam.
Następnym razem dopisałem mu do polecenia

pak -SP new-branded/pak --disable-download-timeout

i poszło. Tyle tylko, że na końcu, znów mi pokazało BŁĄD ale jak sprawdziłem, to pak-git jest odinstalowany, a pak działa
Skpiowałem całość ale chodzi o końcówkę. O co chodzi?
Mnie się wydaje, że na końcu chodzi właśnie o owo [--disable-download-timeout] - mam rację?

W SKRÓCIE BYŁO TAK:
                          pak -SP new-branded/pak --disable-download-timeout   (06-28 01:30)

:: pak konfliktuje z pak-git. Usunąć pak-git? [t/N] t
Pakiety (2) pak-git-1:5.4.1.r1.g921d26a-1 [usunięcie]  pak-1:5.5.2-1
Do zainstalowania:       0,15 MiB
Zmiana po aktualizacji:  0,00 MiB

:: Kontynuować instalację? [T/n] T
(1/1) sprawdzanie kluczy w bazie                   [######################] 100%
(1/1) sprawdzanie spójności pakietów               [######################] 100%
(1/1) wczytywanie listy plików                     [######################] 100%
(1/1) sprawdzanie konfliktów plików                [######################] 100%
(2/2) sprawdzanie dostępnego miejsca na dysku      [######################] 100%
:: Przetwarzanie zmian pakietu...
(1/1) usuwanie pak-git                             [######################] 100%
(1/1) instalowanie pak                             [######################] 100%
Opcjonalne zależności dla pak
    asp: to download PKGBUILD's of official packages
    auracle-git: (AUR) to manage AUR packages [zainstalowano]
    namcap: to validate built packages
    reflector: to keep mirrorlist up to date [zainstalowano]
    subversion: to check upstream for updated -svn packages
    fzf: to display all data about installed packages
    downgrade: (AUR) to downgrade packages
    libnotify: to display desktop notifications [zainstalowano]
:: Uruchamianie po-transakcji...
(1/1) Arming ConditionNeedsUpdate...
                                                                                 I TUTAJ NA KOŃCU :

błąd: Błędna składnia ==> repozytorium/pakiet. Sprawdź, czy pakiet istnieje w POLAUR
        ********************************************************************************************************
i to chyba właśnie chodzi o to [--disable-download-timeout]
Hłe, hłe...     


POZDROWIENIA





 

Zobacz najnowsze wiadomości na forum