Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Klient Spotify 32-bit – jest czy go nie ma?

Zaczęty przez mirekc, Sierpień 10, 2022, 05:11:31 PM

Poprzedni wątek - Następny wątek

mirekc

Na starym 32-bitowym komputerze mam zainstalowany MX Linux 21.1. Działa na nim aplikacja Spotify w wersji 1.0.72.117.g6bd7cc73. Wszystko fajnie, ale jak spróbowałem na maszynie wirtualnej postawić ,,od zera" tego linuxa, to zainstalować Spotify nie byłem w stanie. W repozytoriach MX-a i Debiana nie ma, a ten z repo Spotify nie chce się instalować, bo wymaga libcurl3 a w systemie jest libcurl4. Próbowałem googlać, ale ludzie twierdzą, że 32-bitowego Spotify dla linuxa po prostu nie ma. Jak to nie ma: przecież go mam!

No to czy ktoś wie, jak zainstalować Spotify pod 32-bitowym MX-em?

Ja mam go stąd, że zaczynałem od instalacji MX 21 beta i tam Spotify można było normalnie zainstalować instalatorem pakietów. Potem aktualizowałem (nieoficjalną ścieżką) system do wersji 21 (ostatecznej) a następnie do 21.1. Spotify pozostał i działa jak działał. Skoro tak, to czy czy można go zainstalować nie przechodząc przez moją ścieżkę aktualizacji (jeśliby w ogóle zadziałała, bo repozytoriów od bety pewnie już nie ma)?

PomPom

Masz wersję sprzed 5 lat, więc może wtedy taka była. Może wrzucili w MX to na chwilę do repo, a później uznali, że nie ma po co. Możesz próbować zainstalować ten stary pakiet, np. stąd: https://www.ubuntuupdates.org/package/mint_import/tara/import/base/spotify-client
Komputer - Card Reader | Gry - Xbox Series X | Użytkownik - zadowolony

mirekc

Cytat: PomPom w Sierpień 10, 2022, 06:30:48 PMMasz wersję sprzed 5 lat, więc może wtedy taka była. Może wrzucili w MX to na chwilę do repo, a później uznali, że nie ma po co. Możesz próbować zainstalować ten stary pakiet, np. stąd: https://www.ubuntuupdates.org/package/mint_import/tara/import/base/spotify-client
No cóż: sam nie pamiętam co zrobiłem, a potem piszę głupoty. Tego Spotify zainstalowałem z flatpaka, właśnie dlatego żeby ominąć problem z libcurl3 (pakiet spod linka nie instaluje się – niespełniona zależność).
Tylko że teraz jak próbuję w nowej instalacji zrobić to samo, to kończy się tak:
błąd: Brak odniesienia ,,app/com.spotify.Client/i386/stable" w repozytorium flathubCzyli było i nie ma. To właśnie jest jedna z tych rzeczy, których nie lubię w Linuxie.

pavbaranov

To jest oprogramowanie własnościowe. Pretensje można mieć do Spotify. Dodatkowo masz 32 bitowy system (i/lub komputer), które w małym stopniu są obecnie wspierane, bo po prostu wychodzą już powoli z użytku.
Tu masz jakieś rozwiązania: https://www.spotify.com/pl/download/linux/, ale czy cokolwiek to da - wątpię. Może ten snap.

mirekc

#4
Cytat: pavbaranov w Sierpień 11, 2022, 08:01:37 AMTo jest oprogramowanie własnościowe. Pretensje można mieć do Spotify.
Czy Spotify usunął pakiet z flathuba? Jak to jest z zarządzaniem zawartością? Ja rozumiem, że właściciel nie musi rozwijać w nieskończoność aplikacji na stare platformy, ale jak już coś zostało zrobione i działa, to mogłoby jeszcze podziałać.
Cytat: pavbaranov w Sierpień 11, 2022, 08:01:37 AMDodatkowo masz 32 bitowy system (i/lub komputer), które w małym stopniu są obecnie wspierane, bo po prostu wychodzą już powoli z użytku.
Tak już mam, że nie lubię wyrzucać starego sprzętu dopóki jest sprawny. Chyba że już mnie całkiem bieda przyciśnie i naprawdę nie mogę zrobić czegoś co chcę/muszę, a i to jeszcze się rozglądam czy czasem ten stary komputer jeszcze się na coś/komuś nie przyda. Ale skoro nie wyrzucam, to lubię wycisnąć z niego ile się tylko da.
Cytat: pavbaranov w Sierpień 11, 2022, 08:01:37 AMTu masz jakieś rozwiązania: https://www.spotify.com/pl/download/linux/, ale czy cokolwiek to da - wątpię. Może ten snap.
Właściwie to na wirtualce co mi szkodzi spróbować. A oto wynik:
snap install spotify
error: snap "spotify" is not available on stable for this architecture (i386) but exists on other
       architectures (amd64).
Czyli  jak nie ma, to nie ma.

pavbaranov

No to masz problem. Tego typu problem, z jakim się spotkałeś, wynika często, gdy jakaś paczka jest zbudowana z określonymi zależnościami. Tu na wcześniejszej wersji curl. I to w normalny sposób, na obecnej wersji zadziałać, nie zadziała.
Ba, nikt ze społeczności nie pomoże Ci w zbudowaniu klienta Spotify albowiem nikt nie dysponuje jego źródłami.
Masz kilka możliwości:
- używać starszej wersji jakiegoś systemu, gdzie jest jeszcze libcurl3,
- zwrócić się do Spotify, by i wersję na 32bit przekompilowali,
- zaglądnąć do tych rozwiązań: https://community.spotify.com/t5/Desktop-Linux/libcurl4/m-p/4441288/highlight/false
- zrobić analogicznie, jak to opisane tu: https://bugs.launchpad.net/ubuntu/+source/curl/+bug/1754294/comments/55
- użyć jakiegoś alternatywnego klienta np.: https://github.com/kraxarn/spotify-qt (nie wiem, czy jest w repozytorium bądź w jakiejkolwiek wersji portable na i386, zatem być może trzeba to będzie zbudować); niektóre inne tu: https://alternativeto.net/software/spotify/
- używać Spotify w przeglądarce,
- zaprzestać używać Spotify na tym komputerze,
- i pewnie kilka jeszcze innych.
Wymaganie jednakże od tego, że oprogramowanie z 2018 roku ma działać w roku 2022 jest raczej niedorzeczne. Możesz sobie tupać nogami, ale w przypadku zamkniętego oprogramowania nie ma po prostu tego jak - jeśli woli właściciela oprogramowania w tym zakresie nie ma - spowodować, że będzie to działało ze współczesnym oprogramowaniem.

mirekc

Chciałem udzielić obszernej odpowiedzi. Wszystko posprawdzałem, pięknie sobie pooddzielałem cytaty, napisałem co miałem napisać, ale zanim skończyłem musiałem się zająć inną pracą. I co? System mnie wylogował, całą odpowiedź diabli wzięli. Drugi raz tego nie zrobię, nie mam na to czasu.

Zobacz najnowsze wiadomości na forum