Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: Instalacja VirtualBox 6.1.26 na Ubuntu 20.04  (Przeczytany 338 razy)

Offline krzych888

  • Newbie
  • *
  • Wiadomości: 4
  • Reputacja: 0
Instalacja VirtualBox 6.1.26 na Ubuntu 20.04
« dnia: Październik 09, 2021, 10:26:14 am »
Witam wszystkich Miłośników Linuxa :)
Piszę, ponieważ mam problem, otóż nie mogę zainstalować VirtualBox 6.1.26 na Ubuntu 20.04 LTS

Po wpisaniu komendy instalacyjnej, terminal zwraca mi komunikat:

Następujące pakiety mają niespełnione zależności:
 virtualbox : Wymaga: libgsoap-2.8.91 ale nie da się go zainstalować
              Wymaga: liblzf1 (>= 1.5) ale nie da się go zainstalować
              Wymaga: libsdl1.2debian (>= 1.2.11) ale nie da się go zainstalować
              Poleca: virtualbox-qt (= 6.1.26-dfsg-3~ubuntu1.20.04.1) ale nie zostanie zainstalowany
              Poleca: libqt5opengl5 (>= 5.0.2) ale nie da się go zainstalować
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.

Bardzo prosze o pomoc :(

Offline banan

  • Jr. Member
  • **
  • Wiadomości: 53
  • Reputacja: -1
  • ParrotOS, KodachiOS, QBase
Odp: Instalacja VirtualBox 6.1.26 na Ubuntu 20.04
« Odpowiedź #1 dnia: Październik 09, 2021, 11:37:11 am »
Witam,

Ściągnij VBoxaze strony Oracla:

https://www.virtualbox.org/wiki/Linux_Downloads

wybierz wersję dla ubuntu i plik deb zainstaluj z gui lubw terminalu :

$ sudo  dpkg -i pakiet.deb

PS. Lepszy est virt-manager, oparty na quem-kvm, szybszy i nie potrzebuje dodatków gościa..
$ sudo apt update
$ sudo apt install virt-manager -yyy

Pozdrawiam,

Offline krzych888

  • Newbie
  • *
  • Wiadomości: 4
  • Reputacja: 0
Odp: Instalacja VirtualBox 6.1.26 na Ubuntu 20.04
« Odpowiedź #2 dnia: Październik 09, 2021, 11:48:06 am »
Dzięki za odpowiedź, niestety instalacja pliku ze stronki nie jest możliwa. Czy spowodowane jest to tym, że posiadam procesor I3, a w nazwie pliku jest AMD64?
Programu virt-manager także nie mogę zainstalować. Zależy mi na Virtual Box w wersji z tytułu, ponieważ akurat taki wymagany jest na kursie. Czy da się to ogarnąć, czy muszę zmienić hardware na AMD64?

« Ostatnia zmiana: Październik 09, 2021, 11:50:15 am wysłana przez krzych888 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1756
  • Reputacja: 6
Odp: Instalacja VirtualBox 6.1.26 na Ubuntu 20.04
« Odpowiedź #3 dnia: Październik 09, 2021, 12:56:30 pm »
Zależności, które terminal wypluł są dostępne w Ubuntu 20.04 focal.
Czy odświeżyłeś listę pakietów przed instalacją deba virtualbox?
sudo apt updateNastępnie spróbuj ponownie zainstalować pakiet.

Poza tym, pakiet virtualbox i virtualbox-qt w wersji 6.1.26 jest w repo focal, więc wystarczy:
sudo apt update
sudo apt install virtualbox-qt
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline krzych888

  • Newbie
  • *
  • Wiadomości: 4
  • Reputacja: 0
Odp: Instalacja VirtualBox 6.1.26 na Ubuntu 20.04
« Odpowiedź #4 dnia: Październik 09, 2021, 01:05:04 pm »
Zrobiłem update systemu przed instalacją.   
xxxxxxxxxxxxxxxxxxx~$ sudo apt update
[sudo] hasło użytkownika xxx:
Stary:1 http://pl.archive.ubuntu.com/ubuntu focal InRelease
Stary:2 http://pl.archive.ubuntu.com/ubuntu focal-updates InRelease
Stary:3 http://pl.archive.ubuntu.com/ubuntu focal-backports InRelease
Pobieranie:4 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Pobrano 114 kB w 1s (109 kB/s)     
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Wszystkie pakiety są aktualne.
xxxxxxxxxxxxxxxxxxxxxx:~$ sudo apt install virtualbox-qt
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 virtualbox-qt : Wymaga: virtualbox (= 6.1.26-dfsg-3~ubuntu1.20.04.1)
                 Wymaga: libqt5opengl5 (>= 5.0.2) ale nie da się go zainstalować
                 Wymaga: libqt5x11extras5 (>= 5.6.0) ale nie da się go zainstalować
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.


Problem dalej występuje.... Co jest grane??

Wrzucam dane po wpisaniu komendy lscpu:

Architektura:                    x86_64
Tryb(y) pracy CPU:               32-bit, 64-bit
Kolejność bajtów:                Little Endian
Address sizes:                   36 bits physical, 48 bits virtual
CPU:                             4
Lista aktywnych CPU:             0-3
Wątków na rdzeń:                 2
Rdzeni na gniazdo:               2
Gniazd:                          1
Węzłów NUMA:                     1
ID producenta:                   GenuineIntel
Rodzina CPU:                     6
Model:                           58
Nazwa modelu:                    Intel(R) Core(TM) i3-3240 CPU @ 3.40GHz
Wersja:                          9
CPU MHz:                         1747.407
CPU max MHz:                     3400,0000
CPU min MHz:                     1600,0000
BogoMIPS:                        6784.63
Cache L1d:                       64 KiB
Cache L1i:                       64 KiB
Cache L2:                        512 KiB
Cache L3:                        3 MiB
Procesory węzła NUMA 0:          0-3
Vulnerability Itlb multihit:     KVM: Mitigation: VMX unsupported
Vulnerability L1tf:              Mitigation; PTE Inversion
Vulnerability Mds:               Mitigation; Clear CPU buffers; SMT vulnerable
Vulnerability Meltdown:          Mitigation; PTI
Vulnerability Spec store bypass: Mitigation; Speculative Store Bypass disabled v
                                 ia prctl and seccomp
Vulnerability Spectre v1:        Mitigation; usercopy/swapgs barriers and __user
                                  pointer sanitization
Vulnerability Spectre v2:        Mitigation; Full generic retpoline, IBPB condit
                                 ional, IBRS_FW, STIBP conditional, RSB filling
Vulnerability Srbds:             Not affected
Vulnerability Tsx async abort:   Not affected
Flagi:                           fpu vme de pse tsc msr pae mce cx8 apic sep mtr
                                 r pge mca cmov pat pse36 clflush dts acpi mmx f
                                 xsr sse sse2 ss ht tm pbe syscall nx rdtscp lm
                                 constant_tsc arch_perfmon pebs bts rep_good nop
                                 l xtopology nonstop_tsc cpuid aperfmperf pni pc
                                 lmulqdq dtes64 monitor ds_cpl est tm2 ssse3 cx1
                                 6 xtpr pdcm pcid sse4_1 sse4_2 popcnt tsc_deadl
                                 ine_timer xsave avx f16c lahf_lm cpuid_fault ep
                                 b pti ssbd ibrs ibpb stibp fsgsbase smep erms x
                                 saveopt dtherm arat pln pts md_clear flush_l1d

« Ostatnia zmiana: Październik 09, 2021, 08:53:55 pm wysłana przez pavroo »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1756
  • Reputacja: 6
Odp: Instalacja VirtualBox 6.1.26 na Ubuntu 20.04
« Odpowiedź #5 dnia: Październik 09, 2021, 08:57:28 pm »
Więc tak... odpaliłem Lubuntu 20.04.3 na wirtualu, odświeżyłem listę pakietów i... instalacja virtualbox-qt bez problemu.
Twój problem może być związany z repozytoriami, które używasz.
Zakomentuj repo backports.
Jeśli używasz również innego repo niż oficjalne, również je wyłącz.
Następnie odśwież listę pakietów i spróbuj ponownie.

p.s.
wyniki z terminala wsadzaj w 'code', są bardziej czytelne.
Nic nie jest tak proste, jak się wydaje.
Danielle Steel

Offline robson75

  • Hero Member
  • *****
  • Wiadomości: 1666
  • Reputacja: 11
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: Instalacja VirtualBox 6.1.26 na Ubuntu 20.04
« Odpowiedź #6 dnia: Październik 09, 2021, 09:59:32 pm »
A jeżeli będziesz miał nadal problemy z instalacją VB, to spróbuj zainstalować gnome-boxes, to również jest maszyna wirtualna, tyle tylko że ze stajni GNOME.
Arch Linux Xfce+compiz - 64Bit Linux User #621110 

Offline ch252

  • Newbie
  • *
  • Wiadomości: 5
  • Reputacja: 0
Odp: Instalacja VirtualBox 6.1.26 na Ubuntu 20.04
« Odpowiedź #7 dnia: Październik 12, 2021, 11:29:33 am »
Więc tak... odpaliłem Lubuntu 20.04.3 na wirtualu, odświeżyłem listę pakietów i... instalacja virtualbox-qt bez problemu.
Twój problem może być związany z repozytoriami, które używasz.
Zakomentuj repo backports.

O co chodzi z repo backports?
U mnie w Lubuntu też się VB instaluje a mam tak:
cat /etc/apt/sources.list | grep back
deb http://archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse
# deb-src http://archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse

Offline krzych888

  • Newbie
  • *
  • Wiadomości: 4
  • Reputacja: 0
Odp: Instalacja VirtualBox 6.1.26 na Ubuntu 20.04
« Odpowiedź #8 dnia: Październik 12, 2021, 09:58:02 pm »
Zainstalowałem system na nowo i VB zainstalował się bez problemu. Nie mam pojęcia co było nie tak, ale ważne, że problem się rozwiązał. Wielkie dzięki za pomoc :)