Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: Problem z aktualizacją lib32-libpcap ROZWIĄZANY  (Przeczytany 877 razy)

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 492
  • Reputacja: 0
Odp: Problem z aktualizacją lib32-libpcap
« Odpowiedź #30 dnia: Czerwiec 17, 2021, 03:33:35 pm »
@robson75
Na razie zrobiłem to:

pacman/pkg]# pacman -U skypeforlinux-stable-bin-8.73.0.92-1-x86_64.pkg.tar.zst octopi-notifier-qt5-0.11.0-2-x86_64.pkg.tar.zst zoom-5.6.7-1-x86_64.pkg.tar.zst
wczytywanie pakietów…
błąd:  'skypeforlinux-stable-bin-8.73.0.92-1-x86_64.pkg.tar.zst': nie udało się znaleźć bądź odczytać pakietu
błąd:  'octopi-notifier-qt5-0.11.0-2-x86_64.pkg.tar.zst': nie udało się znaleźć bądź odczytać pakietu
błąd:  'zoom-5.6.7-1-x86_64.pkg.tar.zst': nie udało się znaleźć bądź odczytać pakietu

teraz będę działał dalej

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 492
  • Reputacja: 0
Odp: Problem z aktualizacją lib32-libpcap
« Odpowiedź #31 dnia: Czerwiec 17, 2021, 03:58:56 pm »
@robson75
zrobiłem co kazałeś i poszła wielka aktualizacja. Chodzi o to:
*************************
Ja bym jeszcze inaczej zrobił, wyłączył tymczasowo repo chaotic-aur
Kod: [Zaznacz]
#[chaotic-aur]
#Include = /etc/pacman.d/chaotic-mirrorlist
I przeprowadził pełną aktualizacje systemu, a dopiero potem się bawił z tymi paczkami z chaotic-aur.
***************************
 Nawet nie wstawiam tu kopii, bo jest tego ogromna ilość

następnie zrobiłem [pak -Sc] łącznie z czyszczeniem POLAUR




« Ostatnia zmiana: Czerwiec 17, 2021, 04:01:57 pm wysłana przez Piejanto »

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 492
  • Reputacja: 0
Odp: Problem z aktualizacją lib32-libpcap
« Odpowiedź #32 dnia: Czerwiec 17, 2021, 04:16:30 pm »
Po czyszczeniu włączyłem (odhasztagowałem)
[chaotic-aur]
Include = /etc/pacman.d/chaotic-mirrorlist

i zrobiłem aktualizację. Teraz jest tak:

:: Synchronizowanie baz danych z pakietami…
 core is up to date
 extra is up to date
 community is up to date
 chaotic-aur          1106,1 KiB   400 KiB/s 00:03 [######################] 100%
:: Rozpoczynanie pełnej aktualizacji systemu…
rozwiązywanie zależności…
szukanie sprzecznych pakietów...

Pakiety (4) archlinux-appstream-data-pamac-20210612-1
            octopi-notifier-qt5-0.11.0-2  skypeforlinux-stable-bin-8.73.0.92-1
            zoom-5.6.7-1

Do pobrania:             195,69 MiB
Do zainstalowania:       490,60 MiB
Zmiana po aktualizacji:    3,10 MiB

:: Kontynuować instalację? [T/n] T
:: Pobieranie pakietów…
 archlinux-appstr...    18,6 MiB  1104 KiB/s 00:17 [######################] 100%
 octopi-notifier-...   718,9 KiB   369 KiB/s 00:02 [######################] 100%
 skypeforlinux-st...   108,6 MiB  1196 KiB/s 01:33 [######################] 100%
 zoom-5.6.7-1-x86_64    67,8 MiB  1045 KiB/s 01:06 [######################] 100%
 Total (4/4)           195,7 MiB  1115 KiB/s 03:00 [######################] 100%
błąd:  nie udało się pobrać pliku 'archlinux-appstream-data-pamac-20210612-1-any.pkg.tar.zst' z random-mirror.chaotic.cx : Could not resolve host: mirror.theash.xyz
ostrzeżenie: too many errors from random-mirror.chaotic.cx, skipping for the remainder of this transaction
(4/4) sprawdzanie kluczy w bazie                   [######################] 100%
(4/4) sprawdzanie spójności pakietów               [######################] 100%
błąd:  archlinux-appstream-data-pamac: podpis od "Nico Jensch <dr460nf1r3@garudalinux.org>" posiada nieznane zaufanie
:: Plik /var/cache/pacman/pkg/archlinux-appstream-data-pamac-20210612-1-any.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
błąd:  octopi-notifier-qt5: podpis od "Nico Jensch <dr460nf1r3@garudalinux.org>" posiada nieznane zaufanie
:: Plik /var/cache/pacman/pkg/octopi-notifier-qt5-0.11.0-2-x86_64.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
błąd:  skypeforlinux-stable-bin: podpis od "Nico Jensch <dr460nf1r3@garudalinux.org>" posiada nieznane zaufanie
:: Plik /var/cache/pacman/pkg/skypeforlinux-stable-bin-8.73.0.92-1-x86_64.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
błąd:  zoom: podpis od "Nico Jensch <dr460nf1r3@garudalinux.org>" posiada nieznane zaufanie
:: Plik /var/cache/pacman/pkg/zoom-5.6.7-1-x86_64.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
błąd:  nie udało się dokonać transakcji (Niepoprawny lub uszkodzony pakiet (podpis PGP))
Wystąpiły błędy, nie zaktualizowano żadnego pakietu.
********************


Wychodzi mi, że powinienem pobrać ręcznie:
****
archlinux-appstream-data-pamac-20210612-1
            octopi-notifier-qt5-0.11.0-2  skypeforlinux-stable-bin-8.73.0.92-1
            zoom-5.6.7-1
******
Ale dlaczego też [archlinux-appstream-data-pamac-20210612-1]?
sprawdziłem przez Octopi, ale nie pokazuje w ogóle takiego czegoś.



Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 492
  • Reputacja: 0
Odp: Problem z aktualizacją lib32-libpcap
« Odpowiedź #33 dnia: Czerwiec 17, 2021, 04:26:46 pm »
ściągnąłem z Chaotic-Aur te pakiety:

archlinux-appstream-data-pamac-20210612-1
octopi-notifier-qt5-0.11.0-2 
skypeforlinux-stable-bin-8.73.0.92-1
zoom-5.6.7-1


I spróbuję zainstalować poleceniem od Robsona

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 492
  • Reputacja: 0
Odp: Problem z aktualizacją lib32-libpcap
« Odpowiedź #34 dnia: Czerwiec 17, 2021, 04:47:45 pm »
Coś jest nie tak. Czy powinienem coś zrobić ze ściągnietymi pakietami, przed ich instalacją?

Mam je w oddzielnym katalogu
Uruchomiłem Octopi (jak kazał @robson75  na zrzucie ekranu)) i kazałem zainstalować [plik lokalny]. Pokazuje mi tak:

Instalacja wybranych pakietów...

error: invalid option '--force'
[?25l[?25h

Polecenie zakończone z błędami!
 

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 492
  • Reputacja: 0
Odp: Problem z aktualizacją lib32-libpcap
« Odpowiedź #35 dnia: Czerwiec 17, 2021, 04:52:05 pm »
spróbowałem aktualizacji przez Octopi.

Uruchomienie pełnej aktualizacji systemu...

core
F is up to date
E extra
E community
E chaotic-aur
Syncing chaotic-aur
E
resolving dependencies...
looking for conflicting packages...
Packages (4) archlinux-appstream-data-pamac-20210612-1 octopi-notifier-qt5-0.11.0-2 skypeforlinux-stable-bin-8.73.0.92-1
zoom-5.6.7-1
Total Download Size: 195.69 MiB
Total Installed Size: 490.60 MiB
Net Upgrade Size: 3.10 MiB
:: Proceed with installation? [Y/n]
:: Retrieving packages...
archlinux-appstream-data-pamac-20210612-1-any
Total
Polecenie zakończone z błędami!

A może powinienem wyrzucić te programy i zainstalować je od nowa?


Offline robson75

  • Hero Member
  • *****
  • Wiadomości: 1628
  • Reputacja: 9
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: Problem z aktualizacją lib32-libpcap
« Odpowiedź #36 dnia: Czerwiec 17, 2021, 05:49:58 pm »
Janek, jeżeli nie masz w systemie pamaca to weź wywal archlinux-appstream-data-pamac
sudo pacman -Rns archlinux-appstream-data-pamac
Jeżeli chodzi o te paczki które pobrałeś ręcznie, to wejdź do katalogu w którym się one znajdują (przeważnie Pobrane), i kliknij PPM i wybierz uruchom w terminalu i wklej to
sudo pacman -U skypeforlinux-stable-bin-8.73.0.92-1-x86_64.pkg.tar.zst octopi-notifier-qt5-0.11.0-2-x86_64.pkg.tar.zst zoom-5.6.7-1-x86_64.pkg.tar.zst
Arch Linux Xfce+compiz - 64Bit Linux User #621110 

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 492
  • Reputacja: 0
Odp: Problem z aktualizacją lib32-libpcap
« Odpowiedź #37 dnia: Czerwiec 17, 2021, 06:35:25 pm »
@robson75
Usunąłem tę pozostałość Pamaca, a następnie :
************
Pulpit/chaotic aur]$ sudo pacman -U skypeforlinux-stable-bin-8.73.0.92-1-x86_64.pkg.tar.zst octopi-notifier-qt5-0.11.0-2-x86_64.pkg.tar.zst zoom-5.6.7-1-x86_64.pkg.tar.zst
[sudo] hasło użytkownika jan:
wczytywanie pakietów…
błąd:  'skypeforlinux-stable-bin-8.73.0.92-1-x86_64.pkg.tar.zst': Niepoprawny lub uszkodzony pakiet (podpis PGP)
błąd:  'octopi-notifier-qt5-0.11.0-2-x86_64.pkg.tar.zst': Niepoprawny lub uszkodzony pakiet (podpis PGP)
***************

To są pobrane pakiety z Chaotic-Aur bezpośrednio i ręcznie.
I chyba rence mnie opadowywują...

 ALE... wygląda, że Zoom został zaktualizowany...

« Ostatnia zmiana: Czerwiec 17, 2021, 06:56:40 pm wysłana przez Piejanto »

Offline robson75

  • Hero Member
  • *****
  • Wiadomości: 1628
  • Reputacja: 9
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: Problem z aktualizacją lib32-libpcap
« Odpowiedź #38 dnia: Czerwiec 17, 2021, 06:56:26 pm »
A weź wklep w terminalu
pak -Syu chaotic-keyringA następnie
pak -Syu
Arch Linux Xfce+compiz - 64Bit Linux User #621110 

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 492
  • Reputacja: 0
Odp: Problem z aktualizacją lib32-libpcap
« Odpowiedź #39 dnia: Czerwiec 17, 2021, 07:04:00 pm »

zrobiłem:

pak -Syu chaotic-keyring                             (06-17 18:58)
*****
:: Synchronizowanie baz danych z pakietami…
 core                  134,2 KiB  93,9 KiB/s 00:01 [######################] 100%
 extra is up to date
 community               5,6 MiB   552 KiB/s 00:10 [######################] 100%
 chaotic-aur          1106,3 KiB   447 KiB/s 00:02 [######################] 100%
:: Rozpoczynanie pełnej aktualizacji systemu…
rozwiązywanie zależności…
szukanie sprzecznych pakietów...

Pakiety (5) mkinitcpio-busybox-1.33.1-1  octopi-notifier-qt5-0.11.0-2
            skypeforlinux-stable-bin-8.73.0.92-1  zoom-5.6.7-1
            chaotic-keyring-20210615-1

Do pobrania:             176,14 MiB
Do zainstalowania:       471,70 MiB
Zmiana po aktualizacji:    2,92 MiB

:: Kontynuować instalację? [T/n] T
:: Pobieranie pakietów…
 chaotic-keyring-...    14,2 KiB  3,92 KiB/s 00:04 [######################] 100%
 mkinitcpio-busyb...   269,5 KiB   402 KiB/s 00:01 [######################] 100%
 skypeforlinux-st...   108,0 MiB   956 KiB/s 01:56 [######################] 100%
 zoom-5.6.7-1-x86_64    67,8 MiB   675 KiB/s 01:43 [######################] 100%
 Total (4/4)           176,1 MiB   805 KiB/s 03:44 [######################] 100%
błąd:  nie udało się pobrać pliku 'zoom-5.6.7-1-x86_64.pkg.tar.zst' z random-mirror.chaotic.cx : Could not resolve host: mirror.theash.xyz
ostrzeżenie: too many errors from random-mirror.chaotic.cx, skipping for the remainder of this transaction
(5/5) sprawdzanie kluczy w bazie                   [######################] 100%
(5/5) sprawdzanie spójności pakietów               [######################] 100%
błąd:  octopi-notifier-qt5: podpis od "Nico Jensch <dr460nf1r3@garudalinux.org>" posiada nieznane zaufanie
:: Plik /var/cache/pacman/pkg/octopi-notifier-qt5-0.11.0-2-x86_64.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
błąd:  skypeforlinux-stable-bin: podpis od "Nico Jensch <dr460nf1r3@garudalinux.org>" posiada nieznane zaufanie
:: Plik /var/cache/pacman/pkg/skypeforlinux-stable-bin-8.73.0.92-1-x86_64.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
błąd:  zoom: podpis od "Nico Jensch <dr460nf1r3@garudalinux.org>" posiada nieznane zaufanie
:: Plik /var/cache/pacman/pkg/zoom-5.6.7-1-x86_64.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
błąd:  nie udało się dokonać transakcji (Niepoprawny lub uszkodzony pakiet (podpis PGP))
Wystąpiły błędy, nie zaktualizowano żadnego pakietu.


Offline robson75

  • Hero Member
  • *****
  • Wiadomości: 1628
  • Reputacja: 9
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: Problem z aktualizacją lib32-libpcap
« Odpowiedź #40 dnia: Czerwiec 17, 2021, 07:09:04 pm »
To w takim razie musisz pobrać ręcznie paczkę chaotic-keyring, i ja zainstalować przez pacman -U.
U mnie bez problemu zainstalowałem octopi-notifier-qt5
❯ pacs octopi-notifier-qt5
rozwiązywanie zależności…
szukanie sprzecznych pakietów...

Pakiet (1)                       Nowa wersja  Zmiana    Do pobrania

chaotic-aur/octopi-notifier-qt5  0.11.0-2     2,51 MiB     0,70 MiB

Do pobrania:        0,70 MiB
Do zainstalowania:  2,51 MiB

:: Kontynuować instalację? [T/n]
:: Pobieranie pakietów…
 octopi-notifier-...   718,9 KiB   297 KiB/s 00:02 [----------------------] 100%
(1/1) sprawdzanie kluczy w bazie                   [----------------------] 100%
(1/1) sprawdzanie spójności pakietów               [----------------------] 100%
(1/1) wczytywanie listy plików                     [----------------------] 100%
(1/1) sprawdzanie konfliktów plików                [----------------------] 100%
(1/1) sprawdzanie dostępnego miejsca na dysku      [----------------------] 100%
:: Przetwarzanie zmian pakietu...
(1/1) instalowanie octopi-notifier-qt5             [----------------------] 100%
Opcjonalne zależności dla octopi-notifier-qt5
    xfce4-notifyd: for notifications in XFCE [zainstalowano]
:: Uruchamianie po-transakcji...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Updating the desktop file MIME type cache...
Arch Linux Xfce+compiz - 64Bit Linux User #621110 

Offline robson75

  • Hero Member
  • *****
  • Wiadomości: 1628
  • Reputacja: 9
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: Problem z aktualizacją lib32-libpcap
« Odpowiedź #41 dnia: Czerwiec 17, 2021, 07:19:31 pm »
Janek, właśnie przed chwilą miałem update paczki chaotic-keyring. Weź po prostu wklep w terminalu
pak -SyyI
pak -S chaotic-keyringI
pak -Syu
Arch Linux Xfce+compiz - 64Bit Linux User #621110 

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 3076
  • Reputacja: 48
Odp: Problem z aktualizacją lib32-libpcap
« Odpowiedź #42 dnia: Czerwiec 17, 2021, 07:40:24 pm »
Nein! pacman -Sy chaotic-keyring chaotic-mirrorlistNie pak! Pak działa 100/100, ale gdy system nie jest spieprzony.

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 492
  • Reputacja: 0
Odp: Problem z aktualizacją lib32-libpcap ROZWIĄZANY
« Odpowiedź #43 dnia: Czerwiec 17, 2021, 08:28:36 pm »
@pavbaranov
DOSKONAŁA UWAGA. Zrobiłem

[pacman -Sy chaotic-keyring chaotic-mirrorlist]


Na początku powiedziało mi  że błąd ale....
*********
błąd:  nie udało się pobrać pliku 'chaotic-aur.db' z random-mirror.chaotic.cx : Could not resolve host: mirror.theash.xyz
ostrzeżenie: too many errors from random-mirror.chaotic.cx, skipping for the remainder of this transaction
:: Rozpoczynanie pełnej aktualizacji systemu…
rozwiązywanie zależności…
szukanie sprzecznych pakietów...
****************

poszła aktualizacja.

Na wszelki wypadek później zrobiłem jeszcze:
***
pak -Syu                                             (06-17 20:17)
Używana jest konfiguracja użytkownika: /***/***/.config/pak/pak.conf

[sudo] hasło użytkownika jan:
:: Synchronizowanie baz danych z pakietami…
 core is up to date
 extra                1566,4 KiB   704 KiB/s 00:02 [######################] 100%
 community               5,6 MiB   829 KiB/s 00:07 [######################] 100%
 chaotic-aur          1106,3 KiB   348 KiB/s 00:03 [######################] 100%
:: Rozpoczynanie pełnej aktualizacji systemu…
 nie ma nic do zrobienia
**********
WIELKIE DZIĘKI !

Wyprowadziliście mnie na prostą, a już miałem ciemno przed oczami.




   
« Ostatnia zmiana: Czerwiec 17, 2021, 08:52:33 pm wysłana przez Piejanto »

Offline robson75

  • Hero Member
  • *****
  • Wiadomości: 1628
  • Reputacja: 9
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: Problem z aktualizacją lib32-libpcap
« Odpowiedź #44 dnia: Czerwiec 19, 2021, 01:12:52 pm »
Uruchomiłem Octopi (jak kazał @robson75  na zrzucie ekranu)) i kazałem zainstalować [plik lokalny]. Pokazuje mi tak:

Instalacja wybranych pakietów...

error: invalid option '--force'
[?25l[?25h

Polecenie zakończone z błędami!
Rzeczywiście, w tej chwili nie można zainstalować pakietu lokalnego przez octopi.
Zgłosiłem to
https://github.com/aarnt/octopi/issues/486
« Ostatnia zmiana: Czerwiec 19, 2021, 02:07:15 pm wysłana przez robson75 »
Arch Linux Xfce+compiz - 64Bit Linux User #621110